Colour distortion (purple/green) during video playback

RESOLVED FIXED in Firefox 57

Status

()

P1
normal
RESOLVED FIXED
a year ago
7 months ago

People

(Reporter: philipp, Assigned: jya)

Tracking

({regression})

57 Branch
mozilla59
Unspecified
Windows
regression
Points:
---

Firefox Tracking Flags

(relnote-firefox 57+, firefox-esr52 unaffected, firefox57+ fixed, firefox58 fixed, firefox59 fixed)

Details

Attachments

(6 attachments)

(Reporter)

Description

a year ago
[Tracking Requested - why for this release]:
we've received a number of user reports on various support channels about a regression that causes video content on youtube and other sites to be distorted and with purple/pink/green overlays.

https://support.mozilla.org/en-US/questions/1185025
https://support.mozilla.org/en-US/questions/1184591
https://support.mozilla.org/en-US/questions/1185078
https://www.reddit.com/r/firefox/comments/7cya40/having_some_issues_with_firefox_update_all_videos/
https://www.reddit.com/r/firefox/comments/7d3xuz/welp_is_this_normal_bug/

most of the affected users are on windows 8.1 with an amd gpu and older drivers.
Kyle,
Is it a known issue in old drivers or not?
Flags: needinfo?(kyle.plumadore)
Priority: -- → P1
(Assignee)

Comment 2

a year ago
the cards reported being used in those reports are :
AMD Radeon R7 200 Series Manufacturer: Advanced Micro Devices, Inc. Chip type: AMD Radeon Graphics Processor (0x6613)
AMD Radeon(TM) R2 Graphics Vendor ID: 0x1002 Device ID: 0x9852
0x9851

At first I thought it could be a nv12 vs yuv420 issue, however while those cards aren't in the blacklisted list for receiving nv12, but we block all AMD drivers lesser than 21.19.411.0

And there was no change between 56 and 57 in regards to surface format...
So it could be people that weren't using 56 before.

Or it's an issue in the VP9 decoder, that somehow is marked as working...

Kyle, could those cards/devices incorrectly reports the AMD VP9 decoder as being present?
(Assignee)

Comment 3

a year ago
drivers listed as being installed: 15.300.1025.1001
13.351.1105.1001

I'm starting to think that the issue isn't media decoder related ...
(Reporter)

Comment 4

a year ago
https://pastebin.mozilla.org/9072819 was another about:support log from an affected user in case it helps and i will start tagging new questions on sumo about this so that they show up under this link: https://support.mozilla.org/en-US/questions/firefox?owner=all&tagged=bug1417442&show=all

Comment 5

a year ago
The VP9 MFT support wasn't implemented in drivers before version 16.30.** so I don't think the issue is related to incorrectly reporting vp9 support.

This does look like something that could definitely be a driver bug though - more likely related to any dx/ogl apis that use nv12 surfaces as shader input/output.
Flags: needinfo?(kyle.plumadore)

Comment 6

a year ago
.. The chroma data is corrupt - luma seems fine.

From a quick look it appears to be limited to windows 8.1 - are there any reports that happen on e.g. windows 10?
(Assignee)

Comment 7

a year ago
nv12 is disabled on driver < 21.19.411.0, so this is using an old code path, which hasn't changed in many years.
tracking-firefox57: ? → +
(Assignee)

Updated

a year ago
Duplicate of this bug: 1417252
(Assignee)

Updated

a year ago
Duplicate of this bug: 1417544
(Assignee)

Comment 11

a year ago
in one of those reports, it's a rather recent version of the AMD drivers:
AMD Radeon R5 Graphics Vendor ID: 0x1002 Device ID: 0x9874 Driver Version: 21.19.407.0 Driver Date: 12-23-2016

nv12 would have been disabled there too...
(Assignee)

Comment 12

a year ago
Kyle, here https://www.reddit.com/r/firefox/comments/7d4weh/help_there_is_a_green_stripe_and_discoloration_in/ the user is on Windows 10, with recent drivers (though not the latest)
Sotaro, Bas, any recent YCbCr work that could explain this?  Or something else?
Flags: needinfo?(sotaro.ikeda.g)
Flags: needinfo?(bas)
Also, does it work with acceleration still enabled, but with layers.mlgpu.enabled and layers.mlgpu.enable-on-windows7 both set to false in about:config?
Flags: needinfo?(madperson)
(Assignee)

Comment 15

a year ago
A person confirmed that setting media.wmf.use-nv12-format fixed the problem on their AMD setup.

Now, for all the reports I've seen, nv12 should have been disabled automatically, either because their drivers were too old, or because it was a blacklisted card.

So we have a bug in the feature detection https://searchfox.org/mozilla-central/source/dom/media/platforms/wmf/DXVA2Manager.cpp#1257

This is called at startup from https://searchfox.org/mozilla-central/source/gfx/thebes/D3D11Checks.cpp#414

It indicates that either we retrieve a rubbish driver version, or that it's an invalid version that is being read (one that is greater than 21.19.411.0

The test is:
    if (widget::ParseDriverVersion(aDriverVersionString, &driverVersion) &&
        driverVersion < widget::V(21, 19, 411, 0)) {
      return false;
    }

we should make that:
    if (!widget::ParseDriverVersion(aDriverVersionString, &driverVersion) ||
        driverVersion < widget::V(21, 19, 411, 0)) {
      return false;
    }

it doesn't explain why the version string would be invalid however...

Matt is this something you could look into ASAP? I'll get back on it tomorrow morning if you didn't get the change.

Thanks
Flags: needinfo?(matt.woodrow)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Reporter)

Comment 18

a year ago
(In reply to Milan Sreckovic [:milan] from comment #14)
> Also, does it work with acceleration still enabled, but with
> layers.mlgpu.enabled and layers.mlgpu.enable-on-windows7 both set to false
> in about:config?

a user at https://support.mozilla.org/questions/1185577 gave feedback that disabling the layers.mlgpu.* prefs didn't fix the problem.
Flags: needinfo?(madperson)
(Assignee)

Updated

a year ago
Assignee: nobody → jyavenard
(Assignee)

Comment 19

a year ago
The issue is a bug in the gfxInfo ipc service, it doesn't work.. so we get an empty version number.
(Assignee)

Updated

a year ago
Flags: needinfo?(sotaro.ikeda.g)
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(bas)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Comment 23

a year ago
As discussed on IRC, with P1, ./mach try won't even start immediately crashing.
Flags: needinfo?(dvander)
Comment on attachment 8928739 [details]
Bug 1417442 - P2. fix nsIGfxInfo in GPU process.

https://reviewboard.mozilla.org/r/200002/#review205138

r=me for m-c, but please do test that nsIGfxInfo starts up correctly - XPCOM modules are good at silently failing to initialize.
Attachment #8928739 - Flags: review?(dvander) → review+
(In reply to David Anderson [:dvander] from comment #24)
> Comment on attachment 8928739 [details]
> Bug 1417442 - P1. fix nsIGfxInfo in GPU process.
> 
> https://reviewboard.mozilla.org/r/200002/#review205138
> 
> r=me for m-c, but please do test that nsIGfxInfo starts up correctly - XPCOM
> modules are good at silently failing to initialize.

This is a pretty big change to uplift to release.  Makes me plenty nervous, and it affects all Windows users, not just the ones with the current video problems.
Yeah, we definitely do not want to uplift that to release.
Flags: needinfo?(dvander)
(Assignee)

Updated

a year ago
See Also: → bug 1417716
Could we check with one of the users that experiences this if, after setting the rest of the preferences back to default, if setting layers.gpu-process.enabled to false in about:config, and restarting, the problem goes away?  If that works, we have a downloadable blocklist way of dealing with this short term.
Flags: needinfo?(madperson)
This should be added to the downloadable blocklist (once the review passes and once we know disabling the GPU process helps); we need four entries to cover Windows 8 and 8.1, and both vendor IDs for AMD (0x1002 and 0x1022).  The rest is the same - block the GPU process for driver versions lesser than 21.19.411.0.

Jeff, could you review the blocklist entries?


<gfxBlacklistEntry>
  <os>WINNT 6.2</os>
  <vendor>0x1002</vendor>
  <feature>GPU_PROCESS</feature>
  <featureStatus>BLOCKED_DRIVER_VERSION</featureStatus>
  <driverVersion>21.19.411.0</driverVersion>
  <driverVersionComparator>LESS_THAN</driverVersionComparator>
</gfxBlacklistEntry>

<gfxBlacklistEntry>
  <os>WINNT 6.2</os>
  <vendor>0x1022</vendor>
  <feature>GPU_PROCESS</feature>
  <featureStatus>BLOCKED_DRIVER_VERSION</featureStatus>
  <driverVersion>21.19.411.0</driverVersion>
  <driverVersionComparator>LESS_THAN</driverVersionComparator>
</gfxBlacklistEntry>

<gfxBlacklistEntry>
  <os>WINNT 6.3</os>
  <vendor>0x1002</vendor>
  <feature>GPU_PROCESS</feature>
  <featureStatus>BLOCKED_DRIVER_VERSION</featureStatus>
  <driverVersion>21.19.411.0</driverVersion>
  <driverVersionComparator>LESS_THAN</driverVersionComparator>
</gfxBlacklistEntry>

<gfxBlacklistEntry>
  <os>WINNT 6.3</os>
  <vendor>0x1022</vendor>
  <feature>GPU_PROCESS</feature>
  <featureStatus>BLOCKED_DRIVER_VERSION</featureStatus>
  <driverVersion>21.19.411.0</driverVersion>
  <driverVersionComparator>LESS_THAN</driverVersionComparator>
</gfxBlacklistEntry>
Flags: needinfo?(jmuizelaar)
Jorge, heads up that we may need a downloadable blocklist update to deal with a 57 issue.  No action yet, but please check what other information we need in addition to that in comment 28 to get this properly taken care of, once confirmed/approved.  Thanks!
Flags: needinfo?(jorge)
We can also distribute the hotfix addon with JS code to detect the version number and just set the pref value to false.

That's a much more targeted fix, but more work too obviously.
(Assignee)

Comment 31

a year ago
(In reply to Milan Sreckovic [:milan] from comment #28)
> This should be added to the downloadable blocklist (once the review passes
> and once we know disabling the GPU process helps); we need four entries to
> cover Windows 8 and 8.1, and both vendor IDs for AMD (0x1002 and 0x1022). 
> The rest is the same - block the GPU process for driver versions lesser than
> 21.19.411.0.

the issue also exists with Windows 10. It is not limited to windows 8 and 8.1
(Assignee)

Comment 32

a year ago
(In reply to Milan Sreckovic [:milan] from comment #27)
> Could we check with one of the users that experiences this if, after setting
> the rest of the preferences back to default, if setting
> layers.gpu-process.enabled to false in about:config, and restarting, the
> problem goes away?  If that works, we have a downloadable blocklist way of
> dealing with this short term.

the problem goes away when setting media.wmf.use-nv12-format to false
(Assignee)

Comment 33

a year ago
in 57 the pref is "media.windows-media-foundation.use-nv12-format"

confirmed by more users that setting it to false fixed their playback issue
(Reporter)

Comment 34

a year ago
(In reply to Milan Sreckovic [:milan] from comment #27)
> Could we check with one of the users that experiences this if, after setting
> the rest of the preferences back to default, if setting
> layers.gpu-process.enabled to false in about:config, and restarting, the
> problem goes away?  If that works, we have a downloadable blocklist way of
> dealing with this short term.

a user on irc confirmed that this fixed the playback problem for them as well.
Flags: needinfo?(madperson)
If this is other Windows versions as well, the blocklist should be this:

<gfxBlacklistEntry>
  <os>All</os>
  <vendor>0x1002</vendor>
  <feature>GPU_PROCESS</feature>
  <featureStatus>BLOCKED_DRIVER_VERSION</featureStatus>
  <driverVersion>21.19.411.0</driverVersion>
  <driverVersionComparator>LESS_THAN</driverVersionComparator>
</gfxBlacklistEntry>

<gfxBlacklistEntry>
  <os>All</os>
  <vendor>0x1022</vendor>
  <feature>GPU_PROCESS</feature>
  <featureStatus>BLOCKED_DRIVER_VERSION</featureStatus>
  <driverVersion>21.19.411.0</driverVersion>
  <driverVersionComparator>LESS_THAN</driverVersionComparator>
</gfxBlacklistEntry>
(Assignee)

Comment 36

a year ago
Kyle, would you have an exhaustive list of the AMD devices that are impacted with the nv12 bug?

My machines with an AMD adapter here, even with an old (2015) AMD driver don't have the problem.
It would help narrow the blacklisting. The solution right now is to disable the GPU compositor/decoding process on those devices.

Comment 37

a year ago
I suspect it's limited to our kaveri/carrizo based APU parts.

Did you have any previous discussion with AMD about this issue? I've been trying to track down the bug ID in our internal bug tracking system to see what it listed as affected parts - but I haven't been able to find it. If not, then I would say to start with the following list of DIDs:

kaveri:
0x9830..0x983f
0x9850..0x985f

carrizo:
0x9874 .. 0x9877
Since the move to Kinto, we (Add-ons) aren't the ones maintaining the graphics blocks. I assumed someone from your team had access to do it. As far as I can remember, the data looks right, though.
Flags: needinfo?(jorge)
(Assignee)

Comment 39

a year ago
(In reply to kyle.plumadore from comment #37)
> I suspect it's limited to our kaveri/carrizo based APU parts.
> 
> Did you have any previous discussion with AMD about this issue? I've been
> trying to track down the bug ID in our internal bug tracking system to see
> what it listed as affected parts - but I haven't been able to find it. If
> not, then I would say to start with the following list of DIDs:
> 

we did have a discussion about this a few months back when we found that using nv12 surfaces was incorrectly displayed on some AMD cards with some drivers.

You had mentioned that it was only fixed in drivers from 2017 and forward.


> kaveri:
> 0x9830..0x983f
> 0x9850..0x985f
> 
> carrizo:
> 0x9874 .. 0x9877
(Assignee)

Comment 40

a year ago
Kyle, we had in the reports 0x6613 as well...
(Assignee)

Updated

a year ago
Duplicate of this bug: 1417716
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment on attachment 8929064 [details]
Bug 1417442 - P1. Don't attempt to initialize MediaPrefs in the GPU process.

https://reviewboard.mozilla.org/r/200366/#review205522

Does GfxInfo even use MediaPrefs?
Attachment #8929064 - Flags: review?(dvander) → review+
The blocklist entry seems fine if we only do it for 57
Flags: needinfo?(jmuizelaar)
(Assignee)

Comment 48

a year ago
mozreview-review-reply
Comment on attachment 8929064 [details]
Bug 1417442 - P1. Don't attempt to initialize MediaPrefs in the GPU process.

https://reviewboard.mozilla.org/r/200366/#review205522

it doesn't.. however this is where the initialisation was put, because that's where the gfxPrefs were also initialised. I guess a convenient method initialised early enough to guarantee to be set before anything else.
gfxPrefs is initialized in a bunch of places.. probably gfxPlatform is the right place, not gfxInfo.
(Assignee)

Comment 50

a year ago
oh but that's what we did with MediaPrefs, we followed gfxPrefs around and added MediaPrefs initialization wherever gfxPrefs did it.

except that nothing was done to make MediaPrefs work in the GPU process unfortunately, which has lead to a lot of discrepency en preferences use.
(Assignee)

Comment 51

a year ago
I can confirm that those 4 patches apply on release and beta without changes.

P3 would be the safest to apply on release (it would get around the problem on all machines with an AMD cards).
P1 and P2 are the actual fixes required for everything to get back in order.

P4 is only useful to verify the change is working as you can have description on what is happening
After talking to jrmuizel, we agreed we should just block AMD (not ATI), and explicitly make it 57 only, assuming the patches above would show up in 57.0.1.

<gfxBlacklistEntry>
  <os>All</os>
  <vendor>0x1002</vendor>
  <feature>GPU_PROCESS</feature>
  <featureStatus>BLOCKED_DRIVER_VERSION</featureStatus>
  <driverVersion>21.19.411.0</driverVersion>
  <driverVersionComparator>LESS_THAN</driverVersionComparator>
  <versionRange minVersion="57.0" maxVersion="57.0"/>
</gfxBlacklistEntry>
Heh, I opened bug 1418087 for the blocklist update, but I see it went to :jorgev and we already established that's not done by that team anymore.  :kev, :jorgev, do you know where that stuff lives?  I recall perhaps even having access, but I can't find it now.
Flags: needinfo?(kev)
Flags: needinfo?(jorge)
I'll send you an email with the details.
Flags: needinfo?(kev)
Flags: needinfo?(jorge)
According to the blocklist collection the people having the permission to do the edit are:

- amckay@mozilla.com
- awagner@mozilla.com
- jvillalobos@mozilla.com
- pkewisch@mozilla.com

Jorge if you can do it one more time it would be great, we can then figure out new permissions for that blocklist if your team is not planning to do it anymore, but that's the current setup.

Comment 56

a year ago
mozreview-review
Comment on attachment 8928692 [details]
Bug 1417442 - P3. Don't enable nv12 surfaces if we failed to parse the version string.

https://reviewboard.mozilla.org/r/199942/#review205900
Attachment #8928692 - Flags: review?(matt.woodrow) → review+

Comment 57

a year ago
mozreview-review
Comment on attachment 8928693 [details]
Bug 1417442 - P4. Indicate surface type in decoder description.

https://reviewboard.mozilla.org/r/199944/#review205902
Attachment #8928693 - Flags: review?(matt.woodrow) → review+

Comment 58

a year ago
Pushed by jyavenard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d197e7c3b897
P1. Don't attempt to initialize MediaPrefs in the GPU process. r=dvander
https://hg.mozilla.org/integration/autoland/rev/f1ce735006d8
P2. fix nsIGfxInfo in GPU process. r=dvander
https://hg.mozilla.org/integration/autoland/rev/eeb2f534cf10
P3. Don't enable nv12 surfaces if we failed to parse the version string. r=mattwoodrow
https://hg.mozilla.org/integration/autoland/rev/be47971d367a
P4. Indicate surface type in decoder description. r=mattwoodrow

Comment 59

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/d197e7c3b897
https://hg.mozilla.org/mozilla-central/rev/f1ce735006d8
https://hg.mozilla.org/mozilla-central/rev/eeb2f534cf10
https://hg.mozilla.org/mozilla-central/rev/be47971d367a
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox59: ? → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
On a side note - there is no way to blocklist GPU process, so this is the only solution we have right now.
(Assignee)

Comment 61

a year ago
Comment on attachment 8928692 [details]
Bug 1417442 - P3. Don't enable nv12 surfaces if we failed to parse the version string.

Approval Request Comment
[Feature/Bug causing the regression]: Issue is quite old (first introduced in 55) but it was only enabled in 57 for AMD users.
[User impact if declined]: Unwatchable videos (any videos) for AMD users
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: yes. People with access to older AMD cards with older drivers
[List of other uplifts needed for the feature/fix]: all 4 patches of this bug
[Is the change risky?]: medium. Enabling gfxInfo in the GPU process could cause unforeseen issue. This is unlikely however.
[Why is the change risky/not risky?]:
[String changes made/needed]: none
Attachment #8928692 - Flags: approval-mozilla-beta?
Hi philipp,
Can you help reach someone to verify this?
Flags: needinfo?(madperson)
(Reporter)

Updated

a year ago
Duplicate of this bug: 1419050
Duplicate of this bug: 1418843
Noting that we just pushed a system add-on to fix this for 57 release, in bug 1418556.
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #65)
> Noting that we just pushed a system add-on to fix this for 57 release, in
> bug 1418556.

Is there a way for users to tell if they have this addon yet?
(In reply to Ben Kelly [:bkelly] from comment #66)
> (In reply to Liz Henry (:lizzard) (needinfo? me) from comment #65)
> > Noting that we just pushed a system add-on to fix this for 57 release, in
> > bug 1418556.
> 
> Is there a way for users to tell if they have this addon yet?

Yes, it shows up in `about:support` as `disable-media-wmf-nv12@mozilla.org`

Just FYI - hotfix update is not triggered by the About page, it should be automatically fetched in the background over the next 24 hours, and within a few minutes of anyone starting up at any point after that.

Last we measured, it took ~3 days to get hotfix to 90+% of users.
Comment on attachment 8928692 [details]
Bug 1417442 - P3. Don't enable nv12 surfaces if we failed to parse the version string.

Fix some rendering issues, we did an hotfix for that in release, we clearly need that in beta too!
Attachment #8928692 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
status-firefox58: ? → affected
Comment on attachment 8928692 [details]
Bug 1417442 - P3. Don't enable nv12 surfaces if we failed to parse the version string.

[Triage Comment]
Discussed with jya on irc, taking it to release just to be safe.
Attachment #8928692 - Flags: approval-mozilla-release+
(Reporter)

Comment 70

a year ago
(In reply to Gerry Chang [:gchang] from comment #62)
> Hi philipp,
> Can you help reach someone to verify this?
sorry, i didn't come across any affected user able/willing to check that in nightly till now...
Flags: needinfo?(madperson)
Comment on attachment 8928692 [details]
Bug 1417442 - P3. Don't enable nv12 surfaces if we failed to parse the version string.

Sorry, I didn't realize that the request was for the 4 patches. I will think again for 57.
Attachment #8928692 - Flags: approval-mozilla-release+ → approval-mozilla-release?
(In reply to Robert Helmer [:rhelmer] from comment #67)
> (In reply to Ben Kelly [:bkelly] from comment #66)
> > Is there a way for users to tell if they have this addon yet?
> 
> Yes, it shows up in `about:support` as `disable-media-wmf-nv12@mozilla.org`

If I asked users to disable hardware acceleration for this issue, is it reasonable to ask them to re-enable hardware acceleration if they have this system addon?
(Assignee)

Comment 73

a year ago
Disabling HW acceleration was a bad advice to start with :( especially as the issue was identified almost immediately.

Yes.. Please ask them to re-enable HW acceleration.

They can also manually set the preference containing .use-nv12-format to false.
(Assignee)

Comment 74

a year ago
(In reply to Sylvestre Ledru [:sylvestre] from comment #71)
> Comment on attachment 8928692 [details]
> Bug 1417442 - P3. Don't enable nv12 surfaces if we failed to parse the
> version string.
> 
> Sorry, I didn't realize that the request was for the 4 patches. I will think
> again for 57.

We could just uplift P3 if it's a concern. The effects are identical to the hotfix, but people without the GPU decoder active will benefit however of faster display path
(In reply to Jean-Yves Avenard [:jya] from comment #73)
> Disabling HW acceleration was a bad advice to start with :( especially as
> the issue was identified almost immediately.

Sorry I'm not omniscient and unaware of every bug reported in the system.  This was the advice I got from media/gfx for discolored content in previous releases.

> Yes.. Please ask them to re-enable HW acceleration.
> 
> They can also manually set the preference containing .use-nv12-format to
> false.

I will follow-up with this next week after the system addon has had time to propagate.
(Assignee)

Comment 76

a year ago
(In reply to Ben Kelly [:bkelly] from comment #75)

> I will follow-up with this next week after the system addon has had time to
> propagate.

If you can get in touch to tell them to re-enable the HW decoder, can't they set .use-nv12-format to false while at it?
(In reply to Jean-Yves Avenard [:jya] from comment #76)
> (In reply to Ben Kelly [:bkelly] from comment #75)
> > I will follow-up with this next week after the system addon has had time to
> > propagate.
> 
> If you can get in touch to tell them to re-enable the HW decoder, can't they
> set .use-nv12-format to false while at it?

I try to avoid directing non-technical users to about:config.  Its kind of a footgun and the more steps the more likely they are to just ignore me.
(Reporter)

Updated

a year ago
Duplicate of this bug: 1419945
Flags: qe-verify+
(In reply to Jean-Yves Avenard [:jya] from comment #74)
> We could just uplift P3 if it's a concern. 

OK, let's do that then:
https://hg.mozilla.org/releases/mozilla-release/rev/c971c6beda8dd8431ed66b45c23aa8694fe84a6a
status-firefox57: affected → fixed
Attachment #8928692 - Flags: approval-mozilla-release? → approval-mozilla-release+
Added to the release notes with "Fix a video color distortion issue on YouTube and other video sites with some AMD devices (bug 1417442)" as wording
relnote-firefox: --- → 57+

Comment 82

a year ago
Hi, I hope that this issue is actually fixed and it's same/similar issue I have. 
Graphic distortion was happening on a daily basis on my Dell 5510 laptop with windows 7 - even on sites that were build dashboards without any video. 

It have 2 graphic cars Intel P530 and Nvidia Quadro M1000M. Nvidai is my main graphic card. I updated nvidia drier to latest available on dell site (nVIDIA-N15V-GM-N16V-GM-and-GeForce-Graphics-Driver_XRJCR_WIN_22.21.13.8477_A03) still the issue was there.

So I think this issue wasn't related to AMD only or issue I have is different.
(Assignee)

Comment 83

a year ago
the bug was about an issue with the AMD devices. Not nvidia or intel, and certainly not the Quadro M1000M.

The bug would also only refer to issue related to D3D11, which Windows 7 doesn't do (it's D3D9 maximum)

So if you're seeing a problem, it's not going to be a recent regression found in 57 only, as the D3D9 code hasn't changed in a long time...

If you are seeing a problem, is it fixed when you follow the instructions in Comment 73? I'm guessing not.

in any case, re-open a bug.

Comment 84

a year ago
My issue is still there > Bug 1422114

Comment 85

a year ago
Created attachment 8934189 [details]
A printscreen of the bug

NOT fixed in Firefox 57.0.1.

Comment 86

a year ago
Not fixed and I'm using a NVIDIA GTX 550Ti with updated drivers.
I'll clone a bug for nvidia.
I tried to reproduced this issue on:
1. 59.0a1 (build ID: 20171115220414) on Windows 8.1 x64, ATI Radeon 3000 Graphics, Driver Version: 8.970.100.7000, Driver Date :11-16-2012 but it doesn't reproduced for me.
2. Not reproduced on Windows 7 x86, AMD 760G (Microsoft Corporation WDDM 1.1, Driver Version: 8.56.1.16 , Driver Date: 2009 not reproduced.
3. Not reproduced on Windows 7 x64, NVIDIA, Driver Version: OpenGL ES 2.0 (ANGLE 2.1.0.db3422764a9b), Driver Date: 9.18.13.4181 (2015)
Could someone help me to reproduce this issue?
Flags: needinfo?(jyavenard)
(Assignee)

Comment 89

11 months ago
the list of affected drivers and cards were mentioned earlier on. you need to use one of those to be certain.. not all cards were affected.
Flags: needinfo?(jyavenard)

Comment 90

10 months ago
Created attachment 8941244 [details]
ChromeVsFirefox.JPG

Comment 91

10 months ago
Comment on attachment 8941244 [details]
ChromeVsFirefox.JPG

Application Basics
------------------

Name: Firefox
Version: 57.0.2
Build ID: 20171206182557
Update Channel: release-cck-mozilla101
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
OS: Windows_NT 10.0
Multiprocess Windows: 11/11 (Enabled by default)
Web Content Processes: 2/1
Stylo: true (enabled by default)
Google Key: Found
Mozilla Location Service Key: Found
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Firefox Features
----------------

Name: Activity Stream
Version: 2017.11.07.1100-7f4e3634
ID: activity-stream@mozilla.org

Name: Application Update Service Helper
Version: 2.0
ID: aushelper@mozilla.org

Name: Firefox Screenshots
Version: 19.2.0
ID: screenshots@mozilla.org

Name: Follow-on Search Telemetry
Version: 0.9.6
ID: followonsearch@mozilla.com

Name: Form Autofill
Version: 1.0
ID: formautofill@mozilla.org

Name: Multi-process staged rollout
Version: 3.05
ID: e10srollout@mozilla.org

Name: Photon onboarding
Version: 1.0
ID: onboarding@mozilla.org

Name: Pocket
Version: 1.0.5
ID: firefox@getpocket.com

Name: Shield Recipe Client
Version: 76.1
ID: shield-recipe-client@mozilla.org

Name: Web Compat
Version: 1.1
ID: webcompat@mozilla.org

Extensions
----------

Name: Adaware Ad Block
Version: 2.0.0.6
Enabled: true
ID: AdBlockerLavaSoftFF@lavasoft.com

Name: Enhancer for YouTube™
Version: 2.0.55
Enabled: true
ID: enhancerforyoutube@maximerf.addons.mozilla.org

Name: Flash Video Downloader
Version: 16.0.5
Enabled: true
ID: artur.dubovoy@gmail.com

Name: New Tab Override
Version: 11.0.0
Enabled: true
ID: newtaboverride@agenedia.com

Name: Remove Facebook Sponsored Posts
Version: 0.0.8
Enabled: true
ID: {aa2d4c7b-621a-4aa4-a618-6a1656d06d8d}

Name: Auto Opt-out for Flash
Version: 1.1.0
Enabled: false
ID: @mcafee-optout

Name: Autoplay No More
Version: 0.3.4
Enabled: false
ID: jid1-XQEcUtyD5PwB8w@jetpack

Name: Awesome Screenshot - Capture, Annotate & More
Version: 3.0.21
Enabled: false
ID: jid0-GXjLLfbCoAx0LcltEdFrEkQdQPI@jetpack

Name: Disable Autoplay for YouTube™
Version: 0.1.0
Enabled: false
ID: {b414ff62-445b-4713-853e-28e4f76b01b4}

Name: Empty Cache Button
Version: 3.4
Enabled: false
ID: {4cc4a13b-94a6-7568-370d-5f9de54a9c7f}

Name: MEGA
Version: 3.20.5
Enabled: false
ID: firefox@mega.co.nz

Name: Take Webpage Screenshots Entirely - FireShot
Version: 0.98.94.10
Enabled: false
ID: {0b457cAA-602d-484a-8fe7-c1d894a011ba}

Name: TinEye Reverse Image Search
Version: 1.3.2
Enabled: false
ID: tineye@ideeinc.com

Name: YouTube High Definition
Version: 62.0
Enabled: false
ID: {7b1bf0b6-a1b9-42b0-b75d-252036438bdc}

Name: YouTube™ No Buffer (Stop Auto-playing)
Version: 0.2.6
Enabled: false
ID: {551f032e-353d-4d10-b186-b0026b1a666d}

Graphics
--------

Features
Compositing: Direct3D 11 (Advanced Layers)
Asynchronous Pan/Zoom: wheel input enabled; scrollbar drag enabled; keyboard enabled; autoscroll enabled
WebGL 1 Driver WSI Info: EGL_VENDOR: Google Inc. (adapter LUID: 00000000000ecf50) EGL_VERSION: 1.4 (ANGLE 2.1.0.dec065540d5f) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_ANGLE_direct_composition EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
WebGL 1 Driver Renderer: Google Inc. -- ANGLE (ATI Mobility Radeon HD 3650 Direct3D11 vs_4_1 ps_4_1)
WebGL 1 Driver Version: OpenGL ES 2.0 (ANGLE 2.1.0.dec065540d5f)
WebGL 1 Driver Extensions: GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
WebGL 1 Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc MOZ_WEBGL_depth_texture
WebGL 2 Driver WSI Info: EGL_VENDOR: Google Inc. (adapter LUID: 00000000000ecf50) EGL_VERSION: 1.4 (ANGLE 2.1.0.dec065540d5f) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_ANGLE_direct_composition EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
WebGL 2 Driver Renderer: Google Inc. -- ANGLE (ATI Mobility Radeon HD 3650 Direct3D11 vs_4_1 ps_4_1)
WebGL 2 Driver Version: OpenGL ES 3.0 (ANGLE 2.1.0.dec065540d5f)
WebGL 2 Driver Extensions: GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_float GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_norm16 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_EGL_image_external_essl3 GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
WebGL 2 Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc
Direct2D: true
DirectWrite: true (10.0.14393.1358)
GPU #1
Active: Yes
Description: ATI Mobility Radeon HD 3650
Vendor ID: 0x1002
Device ID: 0x9591
Driver Version: 8.792.5.2000
Driver Date: 5-4-2012
Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Subsys ID: 211717aa
RAM: 256

Diagnostics
AzureCanvasAccelerated: 0
AzureCanvasBackend: Direct2D 1.1
AzureCanvasBackend (UI Process): skia
AzureContentBackend: Direct2D 1.1
AzureContentBackend (UI Process): skia
AzureFallbackCanvasBackend (UI Process): cairo
GPUProcessPid: 3896
Decision Log
HW_COMPOSITING:
force_enabled by user: Force-enabled by pref
WEBRENDER:
opt-in by default: WebRender is an opt-in feature
unavailable by runtime: Build doesn't include WebRender




Media
-----

Audio Backend: wasapi
Max Channels: 2
Preferred Channel Layout: stereo
Preferred Sample Rate: 44100
Output Devices
Name: Group
Mic Volume (Conexant 20561 SmartAudio HD): HDAUDIO\FUNC_01&VEN_14F1&DEV_5051&SUBSYS_17AA2100&REV_1000\4&1ef6f303&0&0001
Line (Conexant 20561 SmartAudio HD): HDAUDIO\FUNC_01&VEN_14F1&DEV_5051&SUBSYS_17AA2100&REV_1000\4&1ef6f303&0&0001
Speakers (AnvSoft Virtual Sound Device): ROOT\MEDIA\0000
Headphones (Conexant 20561 SmartAudio HD): HDAUDIO\FUNC_01&VEN_14F1&DEV_5051&SUBSYS_17AA2100&REV_1000\4&1ef6f303&0&0001
Line (Conexant 20561 SmartAudio HD): HDAUDIO\FUNC_01&VEN_14F1&DEV_5051&SUBSYS_17AA2100&REV_1000\4&1ef6f303&0&0001
Speakers (Conexant 20561 SmartAudio HD): HDAUDIO\FUNC_01&VEN_14F1&DEV_5051&SUBSYS_17AA2100&REV_1000\4&1ef6f303&0&0001
SPDIF Interface (Conexant 20561 SmartAudio HD): HDAUDIO\FUNC_01&VEN_14F1&DEV_5051&SUBSYS_17AA2100&REV_1000\4&1ef6f303&0&0001
Headphones (Conexant 20561 SmartAudio HD): HDAUDIO\FUNC_01&VEN_14F1&DEV_5051&SUBSYS_17AA2100&REV_1000\4&1ef6f303&0&0001
Mic Volume (Conexant 20561 SmartAudio HD): HDAUDIO\FUNC_01&VEN_14F1&DEV_5051&SUBSYS_17AA2100&REV_1000\4&1ef6f303&0&0001
Input Devices
Name: Group
Internal AUX Jack (Conexant 20561 SmartAudio HD): HDAUDIO\FUNC_01&VEN_14F1&DEV_5051&SUBSYS_17AA2100&REV_1000\4&1ef6f303&0&0001
MIDI (AnvSoft Virtual Sound Device): ROOT\MEDIA\0000
Internal AUX Jack (Conexant 20561 SmartAudio HD): HDAUDIO\FUNC_01&VEN_14F1&DEV_5051&SUBSYS_17AA2100&REV_1000\4&1ef6f303&0&0001
Internal Microphone (Conexant 20561 SmartAudio HD): HDAUDIO\FUNC_01&VEN_14F1&DEV_5051&SUBSYS_17AA2100&REV_1000\4&1ef6f303&0&0001
Internal AUX Jack (Conexant 20561 SmartAudio HD): HDAUDIO\FUNC_01&VEN_14F1&DEV_5051&SUBSYS_17AA2100&REV_1000\4&1ef6f303&0&0001
MIDI (AnvSoft Virtual Sound Device): ROOT\MEDIA\0000
Internal AUX Jack (Conexant 20561 SmartAudio HD): HDAUDIO\FUNC_01&VEN_14F1&DEV_5051&SUBSYS_17AA2100&REV_1000\4&1ef6f303&0&0001
:
Microphone (AnvSoft Virtual Sound Device): ROOT\MEDIA\0000
MIDI (AnvSoft Virtual Sound Device): ROOT\MEDIA\0000
External Microphone (Conexant 20561 SmartAudio HD): HDAUDIO\FUNC_01&VEN_14F1&DEV_5051&SUBSYS_17AA2100&REV_1000\4&1ef6f303&0&0001
External Microphone (Conexant 20561 SmartAudio HD): HDAUDIO\FUNC_01&VEN_14F1&DEV_5051&SUBSYS_17AA2100&REV_1000\4&1ef6f303&0&0001

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 1048576
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.hashstats_reported: 1
browser.cache.disk.smart_size.enabled: false
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 4
browser.cache.memory.capacity: 65536
browser.download.folderList: 0
browser.link.open_newwindow: 2
browser.places.smartBookmarksVersion: 8
browser.search.suggest.enabled: false
browser.search.update: false
browser.search.useDBForOrder: true
browser.sessionstore.restore_on_demand: false
browser.sessionstore.upgradeBackup.latestBuildID: 20171206182557
browser.startup.homepage: www.google.ca
browser.startup.homepage_override.buildID: 20171206182557
browser.startup.homepage_override.mstone: 57.0.2
browser.tabs.crashReporting.includeURL: true
browser.tabs.drawInTitlebar: false
browser.tabs.remote.autostart.2: true
browser.tabs.warnOnClose: false
browser.tabs.warnOnOpen: false
browser.urlbar.maxRichResults: 12
browser.urlbar.suggest.bookmark: false
browser.urlbar.suggest.history: false
browser.urlbar.suggest.openpage: false
dom.apps.lastUpdate.buildID: 20161019084923
dom.apps.lastUpdate.mstone: 49.0.2
dom.apps.reset-permissions: true
dom.ipc.plugins.asyncInit.enabled: true
dom.ipc.plugins.flash.disable-protected-mode: true
dom.mozApps.used: true
dom.push.enabled: false
dom.push.userAgentID: 59c134499e0f4d9ab54ac4d0a8bd8c20
extensions.lastAppVersion: 57.0.2
font.internaluseonly.changed: true
general.autoScroll: false
gfx.crash-guard.d3d11layers.appVersion: 56.0
gfx.crash-guard.d3d11layers.deviceID: 0x9591
gfx.crash-guard.d3d11layers.driverVersion: 8.970.100.9001
gfx.crash-guard.d3d11layers.feature-d2d: true
gfx.crash-guard.d3d11layers.feature-d3d11: true
gfx.crash-guard.status.: 3
gfx.crash-guard.status.d3d11layers: 2
gfx.crash-guard.status.d3d11video: 2
gfx.crash-guard.status.d3d9video: 2
keyword.URL: true
layers.acceleration.force-enabled: true
layers.mlgpu.sanity-test-failed: false
media.benchmark.vp9.fps: 39
media.benchmark.vp9.versioncheck: 2
media.gmp-eme-adobe.abi: x86_64-msvc-x64
media.gmp-eme-adobe.lastUpdate: 1474776875
media.gmp-eme-adobe.version: 17
media.gmp-gmpopenh264.abi: x86_64-msvc-x64
media.gmp-gmpopenh264.enabled: false
media.gmp-gmpopenh264.lastUpdate: 1472413220
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20171206182557
media.gmp-manager.lastCheck: 1515539389
media.gmp-widevinecdm.abi: x86_64-msvc-x64
media.gmp-widevinecdm.autoupdate: true
media.gmp-widevinecdm.lastUpdate: 1512861379
media.gmp-widevinecdm.version: 1.4.8.1008
media.gmp.storage.version.observed: 1
media.hardware-video-decoding.failed: false
media.webrtc.debug.aec_log_dir: C:\Users\ADMINI~1\AppData\Local\Temp
media.webrtc.debug.log_file: C:\Users\ADMINI~1\AppData\Local\Temp\WebRTC.log
media.windows-media-foundation.allow-d3d11-dxva: false
network.cookie.prefsMigrated: true
network.dns.disablePrefetch: true
network.http.pipelining: true
network.http.pipelining.aggressive: true
network.http.pipelining.max-optimistic-requests: 32
network.http.pipelining.maxrequests: 96
network.http.pipelining.maxsize: 600000
network.http.pipelining.ssl: true
network.http.proxy.pipelining: true
network.http.speculative-parallel-limit: 0
network.predictor.cleaned-up: true
network.predictor.enabled: false
network.prefetch-next: false
places.database.lastMaintenance: 1515486844
places.history.expiration.transient_current_max_pages: 143923
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.flash: 2
plugins.ctprollout.cohort: user-changed-from-test
plugins.ctprollout.cohortSample: 0.078973
plugins.flashBlock.enabled: false
print.printer_Brother_HL-2040_series.print_bgcolor: false
print.printer_Brother_HL-2040_series.print_bgimages: false
print.printer_Brother_HL-2040_series.print_duplex: -437918235
print.printer_Brother_HL-2040_series.print_edge_bottom: 0
print.printer_Brother_HL-2040_series.print_edge_left: 0
print.printer_Brother_HL-2040_series.print_edge_right: 0
print.printer_Brother_HL-2040_series.print_edge_top: 0
print.printer_Brother_HL-2040_series.print_evenpages: true
print.printer_Brother_HL-2040_series.print_footercenter:
print.printer_Brother_HL-2040_series.print_footerleft: &PT
print.printer_Brother_HL-2040_series.print_footerright: &D
print.printer_Brother_HL-2040_series.print_headercenter:
print.printer_Brother_HL-2040_series.print_headerleft: &T
print.printer_Brother_HL-2040_series.print_headerright: &U
print.printer_Brother_HL-2040_series.print_in_color: true
print.printer_Brother_HL-2040_series.print_margin_bottom: 0.5
print.printer_Brother_HL-2040_series.print_margin_left: 0.5
print.printer_Brother_HL-2040_series.print_margin_right: 0.5
print.printer_Brother_HL-2040_series.print_margin_top: 0.5
print.printer_Brother_HL-2040_series.print_oddpages: true
print.printer_Brother_HL-2040_series.print_orientation: 0
print.printer_Brother_HL-2040_series.print_page_delay: 50
print.printer_Brother_HL-2040_series.print_paper_data: 1
print.printer_Brother_HL-2040_series.print_paper_height: 11.00
print.printer_Brother_HL-2040_series.print_paper_name:
print.printer_Brother_HL-2040_series.print_paper_size_unit: 0
print.printer_Brother_HL-2040_series.print_paper_width: 8.50
print.printer_Brother_HL-2040_series.print_resolution: 600
print.printer_Brother_HL-2040_series.print_reversed: false
print.printer_Brother_HL-2040_series.print_scaling: 1.00
print.printer_Brother_HL-2040_series.print_shrink_to_fit: true
print.printer_Brother_HL-2040_series.print_to_file: false
print.printer_Brother_HL-2040_series.print_unwriteable_margin_bottom: 0
print.printer_Brother_HL-2040_series.print_unwriteable_margin_left: 0
print.printer_Brother_HL-2040_series.print_unwriteable_margin_right: 0
print.printer_Brother_HL-2040_series.print_unwriteable_margin_top: 0
print.printer_Microsoft_Print_to_PDF.print_bgcolor: false
print.printer_Microsoft_Print_to_PDF.print_bgimages: false
print.printer_Microsoft_Print_to_PDF.print_duplex: -437918235
print.printer_Microsoft_Print_to_PDF.print_edge_bottom: 0
print.printer_Microsoft_Print_to_PDF.print_edge_left: 0
print.printer_Microsoft_Print_to_PDF.print_edge_right: 0
print.printer_Microsoft_Print_to_PDF.print_edge_top: 0
print.printer_Microsoft_Print_to_PDF.print_evenpages: true
print.printer_Microsoft_Print_to_PDF.print_footercenter:
print.printer_Microsoft_Print_to_PDF.print_footerleft: &PT
print.printer_Microsoft_Print_to_PDF.print_footerright: &D
print.printer_Microsoft_Print_to_PDF.print_headercenter:
print.printer_Microsoft_Print_to_PDF.print_headerleft: &T
print.printer_Microsoft_Print_to_PDF.print_headerright: &U
print.printer_Microsoft_Print_to_PDF.print_in_color: true
print.printer_Microsoft_Print_to_PDF.print_margin_bottom: 0.5
print.printer_Microsoft_Print_to_PDF.print_margin_left: 0.5
print.printer_Microsoft_Print_to_PDF.print_margin_right: 0.5
print.printer_Microsoft_Print_to_PDF.print_margin_top: 0.5
print.printer_Microsoft_Print_to_PDF.print_oddpages: true
print.printer_Microsoft_Print_to_PDF.print_orientation: 0
print.printer_Microsoft_Print_to_PDF.print_page_delay: 50
print.printer_Microsoft_Print_to_PDF.print_paper_data: 1
print.printer_Microsoft_Print_to_PDF.print_paper_height: -1.00
print.printer_Microsoft_Print_to_PDF.print_paper_name:
print.printer_Microsoft_Print_to_PDF.print_paper_size_unit: 0
print.printer_Microsoft_Print_to_PDF.print_paper_width: -1.00
print.printer_Microsoft_Print_to_PDF.print_resolution: 600
print.printer_Microsoft_Print_to_PDF.print_reversed: false
print.printer_Microsoft_Print_to_PDF.print_scaling: 1.00
print.printer_Microsoft_Print_to_PDF.print_shrink_to_fit: true
print.printer_Microsoft_Print_to_PDF.print_to_file: false
print.printer_Microsoft_Print_to_PDF.print_unwriteable_margin_bottom: 0
print.printer_Microsoft_Print_to_PDF.print_unwriteable_margin_left: 0
print.printer_Microsoft_Print_to_PDF.print_unwriteable_margin_right: 0
print.printer_Microsoft_Print_to_PDF.print_unwriteable_margin_top: 0
privacy.cpd.cache: false
privacy.cpd.formdata: false
privacy.donottrackheader.enabled: true
privacy.sanitize.timeSpan: 0
security.sandbox.content.tempDirSuffix: {9507705a-5a12-476f-940a-76a8b9dbde82}
services.sync.declinedEngines: tabs,history,forms
services.sync.engine.history: false
services.sync.engine.prefs.modified: false
services.sync.engine.tabs: false
services.sync.lastPing: 1515469116
services.sync.lastSync: Tue Jan 09 2018 17:09:06 GMT-0600 (Canada Central Standard Time)
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1514693813
ui.osk.debug.keyboardDisplayReason: IKPOS: Touch screen not found.
ui.osk.enabled: false

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0
Accessible Handler Used: true
Accessibility Instantiator:

Library Versions
----------------

NSPR
Expected minimum version: 4.17
Version in use: 4.17

NSS
Expected minimum version: 3.33
Version in use: 3.33

NSSSMIME
Expected minimum version: 3.33
Version in use: 3.33

NSSSSL
Expected minimum version: 3.33
Version in use: 3.33

NSSUTIL
Expected minimum version: 3.33
Version in use: 3.33

Experimental Features
---------------------

Sandbox
-------

Content Process Sandbox Level: 3
Effective Content Process Sandbox Level: 3
Removing the qe+ flag since we cannot confirm the fix due to the lack of adequate hardware.
Flags: qe-verify+

Comment 93

10 months ago
(In reply to Timea Zsoldos from comment #92)
> Removing the qe+ flag since we cannot confirm the fix due to the lack of
> adequate hardware.

I can test...but I need to know which version to load or what to change.
If you have AMD cards with older drivers, please reproduced this issue on 59.0a1 from 2017.11.15 (build ID: 20171115220414) and verified on Firefox 57, 58 and 59. Please let me known if you managed to do this!

Comment 95

10 months ago
(In reply to Timea Zsoldos from comment #94)
> If you have AMD cards with older drivers, please reproduced this issue on
> 59.0a1 from 2017.11.15 (build ID: 20171115220414) and verified on Firefox
> 57, 58 and 59. Please let me known if you managed to do this!

Yes, I am currently having this issue on 57.0.2 with ATI Mobility Radeon HD 3650.
So just to confirm, you want me to upgrade from 57.0.2 64bit to 59.0a1 and test?
Flags: needinfo?(timea.zsoldos)
Based on comment 81, this issue is fixed on some AMD drivers. Please file a new bug for your issue!
Flags: needinfo?(timea.zsoldos)

Comment 97

8 months ago
This bug is still occurring for me. I have reproduced it on Firefox 59.0 and on 61.0a1 (Build ID: 20180315223216). I am running Windows 8.1 Pro 64 bit with an ATI Radeon HD 2400 PRO card (Driver version: 8.97.10.6).

On the test video I used on Youtube the 480p version with Codecs: avc1.4d401e (135) / opus (251) has the pink and green distortion however the 360p version with Codecs: avc1.4d4015 (134) / opus (251) plays without issue.
You need to log in before you can comment on or make changes to this bug.