BigInt TypedArray extensions

RESOLVED FIXED in Firefox 68

Status

()

enhancement
P2
normal
RESOLVED FIXED
Last year
5 days ago

People

(Reporter: terpri, Assigned: terpri)

Tracking

(Depends on 4 bugs, Regressed 1 bug, {dev-doc-needed})

Trunk
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox61 wontfix, firefox68 fixed)

Details

Attachments

(1 attachment, 9 obsolete attachments)

Assignee

Description

Last year
Implement BigInt features related to TypedArrays, including:

 - BigInt64Array and BigUint64Array
 - 64-bit DataView methods
 - 64-bit atomic operations
Priority: -- → P2
Assignee

Comment 1

Last year
Assignee

Comment 2

Last year
Posted patch Part 2: TypedArrays (obsolete) — Splinter Review
Assignee

Comment 3

Last year
Posted patch Part 3: DataViews (obsolete) — Splinter Review
Assignee

Comment 4

Last year
Posted patch Part 4: Atomics (obsolete) — Splinter Review
Assignee

Updated

Last year
Depends on: js-bigint
Assignee

Comment 5

Last year
Assignee

Updated

Last year
Attachment #8973906 - Attachment is obsolete: true
Attachment #8973907 - Attachment is obsolete: true
Attachment #8973908 - Attachment is obsolete: true
Attachment #8973909 - Attachment is obsolete: true
Assignee

Comment 6

Last year
Posted patch Part 2: TypedArrays (obsolete) — Splinter Review
Assignee

Comment 7

Last year
Posted patch Part 3: DataViews (obsolete) — Splinter Review
Assignee

Comment 8

Last year
Posted patch Part 4: Atomics (obsolete) — Splinter Review
Blocks: js-bigint
No longer depends on: js-bigint
Assignee

Updated

7 months ago
Attachment #8981519 - Attachment is obsolete: true
Assignee

Updated

7 months ago
Attachment #8981520 - Attachment is obsolete: true
Assignee

Updated

7 months ago
Attachment #8981521 - Attachment is obsolete: true
Assignee

Updated

7 months ago
Attachment #8981522 - Attachment is obsolete: true
Assignee

Comment 10

6 months ago
Rough draft of Ion support for BigInt values

Updated

5 months ago
Depends on: 1522431

Comment on attachment 9032069 [details]
Bug 1507484 - Implement JIT support for BigInt

Revision D14826 was moved to bug 1507484. Setting attachment 9032069 [details] to obsolete.

Attachment #9032069 - Attachment is obsolete: true

Updated

4 months ago
Depends on: 1526838

Updated

4 months ago
Blocks: js-bigint-ship
No longer blocks: js-bigint
Assignee

Updated

4 months ago
Depends on: 1528582
Duplicate of this bug: 1530828

Updated

4 months ago
Assignee: nobody → robin
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Assignee

Updated

4 months ago
Depends on: 1531647
Assignee

Updated

3 months ago
Depends on: 1536695
Assignee

Updated

3 months ago
Depends on: 1536699
Assignee

Updated

3 months ago
Depends on: 1536702
Assignee

Updated

3 months ago
Depends on: 1536703
Assignee

Updated

3 months ago
Depends on: 1538408
Assignee

Updated

3 months ago
Keywords: checkin-needed

Comment 13

3 months ago

Pushed by aiakab@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6ccad746f5d8
Implement BigInt64 and BigUint64Array. r=wingo,jwalden,sfink

Keywords: checkin-needed

Comment 14

3 months ago
Backout by nerli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/68ac00e863e0
Backed out changeset 6ccad746f5d8 for Linting opt failure in TypedArray.js CLOSED TREE

Wow, that's irritating! The error was "invalid typeof comparison value", complaining about "bigint". The bug is in the linter; since bigint, there's a new typeof around!

Updated

3 months ago
Depends on: 1540982

Apparently a workaround can be adding // eslint-disable-line valid-typeof to the end of the "offending" lines. Or doing like

// eslint-disable valid-typeof
...
// eslint-enable valid-typeof

Updated

3 months ago
No longer depends on: 1540982

Updated

3 months ago
See Also: → 1540982

(In reply to Andy Wingo [:wingo] from comment #17)

Apparently a workaround can be adding // eslint-disable-line valid-typeof to the end of the "offending" lines. Or doing like

// eslint-disable valid-typeof
...
// eslint-enable valid-typeof

You can also use:

// eslint-disable-next-line valid-typeof

(which I find generally nicer overall).

Assignee

Comment 19

3 months ago

i updated the typeof expressions; this should be landable now (thanks :wingo and :standard8 for suggesting workarounds)

try run: https://treeherder.mozilla.org/#/jobs?repo=try&revision=fec598b8ec6cc75f702258798bec22b73b7b1adb

Flags: needinfo?(robin)
Keywords: checkin-needed

Comment 20

3 months ago

Pushed by dluca@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/efc786c70693
Implement BigInt64 and BigUint64Array. r=wingo,jwalden,sfink

Keywords: checkin-needed

Comment 21

3 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Updated

3 months ago
Depends on: 1541873
Regressions: 1556220
Regressions: 1556294
You need to log in before you can comment on or make changes to this bug.