mozilla mail can only import outlook messages when outlook is installed

NEW
Unassigned

Status

MailNews Core
Import
--
enhancement
16 years ago
2 years ago

People

(Reporter: Ketan Gangatirkar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gs], URL)

(Reporter)

Description

16 years ago
I have .pst (Outlook archive) files from a different installation of Windows.  I
do not have Outlook installed on this machine at this time.  As a result,
Mozilla balks at importing the mail from those archives.  Is there any way to
just point Mozilla at the .pst files and input some context (such as the email
address/name, destination mail account, etc.)?  The only way I see to do it now
is to install Outlook, import the archive files to Outlook, import the Outlook
mail to Mozilla, and then uninstall Outlook.
(Reporter)

Updated

16 years ago
Summary: mozilla mail can only import outlook files when installed → mozilla mail can only import outlook files when outlook is installed
(Reporter)

Updated

16 years ago
Summary: mozilla mail can only import outlook files when outlook is installed → mozilla mail can only import outlook messages when outlook is installed

Comment 1

16 years ago
I have this same problem.  However, I think the problem is more general.  I am
having the same problem with mitgrating from an older PC to a new one.  The old
PC has Netscape 4.78 installed.  I want to mitgrate my account to a new PC on
the same network to Mozilla 1.x  When trying to use the import wizard, it does
not allow me to just point at my profile on the other box.  

This is probably a feature, but it seems to me a very valuable feature for
people mitgrating or upgrading.   

Comment 2

15 years ago
Outlook mail/contacts import is done via the magic of MAPI. PST is a proprietry
file format (whaddya expect from MS?). Although it might be possible to make a
native .PST reader, rather than requiring Outlook to provide the MAPI interface
to it, it would be complicated and infringe 101 Microsoft EULAs, etc.

It ain't gonna happen any time soon. :(
Should think this'll get WONTFIXed.

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 124486 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core

Comment 4

13 years ago
*** Bug 260586 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
*** Bug 261295 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
*** Bug 264024 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 7

9 years ago
Regarding Comment #2, it's not helpful to promulgate vague legal threats.  If there is a specific EULA clause, it's best to cite it.  And even then, such clauses are often not enforceable, and/or can be worked around through clean-room techniques.

Comment 8

9 years ago
Reopening.  Bug 124486 is specific to Outlook Express; this bug relates to Outlook.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 9

9 years ago
Also note <http://blogs.msdn.com/interoperability/archive/2009/10/26/roadmap-for-outlook-personal-folders-pst-documentation.aspx>, which indicates that Microsoft plans to release and document the .pst format.
Assignee: cavin → nobody
QA Contact: nbaca → import

Updated

7 years ago

Updated

7 years ago
OS: Windows 2000 → All
Hardware: x86 → All

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [gs]
You need to log in before you can comment on or make changes to this bug.