Bug 163254 (mp2_is_NOT_mp3)

Mozilla appends an extra / wrong extension to filename when saving a file (Save Target Link As type is changed): .jpg becomes .jpg.jpeg or .jpg.jfif, .html renamed .html.htm, .mp3 saved as .mp3.mp2

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
16 years ago
2 years ago

People

(Reporter: cmr, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0) Gecko/20020529
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0) Gecko/20020529

 In the page control clicked on download link, save file as box would only save
as mp2! with .mp2 amended mp3.  can down load as mp2 but couldn't play in i tunes 


Reproducible: Always

Steps to Reproduce:
1.went to wayne krantz entered user name and could only save as mp2
2.
3.

Actual Results:  
same as above

Expected Results:  
Should down load as mp3
(Reporter)

Updated

16 years ago
Alias: mp2_is_NOT_mp3
worksforme linux trunk cvs 2002-08-17. This is propably a duplicate of one of:
bug 120327 bug 65827 bug 129979. Reporter, could you test this with a recent
nightly build <http://ftp.mozilla.org/pub/mozilla/nightly/latest-trunk/>?

Comment 2

16 years ago
Chadwick, when I access the URL you provided, the QuickTime plug-in starts
playing the MP3 audio file in the browser window.

Comment 3

16 years ago
Try to save http://slashdot.org/slashdot.rdf

It will want to save it as slashdot.rdf.xml

Then go to http://homepage.mac.com/nikd/mov/xeyes.mov and save the page. It will
want to save it as xeyes.mov.moov

Same problem arises with mp3 files, as reported by the reporter. It will want to
save as mp2.

Bug 129979 is a PC bug, where the extension is not visible when saving. This is
somewhat different, since it actually adds another extension.

Comment 4

16 years ago
Created attachment 95937 [details]
MIME: audio/x-mpeg -> test.mp3.m1a

Go to http://homepage.mac.com/nikd/test.html and save the link target. The
server gives a MIME type audio/x-mpeg for the mp3 file, and Mozilla wants to
save this file as test.mp3.m1a rather than test.mp3.

Comment 5

16 years ago
Created attachment 95938 [details]
MIME: audio/mpeg -> test.mp3.mp2

Default Apache configuration (Darwin localhost) gives a MIME type audio/mpeg
for the mp3 file, and Mozilla wants to save this file as test.mp3.mp2 rather
than test.mp3.
(Reporter)

Comment 6

16 years ago
Will confirm if version is issue.  Haven't got nightly build yet.  Please hang
in there.  Thanks

Comment 7

16 years ago
Confirmed using FizzillaCFM/2002081416.

Per comment 4 and comment 5, Mozilla is getting that extension from the system
file handling prefs (editable only in IE). By default, QT sets a ton of such
prefs, including several for audio/mpeg and audio/x-mpeg; .mp2, .mp3, .mpa,
.mpg, and .mpeg, to name just a few.

It appears Mozilla just picks one and adds that extension to the file name
unnecessarily. It's not clear what logic is behind it, but obviously Mozilla
chooses the wrong one.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: could not save as mp3--only mp2 → Mozilla appends wrong extension to file being saved
wrt comment 7, a windows bug for selecting bad file extension of out of many
given for one mimetype: bug 147679

Comment 9

16 years ago
Mozilla shouldn't interfere unless necessary. Usually, files are called
something terrific (like grand_canyon.jpg), and when they are not, Mozilla could
suggest something (but rather not).

Note that file extensions are not necessary on Mac and UNIX platforms. The file
type can be determined by magic numbers, resources, or file extensions.

Comment 10

16 years ago
Obviously not correct behavior, though Mozilla is picking an extension that
matches the MIME type.

*** This bug has been marked as a duplicate of 129979 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED

Comment 12

16 years ago
*** Bug 186710 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
Bringing back from the grave. This is not a duplicate of bug 129979. That bug deals with the 
filename extension Mozilla (for Windows) chooses when saving a file without a filename extension 
(e.g., saving a file as "filename"). This bug is that Mozilla incorrectly adds an additional extension 
(taken from the MIME content-type) to filenames that already contain an extension when saving 
(the fix for bug 129979, if there ever is one, will NOT fix this). Mozilla should only attempt to 
append a filename extension to the filename of saved files if they are saved without one.

Updating steps to reproduce (URL from bug 202403):
1) Visit URL
2) Control+click on a link to download one of the (MP3) files
3) Select the 'Save Link Target As...' item

Actual results: The default filename for the target download in the resulting save dialog will be 
similar to 'song-title.mp3.mpeg' (where '.mpeg' will be an extension determined by your Internet 
Config or Launch Services settings)

Expected results: The default filename for the target download in the resulting save dialog should 
be 'song-title.mp3' (the actual name of the file on the server, as there is absolutely no reason to 
modify it in this case as it already contains an appropriate filename extension)

Updating summary, url, fun stuff like that.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
Summary: Mozilla appends wrong extension to file being saved → Mozilla appends an extra extension to filename when saving files (Save Target Link As...) (Mozilla appends wrong extension to file being saved)

Comment 14

16 years ago
*** Bug 202403 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
----

Can also be reproduced by going here:

http://download.tucows.com/perl/step-2.html?Platform=TUCOWS&Ext=adnload/194967_75076.html&dltarget=download&template=tucows&Target=window95&REGION_UnitedStates=MO&CHOICE_UnitedStates.x=selected

choose 'save-as' when download dialog appears

file name is 'xxx.exe.gif' 

QA Contact: sairuh → petersen

Comment 16

16 years ago
moz has been downloading .exe files as .jpg on my machine for months - just
realized today that it still was telling me it was an application, but was
appending the .jpg extension anyway. i went into "helper applications" pref,
edited application/octet-stream, changed "JPEG image" to "Application" - problem
solved. mozilla (1.4, RC1) now treats octet stream applications as an .exe file,
and no longer appends the .jpg extension.

anyone willing to poke around in the helper apps section can fix their own
machine, but this won't fix the bug as a whole - still doesn't tell me why moz
thought an octet stream should be treated as an image in the first place.
*** Bug 213516 has been marked as a duplicate of this bug. ***
*** Bug 214014 has been marked as a duplicate of this bug. ***

Comment 19

15 years ago
At least two W32 bugs have been duped to this Mac-only bug. This bug depends on
a Linux-only bug. Those doing a search might more easily find this bugs behavior
if it wasn't so marked. -> all/all
OS: MacOS X → All
Hardware: Macintosh → All

Comment 20

15 years ago
Fixing summary to include b.m.o searches for duped bugs (catching all keywords).
Summary: Mozilla appends an extra extension to filename when saving files (Save Target Link As...) (Mozilla appends wrong extension to file being saved) → Mozilla appends an extra / wrong extension to filename when saving a file (Save Target Link As type is changed): .jpg becomes .jpg.jpeg, .html renamed .html.htm, .mp3 saved as .mp3.mp2
*** Bug 214429 has been marked as a duplicate of this bug. ***

Comment 22

15 years ago
*** Bug 215005 has been marked as a duplicate of this bug. ***

Comment 23

15 years ago
I found a similar problem with .tar.gz files, downloaded on Windows: a file
called "abcdef.tar.gz" becomes, after saving it to disk, "abcdef.tar.gz.tar"
(yes, the "tar" extension is duplicated).

On this system I'm using PowerArchiver to open .tar, .gz and .tar.gz
*** Bug 217178 has been marked as a duplicate of this bug. ***
*** Bug 217652 has been marked as a duplicate of this bug. ***

Comment 26

15 years ago
I've only seen this problem when upgrading to 1.5 (beta or RC1).  I've tried
deleting all helper applications entries, but still, just for jpeg files, it
appends a ".jpeg" on the end of the filename even though there's ".jpg" already.

The problem persists with a new blank profile as well.

I've checked the problem against HTML or GIF files, no appending occurs, the
filenames are how they should be.

Comment 27

15 years ago
In my case, x.jpg, becomes x.jpg.jfif
*** Bug 219740 has been marked as a duplicate of this bug. ***

Comment 29

15 years ago
control-click on an image, with the popup menu selection of "Save Image As..."
presents you with an image file name that has the .jfif extension.
This is definitely not how it was in 1.4

I am using: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5)
Gecko/20030916

Comment 30

15 years ago
re: comment 29 - in my case I still get the .jpeg added to the end of a .jpg
filename.

Comment 31

15 years ago
I'm just downloading 1.5 RC1 at the moment.  One other thing, in case it might
be useful, is that I don't see the problem if I downgrade back to 1.4.

Comment 32

15 years ago
Problem persists re: my comment 26, with Moz 1.5 RC2 / win32 (win2k).

Comment 33

15 years ago
*** Bug 220747 has been marked as a duplicate of this bug. ***

Comment 34

15 years ago
Would I be correct in suggesting that this bug involves
mozilla/uriloader/exthandler/nsExternalHelperAppService.cpp and maybe some other
files in that directory?
Fixing summary to match more dupes, since jfif is the one I came here looking for.
Summary: Mozilla appends an extra / wrong extension to filename when saving a file (Save Target Link As type is changed): .jpg becomes .jpg.jpeg, .html renamed .html.htm, .mp3 saved as .mp3.mp2 → Mozilla appends an extra / wrong extension to filename when saving a file (Save Target Link As type is changed): .jpg becomes .jpg.jpeg or .jpg.jfif, .html renamed .html.htm, .mp3 saved as .mp3.mp2

Comment 36

15 years ago
Here's another:

.mpg becomes .mpg.mpe

I don't understand why this is SO DIFFICULT TO FIX!!!
Just DO NOT CHANGE THE NAME OF THE FILE!

PERIOD!!

WHAT IS THE DIFFICULTY!?
That is EASIER THAN ANYTHING ELSE!

Comment 37

15 years ago
Here is a page with examples of .mpg  -> .mpg.mpe

http://www.star.t.u-tokyo.ac.jp/projects/MEDIA/xv/oc.html

Comment 38

15 years ago
It appends .mpeg here.

Comment 39

15 years ago
Presumably this issue isn't affecting all 1.5x users?  If it is, methinks it
should be a 1.5 blocker.

Comment 40

15 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20030916,
using "save page as" menu or "save link target as": filename.jpg is saved as
filename.jpg.jfif (other graphics apps then refuse to open them), filename.mov
saved as filename.mov.moov, filename.mp3 as filename.mp3.mpeg, filename.mpg as
filename.mpg.mpe, etc.

however, filename.html is saved correctly, and *not* as filename.html.htm, so
bug 213516 probably can't be a dup of this one? (and according to comment #26
it's fixed?) also, filename.gif is saved correctly.

according to comment #32, this behaviour is being seen on windows too? except
.jpeg instead of .jfif, .mpeg instead of .mpe - this is definitely breaking
filesystem functionality on both platforms. I'm going to move it to blocking
1.5. Am I allowed to do that? :-)
Flags: blocking1.5+

Comment 41

15 years ago
You are NOT allowed to set a blocking flag (yes or no) - only drivers can do
that.  The most you can do is *request* blocking status.  I've changed it to a
request.
Flags: blocking1.5+ → blocking1.5?

Comment 42

15 years ago
For that, you have to go to bed without any supper!

Comment 43

15 years ago
My guess as to what's happening here is that we look up the MIME type in
Internet Config, and get the first extension listsed for that file type (say
.jfif). Somewhere, there's code that then checks to see if the current file
extension is the same as that, otherwise append.

Comment 44

15 years ago
I'll confirm Simon's guess - at some point last year it was decided that if a
file's extension didn't match the extension Mozilla decided was registered to
the MIME type the registered extension would get appended.  Some sort of
security fix I assume.  Bad on the Mac because file extensions aren't so
standard and we can have multiple ones logged per MIME type (as it sounds like
is happening here).  The details on why this "feature" wasn't disable on the
Mac, as well as other details, has been purged from my brain.  I _think_ bz may
have been part of the discussion so attempting to cc: him on the bug.
If fixing bug 213877 doesn't fix this, then it's a Mac-specific bug in the
OSHelperAppService...

As for why this code runs on MacOS, it's because it's in JS and JS can't really
tell what platform it's running on too well.

Comment 46

15 years ago
This doesn't affect 1.4.1 if that helps at all.

Comment 47

15 years ago
Problem persists (.jpg.jpeg, .mpg.mpeg) with 1.5 release.

Comment 48

15 years ago
(win32)

Updated

15 years ago
Flags: blocking1.5?

Comment 49

15 years ago
I'm having the same problem on a Mac OS 10.2.8 machine with JPEG files.

Comment 50

15 years ago
This problem appeared when I started using 1.5RC1 on WinXP.  I have uninstalled
and reinstalled 1.5final and it's still there.  It only seems to occur with
renaming .jpg files to .jpg.jpe  

I think this should have been a 1.5 blocker and it is currently the most
annoying   bug for me in the browser.  

Comment 51

15 years ago
Bug is still present in Moz 1.4.1, 1.5 and 1.6a build 2003102104 under WinNT4.

I have a site which serves PP shows (*.pps) as application/vnd.ms-powerpoint.
Mozilla will save it as .pps.ppt because .ppt is the default extension for this
MIME type (see your registry key HKEY_CLASSES_ROOT\MIME\Database\Content
Type\application/vnd.ms-powerpoint). But there are several extensions assigned
to this MIME type: .ppt, .pps, .pot, .ppa, .pwz (see your registry keys
HKEY_CLASSES_ROOT\.xxx).

Moz still uses the default extension even if a valid extension is already there.

Comment 52

15 years ago
Same symptoms as comment 40 in Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O;
en-US; rv:1.5) Gecko/20031007 on 10.3 7B85

I'm putting in a vote for this as it's incredibly irritating. Past versions did
not have this problem.

Comment 53

15 years ago
Found a temporary workaround for Win32: Choose "All files" in the Save dialog
box. Only works when that actually gets displayed, of course. Still, a very
nasty bug - 1.5b used to append the default suffix by default, but at least
honored a change through the user, but in 1.5 even that is no longer the case.
Agree on "should've been a blocker", but it's 2 l8 now...

Comment 54

15 years ago
Same problem in
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20031023
(2003102304)

I use Mozilla to harvest Pic galleries. :(

Stefan

Comment 55

15 years ago
Created attachment 133975 [details]
exe_savedas_jpg example

Updated

15 years ago
Attachment #133975 - Attachment description: example testcase → exe_savedas_jpg example

Comment 56

15 years ago
I just installed Mac OS X 10.3.  My previous mozilla would crash each
time (reported via talkback), so I downloaded 1.5.

Now when I save a page, such as

http://www.fred.net/tds/prius2004.html

it decides to save it as

prius2004.html.htm

This problem is now in the header.  My point is that Mozilla is
getting worse - I don't think this happened in the previous version
(1.4 something a?).

I think that this bug is VERY annoying and it should severity should
be set to blocker.  It is unacceptable.
*** Bug 223696 has been marked as a duplicate of this bug. ***

Comment 58

15 years ago
Random bit of info: I've just installed the latest nightly of Firebird, and it
doesn't appear to have this problem (.jpg + .jpeg).

Comment 59

15 years ago
w.r.t. comment #56, I am not seeing .html -> .html.htm with Moz 1.5 release on
OS X 10.2.8, only jpeg, mpeg, etc.

Comment 60

15 years ago
I haven't seen the .html+.html problem, but it does .shtml.html and jhtml.html

This release shouldn't have been made, since the bug was reported on the release
candidates.

I've gone back to 1.4.1, which does not mess with .jpg files.

Comment 61

15 years ago
Jeff, thanks for comment #59, that confirms my observation.  So there is some
interaction with the OS going on here?  The odd thing is that 'htm' (without
the 'l' on the end) is due to the exploiter operating system being incapable
of handing arbitrary file names ... now why would that show up on a mac?

Comment 62

15 years ago
*** Bug 224092 has been marked as a duplicate of this bug. ***

Comment 63

15 years ago
I did a clean install of Win2k on my laptop and chucked Moz 1.5 release there,
and it doesn't experience this issue.  Thinking that it may be OS released (even
though users of different OSs are experiencing this issue), I decided to nuke a
load of the image file associations on my home PC (also win2k), tried getting
Mozilla (1.5 release also) to grab those associations, and back to the original
program, and nuking the associations and setting them up myself, but this issue
remained every step of the way (and I was restarting Mozilla before each OS
config change).  I'm stumped :-)

The only thing I can think of is that is may be to do with old versions of
Mozilla that have been installed on the machine adding some complication that
1.5 picks up on.  Has anyone encountered this problem on a clean OS install and
going straight to 1.5 release?

My home machine's recent history regarding different versions of Moz that have
been installed:  1.4, 1.4b, 1.5b, 1.5RC1, RC2, 1.5 (all release versions, no
nightlies).

Comment 64

15 years ago
More info, on my home PC (where Moz 1.5x exhibits the bug), I've just removed
all 'helper apps' from Moz, and the only plug-in I have installed is:

QuickTime Plug-in 6.1c

File name: npqtplugin.dll
The QuickTime Plugin allows you to view a wide variety of multimedia content in
Web pages. For more information, visit the QuickTime Web site.

MIME Type           Description                   Suffixes    Enabled
application/sdp     SDP stream descriptor file    sdp           Yes
application/x-sdp   SDP stream descriptor file    sdp           Yes
application/x-rtsp  RTSP stream descriptor file   rtsp,rts      Yes
video/quicktime     QuickTime Movie               mov,qt        Yes
video/flc           AutoDesk Animator (FLC) file  flc,fli       Yes
image/x-macpaint    MacPaint image file           pntg,pnt,mac  Yes

Comment 65

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: 

Files like index.de.html are save up to wrong to index.de.html.htm by default.

de is the iso countrycode for germany and filename.de.html is according to W3C 
standards a german language page. index.en.hmtl would be the english one.

See ffii.org for example that uses this official naming convention for their 
multilingual website.

Mozilla 1.5 (de-at)

Also a "html" alsways was a proper alternative ending of a html file. htm was 
interoduced by microsoft due to their filesystem.

Reproducible: Always

Comment 66

15 years ago
With Mozilla 1.6a I don't see the .html.htm problem anymore (see bug 213516). 

The same issue is bug 144334 with .tar.gz.tar. Use "Save Link Target As" (left
click works) and you'll get the wrong extension. Because this bug is more
general, bug 144334 could be duped IMHO. I don't see any difference to this bug.
*** Bug 198336 has been marked as a duplicate of this bug. ***

Comment 68

15 years ago
Just tried 1.6a release / win32, I still see my .jpg.jpeg issue.

Updated

15 years ago
Flags: blocking1.6b?

Comment 69

15 years ago
Don't know if this helps, but the latest nighties with firebird don't show this problem.  The 1.6b 
nighties of mozilla still have this rather annoying bug.

Comment 70

15 years ago
Created attachment 136097 [details]
Windows XP "Save Image As" dialog .jpg

Comment 71

15 years ago
Comment on attachment 136097 [details]
Windows XP "Save Image As" dialog .jpg

In Mozilla 1.4, the file was correctly saved as "svppc-logo.jpg".  In Mozilla
1.5, it's saved as shown.  This has the side effect of *not* showing the .jpg
files in the Save As directory, which makes it harder to see if you have a file
with the same name.

Comment 72

15 years ago
*** Bug 220140 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Assignee: law → sspitzer
Status: REOPENED → NEW
bug 213877 should have fixed this. 1.6beta as well as 1.6final will contain the
fix; as well as nightlies from tomorrow or later.

NOTE: addition of .tar to .tar.gz filenames is bug 144334, not this bug.
Status: NEW → RESOLVED
Last Resolved: 16 years ago15 years ago
Flags: blocking1.6b?
Resolution: --- → FIXED
v. FIXED in Mac OS X 2003112505
Status: RESOLVED → VERIFIED
*** Bug 228735 has been marked as a duplicate of this bug. ***

Comment 76

15 years ago
*** Bug 229248 has been marked as a duplicate of this bug. ***
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.