Open Bug 1669274 Opened 1 year ago Updated 1 month ago

Display name Not used in from column of e-mail folder view

Categories

(Thunderbird :: Mail Window Front End, defect)

defect

Tracking

(Not tracked)

People

(Reporter: fopenih614, Unassigned)

References

Details

(Whiteboard: [enterprise-relevance])

Attachments

(1 file)

Attached image screenshot.PNG

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.121 Safari/537.36

Steps to reproduce:

  1. add e-mail address after from to contacts
  2. edit the display name of the contact

Actual results:

the display name is show correctly above the e-mail pane, but not in the list of e-mails, see attached screenshot

Expected results:

the name in the list of e-mails should also have changed to the display name

version 78.3.1 64 bit to be precise

That view is extremely performance sensitive, so I think it's not something we can reasonably change.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX

Hi Magnus,

I would like to ask to reconsider: it is not a new feature I'm asking, it is old behaviour (up to TB 68). Although I share your concern for performance.

Also, I have noticed that it seems that the display name IS getting applied for certain contacts (even if in the same address book), but not for others: it is thus buggy...

...it's not something we can reasonably change.

This isn't true at all. See Bug 1669872.

@fop - all you have to do is go to Preferences:General and toggle the "Show only display name.." checkbox to cause the database to be refreshed. For a large folder, particularly if sorted by From, it may be slower entering the folder for the first time, but not nearly as slow as before Bug 1669872 (and it could be made ever more performant). If you also want to use the display name in a Quick Filter search for email type textfilters (Bug 460737), see TotalQuickFilter.

Thank you alta88, thanks for the fix and the tips!

  • please note that this is only a workaround: the problem persists, but can now be resolved temporarily (= until a new contact is added)
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WONTFIX → ---
Status: REOPENED → NEW
Duplicate of this bug: 1672612
Duplicate of this bug: 1674708
Duplicate of this bug: 1687044
Duplicate of this bug: 1688848

By “the list of e-mails” the reporter must have meant the Message List Pane. IMHO this bug has not been resolved. Neither have the “duplicate” bugs listed above.

It is now the Ides of March 2021 and this bug has yet to be resolved. This has to be the most annoying bug in all of Thunderbird.

Duplicate of this bug: 1730414

I can confirm it is annoying (In reply to alta88 from comment #4)

...it's not something we can reasonably change.

This isn't true at all. See Bug 1669872.

@fop - all you have to do is go to Preferences:General and toggle the "Show only display name.." checkbox to cause the database to be refreshed. For a large folder, particularly if sorted by From, it may be slower entering the folder for the first time, but not nearly as slow as before Bug 1669872 (and it could be made ever more performant). If you also want to use the display name in a Quick Filter search for email type textfilters (Bug 460737), see TotalQuickFilter.

This method works with thunderbird 68 & ubuntu 20.04, but not with 91.1.0 and Win10 : in this case, unchecking "Show only display name.." makes a blank page and nothing change at restart.

Duplicate of this bug: 1738168
Duplicate of this bug: 1744267

Alex, fyi.

Whiteboard: [enterprise-relevance]
You need to log in before you can comment on or make changes to this bug.