Java applet draws itself over toolbar on initial page load

RESOLVED FIXED

Status

RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: chrispetersen, Assigned: sfraser_bugs)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Build: 2002-10-04-04
Platform: OS X 10.2.1
Expected Results: Applet should remain in the browser window
What I got: As window is resized vertically, the applet will "float" over the
bookmark and main toolbar.

Steps to reproduce:

1) Go to url
2) Applet is intialized on the page. Resize the page vertically so that window's
size is reduced.
3) Notice the applet will float over the toolbar instead of remaining on the
content area of page.
(Reporter)

Comment 1

17 years ago
Created attachment 101764 [details]
Applet element that is inside a DIV (no alignment specified).

Applet should float over toolbar when window size is reduced(vertically).
(Reporter)

Comment 2

17 years ago
Created attachment 101765 [details]
Same test case but DIV has a alignment of "center"

The applet remains in the content area of the page when the window is resized.
(Reporter)

Comment 3

17 years ago
Notice that second test case doesn't have the same problem since the DIV has
been centered. This test case is based on a applet found at
http://www.webreference.com/html/tools/colorizer/ which wasn't reproducing the
same problem I was seeing with other applet tests.  

Updated

17 years ago
Blocks: 145806

Comment 4

17 years ago
Any progress on this bug?
->sfraser, for the time being
Assignee: bnesse → sfraser
(Assignee)

Comment 6

17 years ago
This is an issue with the Java plugin.
(Reporter)

Comment 7

16 years ago
*** Bug 179602 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

16 years ago
This is applet from the bbc site (bug 79602). After loading this url, reducing
the window size vertically will cause the applet to float over the toolbar.


http://news.bbc.co.uk/ticker/ticker_applet.252.htm
(Assignee)

Comment 9

16 years ago
Scrolling with Java plugins is much better after some recent fixes (note that
the issue was with applets inside <iframe>s, which is what the BBC site has.

However, there is still an issue where the applet draws over the toolbar on
initial page load.
Status: NEW → ASSIGNED
(Assignee)

Comment 10

16 years ago
*** Bug 180559 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

16 years ago
Revising summary
Summary: Applet can reposition itself over toolbar when window is resized vertically → Applet draws itself over toolbar on initial page load
(Assignee)

Comment 12

16 years ago
*** Bug 179925 has been marked as a duplicate of this bug. ***
*** Bug 184900 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 14

16 years ago
*** Bug 186039 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 15

16 years ago
This problem still occurs in the 2003081002 chimera NB. The applet can float
over the bookmark toolbar when the browser window is reduced. Tested under 10.2.6.
Resizing the page with the attachment in comment 1 seems to work properly in
Camino 20041212 0.8+ using the Java Embedding Plugin being developed in bug 197813.

Comment 17

14 years ago
Yep looks fixed using the java embedding plugin and 20050130 NB.

Updated

14 years ago
Summary: Applet draws itself over toolbar on initial page load → Java applet draws itself over toolbar on initial page load

Updated

14 years ago
Blocks: 224615
This might not be fixed (completely) by the JEP; with the testcase in comment 1,
when I resize the page, I notice some detritus in the tab bar (when tabs are
open), but nothing like without the JEP.
Fixed by bundling the Java Embedding Plugin with Camino (nightly builds 20050729
and later), bug 301076.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.