Closed Bug 221604 Opened 16 years ago Closed 13 years ago

When I open Firefox, the screen shakes (jitters)

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 178884

People

(Reporter: mitsi18, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

The bar at the top of the page that holds "file," "edit," etc. doesn't shake. 
Only the actual screen that holds the web pages.  I've tried different web
pages.  Even removing mozilla firebird and re-installing it.  I installed
mozilla 1.4 and it doesn't do this.  It began suddenly the other day and now
won't go away.  My internet explorer browser works fine, as do my other programs
so I have no idea what happened (I was merely surfing the web).  One minute
fine, then suddenly, shaking.  

Reproducible: Always

Steps to Reproduce:
1. open mozilla firebird
2. there was nothing I could find that I did differently so basically, that' it
3.

Actual Results:  
the screen shakes

Expected Results:  
not shake

This seems to only occur in "phusion" theme.  When I change it back to "mozilla
firebird" theme, it's fine.  (But phusion had been working up until a few days
ago when the shaking began.)
What version of Firebird are you using, or does this happen with mozilla?
can you download latest nightly firebird build and try again?

http://ftp.mozilla.org/pub/mozilla.org/firebird/nightly/latest-trunk/
Confirmed shaking using the Phusion theme and the following build:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031129
Firebird/0.7+

Do we consider this a bug in Firebird, or in the theme?  I've never seen this
before in any other theme.
This is happening to me in regular Mozilla 1.5, with the classic or modern
theme. The shake is less pronounced in the modern theme - it seems to be just
one or two pixels, as opposed to 3 or 4 on the classic theme. It is entirely
vertical in nature.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

Sometimes it doesn't start unless I open a tab. It's kind of erratic.

It didn't happen in 1.4.

I've tried changing the graphics settings to no acceleration, but this made no
difference (other than making the shaking a little slower.

This window that I am typing in seems to have stopped shaking for the moment,
but the about: screen (which is open as I type) is still shaking. Saying that,
this window has just started to shake.
Note: the problem does not occur if you use full screen mode.
probably dupe of bug 178884
I have also had this problem.  The problem just started today while browsing a
few of my usual sites.  I have changed no settings in Firefox 0.8, and have been
using it since it came out with no problems.  I noticed that my homepage had
somehow been set back to the firefox page before the problem began.  The browser
has also began asking me about unencrypted pages again, as if this was my first
time using it.  I am using the default theme as installed.
The only way I've gotten this problem to stop is to open another url. This bug 
exists only when you first open the browser or when you open up another 
browser window. Once you change the url it stops. Extremely annoying.
We should investigate this before shipping 1.0.  If any significant number of
users are seeing this, then it needs to be fixe. 

It would be good if anyone seeing this could tell us if you're seeing it on a
new profile, what home page you have set, if you still see it after hiding the
bookmarks toolbar, and if you still see it when using an alternate theme. Thanks.
Flags: blocking-aviary1.0?
Happening to me in Firefox .9 was using mozilla 1.6 before with no problem
Flags: blocking-aviary1.0?
I have the same problem as soon as I access Firefox browser. Screen jumps! I am
using Firefox .9 default theme. The routine as the initial comment below. Top
tool bar doesn't move, everything below jumps. Tried uninstalling and
reinstalling, no luck. Mozilla is fine. Using XP.
*** Bug 258873 has been marked as a duplicate of this bug. ***
Summary: when i open mozilla firebird navigator, the screen shakes → when i open mozilla firebird navigator, the screen shakes (jitters)
I switched my Theme back to the standard theme and have not once had the screen
jitter.  This stongly points to the alternate themes or the handling of the
themes within the base.
*** Bug 260990 has been marked as a duplicate of this bug. ***
I can confirm I'm seeing what I think is the same bug.  Some more background. 
Earlier, I installed on WinNT 4.0 (patched with all the latest service packs,
etc) and have not seen the bug at all.   However, this is a fresh install on XP
(also patched etc) and I'm seeing it a lot.  Version info is: FireBird 1.0
Prerelease Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001
Firefox/0.10.1.  As mentioned, this is a fresh install.  

The only thing I've changed is to move the Bookmarks Toolbar Items, up and
directly to the right of the menu commands (i.e. just to right of the Help drop
down menu), I've deleted all the Bookmark Toolbar Items, and I've hidden the
Bookmarks Toolbar.

The jittering I'm seeing is in the icon of the web page inside 
1) the navbar (the component that lets you see and type URLS),   Notably, even
though the web page icon in the navbar is jittering, the text of the URL is not
jittering. Also, the icon appears to be "tearing" - a horizontal band of pixels
at the top of the icon is not jittering.
2) the content of the web page rendering area, 
3) and the vertical scrollbar widgets on the right.

All of the jittering items move up and down a few pixels (less than 10, probably
like 5) roughly 5 times a second. 

I can recreate this behavior consistently, but there seem to be several ways to
do it and I'm not sure of all of them.  For instance, I was able to navigate to
this bug without seeing the jittering, but then I popped up the toolbar
customization dialog to look something up (right click near the menu, click
customize), the jittering began when I closed the dialog.  Clicking back to nav
to another page and then forward clears up the jittering.  Reopening the toolbar
customization dialog and closing it start the jittering again.  One thing I
notice is that when I open the toolbar customization dialog, the toolbar that
section that holds the menu and my relocated Bookmark Toolbar Items area is
momentarily increased in size to accomodate the rectangle that shows where
Bookmark Toolbar Items would go (if I had any).

If I add a single Bookmark back into the Bookmark Toolbar It
...continued...

If I add a single Bookmark back into the Bookmark Toolbar Items, the problem
seems to be fixed and the jitters go away.  Deleting the lone Bookmark causes
the jitters to return.
(In reply to comment #14)
> I can confirm I'm seeing what I think is the same bug.  Some more background. 
> Earlier, I installed on WinNT 4.0 (patched with all the latest service packs,
> etc) and have not seen the bug at all.   However, this is a fresh install on XP
> (also patched etc) and I'm seeing it a lot.  Version info is: FireBird 1.0

Er, one correction.  The install that doesn't seem to have a problem is on
Win2K, not 4.0.  I haven't put it on my 4.0 machine.
Please don't confuse this bug with bug 247116.

Is this bug still present in 1.0?
Summary: when i open mozilla firebird navigator, the screen shakes (jitters) → When I open Firefox, the screen shakes (jitters)
This problem seems to be related to non-microsoft visual themes for windows xp.
 This started happening to me after I installed a MacOSX lookalike theme.
*** Bug 276549 has been marked as a duplicate of this bug. ***
*** Bug 275692 has been marked as a duplicate of this bug. ***
I had this problem and resolved it by going to Customize Toolbar screen and 
clicking Restore Default Set. I think it may be caused when attempting to 
customize the toolbar. I've noticed that an item can be "lost" when draging 
it. This is when the shaking began for me.
ya does the same thing to me always when I'm reading the forums at
www.starwarsgalaxies.com it's kinda agrivating reading a shaking screen,
on certain sites the screen shakes in an up-down motion. Sometimes it does and
sometimes it doesnt on a single site. It is completly random. 
(In reply to comment #23)
> on certain sites the screen shakes in an up-down motion. Sometimes it does and
> sometimes it doesnt on a single site. It is completly random. 

firefox 1.0.6, windows XP sp2 with classic desktop. when quite a large page is
resized into a small space the content constantly vibrates up and down by a
couple of pixels.

try this: go to http://tantek.com/favelets/ and click on the Pocket PC/iPaq
browser resize link on the right. on my system the compressed content shakes.
obviously you need to enable javascript resizing, but perhaps just resizing the
browser manually might do it
IT happens only when we use certain windows themes like mac os for windows and may be due to the patched uxtheme.dll file incase i revert back to the old windows theme the jitter goes off and it doesn't happen
Suggested Test Case:

On a Windows XP SP2 computer with Firefox:
1. Start Firefox.
2. In Firefox View; Tools; make sure the Navigation, Bookmarks and Google toolbars are all enabled.
3. Right-click on the desktop and set the theme to the "Windows XP theme".  
(If you don't see this theme go to Administrative Tools; Services; and check that the "Themes Service" is started.)
4. Navigate to some web pages containing a lot of text and some images.
5. Observe whether the web page shakes vertically.
6. Shutdown Firefox.
7. Start Firefox.
8. Navigate to some web pages containing a lot of text and some images.
9. Observe whether the web page shakes vertically.
10. Repeat steps 3 thru 10 with the CrystalBlue XP and Royale themes.


Thoughts:
=========

A. My understanding is that the themes concerned all use Microsoft's UXTHEME.DLL.  

B. There is some thought that the shaking depends on which tool bars are enabled.

C. This change seems to *sometimes* eliminate the shaking:

[quote]
To fix it, add the following code to your userChrome.css file.

#navigator-throbber
{
height: 21px !important;
}
[/quote]
This is sort of what I have happening.  Basically, I will enter Firfox but whenever I make a change the screen that lists all my Bookmarks comes up and "flutters" somewhat like a butrterfly shaking it's wings.  This can take a short time or a long time and is annoying.  I just loaded 1.0.7 and hoped this would fix things.  It didn't!  I use Windows XP-Business.  I'm not sure what I'm doing here!  I hope this gets to you!!
Confirming with 1.5.0.1 in Mandrivalinux cooker with CrystalSVG 0.2 theme. I dohave Menu + Bookmarks + ImageZoom extension in one bar and the behaviour happens just when the size of the window causes all the bookmarks to hide, leaving just ">>" (also with about:blank page). The page jumps by about 5 px. Also the height of the bar changes depending on the visibility or not of the bookmarks.
My browser shakes using the Pack Crystal XP 3.0 a Windows XP theme and the following build:

Firefox/1.5.0.4 (Windows XP SP2)

Note: The shake begins on google or gmail page (Google talk).
Assignee: bross2 → nobody
QA Contact: general
Duplicate of this bug: 371471
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 178884
You need to log in before you can comment on or make changes to this bug.