Closed Bug 237148 Opened 16 years ago Closed 13 years ago

Disable unsupported mail functionality on Sunbird

Categories

(Calendar :: Sunbird Only, defect, minor)

x86
All
defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: brossard, Assigned: sipaq)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla Calendar 2004010914-cal

I have calendar installed in both TBird and Mozilla. Right clicking on an event
and choosing "email selected event(s)" in mozilla does nothing, although it
seems to have limited functionality when calendar is launched from TBird. Also
it would be nice if the plugins for each could share the same config file. 

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
I also have this problem.... Checking the email reminder does nothing. HELP~
I can confirm this bug.

In Sunbird clicking on email selected event doesn't call thunderbird (or any
othe client) to send an e-mail altough the mailto: protocol is properly registered.

In Calendar for thunderbird it works.

This has been confirmed on Windows 98 with latest thunderbird and latest sunbird
and calendar.

I'm currently migrating some of my users from outlook to
firefox/thunderbird/sunbird and this is really a problem (they are now asking me
to put outlook back which really don't want). Along with the bug
http://bugzilla.mozilla.org/show_bug.cgi?id=252736 this is a really blocker for
my attempt to integrate mozilla based tools into this company.
known bug, though surprised there was no Bug report before this...

see netscape.public.mozilla.calendar

The issue is that the smtp features needed are not built in sunbird, or FF

For reference, it does work in Suite, and as noted, Thunderbird.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: email selected event does not work in Mozilla Calendar, only in Thunderbird Calendar → email selected event does not work under FF or Sunbird
*** Bug 274563 has been marked as a duplicate of this bug. ***
-> general
Component: Sunbird and Calendar-Extension Front End → General
*** Bug 277675 has been marked as a duplicate of this bug. ***
*** Bug 282008 has been marked as a duplicate of this bug. ***
*** Bug 274717 has been marked as a duplicate of this bug. ***
*** Bug 292144 has been marked as a duplicate of this bug. ***
I installed the latest nightly build of Calendar for Thunderbird on 10 June
2005, but it turns out to be the one for Firefox.  Not sure how that comes to
be.  Anyhow, I cannot e-mail selected events from the Calendar - and maybe
that's because it's attached to FF???
QA Contact: gurganbl → general
*** Bug 300359 has been marked as a duplicate of this bug. ***
*** Bug 314212 has been marked as a duplicate of this bug. ***
OS: Windows 2000 → All
Same here for Sunbird 0.3a1

(Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051104 Mozilla Sunbird/0.3a1)
I notice that the severity of this bug has been set to minor.  This is a remarkably annoying bug for me. Partly because it is a feature that I would like to use.  And partly because I would have thought that this would be quite straight forward to fix.  Admittedly, I have no experience of any Mozilla code, but Firefox has code to email a link to somebody.  In this case, it would also need to attach an ics export of the event.

Please correct me if I am understating the problem.
Every user I install this on is annoyed by this missing functionality.
Any effort to reduce the resulting whining I have to listen to will be
greatly appreciated!
*** Bug 203638 has been marked as a duplicate of this bug. ***
We should disable the context-menuitem for Sunbird.

The relevant code in http://lxr.mozilla.org/seamonkey/source/calendar/sunbird/base/content/calendar.xul#146 can just be commented out for now.

This should also block 0.3a2, since it's very low-risk/high gain, since we should not advertise a functionality that we do not have at the moment.

Patch coming in a few hours.
Assignee: mostafah → nobody
Component: General → Sunbird and Calendar-Extension Front End
QA Contact: general → sunbird
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Attachment #219208 - Flags: first-review?(jminta)
Comment on attachment 219208 [details] [diff] [review]
Patch v1 - Disable mail-specific menuitems in Sunbird

Looks ok, but it's not clear to me why this is blocking 0.3a2. r=jminta, approval for 0.3a2 pending...
Attachment #219208 - Flags: first-review?(jminta) → first-review+
(In reply to comment #19)
> Looks ok, but it's not clear to me why this is blocking 0.3a2. r=jminta,
> approval for 0.3a2 pending...

As I said in comment 17, the patch

- is very low-risk
- will definitely save us future bug duplicates

And we should not advertise a functionality that we do not have at the moment.
Neither mvl nor I had strong feelings about this, so i'm yielding to sipaq's judgment.  Patch checked in.  Removing blocker, but leaving bug open for more work.
No longer blocks: sunbird-0.3a2
Blocks: 335461
No longer blocks: 335461
IMO this is fixed.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Sorry to say the contrary : NO MAIL sent from sunbird 3.0 either on Linux (Debian Sarge)nor Windows XP
Did not find any way to configure the way mails are sent.( sendmail or default messaging programm) 
Clarifying the summary...
Summary: email selected event does not work under FF or Sunbird → Disable unsupported mail functionality on Sunbird
Why doesn't anyone re-implement mail functions?

I recently added the attached re-written CalendarMail.js into my lightning and it works. Well I have to mention, that this could be poor programming style and early pre-release... - but it works for me.

I deleted all functions for checking mail existance, since I only use Lightning in Thunderbird.
(In reply to comment #25)
> Created an attachment (id=256608) [details]
> Modified CalendarMail for Lightning only.
> 
> 
> Why doesn't anyone re-implement mail functions?
> 
> I recently added the attached re-written CalendarMail.js into my lightning and
> it works. Well I have to mention, that this could be poor programming style and
> early pre-release... - but it works for me.
> 
> I deleted all functions for checking mail existance, since I only use Lightning
> in Thunderbird.
> 
That's a decent stop-gap solution.  But we are working on something that will actually implement iTIP based scheduling so you don't have another half-finished solution (which is what calendarMail.js was).

See Bug 334685 for details
VERIFIED with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4pre) Gecko/20070406 Calendar/0.5pre.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.