Closed Bug 241213 Opened 16 years ago Closed 3 years ago

Message window for .EML file needs working commands

Categories

(SeaMonkey :: MailNews: Message Display, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey1.1alpha

People

(Reporter: mcow, Assigned: iann_bugzilla)

References

(Blocks 1 open bug)

Details

(Keywords: fixed-seamonkey1.0, fixed1.8, Whiteboard: [see comment #31 for scope])

Attachments

(1 file, 3 obsolete files)

Thanks to the patch for bug 239555, it is now possible to directly open .EML 
files from Mail/News.  However, when the window opens, it does not support the 
full range of commands (in toolbars and menus) that should be available.

Toolbar: Reply, Reply All and Forward could all be supported, but the buttons 
are disabled.

Menu:
 - File|Attachments is not available
     (this probably requires a fix for bug 241212)
 - View menu items: Headers, Message Body As, Display Attachments Inline and
     Character Coding do not work, tho enabled; these could all be supported.
     (View|Headers requires a fix for bug 241212.)
 - View | Message Source: disabled, but this should be supported.
 - View | Reload: I don't know whether this works, as there aren't many cases
     where it would make a difference.  It's enabled, currently.
 - Message menu items: Reply, Reply All, Forward (again) could all be supported,
     but are disabled.
 - Message menu items: Create Filter From Message is enabled; I suspect this
     function cannot work (because filters require a specific account), so it
     should be disabled.
 - Message menu items: Move, Copy, Label, Mark -- these all require the message
     to be internal to the mail system; they should be disabled at the top
     level, rather than allowing access to the fully-disabled submenus.

This is similar to bug 204350 in many ways.

Altho not specifically part of this bug, enabling the Message|Copy menu and the 
File Selected Message toolbutton would be a simple interface for implementing 
bug 193281.
Addenda:
 - Message | Edit As New  should work, just as Reply or Forward do.
 - The entire Go menu should be disabled.
 - Items in the Message Body context menus should be active, or disabled, just
   as those in the Message item are.
Blocks: 193281
Bug 204350 is bug for almost same symptom in message/rfc822 attatchment display.
>Bug 204350 (message/rfc822) Attached email message window glitches (forward,
reply, view source disabled)
Same problem?
*** Bug 69359 has been marked as a duplicate of this bug. ***
*** Bug 268746 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
No longer blocks: 279650
Depends on: 279650
Blocks: 279650
No longer depends on: 279650
Blocks: 269826
No longer depends on: 269826
Assignee: sspitzer → mail
This patch:
* Implements reply/forward/edit msg as new for .eml files as per TB bug 268746
Assignee: mail → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #196582 - Flags: review?(mnyromyr)
Depends on: 268746
Attachment #196582 - Flags: review?(mnyromyr)
Changes since v0.1:
* Added latest changes from TB bug 268746 - fix get/set string property
warnings
Attachment #196582 - Attachment is obsolete: true
Attachment #198171 - Flags: review?(mnyromyr)
Attachment #198171 - Flags: review?(mnyromyr)
Changes since v0.1a
* Uses mDummyMsgHeader throughout patch instead of mixed with mDummyHeader
* Adds check for existence of folder prior to trying to use it
Attachment #198171 - Attachment is obsolete: true
Attachment #199059 - Flags: review?(mnyromyr)
Comment on attachment 199059 [details] [diff] [review]
mDummyMsgHeader instead of mDummyHeader patch v0.1b

>Index: mailCommands.js
>===================================================================
> }
> 
>+

Not really essential, I'd say. ;-)

>Index: messageWindow.js
>===================================================================
> function GetLoadedMsgFolder()
> {
>-	if (gCurrentFolderUri)
>-		return RDF.GetResource(gCurrentFolderUri).QueryInterface(Components.interfaces.nsIMsgFolder);
>-	else
>-    return null;
>+  return (gCurrentFolderUri)
>+    ? RDF.GetResource(gCurrentFolderUri).QueryInterface(Components.interfaces.nsIMsgFolder)
>+    : null;
> }

These changes are not helpful, they just make the function far less readable.


r=me with that.
Attachment #199059 - Flags: review?(mnyromyr) → review+
Changes since v0.1b:
* As requested by reviewer

r= carried forward, requesting sr=
Attachment #199059 - Attachment is obsolete: true
Attachment #199222 - Flags: superreview?(bienvenu)
Attachment #199222 - Flags: review+
Attachment #199222 - Flags: superreview?(bienvenu) → superreview+
Comment on attachment 199222 [details] [diff] [review]
Tweaked patch v0.1c (Checked in trunk/branch 1.8 & 1.8.0(excluding messengerdnd.js))

Checking in
mailCommands.js;
new revision: 1.99; previous revision: 1.98
mailWindowOverlay.js;
new revision: 1.228; previous revision: 1.227
messageWindow.js;
new revision: 1.109; previous revision: 1.108
messengerdnd.js;
new revision: 1.59; previous revision: 1.58
msgHdrViewOverlay.js;
new revision: 1.145; previous revision: 1.144
msgMail3PaneWindow.js;
new revision: 1.285; previous revision: 1.284
done
Attachment #199222 - Attachment description: Tweaked patch v0.1c → Tweaked patch v0.1c (Checked in)
No longer blocks: 279650
Comment on attachment 199222 [details] [diff] [review]
Tweaked patch v0.1c (Checked in trunk/branch 1.8 & 1.8.0(excluding messengerdnd.js))

Note: haven't tried this myself, so would need two Councillors (?) to check
Attachment #199222 - Flags: approval-seamonkey1.0?
Comment on attachment 199222 [details] [diff] [review]
Tweaked patch v0.1c (Checked in trunk/branch 1.8 & 1.8.0(excluding messengerdnd.js))

a=me, has been tested on trunk for a while now...
Hmm, I'd like to see a risk evaluation and an assurance that all touched files are SeaMonkey-only and don't touch Thunderbird before I give approval here...
(In reply to comment #13)
> Hmm, I'd like to see a risk evaluation and an assurance that all touched files
> are SeaMonkey-only and don't touch Thunderbird before I give approval here...
> 

All files in this patch have been forked for TB. It is a fairly low risk patch, and as I said has been tested on the trunk for a good month or so.
Attachment #199222 - Flags: approval-seamonkey1.0? → approval-seamonkey1.0+
Comment on attachment 199222 [details] [diff] [review]
Tweaked patch v0.1c (Checked in trunk/branch 1.8 & 1.8.0(excluding messengerdnd.js))

Checking in branch
mailCommands.js;
new revision: 1.96.4.2; previous revision: 1.96.4.1
mailWindowOverlay.js;
new revision: 1.222.2.4; previous revision: 1.222.2.3
messageWindow.js;
new revision: 1.105.2.2; previous revision: 1.105.2.1
messengerdnd.js;
new revision: 1.58.8.1; previous revision: 1.58
msgHdrViewOverlay.js;
new revision: 1.141.2.2; previous revision: 1.141.2.1
msgMail3PaneWindow.js;
new revision: 1.282.2.2; previous revision: 1.282.2.1
done
Attachment #199222 - Attachment description: Tweaked patch v0.1c (Checked in) → Tweaked patch v0.1c (Checked in trunk/branch)
Keywords: fixed1.8
Whiteboard: fixed-seamonkey1.0
(In reply to comment #14)
> (In reply to comment #13)
> > Hmm, I'd like to see a risk evaluation and an assurance that all touched files
> > are SeaMonkey-only and don't touch Thunderbird before I give approval here...
> > 
> 
> All files in this patch have been forked for TB. It is a fairly low risk patch,
> and as I said has been tested on the trunk for a good month or so.
> 

hmm is messengerdnd.js forked?  I didn't think it was....
Not sure why I didn't catch messengerdnd.js wasn't forked, I will back out the change to that file if you want. I'm not sure why the changes to messengerdnd.js didn't go into https://bugzilla.mozilla.org/attachment.cgi?id=196234&action=edit
Comment on attachment 199222 [details] [diff] [review]
Tweaked patch v0.1c (Checked in trunk/branch 1.8 & 1.8.0(excluding messengerdnd.js))

Checking in (branch 1.8.0)
mailCommands.js;
new revision: 1.96.4.1.4.1; previous revision: 1.96.4.1
mailWindowOverlay.js;
new revision: 1.222.2.3.4.1; previous revision: 1.222.2.3
messageWindow.js;
new revision: 1.105.2.1.4.1; previous revision: 1.105.2.1
msgHdrViewOverlay.js;
new revision: 1.141.2.1.2.1; previous revision: 1.141.2.1
msgMail3PaneWindow.js;
new revision: 1.282.2.1.4.1; previous revision: 1.282.2.1
done
Attachment #199222 - Attachment description: Tweaked patch v0.1c (Checked in trunk/branch) → Tweaked patch v0.1c (Checked in trunk/branch 1.8 & 1.8.0(excluding messengerdnd.js))
So still the issues as noted in bug 204350 comment 44 are not working for SM trunk?
*** Bug 321332 has been marked as a duplicate of this bug. ***
(In reply to comment #19)
> So still the issues as noted in bug 204350 comment 44 are not working for
> SM trunk?

See bug 268746 comment 22.  There was a bit of a difference in the scope of problems in a standalone window between message/rfc822 attachments and .EML files, but the differences are minimal now; I think the biggest difference is the print/print preview bug.
(In reply to comment #21)

Not quite. This comment does not mention the non-working Copy and Move functions (see duplicate bug 321332 for more information). As far as I can see, it is only mentioned in the first posting of this bug, and that is already one and a half year ago. Also fixing the bug would be a solution bug 193281, which stands for almost 2 years now.
Bug 328121 notes that, in a message window for a .EML of a message that has a message/rfc822 attachment, opening that attachment results in a new, blank message window.
Depends on: 328121
Whiteboard: fixed-seamonkey1.0
No longer blocks: 193281
Depends on: 193281
Blocks: 326347
Blocks: 310341
No longer blocks: 326347
Ian,
Are you still working on this ?
This was left open to cover any commands still not working when a .EML is opened:
* View, Message Source
* View, Headers, All
* Message, Reply All
* Message, Edit As New
etc

I am happy for others to work on those though.
That 'View message source' feature really needs to be done! 
For example abuse departments are using thunderbird, and they are constantly receiving rfc822 attached spam mails, from which they need to see full headers.
(In reply to comment #26)
> That 'View message source' feature really needs to be done! 
> For example abuse departments are using thunderbird, and they are constantly
> receiving rfc822 attached spam mails, from which they need to see full headers.

Heh.  See bug 204350 comment 85 -- View Source *is* working for .EML files (this bug) but not for attached mails (that bug) which is more likely what the "abuse departments" are encountering.
QA Contact: message-display
Depends on: 700899
This is a very general report and for different problems what appeared (and may be became fixed) in different SeaMonkey versions. For me it's unclear what the current status might be.

I think this one should be closed (leaved as a meta Bug) and for all not working commands separate bugs should be created.

Untouched for 5 years, so ASSIGNEE back to default due to facts.
Assignee: iann_bugzilla → nobody
Status: ASSIGNED → NEW
12 Years old Bug, has been out of maintenance for more than 6  years, so WFM for now. 

Please feel free to reopen this Bug if if you see necessity. But I think for remaining issues it would be more useful to reopen new Bug Reports with a unique, clear description of the issue instead of reanimating this zombie.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
(In reply to Ian Neal from comment #25)
> This was left open to cover any commands still not working when a .EML is
> opened:
> * View, Message Source
> * View, Headers, All
> * Message, Reply All
> * Message, Edit As New
> etc
> 
> I am happy for others to work on those though.

Did you verify that those are covered by other open bugs or have been fixed elsewhere?
Either way, FIXED would be a better resolution than WFM given that patches landed here.
Flags: needinfo?(RainerBielefeldNG)
Indeed, the real status is rather unclear here, but the report is so general, some requests have been fixed, some have not.

I generally prefer WFM (instead of WFM) for Bugs where Fix and/or version for which the bug has become fixed is unclear, because clarity of distinction is bad for issues with similar symptoms.

I did some tests for a saved/reopened .eml with PDF-attachment with Server-Installation of  official  en-US SeaMonkey 2.50a1 (NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0 Build 20170110004313  (Default Classic Theme) on German WIN7 64bit. Some requests have become fixed some have not, for some other issues further investigation will be required ot find out whether they are eml related or related to "separate view window". It is not useful to handle all these different issues in 1 bug, and I doubt that we need this one as a (meta).

I will file separate new Bugs (if necessary because not already do exist) for:
d) View menu items: Display Attachments Inline, Character Coding
e) Message menu items: Reply, Reply All, Forward are all black, but do nothing
f) Message menu items: Create Filter From Message
   Is no longer enabled, but:
   I think this would be possible, the dialog allows to address the filter to
   an account
h) Message | Edit As New: still does not work
i) The entire Go menu should be disabled: Submenus in dropdown are all disabled,
   so the complete "Go" menu item is useless and should be dropped
k) Items in the Message Body context ...
   Currently body context menu is completely broken, contains menu items which 
   should not be there because the functions belong to thread pane

Result was WFM for:
a) File|Attachments is not available
b) View menu items: Headers, Message Body As
c) View - Reload (for whatever that might be useful)
g) Message menu items: Move, Copy, Label, Mark now are disabled
Flags: needinfo?(RainerBielefeldNG)
Ok, so clearly something was fixed here and checked in, thus the status is undoubtedly FIXED. Once you have filed or identified bugs for remaining items, please mark them as blocking this one for reference.

Agreed that one bug should be used for each separate issue, though items may be related code-wise...

I've set the target milestone based on the checkin date of the patch (comment #10).
Assignee: nobody → iann_bugzilla
Resolution: WORKSFORME → FIXED
Whiteboard: [see comment #31 for scope]
Target Milestone: --- → seamonkey1.1alpha
See Also: → 1331042
See Also: → 1038081
See Also: → 1332387
See Also: → 1332705
See Also: → 1332896
You need to log in before you can comment on or make changes to this bug.