Last Comment Bug 208399 - Confirm deletion of a bookmark
: Confirm deletion of a bookmark
Status: VERIFIED WONTFIX
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: All All
: -- normal with 4 votes (vote)
: ---
Assigned To: Pierre Chanial
: Asa Dotzler [:asa]
Mentors:
: 221221 221635 242236 252588 254601 254679 267844 268632 279990 283556 287190 291699 304079 306836 320044 352650 379580 399840 402381 421497 424788 512674 538637 636286 755571 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-05 06:25 PDT by Hakon
Modified: 2012-05-16 03:06 PDT (History)
29 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Hakon 2003-06-05 06:25:51 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030522 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030522 Mozilla Firebird/0.6

I think that there should be a confirmation dialog before a bookmark is deleted,
both in the manager and with the context menu.
Isn't that a standard convention nowadays?

Reproducible: Always

Steps to Reproduce:
Comment 1 Simon Paquet [:sipaq] 2003-06-05 06:48:27 PDT
Not a good idea.

Take a look at the GNOME User Interface Guidelines for example 
http://developer.gnome.org/projects/gup/hig/1.0/usabilityprinciples.html#forgive-the-user

I quote:

| "If an action is very dangerous, and there is no way to undo the result, 
| warn the user and ask for confirmation. Only do this in extreme cases, 
| though; if frequently faced with such confirmation messages, users begin 
| to ignore them, making them worse than useless."

1. The action is not very dangerous.
2. This is absolutely no extreme case.
3. The action can be easily undone.

I recommend WONTFIX. CC'ing a few experienced people for their opinion.
Comment 2 David P James 2003-06-05 12:07:59 PDT
I agree with Simon. Moreover, in the Bookmarks Manager there is "Undo Delete
Bookmark" under the Edit menu. That to me is enough to WONTFIX (or more
accurately won't do) this.

-->WONTFIX
Comment 3 Erik 2003-06-05 12:13:16 PDT
I second Simon's opinion on that and also the experience in the "guideline"
quoted by Simon: too many security checks a la "Do you really want..." tempt the
user to always click the button which allows to perform the action - without
really _thinking_ about what he's doing - he just wants to get rid off this
message box.
I think anyone of us knows the typical reaction when such a message pops up: "OF
COURSE I want to do this and that - don't ask such stupid questions..." :) ... 
Furthermore IIRC there is the chance to undo a action somewhere in the bookmark
manager, hence there's no risk at all and no need for an additional confirmation
box!
Comment 4 David Tenser [:djst] 2003-06-06 02:30:13 PDT
Verifying. There is absolutely no need for a confirmation dialog when there's an
Undo feature already built in.
Comment 5 Mike Connor [:mconnor] 2003-10-04 12:03:51 PDT
*** Bug 221221 has been marked as a duplicate of this bug. ***
Comment 6 Oleg Sidletskiy 2003-10-09 01:13:51 PDT
*** Bug 221635 has been marked as a duplicate of this bug. ***
Comment 7 Bill Mason 2004-04-30 16:28:26 PDT
*** Bug 242236 has been marked as a duplicate of this bug. ***
Comment 8 Mike Connor [:mconnor] 2004-07-22 10:32:21 PDT
*** Bug 252588 has been marked as a duplicate of this bug. ***
Comment 9 Mike Connor [:mconnor] 2004-08-07 09:33:43 PDT
*** Bug 254679 has been marked as a duplicate of this bug. ***
Comment 10 Phil Ringnalda (:philor, back in August) 2004-11-04 19:59:07 PST
*** Bug 267844 has been marked as a duplicate of this bug. ***
Comment 11 Az 2004-11-05 02:39:40 PST
not everyone knows there is an undo feature if they are just deleting directly
from the menu bar.  I'm sure it is quite possible for some users to add/remove
hundreds of bookmarks over a period of time and never use the manage dialogue.

At the moment the current behaviour feels a little odd leaving the user unsure
as to whether it has been deleted or not.  While the gnome guidelines may
suggest aginst it, it is certainly expected behaviour in a Windows environment
(based on experience not windows guidelines).
Comment 12 Phil Ringnalda (:philor, back in August) 2004-11-09 20:33:22 PST
*** Bug 268632 has been marked as a duplicate of this bug. ***
Comment 13 Stasys Adiklis 2004-11-10 00:48:34 PST
My RFE (bug 268632) has been marked as a duplicate of this one, and i'm not
happy about it, bacause i've submitted my RFE asking for an OPTIONAL
confirmation dialog and i've submitted it as a WINDOWS specific issue.

So now i'll try to change summary string to iclude "option" and switch "OS" to
"All".

As expected, i've got a message that i don't have a right to change an OS
parameter or Summary string...

Anyway, i'm asking this bug to be switched back to open because of this reason:

"Delete" command is way too close to the "Sort By Name" command in Bookmarks
contex menu. And due to the sorting problem (bug 250787) i'm using Sort By Name
feature frequently (after every new bookmark addition). 

Who can give me guarantees that beeing sleepy or smth. i haven't clicked
"Delete" by mistake instead of clicking "Sort By Name"? That's why i insist on
delete confirmation dialog option - for an idication that i've clicked the
dangerous thing rather than the innocent Sort By Name. In other words: Undo
feature of the Bookmarks Manager will be useless if i won't even notice that
i've actually Deleted something by mistake. And that can easily happen because
both those commands act identically - the Bookmarks drop down menu simply closes
and that's it.
Comment 14 :Gavin Sharp [email: gavin@gavinsharp.com] 2004-12-02 22:38:57 PST
*** Bug 254601 has been marked as a duplicate of this bug. ***
Comment 15 Stasys Adiklis 2004-12-02 23:36:04 PST
Reopen and fix this ASAP. And inform GNOME User Interface Guidelines folks that
reality is not a simple as they imagine.

Alt+d is used to focus on an address bar in IE as well as Firefox. Now, imagine
me hitting alt+d in attempt to focus on Search bar while i'm in Bookmarks Manager...

In combination with the problem i've described in comment #13 it becomes a big
[CENSORED] problem.
Comment 16 José Jeria 2005-01-27 00:34:36 PST
*** Bug 279990 has been marked as a duplicate of this bug. ***
Comment 17 Kevin Brosnan 2005-03-04 22:32:56 PST
*** Bug 283556 has been marked as a duplicate of this bug. ***
Comment 18 José Jeria 2005-03-22 09:59:19 PST
*** Bug 287190 has been marked as a duplicate of this bug. ***
Comment 19 Matthias Versen [:Matti] 2005-04-24 06:27:19 PDT
*** Bug 291699 has been marked as a duplicate of this bug. ***
Comment 20 Jaime Mitchell (use bugmail@jaimem.org.uk for email) 2005-08-09 15:04:38 PDT
*** Bug 304079 has been marked as a duplicate of this bug. ***
Comment 21 Sergei Shelukhin 2005-08-09 15:19:16 PDT
1) i don't know why, but undo didn't work for me in the bookmark manager. i
didn't go there at once but i didn't close Firefox. When i decicded to go there
there was no undo. Should I file it as a separate bug?

2) Could you at least add a confirmation box to big deletions? I deleted a
folder with ~70 bookmarks across 2 subfolders and folder root. i dunno where the
margin lies (non-empty folder?), but this kind of action should be confirmed.
Comment 22 Adam Guthrie 2005-09-02 12:02:15 PDT
*** Bug 306836 has been marked as a duplicate of this bug. ***
Comment 23 Steve England [:stevee] 2005-12-12 15:59:23 PST
*** Bug 320044 has been marked as a duplicate of this bug. ***
Comment 24 Ria Klaassen (not reading all bugmail) 2006-09-14 05:02:56 PDT
*** Bug 352650 has been marked as a duplicate of this bug. ***
Comment 25 Steve England [:stevee] 2007-05-03 04:41:11 PDT
*** Bug 379580 has been marked as a duplicate of this bug. ***
Comment 26 Jo Hermans 2007-10-15 01:30:32 PDT
*** Bug 399840 has been marked as a duplicate of this bug. ***
Comment 27 Ria Klaassen (not reading all bugmail) 2007-11-04 14:14:58 PST
*** Bug 402381 has been marked as a duplicate of this bug. ***
Comment 28 Bernie 2007-11-04 22:31:37 PST
You marked Bug 402381 as a duplicate of this one.  Not quite, although I can see that my request has also been discussed here.  Although I think it would be a good idea to confirm deleting a bookmark, it is MUCH more important to confirm deleting an entire folder of bookmarks.  In contrast to Simon's reply of 2003-06-05, when deleting a Folder from the Sidebar, which is too easily done inadvertently, there is no obvious Undo.  And with the Sidebar there is little reason to use the Bookmark Manager at all and to even know there is an Undo.  Indeed, it is easier to manage Bookmarks in the Sidebar than in the Bookmark Manager.  

So, rather than Simon's assertions, it is clear that many users over the years have felt that:
1. The action is very dangerous.
2. This can be an extreme case (scores of bookmarks can be deleted by deleting one folder).
3. The action can not be easily undone - by most users.

I don't recall if the Bookmark Sidebar was even available back when htat reply was written in 2003.

I hope this will be reconsidered.  

Comment 29 Kevin Brosnan 2008-03-07 07:00:51 PST
*** Bug 421497 has been marked as a duplicate of this bug. ***
Comment 30 Matthias Versen [:Matti] 2008-03-24 08:26:07 PDT
*** Bug 424788 has been marked as a duplicate of this bug. ***
Comment 31 Marco Bonardo [::mak] (Away 6-20 Aug) 2009-08-26 06:05:10 PDT
*** Bug 512674 has been marked as a duplicate of this bug. ***
Comment 32 Kevin Brosnan 2010-01-08 11:23:32 PST
*** Bug 538637 has been marked as a duplicate of this bug. ***
Comment 33 XtC4UaLL [:xtc4uall] 2011-02-24 03:31:27 PST
*** Bug 636286 has been marked as a duplicate of this bug. ***
Comment 34 Matthew Middleton (:zzxc) 2011-02-24 06:34:37 PST
After eight years, the core issue of this bug should be reexamined.  In Firefox 4, it remains much easier to delete than to undo.  There is no visible indication to the user that undo is even possible, unless the user thinks to open the Edit submenu of the Firefox menu to check.  It remains easy to delete bookmarks via the Delete key, which can happen by accident when using the bookmarks sidebar.

In Firefox 4, the current behavior is more disruptive than previously, as the undo feature is broken when used from the sidebar, leaving no way for users to undo an accidental folder deletion.  (bug 636280)

This could be improved by requiring a confirmation for large deletions, by making accidental deletions harder, or by making undo easier.
Comment 35 Jakub 'Livio' Rusinek 2011-02-24 07:27:07 PST
I've got another idea. After first deletion a notification can be shown. Either window with automatically selected "Do not show in the future" or download-completed-like notification without any checkboxes.

 _________________________________________________
|                                                 |
| ( i ) Did you know, that if you've just deleted |
|       an important bookmarks, you can easily    |
|       have it back using "Undo" in "Manage      |
|       bookmarks?".                              |
|                                                 |
| [ x ] Do not show in the future          [ OK ] |
|_________________________________________________|
Comment 36 Matthias Versen [:Matti] 2012-05-16 03:06:09 PDT
*** Bug 755571 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.