Closed Bug 250415 Opened 15 years ago Closed 8 years ago

Ctrl+scrollwheel should Zoom/Unzoom message by default (mousewheel.withcontrolkey.action = 3)

Categories

(Thunderbird :: Preferences, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 10.0

People

(Reporter: hartsook, Assigned: tipecaml)

References

(Blocks 2 open bugs)

Details

(Whiteboard: parity-opera)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

ctrl-scroll wheel up/down should change the font size. This works fine in the
e-mail message pane in Mozilla, but not in Thunderbird.

Reproducible: Always
Steps to Reproduce:
1.select an email
2.put cursor in e-mail message pane
3.hold control key and rotate scroll wheel on mouse, font size in message pane
does not change 

Actual Results:  
message itself scrolls if longer than pane

Expected Results:  
font in message should increase or decrease, just as it does in Mozilla,
Outlook, etc.
Confirm this in Thunderbird 0.7.1 on Win2k.
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Does this work in Firefox?  Thunderbird was changed from Seamonkey's zoom to
Firefox's zoom some months ago.
works just fine in FireFox 0.9.1
Confirm this in Thunderbird 1.5.0.7 on WinXP Home.
On Firefox 1.5.0.7 (WinXP Home) crtrt-scrollwheel does change font size on any web page.
 
In Thunderbird, you need to set the preference to enable this:
  mousewheel.withcontrolkey.action  =  3
> In Thunderbird, you need to set the preference to enable this: mousewheel.withcontrolkey.action  =  3

Shouldn't this value be set as default?
This is how it works in other popular applications.
(In reply to comment #6)
> Shouldn't this value be set as default?

I suppose it should.


> This is how it works in other popular applications.

In my experience, the default zoom-in/zoom-out action for Mozilla products works in the reverse direction of "other popular applications" -- which, in my case, means Opera.  So I also set:
  mousewheel.withcontrolkey.sysnumlines  =  false
  mousewheel.withcontrolkey.numlines     =  -1
Severity: normal → enhancement
Component: Mail Window Front End → Preferences
OS: Windows XP → All
QA Contact: preferences
Hardware: PC → All
Summary: crtrt-scrollwheel doesn't change font display size in e-mail message pane → ctrl+scrollwheel should default to "change font size" in e-mail message pane (mousewheel pref = 3)
Version: unspecified → Trunk
Summary: ctrl+scrollwheel should default to "change font size" in e-mail message pane (mousewheel pref = 3) → Ctrl+scrollwheel should Zoom/Unzoom message by default (mousewheel.withcontrolkey.action = 3)
Flags: blocking-thunderbird3?
Whiteboard: parity-opera
(In reply to comment #7)
> In my experience, the default zoom-in/zoom-out action for Mozilla products
> works in the reverse direction of "other popular applications"

What others do is not always the right thing to do. I want to provide some reasons to keep the mousewheel-DOWN = increase text size:

- Pulling the mousewheel DOWN is like PULLING the page toward you.

- Pushing the mousewheel UP is like PUSHING the page away from you.

Think of how a fishing reel or a pulley works.

Also, when I "pull" on the mousewheel, it (subtly) brings my body (eyes) closer
to the screen. It's the third Law of Physics: Every Action has an Equal and
Opposite Reaction.

Please either:
1. make mousewheel DOWN = zoom IN by default
2. make this a UI option
3. make this a hidden option (edit:config)

Regarding "Whiteboard: parity-opera": I think to desire parity with a product that has a minuscule market share (likely for a good reason) is poor judgment.
wouldn't block.  assigning to bryan for his call.
Assignee: mscott → clarkbw
Flags: wanted-thunderbird3?
Flags: blocking-thunderbird3?
Flags: blocking-thunderbird3-
Duplicate of this bug: 512974
Duplicate of this bug: 527326
re. comment #7 Exactly - think how a fishing reel works, you wind it in by moving your hand up and away from you NOT down and toward you.
Duplicate of this bug: 567162
Duplicate of this bug: 580232
Since marking my bug 567162 as dup of this one here,
I would like to additionally request FULL ZOOM as default here
(browser.zoom.full = true).
(In reply to comment #12)
> re. comment #7 Exactly - think how a fishing reel works, you wind it in by
> moving your hand up and away from you NOT down and toward you.

Not sure why the discussion about whether in or out is up or down is essential to this change.  If the direction is wrong, at least it's usable.  Right now it's nothing (without advanced configuration that the vast majority of people don't know about).

IMO take the free "win" and make Ctrl-ScrollWheel do /something/, and save the discussion for which direction it works for another Bug.

Also, this Bug has been assigned since 2008-06-17 with no comment from the Assignee.



P.S. my 0.02 is that it's better to be consistent with sister products (e.g. Firefox) than "other populate applications", even if those other applications are every other application in the world.  Having FF and TB be different is just punishing users who are brand-loyal.
I shouldn't be the assignee for these bugs.  Filter against clarkbfilter to delete all these from your emails.
Assignee: clarkbw → nobody
Confirm this on Thunderbird 5.0 on Windows Vista. Zooming by Ctrl-Mouswheel is so common nowadays.
This simple patch fixes this issue.
Attachment #570499 - Flags: review?(bwinton)
Comment on attachment 570499 [details] [diff] [review]
Ctrl+Mousewheel now zooms in/out by default.

Review of attachment 570499 [details] [diff] [review]:
-----------------------------------------------------------------

So, I'm on a Mac, and can't test this, but the patch seems simple enough, and matches the behaviour in mozilla/browser/app/profile/firefox.js, so I'm going to say r=me.

Thanks,
Blake.
Attachment #570499 - Flags: review?(bwinton) → review+
Assignee: nobody → tipecaml
Status: NEW → ASSIGNED
Keywords: checkin-needed
Checked in as http://hg.mozilla.org/comm-central/rev/8fddd3135669
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 10.0
Duplicate of this bug: 705563
Depends on: 512968
I suppose this should be mentioned in Release Notes, and documented on the Keyboard Shortcuts page (1), for which we need a new bug which should then be added to tbkbd-doc-tracker (instead of this bug).
This is a nice improvement, albeit with a small usability problem for composition (from Bug 512968, Comment 0):

> So you will never be able to go back to the default zoom level, because you
> will never know when you reach 100 % again via Ctrl + Mousewheel, since the
> Zoom Level isn't displayed anywhere.

Bug 512968 - Zoom level in COMPOSE window cannot be reset to default 100% (e.g. via exiting/closing and re-opening the window)

The current zoom behaviour when re-opening drafts is pretty much unpredictable, as explained with STR in Bug 512968 Comment 3.

In composition, we can't use Ctrl+0 for resetting the zoom because Ctrl++ and Ctrl+- actually change the font size (surprisingly, and to be reconsidered in a new bug), so Ctrl+0 should bring the font size back to normal (but currently, Ctrl+0 does nothing, another bug).

Cyril (patch coder), can you reset the zoom level to 100% each time we create or re-open a compose window? (and perhaps we need ui-review for that)
This is documented on the "New in TB 10" page (http://support.mozillamessaging.com/kb/new-thunderbird-10).
Ludo, can you check which modifier keys are usually needed to use wheel-zoom on MAC? Make sure you are using default settings, because it seems this can be modified systemwide, looking at http://mactoids.com/zoom-using-scroll-wheel-in-mac-os-x-leopard/

I can't believe it's Command+Ctrl+scroll wheel by default (with *two* concurrent accelerator keys), as currently shown on new-thunderbird-10?
(In reply to Thomas D. from comment #26)
> Ludo, can you check which modifier keys are usually needed to use wheel-zoom
> on MAC? Make sure you are using default settings, because it seems this can
> be modified systemwide, looking at
> http://mactoids.com/zoom-using-scroll-wheel-in-mac-os-x-leopard/
> 
> I can't believe it's Command+Ctrl+scroll wheel by default (with *two*
> concurrent accelerator keys), as currently shown on new-thunderbird-10?

According to (1) and (2), the default on MAC OS X is Control, so I'll fix that in new-thunderbird-10:

> Notice that Mac OS X will also allow you to switch to a different Modifier Key
> if you prefer something other than the *default Control key.*

Confirmation here would still be appreciated.

(1) http://mactoids.com/zoom-using-scroll-wheel-in-mac-os-x-leopard/
(2) http://daringfireball.net/2006/09/zoom_using_scroll_wheel
(In reply to Thomas D. from comment #27)
> (In reply to Thomas D. from comment #26)
> > Ludo, can you check which modifier keys are usually needed to use wheel-zoom
> > on MAC? Make sure you are using default settings, because it seems this can
> > be modified systemwide, looking at
> > http://mactoids.com/zoom-using-scroll-wheel-in-mac-os-x-leopard/
> > 
> > I can't believe it's Command+Ctrl+scroll wheel by default (with *two*
> > concurrent accelerator keys), as currently shown on new-thunderbird-10?

It is. Ctrl + scroll wheel zooms the entire display. Ctrl + command + scroll wheel zooms the message.
Roland, I'm now completely confused after your current revision (1) of "New in Thunderbird 10", which contradicts with comment 28.

In comment 28, Jen has explicitly confirmed that:
> a) {for mac} Ctrl + scroll wheel zooms the *entire display*.
> b) {for mac} Ctrl + *command* + scroll wheel zooms *the message pane* [browser].

In revision 5736, *you* seem to say that:
c) {for mac} Ctrl + scroll wheel zooms *the message pane* [browser]
That's a mixture of a) and b).

So comment 28 says:
- a) there's an OS wide zoom function on MAC, which can be used to magnify *any* part of the display (i.e. the entire screen), in *any* application.
By default, this has an OS-wide shortcut, Ctrl+wheel (which can be customized to use other accelerator keys, as described in (2)). This also works for zooming anything in the TB window, but it's not a TB function.
- b) there's a thunderbird/firefox-specific zoom function which zooms the *content area* of browser elements, here: the message pane area of a message window. This will *only* work for the message pane area (browser).
This TB/browser function has the TB-owned keyboard shortcut Ctrl+*Command*+wheel.

Whereas revision 5736 seems to claim that:
- c) TB is using an MAC-OS system-wide default shortcut (Ctrl+wheel) to zoom its own application-specific message pane (browser) area. That's a mixture of a) and b).

I'm inclined to think that Jen's comment 28 (a+b) is right, and your revision 5736 is wrong, for the following reasons:

- I'm sure Jen didn't just invent the distinction between a) and b), but there is a knowledgable source from which she gathered that information, or she tested this herself on a MAC.
- Jen's comment 28 concurs with documentation like (2) which says that a) is a system-wide MAC-OS shortcut which serves to "magnify a specific area on your Mac desktop?". That's not the same as TB/browser's zoom function for the content area, at all, although it will be easy to be fooled.
- It's surprising that you seem to claim that Command+0 doesn't work on MAC to reset the zoom for *message reader*, but it concurs with my suspicion that you were using the mac system zoom instead of TB's internal browser zoom: of course Command+0 won't work if you used Ctrl+wheel before, which is the mac system zoom, which won't go away with Command+0, because that's a TB shortcut.

STR to test this out on MAC:

1) on MAC, main mail window, with msg preview, view a msg
2) focus on msg in msg list
3) move mouse to hover over msg preview
4) hold Ctrl+Command(sic! two keys!) while spinning mouse wheel to zoom, so that's Ctrl+Command+wheel

Expected result:
- msg pane only is zoomed

5) coming from 4), press Command+0 (that's [cmd], *not* Ctrl!)

Expected result:
- msg pane only: zoom is reset to 100%

6) Compose a new msg, type "hello world" into editor, cursor-focus after world
7) move mouse to hover over "hello world" in editor
8) hold Ctrl+Command(sic! two keys!) while spinning mouse wheel to zoom, so that's Ctrl+Command+wheel

Expected result:
- editor pane only is zoomed

8) Confirm you've got MAC OS default settings for wheel-zoom, per online documentation (3):
ensure (x) "Zoom using scroll wheel while holding" is checked
ensure (x) "Zoom using scroll wheel while holding" is set to "^ Control" (and be careful not to press two keys here simultaneously, because they will be accepted!)
9) Back to TB composition, attach a file, anyfile.ext
10) move mouse to hover over attachment pane
11) hold [Ctrl] only while spinning mouse wheel (still over attachment pane); that's [Ctrl], *not* cmd.

Expected result
- attachment pane (and possibly entire screen) will be zoomed

Unfortunately, I don't have a MAC, so I don't know how exactly mac os zoom function is meant to work.

Right, that's a start.

Roland, can you please verify on MAC with "Actual results" for all of the "Expected results" above?

I'm starting to wish I had a MAC... if only for testing purposes...

(1) https://support.mozillamessaging.com/en-US/kb/new-thunderbird-10/revision/5736
(2) http://mactoids.com/zoom-using-scroll-wheel-in-mac-os-x-leopard/
(3) http://daringfireball.net/2006/09/zoom_using_scroll_wheel
And FTR, as explained in comment 29, I now believe that *my* old revision of "New in Thunderbird 10" is also *wrong* (even though I claimed to fix the wrong shortcut):
https://support.mozillamessaging.com/en-US/kb/new-thunderbird-10/revision/5676

Whereas I think that Jen's revision must be *right*:
https://support.mozillamessaging.com/en-US/kb/new-thunderbird-10/revision/5688
(In reply to Thomas D. from comment #24)
> This is a nice improvement, albeit with a small usability problem for
> composition (from Bug 512968, Comment 0):
> 
> > So you will never be able to go back to the default zoom level, because you
> > will never know when you reach 100 % again via Ctrl + Mousewheel, since the
> > Zoom Level isn't displayed anywhere.
> 
> Bug 512968 - Zoom level in COMPOSE window cannot be reset to default 100%
> (e.g. via exiting/closing and re-opening the window)

Furthermore, fwiw, I had deliberately *not* mentioned on "new in tb10" that accelerator(s)+zoom wheel also works in composition, because we'll just inspire users to run into bug 512968. For users that also use Ctrl++ and Ctrl+- in composition to change the physical size of the text as printed on paper, this will lead to total confusion, and, due to bug 512968, and other bugs still to be filed, we neither show the zoom anywhere nor do we have a shortcut to reliably set this back to 100% (and we can't use Ctrl+0 to reset zoom in composition as long as we have Ctrl++ and Ctrl+- for the text size). So no matter who's right or wrong about comment 29, Thunderbird is *always* wrong, as usual. :(
I believe I fixed in new in thunderbird 10:
For Mac OS X: Command + Control + scroll wheel (not control + screenwheel which is used by Mac OS X  Operating System Level scroll)
Flags: wanted-thunderbird3?
Thunderbird 10 shipped a while ago, I don't know if we documented it, but I don't think we need the relnote now.
Keywords: relnote
Duplicate of this bug: 588034
You need to log in before you can comment on or make changes to this bug.