Display - Fonts tab: The pull-down menu of Character Encodings doesn't work.

VERIFIED FIXED in Thunderbird2.0

Status

Thunderbird
Preferences
--
major
VERIFIED FIXED
13 years ago
11 years ago

People

(Reporter: Hiro, Assigned: Scott MacGregor)

Tracking

({intl, verified1.8.0.2, verified1.8.1.3})

Thunderbird2.0
intl, verified1.8.0.2, verified1.8.1.3
Bug Flags:
blocking1.8rc2 -
blocking-thunderbird2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

5.54 KB, patch
Bienvenu
: superreview+
Scott MacGregor
: approval1.8.0.2+
Scott MacGregor
: approval1.8.1+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
The pull-down menu of �hCharacter encodings" doesn't work when Option is displayed with "Display - Fonts" displayed with last Option and the font button is pushed. 

Reproducible: Always

Steps to Reproduce:
1.Create new profile.
   (Migration is not done. and the mail account need not be made.)
2. Open Tool --> Options
3. Select "Display" tab and "Fonts" tab
4. Close Option window
5. Re-open Option window
6. Push "Fonts" button
7. Close Font setting window
8. Click pull-down menu of "Character encodings"
   (Both Outgoing and Incoming)

Windows XP SP1
trunk and 1.8 branch build
version 1.5 (20051103)
version 1.6a1 (20051103)
(Reporter)

Comment 1

13 years ago
The Mac version reproduced. 
1.8branch build version 1.5 (20051103)
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 2

13 years ago
xref bug 285302, duped to bug 285076 (XUL Template Builder bug).

In bug 285076 comment 53, Scott said:
> this [fix] has been backed out due to Bug #310833.
> no longer a blocker as I've worked around it for 1.5
Severity: normal → major
Flags: blocking1.8rc2?
Summary: Display - Fonts tab: The pull-down menu of �hCharacter encodings" doesn't work. → Display - Fonts tab: The pull-down menu of Character Encodings doesn't work.
Version: unspecified → 1.5
(Assignee)

Comment 3

13 years ago
the character encoding menu still works the first time you open the options dialog. That can be the work around for 1.5.

It's too late in the 1.5 cycle to respin for this. This isn't a show stopper anymore. putting in the 2.0 bucket so we don't lose track of this.
Flags: blocking1.8rc2? → blocking1.8rc2-
Target Milestone: --- → Thunderbird2.0

Comment 4

13 years ago
*** Bug 301858 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
*** Bug 307810 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
Bug 313987 is a similar problem with a different dropdown.
(In reply to comment #6)
> Bug 313987 is a similar problem with a different dropdown.
 
Mike, I don't think that's a similar problem. This bug hides the complete charset list when clicking on it. But on bug 313987 there is no initialisation of the list. Or I'm wrong?
Flags: blocking-thunderbird2?
This won't even get fixed for the 1.5.1 release?

Comment 9

13 years ago
(In reply to comment #7)
> (In reply to comment #6)
> > Bug 313987 is a similar problem with a different dropdown.
> 
> Mike, I don't think that's a similar problem. This bug hides the complete
> charset list when clicking on it. But on bug 313987 there is no initialisation
> of the list. Or I'm wrong?

I think you're right, actually.  Sorry for the noise.

Comment 10

13 years ago
*** Bug 323506 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 11

13 years ago
*** Bug 323751 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Keywords: intl
(Assignee)

Comment 12

13 years ago
Created attachment 209898 [details] [diff] [review]
the fix

don't use the xul template builder in the font pref  panel because the template builder doesn't work with dynamic overlays. Build the menus by hand like we did for the address book list boxes in the privacy and composition dialogs for 1.5.
Attachment #209898 - Flags: superreview?(bienvenu)
Attachment #209898 - Flags: approval1.8.1?
Attachment #209898 - Flags: approval1.8.0.2?
(Assignee)

Updated

13 years ago
Flags: blocking-thunderbird2? → blocking-thunderbird2+

Comment 13

13 years ago
Comment on attachment 209898 [details] [diff] [review]
the fix

+    if (n)
+      return n.QueryInterface(Components.interfaces.nsIRDFLiteral).Value;
+    else
+      return "";


can use return (n) ? n.QI... : ""; here if you want
Attachment #209898 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Updated

13 years ago
Attachment #209898 - Flags: approval1.8.1? → approval1.8.1+
(Assignee)

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Works fine with TB version 1.6a1 (20060128) now.
Status: RESOLVED → VERIFIED

Comment 15

13 years ago
*** Bug 325044 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 16

13 years ago
Comment on attachment 209898 [details] [diff] [review]
the fix

this has baked long enough.
Attachment #209898 - Flags: approval1.8.0.2? → approval1.8.0.2+
(Assignee)

Updated

13 years ago
Keywords: fixed1.8.0.2
verified fixed on the 1.8.0 branch using version 1.5.0.2 (20060308. I was not able to reproduce following the reporter's STR. Adding keyword.
Keywords: fixed1.8.0.2 → verified1.8.0.2

Updated

12 years ago
Duplicate of this bug: 330795

Comment 19

11 years ago
verified fixed thunderbird 2.0.0.0 rc2 windows/linux. If you can reproduce this please download a build from <http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2.0.0.0-candidates/rc2/> and report back here if you can reproduce it with that.
Keywords: fixed1.8.1 → verified1.8.1.3
You need to log in before you can comment on or make changes to this bug.