eBay filters content based on Accept-Language header

RESOLVED INCOMPLETE

Status

Tech Evangelism
Desktop
RESOLVED INCOMPLETE
13 years ago
3 months ago

People

(Reporter: Chris Lawson (gone), Assigned: Chris Lawson (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-de] [needanalysis] [http] [serversniff] [platform-rel-eBay])

(Assignee)

Description

13 years ago
eBay does filtering on certain items, ostensibly to prevent them from being viewed in areas where they're illegal. However, they way they filter is utterly idiotic: they look at the Accept-Language header sent by the browser and filter based on that.

For example (and the way I noticed this issue):

My browser (Camino) sends "fr" and "de" as the fourth and fifth languages, respectively. As a result, I cannot view any items on eBay that *might* be illegal in either France or Germany, because eBay assumes that if I view French or German pages, I must be either French or German and therefore cannot view those items.

eBay needs to find a new way to implement its filtering, because there is absolutely nothing illegal about an American viewing items (specifically, in this case, the book "Clipped Wings" by R. W. Kimball) that may or may not be considered illegal in other jurisdictions.
Agreed, but how is this mozilla.org Tech Evangelism? -> INVALID
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Assignee)

Comment 2

13 years ago
The same way bug 294201 is -- eBay is screwing users of Mozilla browsers, which generally have de and fr in the accept-language string. Browsers such as Safari don't typically do this. I don't know about IE; don't have a copy around to investigate.

cl
(In reply to comment #2)

I don't see how our fixing a bug which caused a change in layout behaviour which caused a menu system to stop working as intended relates to a decision by eBay to censure the content which is presented French and German speakers.

The work around is to temporarily change the accept headers you send to such sites.
(Assignee)

Comment 4

13 years ago
(In reply to comment #3)
> The work around is to temporarily change the accept headers you send to such
> sites.

Yes, but isn't the point of Tech Evangelism bugs to get the offending site's webmaster to fix his/her broken "sniffing"? My apologies if I've misconstrued the purpose of Tech Evangelism. I was hoping having the weight of b.m.o behind a request for smarter censorship might move eBay to act. I know my complaint will be ignored.

cl
The sniffing doesn't seem broken, just wrong and not even effective. I mean it looks like they intentionally do it as a result of a wrong-headed business decision. 

Tech Evangelism is about getting sites to use standards to the extent possible to allow all browsers including ours to be used. For example, suppose a site uses the DOM standards to put annoying advertisements into pages which tracked the scroll position. That happens already. There is not any point in mozilla.org Tech Evangelism trying to convince them not to do it any more than our trying to evangelize sites that want to use unsolicited popup advertisements.

But I would suggest: a) complain to eBay, b) complain to the EFF, c) send a note to several online news organizations about this practice. Turn the light on this decision and see what happens. I just don't think that is our mission in Tech Evangelism.

Updated

10 years ago
Duplicate of this bug: 455233

Updated

10 years ago
Duplicate of this bug: 457816
(Assignee)

Comment 8

10 years ago
Bob, do we have any contacts at eBay we can lean on? As you can see, eBay is expanding their use of this silly practise and it's starting to get rather annoying.
(Assignee)

Updated

10 years ago
Duplicate of this bug: 471541

Comment 10

10 years ago
Two comments:
1. From a user perspective, this is seen as a Camino "bug" because one does not see that behavious when using a different browser - Safari in my case.
That's unfortunate because from the discussion above it's really an ebay issue.
2. I think getting ebay to fix that is a real long shot. Ebay has made many software changes to prevent auctions from being shown to users in certain countries both in their new eBay search software and the new "My Ebay" software - a lot of it is totally illogical and it seems to be driven by their current management team.
This issue falls into the same general category.

Comment 11

10 years ago
This same issue occurs on YouTube as well, only it isn't a 'problem' because it doesn't inhibit anything.  Neither Safari nor Firefox have this issue.

Updated

9 years ago
Duplicate of this bug: 494767

Updated

8 years ago
Duplicate of this bug: 548541
(Assignee)

Comment 14

8 years ago
Because I thought someone had mentioned the workaround here, and no one has...

The workaround is to remove French and/or German from the list of languages in System Preferences. If you only speak English, remove everything except English if you wish.


(In reply to comment #5)
> Tech Evangelism is about getting sites to use standards

Isn't it also about getting sites not to *mis-use* standards? As you noted elsewhere in comment 5, this behaviour, though it uses a standard HTTP header, is not only wrong but ineffective. It isn't an issue of their using standards to create merely annoying behaviour, like a popup ad, but using standards in a wrong way. No one could possibly argue that the presence of a language in the accept-language header means the browser is physically located in the country where that language is natively spoken.

I actually know a lawyer at eBay and I'm happy to take this bug. I'll ping him next time I see him online and see if he knows who we can talk to about this. Geographical IP sniffing seems like a much better solution to eBay's perceived legal issue than their current behaviour is, and it would fix this bug.
Assignee: english-us → cl-bugs-new2
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Assignee)

Updated

8 years ago
Whiteboard: workaround in comment 14

Updated

7 years ago
Duplicate of this bug: 634492

Comment 16

7 years ago
(In reply to comment #15)
> *** Bug 634492 has been marked as a duplicate of this bug. ***
Clearly this bug has not been addressed - the previous entry was over six months ago and even then the blame seems to be directed at eBay when clearly the only browser having difficulty is Camino.
(Assignee)

Comment 17

7 years ago
(In reply to comment #16)
> (In reply to comment #15)
> > *** Bug 634492 has been marked as a duplicate of this bug. ***
> Clearly this bug has not been addressed - the previous entry was over six
> months ago and even then the blame seems to be directed at eBay

Yes, because Camino has absolutely no control over eBay's servers. If you don't understand the problem, you probably shouldn't be trying to assign blame for it.

Comment 18

7 years ago
(In reply to comment #14)
> Because I thought someone had mentioned the workaround here, and no one has...
> 
> The workaround is to remove French and/or German from the list of languages in
> System Preferences. If you only speak English, remove everything except English
> if you wish.
> 
> 
I don't understand how this can be an acceptable workaround.
I'm in Canada and use English, French and German as languages to correspond with. If I remove both French and German from System preferences, then spell check for those languages will no longer work - not sure about special characters like accents and umlauts, if they are affected as well.
Wouldn't it make more sense to have an option in Camino to be able to turn off that language identifier?

Comment 19

7 years ago
There is a (hidden) preference for it; see:
http://caminobrowser.org/documentation/hiddenprefs/#ManualAcceptLang

The workaround Chris mentioned is the simplest approach for most people, because most people only have French and/or German in their list because it is there by default, not because they actually want it there.

Comment 20

7 years ago
Michael: if you are curious about the technical reason for this bug, read bug 455233. We consider doing a better job of supporting multi-lingual users than Safari and Firefox do to be a feature, and we aren't going to remove that feature just because one company doesn't grasp the difference between the accept-language header and geolocation.

>  when clearly the only browser having difficulty is Camino.

This is demonstrably false. Set you OS language to French, launch Safari, and go to the same page. Or configure Firefox to include French in your accept-language header list, and then go to the same page. You'll be blocked exactly the same way. The difference between Safari and Camino is that Safari only allows you to have one accept language. The difference between Firefox and Camino is that Firefox makes you configure your language preferences again even if you've already done it for the OS, whereas Camino uses the OS settings directly (better integration with the OS being a primary goal of Camino).

Comment 21

7 years ago
I have tried Safari and Firefox as my default browser on occasion and always come back to Camino for two basic reasons - one: It's the only one of the three that works on every website I visit regularly.
Yes - sometimes Camino doesn't work especially when it comes to some forms, but that is just the odd occasion, and two - it's the only browser of the three that allows multiple rows in the bookmark bar which is a feature I treasure.
Back to the "problem" at hand - does that actually still exist on ebay?
I haven't come across that on any ebay auction for the longest time. Is there a way to test it?
(Assignee)

Comment 22

7 years ago
(In reply to comment #21)
> I haven't come across that on any ebay auction for the longest time. Is there a
> way to test it?

Sure, just set your OS language to French (or German) and visit, for example, the link in bug 634492.

Trust me, it's still happening. Unfortunately, I spoke with my lawyer friend at eBay and wasn't able to get anywhere. I'll try to talk with him again soon, though.

Comment 23

7 years ago
(In reply to comment #21)
> I have tried Safari and Firefox as my default browser on occasion and always
> come back to Camino for two basic reasons - one: It's the only one of the three
> that works on every website I visit regularly.
> Yes - sometimes Camino doesn't work especially when it comes to some forms, but
> that is just the odd occasion, and two - it's the only browser of the three
> that allows multiple rows in the bookmark bar which is a feature I treasure.
> Back to the "problem" at hand - does that actually still exist on ebay?
> I haven't come across that on any ebay auction for the longest time. Is there a
> way to test it?

I have an item for sale at present that creates this error only in Camino.
Enter 330531260704 and it will bring you to that item (Organic Sunscreen)

Comment 24

7 years ago
Ebay 330531260704 comes up fine for me.

I have language preferences set up for Canadian English, English, Deutsch, Francais Canadien, Espanol....in that order.
I tried the ebay auction with ebay.com and ebay.de
Everything worked as it should - where exactly is the problem?

Comment 25

7 years ago
(In reply to comment #24)
> Ebay 330531260704 comes up fine for me.
> 
> I have language preferences set up for Canadian English, English, Deutsch,
> Francais Canadien, Espanol....in that order.
> I tried the ebay auction with ebay.com and ebay.de
> Everything worked as it should - where exactly is the problem?

I tried going to both eBay.com and eBay.de and ended up with the same error .de the message was is German.
Here is the message I get written in Red:
Unfortunately, access to this particular listing or item has been blocked due to a Paris commercial court decision that bans trade of certain authentic perfumes and cosmetic products on eBay because of French selective distribution laws. eBay is appealing this ruling but is nevertheless required to enforce it. We are blocking your viewing in an effort to comply with this court decision. Regrettably, in some cases, we may prevent users from accessing items that are not within the scope of the decision because of limitations on existing technology.

Comment 26

7 years ago
Well, I set my OS language to German, rebooted and tried that ebay auction again on ebay.com and ebay.de - both fine
Then I set my OS language to Canadian French which actually just shows up as "French" in the language selection window bottom left.
Everything still worked as it should with ebay.

Which OS language preference have you set up where you see the problem?
I remember seeing that message you posted but that was ages ago.

Comment 27

7 years ago
(In reply to comment #26)
The problems occurs no matter which language I select.
This is very baffling.

Comment 28

7 years ago
Since that particular link's ban is just for France, it's likely they look for fr (not fr-CA). It's unlikely German has anything to do with this one at all. The reason German is discussed in this bug is because there are different auctions eBay has to block in Germany for legal reasons.

If you want to keep discussing individual cases between yourselves please use the forums rather than bogging down this bug with a lot of detailed discussion of one specific example. The problem of eBay using accept-language as a location signal unquestionably still exists.

Comment 29

7 years ago
Sorry, I'd be happy to use the forums to understand this issue better if I knew where this discussion was in the forums.

As far as ebay is concerned, the best way to get this resolved is to bring it up in an ebay discussion group that is monitored by the ebay software design team. We had a similar problem fixed where ebay assumed that the ebay location of the bidder was also automatically the shipping address (ie an address the seller would not ship to).
(Assignee)

Comment 30

7 years ago
(In reply to comment #29)
> As far as ebay is concerned, the best way to get this resolved is to bring it
> up in an ebay discussion group that is monitored by the ebay software design
> team.

If you know of such a place, by all means, tell us where it is.

Updated

6 years ago
Duplicate of this bug: 764294

Updated

6 years ago
Duplicate of this bug: 768787
ebay has recently changed its full framework. 
Does this issue still occur?
Status: REOPENED → NEW
Component: English US → Desktop
Whiteboard: workaround in comment 14 → [country-de] [needanalysis] [http] [serversniff]
platform-rel: --- → ?
Whiteboard: [country-de] [needanalysis] [http] [serversniff] → [country-de] [needanalysis] [http] [serversniff] [platform-rel-eBay]
platform-rel: ? → ---
Status: NEW → RESOLVED
Last Resolved: 13 years ago3 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.