Closed Bug 366268 Opened 16 years ago Closed 14 years ago

Update Google Snippets localizations on Firefox Start Page

Categories

(www.mozilla.org :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 444568

People

(Reporter: pascalc, Assigned: pascalc)

References

()

Details

Attachments

(59 files, 21 obsolete files)

1.11 KB, text/plain
Details
1.42 KB, text/plain
Details
1.16 KB, text/plain
Details
1.23 KB, text/plain
Details
1.13 KB, text/plain
Details
1.12 KB, text/plain
Details
1.29 KB, text/plain
Details
1.23 KB, text/plain
Details
1.24 KB, text/plain
Details
1.64 KB, text/plain
Details
1.29 KB, text/plain
Details
1.19 KB, text/plain
Details
1.21 KB, text/plain
Details
1.16 KB, text/plain
Details
1.21 KB, text/plain
Details
1.22 KB, text/plain
Details
1.59 KB, text/plain
Details
1.17 KB, text/plain
Details
1.18 KB, text/plain
Details
1.27 KB, text/plain
Details
1.23 KB, text/plain
Details
1.16 KB, text/plain
Details
1.17 KB, text/plain
Details
1.19 KB, text/plain
Details
1.32 KB, text/plain
Details
1.15 KB, text/plain
Details
1.09 KB, text/plain
Details
1.17 KB, text/plain
Details
1.48 KB, text/plain
Details
1.15 KB, text/plain
Details
1.16 KB, text/plain
Details
1.35 KB, text/plain
Details
1.58 KB, text/plain
Details
1.18 KB, text/plain
Details
1.11 KB, text/plain
Details
1.15 KB, text/utf8
Details
1.30 KB, text/plain
Details
1.13 KB, text/plain
Details
192.07 KB, image/jpeg
Details
1.98 KB, text/plain
Details
1.50 KB, text/plain
Details
1.90 KB, text/plain
Details
1.26 KB, text/plain
Details
1.58 KB, text/plain
Details
1.24 KB, text/plain
Details
1.46 KB, text/plain
Details
2.00 KB, text/plain
Details
1.11 KB, text/plain
Details
1.71 KB, text/plain
Details
1.37 KB, text/plain
Details
1.14 KB, text/plain
Details
1.82 KB, text/plain
Details
1.49 KB, text/plain
Details
1.76 KB, text/plain
Details
1.77 KB, application/octet-stream
Details
1.67 KB, application/octet-stream
Details
2.16 KB, text/plain
Details
1.79 KB, text/plain
Details
2.05 KB, application/octet-stream
Details
The Google/Firefox start page provides tips which are outdated in Localized versions of the page.

Localizers will find attached to this bug a file (ggsnippets.lang) containing the updated strings to translate for their language.

The file is organized as such :

#About Mozilla
About Mozilla


The second string should be localized, like this:

#About Mozilla
À propos de Mozilla

Please attach your translated file to this bug.

Thanks
Status: NEW → ASSIGNED
Component: Other → www.mozilla.org
Product: Websites → mozilla.org
QA Contact: other → www-mozilla-org
Version: unspecified → other
Here's Japanese translation. Thanks!
Attached file pl snippets
Here's the Polish version. :)
Attached file (tr) Turkish
Attaching the Slovene localisation of the snippets.
Attached file Danish (da)
Attached file Snippets for fr locale
fr snippets. Thanks to Frederic and pascalc for reviewing
Attached file Swedish snippets (sv-SE) (obsolete) —
Swedish snippets... (sv-SE)
Attached file Swedish snippets (take 2) (sv-SE) (obsolete) —
Trying again to get the Swedish charachters right (auml, ouml and aring).

(Should they be written as ä etc?)
The swedish textfile looks right if I set Firefox to western (ISO-8859-1)... I wonder why the Danish strings look ok with firefox set to unicode?
David, that is because I configured my text editor to use UTF-8. You should do so too. It looks like http://www.google.com/firefox is in UTF-8, your file should be the same.
Attached file Hebrew (he) snippets
Attached file es-AR snippets
Attached file German, de-DE
Attached file Swedish, sv-SE, UTF-8
Attachment #250886 - Attachment is obsolete: true
Attachment #250887 - Attachment is obsolete: true
Attachment #250913 - Attachment mime type: application/octet-stream → text/plain
Attachment #250868 - Attachment mime type: application/octet-stream → text/plain
Attachment #250833 - Attachment mime type: application/octet-stream → text/plain
Attached file Spanish, es-ES, UTF-8 (obsolete) —
Attachment #250833 - Attachment is obsolete: true
Attachment #250914 - Attachment is obsolete: true
Attached file Italian, it-IT
Italian, it-IT
Attached file Greek (el) snippets (obsolete) —
Attached file Greek (el) snippets
Attachment #250949 - Attachment is obsolete: true
Attached file zh-TW snippets. (obsolete) —
zh-TW strings of google snippets.
Thanks Pascal.
Comment on attachment 250953 [details]
zh-TW snippets.

>*********************************************
>Language: zh-TW
>Localizer(s): Jose Sun
>Date: 2007-01-09
>*********************************************
>
>#About Mozilla
>關於 Mozilla
>
>
>#Mozilla Firefox Start Page
>Mozilla Firefox 開始頁
>
>
>#Upgrade now to <a href="snippet1">Firefox 2</a> for improved security and better browsing.
>立刻升級 <a href="snippet1">Firefox 2</a>,更強的安全防護和更棒的瀏覽體驗等著你!
>
>
>#Thanks for choosing Firefox, the easy-to-use Web browser from Mozilla. <a href="snippet2">Find out more about us</a>.
>感謝您選擇 Mozilla 出品,最易上手的 Firefox 瀏覽器。您可以 <a href="snippet2">深入了解 Mozilla</a>。
>
>
>#Customize Firefox to work your way with <a href="snippet3">free Add-ons</a> - add anything from weather forecasts to music players.
>從天氣預報到音樂播放,用成堆的 <a href="snippet3">免費附加元件</a> 打造你專屬的 Firefox。
>
>
>#Do you love Firefox? So do millions of other people. Help us <a href="snippet4">spread the word</a>!
>喜歡 Firefox 嗎?已經有上百萬人加入支持 Fifefox 的行列了。和大家一起 <a href="snippet4">推廣 Firefox </a>吧!
Attachment #250953 - Attachment is obsolete: true
Attached file zh-TW snippets. (obsolete) —
some strings updated.
Hi. I've added Basque translation of the Start Page.
Attachment #251096 - Attachment mime type: application/octet-stream → text/plain
Here is korean snippet translations.
Duplicate of this bug: 350143
Attached file Hungarian (hu) snipplets (obsolete) —
Attached file Norwegian Bokmaal Snippets (nb-NO) (obsolete) —
Attached file Norwegian Nynorsk Snippets (nn-NO) (obsolete) —
Attachment #251522 - Attachment is obsolete: true
Attachment #251526 - Attachment is obsolete: true
Attachment #251528 - Attachment is obsolete: true
Attached file Snippets for be locale (obsolete) —
Alpha version belarusian translate Google Snippets
Attached file ga-IE (Irish) snippets
Attaching Irish (ga-IE) translations.
Attached file Dutch (nl) snippets
Attached file Romanian (ro) snippets
Snippets for Frisian (fy-NL) locale
>Alpha version belarusian translate Google Snippets

Drive, I hope you are not planning a series of Betas and RC ;)
Attached file Bulgarian snippets
Google snippets translated in Bulgarian
Attachment #251738 - Attachment mime type: application/octet-stream → text/plain
<a href="snippet3">free Add-ons</a>

Does free mean freedom/libre or gratis/no-cost ??
Extensions hosted on AMO are both, aren't they?
>Does free mean freedom/libre or gratis/no-cost ??

That's free as in gratis.
Attached file Snippets in macedonian (mk) (obsolete) —
Attachment #251614 - Attachment mime type: application/octet-stream → text/plain
Attached file zh-CN snippets.
Attached file Snippets for fi
Snippets for fi
Attachment #251924 - Attachment mime type: application/octet-stream → text/plain
Snippets for Arabic locale (ar)
Duplicate of this bug: 366028
Duplicate of this bug: 363278
Duplicate of this bug: 323221
Attached file Snippets for be locale
Attachment #251547 - Attachment is obsolete: true
It's update version for zh-TW.
Attachment #250954 - Attachment is obsolete: true
I think this bug is fixed, so marking as such. However, I'm not sure about attachment 256358 [details].
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Attachment #251501 - Attachment is obsolete: true
Comment on attachment 257479 [details]
Lithuanian (lt) snippets

This is a bit cosmetically changed version, but it's not necessary to make use of it. Feel free to ignore its existance. :)
Duplicate of this bug: 373552
Duplicate of this bug: 373924
Did Google import these snippets? 

I still don't see them on:
http://www.google.com/firefox?client=firefox-a&rls=org.mozilla:mk:official&hl=mk

(That's the page they should appear, right??)

BTW I had to add &hl=mk, otherwise it would show me the english snippets - is this normal or it has something to do with some of my google profiles or something ?!?
They're still testing import from mozilla.org Damjan. We think we have isolated the problems that were preventing them from importing the new snippets, and fixed them. We just need the Google webmasters to sign off on the QA of the fix.
Attached file Snippets in macedonian (mk) - ver 2.0 (obsolete) —
Attachment #251792 - Attachment is obsolete: true
Here is the snippets for Afrikaans (af).
Attached file Snippets in macedonian (mk) - ver 3.0 (obsolete) —
A simple error has sniked in the previous snippets file ...

Google please update!!!
Attachment #260295 - Attachment is obsolete: true
Attachment #270899 - Flags: review?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
One of the things we learned on the recent trip to India was the importance for Indian users to get access to the increasing amount of Indian specific content.  We could improve usability pretty dramatically  for English version Firefox users in India if we adopted one the snippets from the google search page that allows easy switching to get at web content from other Indian languages

Check out http://www.google.co.in/ and the snippet for the section that shows

        Google.co.in offered in: Hindi Bengali Telugu Marathi Tamil

We need to get this snippet added on
http://www.google.co.in/firefox?client=firefox-a&rls=org.mozilla:en-US:official
This is the page that Firefox users see when starting the browser from any location inside India

The snippet also needs to be dynamic so that when one of the above languages is picked as preference then the user can also get back as it works on the google search page
--->  e.g. when hindi is selected this snippet is shown
     Google.co.in इस भाषा में: English বাংলা తెలుగు मराठी தமி

attachment coming....
chofmann, that should be a separate bug.
chofmann, we'll look at this issue in Bug #389825 
Attached file fa-IR localization (obsolete) —
Persian firefox startpage localization.
Attached file Ukrainian (uk) snippets (obsolete) —
Translated Google snippets for ml locale
Attached file Serbian (sr) snippets
Attachment #279524 - Flags: review?
Attachment #279524 - Attachment mime type: application/octet-stream → text/plain
Attachment #279524 - Flags: review?
Attachment #270899 - Flags: review?
Attached file Georgian (ka) snippets
Attached file Kurdish (ku) snippets, UTF-8 (obsolete) —
Snippets for Kurdish (ku)
Latvian (lv) localization strings
Attachment #275161 - Attachment is obsolete: true
There was a mistake because of typing. sorry. it has been corrected.
Attachment #280435 - Attachment is obsolete: true
Attachment #282529 - Attachment description: translation mistake has been corrected → Kurdish (ku), translation mistake has been corrected
Corrected a word.
Attachment #279089 - Attachment is obsolete: true
Attachment #284345 - Attachment mime type: application/octet-stream → text/plain
pascalc, previous change is important because the word in question was spelled wrongly. None version was not uploaded by Google for now and it would be much better if they start with the right one.
Attaching the translated google snippets for Bengali India (bn_IN)
Updated the google snippets for bn_IN to correct the error spotted by Pascal.
Attachment #284641 - Attachment is obsolete: true
We have submitted the strings for ku here long ago, but there is still no localized http://ku.start.mozilla.com/firefox


Erdal, for google, Ku is the locale code for kurdish-Soranî, not kursidh-Kurmancî and they don't seem likely to associate ku with kurmancî, that's why the snippets are not published. This is something we need to see with Axel, I am personnally in favour of using a different locale code for kurdish to avoid this problem as Axel proposed (ku-Latn) and propose an English firefox page to your users.
ku-Latn and the English Firefox page is fine for us. Just go ahead!
Attachment #310033 - Attachment mime type: application/octet-stream → text/plain
Attached file en_ZA Google snippets
These snippets should be identical to en-GB.  But this allows us some flexibility to not have to worry Google and also to depart if needed from en-GB.
Fix a number of minor issues in the translation.  The fixes were commited into the SVN (r11425).
Attachment #311802 - Attachment is obsolete: true
Done for Indonesian (id)

What's the difference between this bug and with bug 407661?
Attached file eo snippets
This attachment contains the whole snippets file, with the new snippet added and the old snippets updated!
Attachment #270899 - Attachment is obsolete: true
Pascal, does this file also need the line for the Mozilla Store? If not can you take it of the dashboard for fy-NL. As far as I can see it's complete, otherwise I will attach a new one as used in bug 407661.
wim, I will merge the strings myself.
Thanks! Can you kick it off my dashboard then also?
Gujarati (gu-IN) translation!
Attachment #310033 - Attachment is obsolete: true
Google snippets for Telugu (te)
Snippets for si locale
Updated the snippet translations for Kannada(kn) language
now a dupe of bug #444568, closing
Status: REOPENED → RESOLVED
Closed: 16 years ago14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 444568
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.