Account Settings dialog cuts off buttons, needs to be wider

RESOLVED FIXED in Thunderbird 3.1a1

Status

Thunderbird
Account Manager
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: brandt24, Assigned: andreasn)

Tracking

Thunderbird 3.1a1
x86
All
Bug Flags:
blocking-thunderbird3 -

Firefox Tracking Flags

(blocking-thunderbird3.0 needed, thunderbird3.0 .1-fixed)

Details

Attachments

(13 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.30729; .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4pre) Gecko/20090914 Shredder/3.0b4pre

Some of the buttons in the Account Settings dialogue are simply cut off by default.

Reproducible: Always

Steps to Reproduce:
1. Start TB.
2. Go to Tools / Account Settings.
3. Look at the Server Settings, for instance.
Actual Results:  
One may see that some of the buttons and text does not fit into the window.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0
(Assignee)

Comment 1

8 years ago
What panes get cuts off? There is already Bug 416263 and 516472 about similar issues with the account settings dialog.
(Reporter)

Comment 2

8 years ago
Created attachment 400772 [details]
screenshot 1
(Reporter)

Comment 3

8 years ago
Created attachment 400773 [details]
screenshot 2
(Reporter)

Comment 4

8 years ago
Created attachment 400774 [details]
screenshot 3

Comment 5

8 years ago
I clearly see this on Windows 7 when running beta 3. bug 516472 could actually solve this problem.

Comment 6

8 years ago
Created attachment 401180 [details]
server settings cutoff

I've see problem like shown in comment #2
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090915 Shredder/3.0b4pre

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

8 years ago
Duplicate of this bug: 512056

Updated

8 years ago
Duplicate of this bug: 514834

Updated

8 years ago
OS: Windows Vista → All

Comment 9

8 years ago
confirmed on Win7
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.4pre) Gecko/20091002 Shredder/3.0pre

Comment 10

8 years ago
And this does not blocks the TB3?

Comment 11

8 years ago
Created attachment 407985 [details]
Server Settings window cut-off on Win7

Comment 12

8 years ago
It works here, seems like 3.0 only issue.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20091020 Shredder/3.1a1pre

Comment 13

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.5pre) Gecko/20091022 Shredder/3.0pre

Comment 14

8 years ago
Created attachment 410485 [details]
account settings cutoff on Vista

Comment 15

8 years ago
Created attachment 410486 [details]
server settings cutoff on Vista

Comment 16

8 years ago
Created attachment 410487 [details]
security cutoff on Vista
see bug #524893 comment #5: workaround fix your issue?

Updated

8 years ago
Component: Preferences → Account Manager
QA Contact: preferences → account-manager

Updated

8 years ago
Duplicate of this bug: 378617

Updated

8 years ago
Depends on: 529245

Comment 19

8 years ago
Also confirmed with TB3 RC1 running on Vista. Added screenshots (accountsettingsvista.zip). Suggest to mark it a blocking.

Comment 20

8 years ago
Created attachment 413640 [details]
Text/button overflow issue in the Account Settings window

Comment 21

8 years ago
Created attachment 413641 [details]
Text/button overflow issue in the Account Settings window

Comment 22

8 years ago
Created attachment 413642 [details]
Text/button overflow issue in the Account Settings window

Comment 23

8 years ago
Created attachment 413643 [details]
Text/button overflow issue in the Account Settings window

Comment 24

8 years ago
Confirmed using TB 3.0 RC1 in Windows 7. 

*Note*: More importantly, this problem does not show up in Ubuntu Linux (version 9.10). Not only are the buttons not cut off (room to spare actually) but the dialog box is re-sizable in Linux but not in Windows. I agree, this should be blocking TB 3.0 final. Even though this problem doesn't affect functionality at all, it does look rather shoddy and unfinished. Considering users have a habit of judging things by their looks plus the fact that Windows has the largest market share, shouldn't this be blocking the final release?

Updated

8 years ago
Flags: blocking-thunderbird3?

Updated

8 years ago
status-thunderbird3.0: --- → wanted
While this is ugly, it doesn't actually inhibit any functionality, and most people will end up using the autoconfig dialog most of the time anyway. We won't hold 3.0 for it, but we'll need to do _something_ here for 3.0.1.  Setting flags appropriately.
blocking-thunderbird3.0: --- → .1
Flags: blocking-thunderbird3? → blocking-thunderbird3-
Duplicate of this bug: 532651
(Assignee)

Updated

8 years ago
Assignee: nobody → nisses.mail
status-thunderbird3.0: wanted → ---

Updated

8 years ago
Duplicate of this bug: 533730
(Assignee)

Comment 28

8 years ago
Created attachment 416887 [details] [diff] [review]
possible fix

This makes the buttons not getting cut off on my system by increasing the width from 97 to 107 of accountManager.size in AccountManager.dtd

I'm not 100% certain that this is the correct place to fix it, based on the paragraph above in that file, but as this is a issue in the en-US locale it might be the right place and I haven't found any other place to fix it.
(Assignee)

Updated

8 years ago
Attachment #416887 - Flags: ui-review?(clarkbw)
(Assignee)

Comment 29

8 years ago
Comment on attachment 416887 [details] [diff] [review]
possible fix

asking for a code review from Neil as well, since he wrote the initial code and should know the details on what is correct and not.
Attachment #416887 - Flags: review?(neil)
Going from 97 to 107ch does seem like a big jump. Does 105ch not suffice?
(Assignee)

Comment 31

8 years ago
Created attachment 417084 [details] [diff] [review]
updated patch (105ch wide)

indeed, 105 ch seems to be just enough
Attachment #416887 - Attachment is obsolete: true
Attachment #417084 - Flags: ui-review?(clarkbw)
Attachment #417084 - Flags: review?(neil)
Attachment #416887 - Flags: ui-review?(clarkbw)
Attachment #416887 - Flags: review?(neil)
Comment on attachment 417084 [details] [diff] [review]
updated patch (105ch wide)

seems good to me
Attachment #417084 - Flags: ui-review?(clarkbw) → ui-review+

Updated

8 years ago
Duplicate of this bug: 530502
Andreas, I set bug #530502 as dupe of this because has similar\dupe symptom: the Account Settings "Manage Identities"  button is hidden because height minor than is necessary... your patch can fix also this? :-D
Keywords: polish
(Assignee)

Comment 35

8 years ago
Aureliano: I think I want to do that one as a separate patch, so I'll attach a patch to the other bug report for that one if it's ok.
Whiteboard: [needs review neil]

Comment 36

8 years ago
I found this bug on my machine too. It's the same with those ones on the screnshots. Buttons are cut off. I'm running windows XP sp3. I also have an Ubuntu 9.10 with thunderbird3, and I'll check that too.

Updated

8 years ago
Attachment #417084 - Flags: review?(neil) → review+
(Assignee)

Updated

8 years ago
Keywords: polish → checkin-needed
Whiteboard: [needs review neil]
Checked in as http://hg.mozilla.org/comm-central/rev/c44f8b55f777
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.1a1
Comment on attachment 417084 [details] [diff] [review]
updated patch (105ch wide)

Setting approval request, I just need to check something first.
Attachment #417084 - Flags: approval-thunderbird3.0.1?

Updated

8 years ago
blocking-thunderbird3.0: .1+ → needed
Attachment #417084 - Flags: approval-thunderbird3.0.1? → approval-thunderbird3.0.1+
Landed on 1.9.1 as <http://hg.mozilla.org/releases/comm-1.9.1/rev/e5629bfffefa>.
status-thunderbird3.0: --- → .1-fixed
Flags: blocking1.8.0.next?
Flags: blocking1.8.0.next?

Updated

8 years ago
Duplicate of this bug: 528057

Comment 41

8 years ago
As of Thunderbird 3.0.2, this problem still exists.
(In reply to comment #41)
> As of Thunderbird 3.0.2, this problem still exists.

Even when you nuke the locastore.rdf file in your profile ? if so please file a new bug.

Comment 43

8 years ago
This problem also exists for me in 3.0.2 (Linux GTK) even after removing locastore.rdf

Comment 44

8 years ago
This bug is manifesting for me in Thunderbird 3.0.4 over Windows Vista Service Pack 2 32-bit.

Even after:

Shutting down Thunderbird.
Removing the file "localstore.rdf" in "the profile" (AppData/Roaming/Thunderbird/profiles/{...}".
Re-startinging Thunderbird.

Comment 45

8 years ago
This "bug zilla" or whatever it is appears to be a technical tool for use by product engineers.

I don't really know what I am looking at here.

We appear to have status "Resolved Fixed". But manifestly that is not the case because I am still seeing the problem here. I've clicked "Check for updates", but it says there aren't any updates, and I'm still getting the problem.

Can someone explain, in straightforward language, how and when that "Resolved Fixed" status might translate into my getting a working version in my hands?

Comment 46

7 years ago
If you still see a problem, please file a new bug, attach a screen shot to the bug, and comment here.

Note this bug addressed dialog width. Bug 416263 / bug 507640 are more specific to addressing vertical size
No longer depends on: 529245
See Also: → bug 529245
Summary: Account Settings dialog cuts off buttons → Account Settings dialog cuts off buttons, needs to be wider
You need to log in before you can comment on or make changes to this bug.