Closed Bug 568256 Opened 10 years ago Closed 10 years ago

form history changes breaks form sync, FF search bar, probably more

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: mconnor, Assigned: Mardak)

References

Details

Attachments

(2 files)

bug 439716 changed the underlying implementation, so we'll need to handle that case in various places.  Affects today's nightly, so we have to suck it up and fix this for 1.3
Flags: blocking-weave1.3+
Duplicate of this bug: 568258
Duplicate of this bug: 568234
Err, how did this break Weave? There shouldn't have been any interface changes or significant changes in functionality -- it was just a straight C++ to JS port.
Not sure if this is legit, but we could fix it from the satchel side by reverting back to the same class id we had before.
Attached patch v1Splinter Review
Attachment #447569 - Flags: review?(mconnor)
Blocks: 568292
Duplicate of this bug: 568286
Comment on attachment 447569 [details] [diff] [review]
v1

Great, thanks, please land ASAP and I'll prep to push a b8.
Attachment #447569 - Flags: review?(mconnor) → review+
http://hg.mozilla.org/labs/weave/rev/5bd2b30e1556
Check for both old and new class IDs and use the one that exists when wrapping. Also add FormTracker as the observer object so that its notify function is correctly called by nsHTMLFormElement.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.3
With FS 1.3rc2 on all clients: Web form data is syncing to and from minefield (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a5pre) Gecko/20100526 Minefield/3.7a5pre)

However,  search bar entries are not syncing out from minefield.  Entries on 3.6.4 do sync back to minefield.

1) Perform a search from the search bar on minefield
2) Sync minefield, wait for it to complete
3) Sync 3.6.4

I'll attach a log from a third client (3.6.4) on it's initial sync.  It also does not get any searchBar data from Minefield.
Outgoing log from Minefield:
2010-05-27 08:23:47	Net.Resource         DEBUG	GET success 200 https://sj-weave08.services.mozilla.com/1.0/mozqasj2/storage/meta/global
2010-05-27 08:23:47	Service.Main         DEBUG	Weave Version: 1.3rc2 Local Storage: 2 Remote Storage: 2
2010-05-27 08:23:47	Engine.Clients       INFO	0 outgoing items pre-reconciliation
2010-05-27 08:23:47	Engine.Clients       INFO	Records: 0 applied, 0 reconciled, 0 left to fetch
2010-05-27 08:23:47	Engine.Clients       DEBUG	Total (ms): sync 1, processIncoming 1, uploadOutgoing 0, syncStartup 0, syncFinish 0
2010-05-27 08:23:47	Engine.Bookmarks     INFO	0 outgoing items pre-reconciliation
2010-05-27 08:23:47	Engine.Bookmarks     INFO	Records: 0 applied, 0 reconciled, 0 left to fetch
2010-05-27 08:23:47	Engine.Bookmarks     DEBUG	Total (ms): sync 2, processIncoming 1, uploadOutgoing 0, syncStartup 0, syncFinish 0
2010-05-27 08:23:47	Engine.Forms         INFO	2 outgoing items pre-reconciliation
2010-05-27 08:23:47	Engine.Forms         INFO	Records: 0 applied, 0 reconciled, 0 left to fetch
2010-05-27 08:23:47	Engine.Forms         INFO	Uploading all of 2 records
2010-05-27 08:23:47	Collection           DEBUG	POST Length: 751
2010-05-27 08:23:47	Collection           DEBUG	POST success 200 https://sj-weave08.services.mozilla.com/1.0/mozqasj2/storage/forms
2010-05-27 08:23:47	Engine.Forms         DEBUG	Total (ms): sync 410, processIncoming 0, uploadOutgoing 409, syncStartup 0, syncFinish 0, createRecord 0
2010-05-27 08:23:47	Engine.History       INFO	2 outgoing items pre-reconciliation
2010-05-27 08:23:47	Engine.History       INFO	Records: 0 applied, 0 reconciled, 0 left to fetch
2010-05-27 08:23:47	Engine.History       INFO	Uploading all of 2 records
2010-05-27 08:23:47	Collection           DEBUG	POST Length: 1160
2010-05-27 08:23:47	Collection           DEBUG	POST success 200 https://sj-weave08.services.mozilla.com/1.0/mozqasj2/storage/history
2010-05-27 08:23:47	Engine.History       DEBUG	Total (ms): sync 488, processIncoming 0, uploadOutgoing 487, syncStartup 1, syncFinish 0, createRecord 20
2010-05-27 08:23:47	Engine.Passwords     INFO	1 outgoing items pre-reconciliation
2010-05-27 08:23:47	Engine.Passwords     INFO	Records: 0 applied, 0 reconciled, 0 left to fetch
2010-05-27 08:23:47	Engine.Passwords     INFO	Uploading all of 1 records
2010-05-27 08:23:47	Collection           DEBUG	POST Length: 678
2010-05-27 08:23:48	Collection           DEBUG	POST success 200 https://sj-weave08.services.mozilla.com/1.0/mozqasj2/storage/passwords
2010-05-27 08:23:48	Engine.Passwords     DEBUG	Total (ms): sync 464, processIncoming 0, uploadOutgoing 463, syncStartup 1, syncFinish 0, createRecord 3
2010-05-27 08:23:48	Engine.Prefs         INFO	0 outgoing items pre-reconciliation
2010-05-27 08:23:48	Engine.Prefs         INFO	Records: 0 applied, 0 reconciled, 0 left to fetch
2010-05-27 08:23:48	Engine.Prefs         DEBUG	Total (ms): sync 1, processIncoming 0, uploadOutgoing 0, syncStartup 0, syncFinish 0
2010-05-27 08:23:48	Engine.Tabs          INFO	1 outgoing items pre-reconciliation
2010-05-27 08:23:48	Engine.Tabs          INFO	Records: 0 applied, 0 reconciled, 0 left to fetch
2010-05-27 08:23:48	Engine.Tabs          INFO	Uploading all of 1 records
2010-05-27 08:23:48	Collection           DEBUG	POST Length: 1905
2010-05-27 08:23:49	Collection           DEBUG	POST success 200 https://sj-weave08.services.mozilla.com/1.0/mozqasj2/storage/tabs
2010-05-27 08:23:49	Engine.Tabs          DEBUG	Total (ms): sync 598, processIncoming 1, uploadOutgoing 597, syncStartup 0, syncFinish 0, getAllClients 0, locallyOpenTabMatchesURL 24, createRecord 12
2010-05-27 08:23:49	Service.Main         INFO	Sync completed successfully in 32.95 secs.


incoming log from 3.6.4:
2010-05-27 08:25:50	Net.Resource         DEBUG	GET success 200 https://sj-weave08.services.mozilla.com/1.0/mozqasj2/info/collections
2010-05-27 08:25:51	Net.Resource         DEBUG	GET success 200 https://sj-weave08.services.mozilla.com/1.0/mozqasj2/storage/meta/global
2010-05-27 08:25:51	Service.Main         DEBUG	Weave Version: 1.3rc2 Local Storage: 2 Remote Storage: 2
2010-05-27 08:25:51	Engine.Clients       INFO	0 outgoing items pre-reconciliation
2010-05-27 08:25:51	Engine.Clients       INFO	Records: 0 applied, 0 reconciled, 0 left to fetch
2010-05-27 08:25:51	Engine.Clients       DEBUG	Total (ms): sync 1, processIncoming 1, uploadOutgoing 0, syncStartup 0, syncFinish 0
2010-05-27 08:25:51	Engine.Bookmarks     INFO	0 outgoing items pre-reconciliation
2010-05-27 08:25:51	Engine.Bookmarks     INFO	Records: 0 applied, 0 reconciled, 0 left to fetch
2010-05-27 08:25:51	Engine.Bookmarks     DEBUG	Total (ms): sync 2, processIncoming 0, uploadOutgoing 0, syncStartup 1, syncFinish 0
2010-05-27 08:25:51	Engine.Forms         INFO	0 outgoing items pre-reconciliation
2010-05-27 08:25:51	Engine.Forms         INFO	Records: 0 applied, 0 reconciled, 0 left to fetch
2010-05-27 08:25:51	Engine.Forms         DEBUG	Total (ms): sync 1, processIncoming 1, uploadOutgoing 0, syncStartup 0, syncFinish 0
2010-05-27 08:25:51	Engine.History       INFO	0 outgoing items pre-reconciliation
2010-05-27 08:25:51	Collection           DEBUG	GET success 200 https://sj-weave08.services.mozilla.com/1.0/mozqasj2/storage/history?newer=1274966171.36&full=1&sort=index
2010-05-27 08:25:51	Engine.History       INFO	Records: 2 applied, 0 reconciled, 0 left to fetch
2010-05-27 08:25:51	Engine.History       DEBUG	Total (ms): sync 517, processIncoming 514, uploadOutgoing 0, syncStartup 0, syncFinish 0, findDupe 0, createRecord 32, isEqual 32, reconcile 33
2010-05-27 08:25:51	Engine.Passwords     INFO	0 outgoing items pre-reconciliation
2010-05-27 08:25:52	Collection           DEBUG	GET success 200 https://sj-weave08.services.mozilla.com/1.0/mozqasj2/storage/passwords?newer=1274966171.84&full=1&sort=index
2010-05-27 08:25:52	Engine.Passwords     INFO	Records: 0 applied, 1 reconciled, 0 left to fetch
2010-05-27 08:25:52	Engine.Passwords     DEBUG	Total (ms): sync 463, processIncoming 461, uploadOutgoing 0, syncStartup 1, syncFinish 0, createRecord 2, isEqual 2, reconcile 4
2010-05-27 08:25:52	Engine.Prefs         INFO	0 outgoing items pre-reconciliation
2010-05-27 08:25:52	Engine.Prefs         INFO	Records: 0 applied, 0 reconciled, 0 left to fetch
2010-05-27 08:25:52	Engine.Prefs         DEBUG	Total (ms): sync 1, processIncoming 1, uploadOutgoing 0, syncStartup 0, syncFinish 0
2010-05-27 08:25:52	Engine.Tabs          INFO	0 outgoing items pre-reconciliation
2010-05-27 08:25:52	Store.Tabs           DEBUG	Adding remote tabs from tracy's Firefox on trunkSyncrc2-tracy-walkers-macbook-pro
2010-05-27 08:25:52	Collection           DEBUG	GET success 200 https://sj-weave08.services.mozilla.com/1.0/mozqasj2/storage/tabs?newer=1274966172.43&full=1&sort=index
2010-05-27 08:25:52	Engine.Tabs          INFO	Records: 1 applied, 0 reconciled, 0 left to fetch
2010-05-27 08:25:52	Engine.Tabs          DEBUG	Total (ms): sync 459, processIncoming 459, uploadOutgoing 0, syncStartup 0, syncFinish 0, findDupe 0, reconcile 0
2010-05-27 08:25:52	Service.Main         INFO	Sync completed successfully in 2.35 secs.
Attachment #447745 - Attachment description: intiial sync log on 3rd client → intial sync log on 3rd client
Attachment #447745 - Attachment mime type: application/octet-stream → text/html
Attachment #447745 - Attachment mime type: text/html → text/plain
Duplicate of this bug: 568477
Blocks: 568587
Still not working on:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100527 Minefield/3.7a5pre (.NET CLR 3.5.30729)
Duplicate of this bug: 568865
(In reply to comment #13)
> Still not working on:
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100527
> Minefield/3.7a5pre (.NET CLR 3.5.30729)

The fix requires that Weave (now Firefox Sync) has been updated to 1.3. If it's still not working after you update, please give your weave version.
Investigating this bug for being potential crossweave automation test case
candidate.
Flags: in-testsuite?
item is undefined JS Stack trace: getGUID("end","today")@forms.js:79 < 

In fact, "item" object is used, even if undefined.
Must do a check before. Else, it breaks synchronization.
Gaétan: This bug is fixed. Please file a new bug for whatever issue you're seeing.
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.