Open Bug 62067 Opened 20 years ago Updated 1 year ago

Keypress to to a search in URL bar (Alt+Enter or Alt+A accesskey)

Categories

(Core :: DOM: UI Events & Focus Handling, enhancement, P3)

enhancement

Tracking

()

mozilla1.8alpha2

People

(Reporter: mozbug, Unassigned)

References

Details

(Whiteboard: [KEYBASE+])

2000120520 trunk NT4

Currently to do a search using the location bar, you have to type the keywords
and then, click on the search button.
I think it would be nice to have somthing like ctrl-enter (or alt or shift) to
act as if you click on the search button.
over to Matt who handles search stuff. not sure what the best key combo would be
for this --akkana/blake/claudius/timeless, d'y'all have any preferences for
that? confirming as enhancement request, in any case.
Assignee: don → matt
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows NT → All
Hardware: PC → All
I'll register a slight preference for alt-Enter (or accel-Enter).
w32: alt-Enter => properties. BAD.
So..  Accel-Enter?
Summary: Have a combination of something + ENTER to to a search → [RFE] Have a combination of something + ENTER to to a search
Other things that some people want fast keyboard access to while in the 
locataion bar:
- Open url in new window (this actually makes more sense for the Ctrl+L dialog 
than it does for the location bar)
- Go to www.[location bar contents].com (bug 37867)

Space+enter should work for searching once bug ? (urls with spaces and no 
protocol should search) is fixed...
See also bug 53171 (search when just hitting enter).
Blocks: 67414
Ctrl+Enter on a link is going to enter it in a new Window (bug 63957). I'd like
that to work in the URL Bar as well.

So... can we use Shift+Enter for this?
<down>;<enter> | <up>;<enter> => selects the search entry in the completion 
widget and searches using it.
Since the new autocomplete has landed and has a "search using default engine"
line, I wonder it this rfe is still useful.
Still has uses:
- autocomplete can be turned off
- sometimes I don't get the autocomplete menu (bug ?)

However, I think for the average user the autocomplete menu will be a more
intuitive method for searching.
No longer blocks: 67414
Target Milestone: --- → Future
Have a look at bug 84809. That should cover fixing this bug, I believe. You can
now search easily from the location bar without being bothered by autocomplete.
Or check out Mozilla Custom Keywords at:
http://www.mozilla.org/docs/end-user/keywords.html

---> WORKSFORME
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
So you're saying that typing "search foo" is your solution, right?  I don't
think this is the same, or as nice, as being able to just type your term and
hitting ctrl- or alt- enter in the location bar.

Even if it is, your solution isn't what this bug calls for, so I don't think it
should be WORKSFORME.
Ctrl-Enter in the location bar opens a URL in a new tab, so this is not possible
anymore. I resolved this due to the following considerations:

- You can now perform a search by entering your search term followed by tab and
then enter.

David said that 

> Still has uses:
> - autocomplete can be turned off
> - sometimes I don't get the autocomplete menu (bug ?)

This is no longer a problem, autocomplete can be turned off but you can still
show the default search engine in the autocomplete dropdown window.

If you feel that this is not enough, reopen this bug or voice your opinion and I
will reopen it for you if you do not have sufficient bugzilla privileges.
Okay, I entirely understand your reasoning.  Personally, I use tab-enter to get
my search done, and it works fine for me (as long as that other bug that wants
autocomplete out of the tab order stays WONTFIXED).  I posted my comment purely
on the academic fact that while there are other ways to quickly get a search,
they are not what this bug requests.  If nobody else argues for this feature,
then I'm fine, but perhaps WONTFIX would be a more accurate resolution.
Tab/Enter doesn't work for me.  I have the autocomplete dropdown turned off,
because it grabs the keyboard and makes it impossible to type in any other
window unless I click twice in the other window. When focus is in the urlbar,
tab shifts focus to the content area.  (Which seems like the right thing for it
to do, but it means that there's no way to search using only the keyboard.)

Is there something else I need to enable to get this to work?
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Akkana: is there a bug about that autocomplete problem?  It sounds pretty 
serious, especially since it's preventing you from using autocomplete.  I don't 
see any point in keeping this bug open for that problem, though.

Btw, if you have autocomplete turned off, then Up, Up, Enter should run a 
search.
Status: REOPENED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → WORKSFORME
There are longstanding bugs on the dropdown, which have been futured.

Up, Up, Enter?  Doesn't work for me (Linux build from Friday).  What are the two
Ups supposed to do when focus is in the urlbar?  They don't do anything obvious
here.  Is there really a browser window binding for Up with no modifier key?

Reopening since there's still no binding that works if autocomplete is off.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
We could also underline a letter in Sea_r_ch, which has the advantage of being
discoverable as an accesskey.

What do people think of that possibility?
*** Bug 116201 has been marked as a duplicate of this bug. ***
akkana?
Assignee: matt → akkana
Status: REOPENED → NEW
mass moving open bugs pertaining to find in page/frame to pmac@netscape.com as
qa contact.

to find all bugspam pertaining to this, set your search string to
"AppleSpongeCakeWithCaramelFrosting".
QA Contact: sairuh → pmac
Bug 97123 would take over shift+Enter and Ctrl+Enter in the URL bar, so those
would be unavailable.

Timeless says that Alt+Enter is used for properties, which is true. However, I
think we can still use it for the URL bar search. Keys often have specific
unique functionality in different contexts.
Summary: [RFE] Have a combination of something + ENTER to to a search → [RFE] Alt + ENTER to to a search in URL bar
Whiteboard: [KEYBASE+]
Blocks: 66519
Based on the fact that bug 135363 has 20 dups, I think hitting Enter in the
address bar should search if the text is not a URL (bug 131648).  If the text
does not contain a space, we could do what IE does: try http://foo/, and if that
doesn't work, search.  Making search the default action would make this bug
unnecessary.
No longer blocks: 66519
Summary: [RFE] Alt + ENTER to to a search in URL bar → Alt + ENTER to to a search in URL bar
Not sure why this ended up assigned to me -- should go to a browser
command-handling person.
Assignee: akkana → aaronl
QA Contact: pmac → sairuh
*** Bug 238553 has been marked as a duplicate of this bug. ***
*** Bug 88241 has been marked as a duplicate of this bug. ***
Summary: Alt + ENTER to to a search in URL bar → Keypress to to a search in URL bar (Alt+Enter or Alt+A accesskey)
Target Milestone: Future → mozilla1.8alpha2
(In reply to comment #22)
> Based on the fact that bug 135363 has 20 dups, I think hitting Enter in the
> address bar should search if the text is not a URL (bug 131648).  If the text
> does not contain a space, we could do what IE does: try http://foo/, and if that
> doesn't work, search.  Making search the default action would make this bug
> unnecessary.

Pressing Enter to search worked in version 1.5 (I think). It doesn't work in 1.7
now (Windows). I would like to see this functionality back.
*** Bug 260942 has been marked as a duplicate of this bug. ***
Mass un-assigning bugs assigned to Aaron.
Assignee: aaronleventhal → nobody
QA Contact: bugzilla → keyboard.navigation
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.