Closed Bug 135363 Opened 18 years ago Closed 17 years ago

location bar search fails after accidentally hitting enter (which tries to use search terms as url)

Categories

(SeaMonkey :: Location Bar, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.3alpha

People

(Reporter: skrulx, Assigned: hewitt)

References

Details

(Keywords: polish, Whiteboard: [adt2])

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9+)
Gecko/20020401
BuildID:    2002040103

Often when I am typing search terms into the address bar intending to hit
down-arrow and enter, I mistakenly hit enter instead.  This causes a "site not
found" alert dialog.  Then when I go back to the address bar, hit down-arrow and
enter, it pops up the "site not found" altert dialog again instead of searching.

Reproducible: Always
Steps to Reproduce:
1. Type "conan o'brien" in the address bar and hit enter
2. Dismiss the "site not found" alert dialog
3. Click back to the address bar to get focus
4. Hit the down arrow and enter to search instead.


Actual Results:  "site not found" alert dialog pops up.

Expected Results:  the string in the address bar to be used as a search term for
your favorite search engine.
URL bar -> hewitt
Assignee: sgehani → hewitt
qa --> claudius@netscape.com
QA Contact: paw → claudius
Depends on: 136522
No longer depends on: 136522
Confirming using Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0rc1) Gecko/20020418

A workaround is to click the "Search" button instead of hitting down arrow and
enter in step 4.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 145182 has been marked as a duplicate of this bug. ***
Bug 141071 is a dup of this bug too.
Christian can you close it?
*** Bug 141071 has been marked as a duplicate of this bug. ***
Additional quirk/workaround:
After pressing up or down to bring down the search option, clicking on it
instead of pressing enter will affect the search.
I think 147858 is a duplicate of this one.
Attached patch patchSplinter Review
This is my first patch to mozilla - 
as you can see a very short one but I think does the job.

After a the "Enter" is hit "this.mNeedToFinish" becomes false
I think it should become true again once the user has manualy opened the
autocompleate
dropdown menu.
Can confirm this with 1.0 on WinXPpro. I notice if you edit the text you've
already typed in the location bar (eg. add a space), selecting search from the
location bar will work again.
Summary: quick search from address bar gets confused → location bar search fails after accidentally hitting enter (which tries to use search terms as url)
*** Bug 147667 has been marked as a duplicate of this bug. ***
This bug has been duped a lot of times now.
See how many times Bug 147667 was duped before marking it as a dup of this one.
Can anyone r= & sr= the patch so maybe, just maybe it will get in to 1.1 Beta
I got my fingers crossed :-)
*** Bug 156917 has been marked as a duplicate of this bug. ***
Keywords: patch
Blocks: 123569
*** Bug 159367 has been marked as a duplicate of this bug. ***
Also happens in linux. Changing OS to All.
OS: Windows 2000 → All
*** Bug 132219 has been marked as a duplicate of this bug. ***
*** Bug 161796 has been marked as a duplicate of this bug. ***
*** Bug 161821 has been marked as a duplicate of this bug. ***
Nominating for nsbeta and mozilla1.2.
Platform -> All due to comment #3.

 -> URL Bar
Component: XP Apps → URL Bar
Hardware: PC → All
To reiterate a suggestion I made to Bug 147667 (I'm not sure this rates a RFE
for itself):

A nice usability enhancement would be to make search the default whenever the
text typed in the URL bar includes a space, which shouldn't appear in a URL.
*** Bug 164224 has been marked as a duplicate of this bug. ***
*** Bug 147024 has been marked as a duplicate of this bug. ***
*** Bug 157260 has been marked as a duplicate of this bug. ***
*** Bug 168404 has been marked as a duplicate of this bug. ***
This is actually a little more involved than this. Once you hit enter (by
accident) for search terms, the browser can't recover even when you hit the down
arrow. Example: Enter "search words" in URL field and hit enter. Browser says
"The URL is not valid and cannot be loaded." Click OK. Click in the URL field
again and hit DownArrow. The "Seach Google (etc.) for 'search words'" appears.
Hit DownArrow again to select. Hit enter. Browser again says "The URL is not
valid and cannot be loaded." To get around it, you have to select the text,
backspace to erase the last character, retype the last character, then DownArrow
and Enter.
*** Bug 172745 has been marked as a duplicate of this bug. ***
*** Bug 157120 has been marked as a duplicate of this bug. ***
*** Bug 168019 has been marked as a duplicate of this bug. ***
*** Bug 174286 has been marked as a duplicate of this bug. ***
*** Bug 174428 has been marked as a duplicate of this bug. ***
*** Bug 174722 has been marked as a duplicate of this bug. ***
*** Bug 137442 has been marked as a duplicate of this bug. ***
"Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.2b) Gecko/20021016"

Bug still there.
*** Bug 176219 has been marked as a duplicate of this bug. ***
It is already possible to change the behaviour, if spaces are typed in the URL:
Enable Internet Keywords and put the following line into your prefs.js:

user_pref("keyword.URL", "http://www.google.de/search?hl=de&btnI=Auf%20gut%20Gl%
81ck!&q=");

(The fastest way to go to a site).

Sebastian
Thanks Sebastian, this tip very helpful, and as far as I am concerned makes this
bug a non-issue (I always use multiple words to search Google).
This bug, it seems, is still a bug.
That there is a workaround is not a resolution, and certainly doesn't make this
bug a nonissue.
*** Bug 178100 has been marked as a duplicate of this bug. ***
nsbeta1+/adt2 per the nav triage team.
Keywords: nsbeta1nsbeta1+
Whiteboard: [adt2]
*** Bug 168103 has been marked as a duplicate of this bug. ***
*** Bug 181112 has been marked as a duplicate of this bug. ***
Yep, this is remarkably annoying.  Got my vote.
*** Bug 166570 has been marked as a duplicate of this bug. ***
*** Bug 182016 has been marked as a duplicate of this bug. ***
Nominating for 1.3.
Flags: wanted1.3a?
Keywords: mozilla1.2mozilla1.3
*** Bug 182445 has been marked as a duplicate of this bug. ***
*** Bug 182283 has been marked as a duplicate of this bug. ***
*** Bug 181577 has been marked as a duplicate of this bug. ***
Come on guys, this is a really annoying bug.  It shouldn't be that hard to fix.
 It's been in since 0.9.9!
Joe, drivers would like to see this fixed in the 1.3 cycles. Can you take a look
at the patch and see if it's useful. If it's not can you help us get this fixed
for 1.3a?
Flags: blocking1.3a? → blocking1.3a+
Attachment #89135 - Flags: review?(hewitt)
Finally someone has noticed this one :-/
Tell me if you need to repatch...
Yes, this is annyoing me since several months. Please fix it.
I don't like to use the "klickwithmouseonsearchbutton" Workaround.
*** Bug 183452 has been marked as a duplicate of this bug. ***
*** Bug 184132 has been marked as a duplicate of this bug. ***
I've tested the patch and it works fine (even though the line numbers in the
diff are a little off the real line numbers). It's a one line fix for a heavily
voted bug that has irritated me a long time and I would really want to see this
in the next release. What's stopping the review? Is hewitt unavailable for the
moment so someone else should review this? I can vouch for its external
functionality, but am not qualified to give r= in this area of Mozilla. 
*** Bug 184224 has been marked as a duplicate of this bug. ***
*** Bug 184332 has been marked as a duplicate of this bug. ***
*** Bug 184364 has been marked as a duplicate of this bug. ***
Comment on attachment 89135 [details] [diff] [review]
patch

r=dveditz
Attachment #89135 - Flags: review?(hewitt) → review+
Comment on attachment 89135 [details] [diff] [review]
patch

Thanks for the reviews! a=asa for checkin to 1.3a. Who can land this for us
today?
Attachment #89135 - Flags: approval1.3a+
Itamar's patch checked in to the trunk.

Checking in autocomplete.xml;
/cvsroot/mozilla/xpfe/components/autocomplete/resources/content/autocomplete.xml,v
 <--  autocomplete.xml
new revision: 1.92; previous revision: 1.91

Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.3alpha
Verified 2002121004 PC/Win98.
Status: RESOLVED → VERIFIED
*** Bug 184726 has been marked as a duplicate of this bug. ***
*** Bug 185284 has been marked as a duplicate of this bug. ***
*** Bug 186144 has been marked as a duplicate of this bug. ***
*** Bug 186659 has been marked as a duplicate of this bug. ***
*** Bug 187080 has been marked as a duplicate of this bug. ***
*** Bug 187585 has been marked as a duplicate of this bug. ***
*** Bug 187922 has been marked as a duplicate of this bug. ***
[Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.3a) Gecko/20021212]

(Confirming comment 63: fixed)
*** Bug 188651 has been marked as a duplicate of this bug. ***
*** Bug 191577 has been marked as a duplicate of this bug. ***
*** Bug 191604 has been marked as a duplicate of this bug. ***
*** Bug 192094 has been marked as a duplicate of this bug. ***
*** Bug 192093 has been marked as a duplicate of this bug. ***
*** Bug 193413 has been marked as a duplicate of this bug. ***
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.