Status

()

enhancement
RESOLVED INVALID
8 years ago
10 months ago

People

(Reporter: megabyte, Assigned: mreavy)

Tracking

(Depends on 3 bugs, Blocks 1 bug, {meta})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-kilimanjaro:-)

Details

(Whiteboard: tracking-webrtc, )

Reporter

Description

8 years ago
"WebRTC is a free, open project that enables web browsers with Real-Time Communications (RTC) capabilities via simple Javascript APIs. The WebRTC components have been optimized to best serve this purpose. 

Our mission: To enable rich, high quality, RTC applications to be developed in the browser via simple Javascript APIs and HTML5.

Our first milestone: To provide the key RTC components to the browser community and collaborate on implementing a universal set of Javascript APIs.

The WebRTC initiative is a project supported by Google, Mozilla and Opera."

Since this hits several technologies, I expect this will serve as the tracking bug, with new bugs for relevant components.
Reporter

Updated

8 years ago

Comment 1

8 years ago
Dupe of Bug 650295?

Comment 2

8 years ago
That bug doesn't seem to be tracking everything in the FAQ at http://www.webrtc.org/faq#TOC-What-is-WebRTC-
"It includes the fundamental building blocks for high quality communications on the web such as network, audio and video components used in voice and video chat applications."
Depends on: 650295
Reporter

Updated

8 years ago
Alias: webrtc
Depends on: 693057
Depends on: 709883
Assignee: nobody → mreavy
Assignee: mreavy → nobody
Component: General → WebRTC
QA Contact: general → webrtc-general
Assignee: nobody → mreavy

Updated

7 years ago
Depends on: 732474

Updated

7 years ago
Depends on: 732492

Updated

7 years ago
blocking-kilimanjaro: --- → +
Whiteboard: [k9o:p2:fx17?]

Updated

7 years ago

Updated

7 years ago
No longer blocks: k9o-web-platform
blocking-kilimanjaro: + → ---
Whiteboard: [k9o:p2:fx17?]
Depends on: 748844
This will not make FF15 or 16.  We'd like to ship this in 2012.
blocking-kilimanjaro: --- → ?
Whiteboard: [k9o:p2:fx17?]

Updated

7 years ago
blocking-kilimanjaro: ? → -
No longer depends on: 729541

Updated

7 years ago
Depends on: 773454
QA Contact: jsmith

Comment 4

7 years ago
When I try the Video at the gUM Test Page the browser crashes.

Mac OS X 10.6.8
Browser: 17.0a1
(In reply to Andy Bajka from comment #4)
> When I try the Video at the gUM Test Page the browser crashes.
> 
> Mac OS X 10.6.8
> Browser: 17.0a1

Can you give me a link to your crash report? Do the following:

1. Go to about:crashes
2. Find the date of when you think the crash happened
3. Go to that link
4. Copy and paste the URL here

Comment 7

7 years ago
(In reply to Jason Smith [:jsmith] from comment #5)
> (In reply to Andy Bajka from comment #4)
> > When I try the Video at the gUM Test Page the browser crashes.
> Can you give me a link to your crash report? Do the following:
> 
> 1. Go to about:crashes
> 2. Find the date of when you think the crash happened
> 3. Go to that link
> 4. Copy and paste the URL here

It crashes for me too (click video, webcam light turns on, browser crashes).

https://crash-stats.mozilla.com/report/index/fe2263ee-c388-4808-afd8-0cc492120824

Comment 8

7 years ago
Andy, Rob, your crashes are consistent, both in mozilla::layers::PlanarYCbCrImage::CopyData, and Scoobidiver filed bug 785001 for that one.

As this here is a tracking bug, let's just track the crash over there.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Any explanation about why this bug has been resolved as WONTFIX?
(In reply to Mounir Lamouri (:mounir) from comment #9)
> Any explanation about why this bug has been resolved as WONTFIX?

Sorry for the lack of response (triage just happened that went massively fast). We are moving to a different tracking mechanism that won't use the tracking bug, but instead use:

- [WebRTC] in the whiteboard for a bug related to the full stack of WebRTC implementation
- [blocking-webrtc+] in the whiteboard for blocker to ship full stack of webrtc
- [blocking-webrtc-] in the whiteboard for a non-blocker to ship full stack of webrtc
Lets mark this INVALID then. WONTFIX would means we no longer want to have WebRTC.
Resolution: WONTFIX → INVALID
Depends on: 790929
Whiteboard: [k9o:p2:fx17?] → tracking-webrtc
No longer depends on: android-webrtc

Updated

6 years ago
No longer depends on: 871577

Updated

6 years ago
Depends on: 882145
No longer depends on: 882145

Updated

5 years ago
Depends on: 970265

Comment 12

4 years ago
WebRtc is a great addition that could bring more users to Firefox. 

However it is odd that there is not more control over the settings. 

Why does the webcam come on by default and this cannot be disabled, easily at least. This has privacy implications.

More people want to make voice-chats only than video and chats; and this market is clearly larger. 

When enabling Firefox Hello, the option to have a voice chat only should be given upfront. 

Firefox Hello should also allow the camera to be disabled entirely, about:permissions doesn't work on this.
Flags: needinfo?(mreavy)
(In reply to stochos from comment #12)
> WebRtc is a great addition that could bring more users to Firefox. 

This sort of general commentary should go in the mozilla.dev.media newsgroup/mailing-list; an old, closed bug on the general feature is not a good way to get results.

> 
> However it is odd that there is not more control over the settings. 
> 
> Why does the webcam come on by default and this cannot be disabled, easily
> at least. This has privacy implications.

It's always easy to disable the camera/mic from the top-of-the-screen, always-visible indicator.  Also, it only comes on from a direct request from the user of one sort or another.
  
> 
> More people want to make voice-chats only than video and chats; and this
> market is clearly larger. 

Quite arguable, and likely dependent on the subset of the user population you're familiar with.  Hello (which uses WebRTC, but is a separate feature/service built on top of WebRTC) has the option for voice-only in any direct call to a user from the contact list, and the camera can be turned off at any time.

Applications using WebRTC can do Audio, Video or let the user decide.  That's up to the application built on top of WebRTC, not WebRTC itself.

> 
> When enabling Firefox Hello, the option to have a voice chat only should be
> given upfront. 
> 
> Firefox Hello should also allow the camera to be disabled entirely,
> about:permissions doesn't work on this.

For these, file bugs ((enhancement requests) in Loop::Client (Loop is the codename for Hello)
Flags: needinfo?(mreavy)

Comment 14

3 years ago
Host-relay pair failed in firefox webrtc. What is the reason?
OS: Ubuntu 17.04
Firefox: Stable(54), Nightly (57)

I've noticed a bug related to RTCDataChannel.close method.
According to this doc: https://developer.mozilla.org/en-US/docs/Web/API/RTCDataChannel/close
The close process ends by "7. A close event is sent to the channel.", but the Close Event does not fire on RTCDataChannel (RTCDataChannel.onclose callback never called). In Chrome (tested on stable and canary) it works as intended.

However it works when calling close method on RTCPeerConnection rather then on related RTCDataChannel.
(In reply to philippe.kalitine from comment #15)
> OS: Ubuntu 17.04
> Firefox: Stable(54), Nightly (57)
> 
> I've noticed a bug related to RTCDataChannel.close method.
> According to this doc:
> https://developer.mozilla.org/en-US/docs/Web/API/RTCDataChannel/close
> The close process ends by "7. A close event is sent to the channel.", but
> the Close Event does not fire on RTCDataChannel (RTCDataChannel.onclose
> callback never called). In Chrome (tested on stable and canary) it works as
> intended.
> 
> However it works when calling close method on RTCPeerConnection rather then
> on related RTCDataChannel.

Could you open a new bug for that in Core::WebRTC?
You need to log in before you can comment on or make changes to this bug.