Closed Bug 707489 Opened 8 years ago Closed 6 years ago

About Thunderbird dialog "Check for Updates" button disregards user prefs - available update(s) are downloaded and queued for installation

Categories

(Thunderbird :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 29.0

People

(Reporter: reply2discussion, Assigned: AMiras)

References

()

Details

(Keywords: ux-control, Whiteboard: [gs][good next bug][mentor=mkmelin][lang=js][port of bug 600500, bug 950357])

Attachments

(1 file, 2 obsolete files)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

Open the About dialog
Attempt to check if newer version of TB is available
For this purpose I push the button "Check for updates"


Actual results:

TB starts to download an update if such available


Expected results:

TB just only checks if any update is available, finally it presents the user with the
search result. It does not pulls the available download in unsolicited manner.
(In reply to 2t2 from comment #0)
This setting is already available in Edit (Tools) -> Preferences (Options) -> Advanced -> Update
We have no current plans on changing the defaults.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
Edit (Tools) -> Preferences (Options) -> Advanced -> Update -> Firefox updates
..the middle option is selected
Even though Fx and Tb behave as described in bug report.
End-user and no PC-freak expects just checking for update availability
when seeing "Check for updates". He/she will not expect more actions.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
Component: General → Application Update
Product: Thunderbird → Toolkit
QA Contact: general → application.update
Version: 8 → 8 Branch
This is actually Thunderbird code in its about dialog that decides whether to immediately download the update and not application update code so moving back to the Thunderbird product.
Component: Application Update → General
Product: Toolkit → Thunderbird
QA Contact: application.update → general
Version: 8 Branch → 8
I have "Never check for updates" selected. Clicking "Check for updates" caused installation of a new version of Firefox. Very misleading.
 I see this too - I was just bitten by it. Taking the liberty of confirming and clarifying the subject.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: "About"-"Check for Updates" performs more as its manifest is. → About Thunderbird dialog "Check for Updates" button disregards user prefs - available update(s) are downloaded and queued for installation
Version: 8 → 14
This has been a major pain in the *ss for users in support forum and elsewhere. The word" Stupid" comes to mind when thinking about how this button behaves.

The firefox equivalent is bug 600500, which has much discussion. IMO it shouldn't matter what the prefs are - if the button wording is "check for..." then that's all it should do, and then prompt regardless of pref settings.
Keywords: ux-control
OS: Windows XP → All
See Also: → 600500
Whiteboard: [has l10n impact][gs]
Version: 14 → Trunk
I am never going to trust that button again because it ignores my settings and no longer does what it says.  Why the button was not relabelled when its behaviour was changed, I cannot imagine.  A lot of other people who contribute to web fora about Mozilla applications also distrust it and are advising not trusting it.  If that is the way it is going to behave, you might as well just remove it.
I created http://kb.mozillazine.org/Mislabeled_buttons_-_Thunderbird to start documenting issues like this for the support forums.
This is still an issue in TBird ver 17.

See also Fox bugs:  
Bug 600500, appears to have a fix in progress?
Bug 690964, was reopened 2012-11-06
Depends on: 600500
Duplicate of this bug: 690964
Bug 600500 landed, so this should be straight forward for someone to take on.
Whiteboard: [has l10n impact][gs] → [gs][good next bug][mentor=mkmelin][lang=js][port of bug 600500]
Hello Magnus.

I'm new to the community. Just compiled Thunderbird this morning.

May I get this bug?
Absolutely! Welcome, Antonio!
Assignee: nobody → amarostegui
Hardware: x86 → All
Also please include what was done in bug 950357.
Whiteboard: [gs][good next bug][mentor=mkmelin][lang=js][port of bug 600500] → [gs][good next bug][mentor=mkmelin][lang=js][port of bug 600500, bug 950357]
OK
Before bug 600500, depending on the update (major or not) Firefox showed different messages. The team decided to unify both messages. 

Thunderbird's implementation was slightly different and also considered 'isPending' and 'isApplied' properties to show a different message.

I've taken Firefox's approach.
Attachment #8348853 - Flags: review?(mkmelin+mozilla)
Comment on attachment 8348853 [details] [diff] [review]
Port Firefox bug 600500 to Thunderbird's 707489

Review of attachment 8348853 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good, thx for the patch!
Just a few nits

::: mail/base/content/aboutDialog.js
@@ +494,5 @@
>        this.startDownload();
>        return;
>      }
>  
> +    this.selectPanel("apply");   

trailing whitespace

::: mail/locales/en-US/chrome/messenger/aboutDialog.dtd
@@ +2,5 @@
>  
> +
> +<!-- LOCALIZATION NOTE (update.checkForUpdatesButton.*, update.updateButton.*, update.applyButtonBillboard.*):
> +# Only one button is present at a time.
> +# The button when displayed is located directly under the Firefox version in

Thunderbird version

@@ +5,5 @@
> +# Only one button is present at a time.
> +# The button when displayed is located directly under the Firefox version in
> +# the about dialog.
> +-->
> +<!ENTITY update.checkForUpdatesButton.label       "Check for updates">

The u should be uppercased here I think, like the other buttons.
Attachment #8348853 - Flags: review?(mkmelin+mozilla) → review+
Done.
Attachment #8348853 - Attachment is obsolete: true
Attachment #8349297 - Flags: review?(mkmelin+mozilla)
Comment on attachment 8349297 [details] [diff] [review]
Rev1: Port Firefox bug 600500 to Thunderbird's 707489

Review of attachment 8349297 [details] [diff] [review]:
-----------------------------------------------------------------

For cases like this when you already got review+ you can attach an updated patch and mark it r+ and comment that you're carrying forward the review.

Forgot to mention, but it's good to also add the full commit message also to the patch so it's easier for someone else to check it in for you
https://developer.mozilla.org/en-US/docs/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F

When everything is ready, add the checkin-needed keyword and someone will check the patch in for you.
Attachment #8349297 - Flags: review?(mkmelin+mozilla) → review+
Ok. Thank you.
Attachment #8349297 - Attachment is obsolete: true
Attachment #8349955 - Flags: review+
Keywords: checkin-needed
Keywords: checkin-needed
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/0c46aa59fd71
Status: NEW → RESOLVED
Closed: 8 years ago6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 29.0
Thanks!

Might I suggest to also port two related Firefox bugs, especially the first one:
Bug 600505 - App update preference ui favors disabling app update.
Bug 701987 - Remove checkbox for add-on auto-checking for updates (extensions.update.enabled) from the options window, and make enabling extensions.update.autoUpdateDefault in the add-ons manager also enable extensions.update.enabled.
Thx for the suggestion Steffen! Filed as bug 958850.
Duplicate of this bug: 1042255
You need to log in before you can comment on or make changes to this bug.