Bug 730101 (prerendering)

Implement prerendering in Firefox

NEW
Assigned to

Status

()

enhancement
7 years ago
a month ago

People

(Reporter: bug.zilla, Assigned: Ehsan)

Tracking

(Depends on 20 bugs, {dev-doc-needed, parity-chrome, parity-ie})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Can Firefox implement prerendering of pages like Chrome (http://code.google.com/chrome/whitepapers/prerender.html)?

This is one of the main reasons users report that Chrome is "faster" than Firefox even though Javascript performance is probably not noticeably different.
Comment hidden (obsolete)
Comment hidden (obsolete)
I have tested this in Nightly 20.0a1 (2012-11-21) and prerender is not supported.
Comment hidden (obsolete)

Comment 5

6 years ago
This is a great feature in Chrome that definitely does _not_ exist in Firefox.  Firefox implements prefetching for single links into the cache.  Prerender on Chrome will render an entire page in the background and hot-swap it when the URL is actually requested, so the page load is instantaneous.

It strikes me that Firefox already has most of this functionality available in the bfcache (i.e. ability to have a hidden but active page that can be activated), so this should be relatively easy.

Updated

5 years ago
Whiteboard: [parity-chrome][parity-IE]

Updated

5 years ago
Severity: normal → enhancement
Component: General → Networking: Cache
Product: Firefox → Core
Version: 12 Branch → unspecified
Comment hidden (obsolete)
OS: Windows 7 → All
Hardware: x86_64 → All
(Assignee)

Comment 7

5 years ago
FWIW I will be mentoring an intern starting soon who will work on this.
Assignee: nobody → ehsan
I assume this will be based on data collected with the Network Seer?
(Assignee)

Comment 9

5 years ago
(In reply to comment #8)
> I assume this will be based on data collected with the Network Seer?

It could be, yes.  Once we have the support in the platform, we can look into various types of heuristics to determine when to prerender content, and the network seer could be one of them.
(Assignee)

Updated

5 years ago
Assignee: ehsan → roshanvid
(Assignee)

Updated

5 years ago
Component: General → Tracking
QA Contact: chofmann
Depends on: 1038993
(Assignee)

Updated

5 years ago
Depends on: 1045212
(Assignee)

Updated

5 years ago
Depends on: 1045215
(Assignee)

Updated

5 years ago
Depends on: 1045759
(Assignee)

Updated

5 years ago
Depends on: 1046291
Comment hidden (advocacy)
(Assignee)

Updated

5 years ago
Depends on: 1050456
(Assignee)

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

5 years ago
Depends on: 1052421
(Assignee)

Updated

5 years ago
Depends on: 1052423
Depends on: 1057585
Depends on: 1058838
Depends on: 1058842
Depends on: 1058901
Depends on: 1058904
Depends on: 1058908
Depends on: 1058913
Depends on: 1058918
Depends on: 1058920
Depends on: 1058921
Depends on: 1058922
Depends on: 1058924
Depends on: 1058928
Depends on: 1058948
Depends on: 1058960
Depends on: 1058961
Depends on: 1058964
Depends on: 1058970
Depends on: 1058980
(Assignee)

Updated

5 years ago
Depends on: 1060603
Depends on: 1061864
Depends on: 1069719
Depends on: 1069772
Depends on: 1085045
(Assignee)

Updated

4 years ago
Assignee: roshanvid → ehsan
(Assignee)

Updated

4 years ago
Depends on: 1117876
(Assignee)

Updated

4 years ago
Alias: prerendering
(Assignee)

Updated

4 years ago
Depends on: 1119866
(Assignee)

Updated

4 years ago
Depends on: 1125351
(Assignee)

Updated

4 years ago
Depends on: 1161646

Updated

4 years ago
Depends on: 1161663

Updated

4 years ago
Depends on: 1161665

Updated

4 years ago
Depends on: 1161679

Updated

4 years ago
Depends on: 1161680
Comment hidden (off-topic)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1190805
Francisco,
the FxOS 2.5 Architecture Evolution deliverables are dependent on this bug 730101 now that 1190805 is resolved as duplicate. is that correct? are we blocked in our delivery unless this is resolved in core?
Flags: needinfo?(francisco)
(Assignee)

Comment 14

4 years ago
(In reply to Caitlin Galimidi [:c8o] from comment #13)
> Francisco,
> the FxOS 2.5 Architecture Evolution deliverables are dependent on this bug
> 730101 now that 1190805 is resolved as duplicate. is that correct? are we
> blocked in our delivery unless this is resolved in core?

This is not happening by November, as there is no active developer working on it, and in top of that, the implementation will probably take much longer.
Flags: needinfo?(francisco)
Depends on: 1231753
Duplicate of this bug: 1148867
Duplicate of this bug: 1213434
(Assignee)

Updated

3 years ago
Depends on: 1266910
Depends on: 1271240

Updated

3 years ago
Component: Tracking → Document Navigation
(Assignee)

Updated

3 years ago
Depends on: 1302260
No longer depends on: 1276553
No longer depends on: 1276552
Depends on: 1330577
Depends on: 1330583
Mass bug change to replace various 'parity' whiteboard flags with the new canonical keywords. (See bug 1443764 comment 13.)
Whiteboard: [parity-chrome][parity-IE]
You need to log in before you can comment on or make changes to this bug.