Use 2x images for Developer Tools UI for HiDPI

RESOLVED FIXED in Firefox 32

Status

defect
RESOLVED FIXED
6 years ago
11 months ago

People

(Reporter: shorlander, Assigned: bgrins)

Tracking

(Blocks 3 bugs, {feature})

unspecified
Firefox 32
Dependency tree / graph

Firefox Tracking Flags

(firefox32 fixed, relnote-firefox 32+)

Details

Attachments

(1 attachment)

The DevTools UI needs images and CSS rules for HiDPI screens.
(In reply to Stephen Horlander from comment #0)
> The DevTools UI needs images and CSS rules for HiDPI screens.

I don't anything about HiDPI. How does it work? Do we have special mediaqueries/classes to know when to use the right images?
(In reply to Paul Rouget [:paul] from comment #1)
> I don't anything about HiDPI. How does it work? Do we have special
> mediaqueries/classes to know when to use the right images?


@media (min-resolution: 2dppx) {
  .something {
    background-image: url("image@2x.png");
    background-size: |double|px;
  }
}
Also see bug 781327 for how it was done for the main browser UI.

Updated

6 years ago
Blocks: osx-hidpi
Summary: Use 2x Image for Developer Tools UI for HiDPI → Use 2x images for Developer Tools UI for HiDPI

Updated

6 years ago
Assignee: nobody → paul
Stephen, can you provide the icons for this? At least the tools' icons (in the tabs).
Flags: needinfo?(shorlander)
These are all the icons from the osx and shared themes directories except the breadcrumbs.

I took the opportunity to clean up all the @1x icons as well so if you could please just do an image swap on those when adding the @2x versions.

Will follow-up with the breadcrumbs images.
Flags: needinfo?(shorlander)

Updated

6 years ago
Blocks: 916766
Brian, can you take a look at this?
Assignee: paul → nobody
(Assignee)

Updated

6 years ago
Assignee: nobody → bgrinstead
Depends on: 941673
(Assignee)

Updated

6 years ago
Depends on: 947309
(Assignee)

Comment 8

5 years ago
Bug 947309 uses 2x icons for the top toolbar.  The remaining icons that need to be converted to 2x (and moved into the shared folder) are: responsive mode, webconsole output, webconsole input prompt, inspector twisties and checkboxes, debugger breakpoint, debugger widget arrow, debugger icons (controls and blackboxing & breakpoints buttons), style editor sidebar arrow & eye, profiler icon.

I will take a look at these and see how many changes will be needed for each, and if they can be done all together here.
(Assignee)

Updated

5 years ago
Depends on: 957160
(Assignee)

Updated

5 years ago
Depends on: 1000928
(Assignee)

Updated

5 years ago
Depends on: 1005431
(Assignee)

Updated

5 years ago
Depends on: 1006906
No longer depends on: 1006906
(Assignee)

Updated

5 years ago
Depends on: 1006906

Comment 9

5 years ago
Can I fix the remaining images ? If so, should I file a new bug (since this might be for tracking) ?
Flags: needinfo?(bgrinstead)

Comment 10

5 years ago
Ok, so I'm gonna split this up in multiple small bugs, otherwise it's gonna be a mess.
Flags: needinfo?(bgrinstead)
(Assignee)

Comment 11

5 years ago
(In reply to Tim Nguyen [:ntim] from comment #9)
> Can I fix the remaining images ? If so, should I file a new bug (since this
> might be for tracking) ?

Please do!

(In reply to Tim Nguyen [:ntim] from comment #10)
> Ok, so I'm gonna split this up in multiple small bugs, otherwise it's gonna
> be a mess.

Yes, let's file a separate bug (blocking this one) for each image / each logical group of images.

Updated

5 years ago
Depends on: 1009002

Updated

5 years ago
Depends on: 1009145

Updated

5 years ago
Depends on: 1011249

Updated

5 years ago
Depends on: 1012139

Updated

5 years ago
Depends on: 1012166

Updated

5 years ago
Depends on: 1012829

Updated

5 years ago
Depends on: 1017890

Updated

5 years ago
Duplicate of this bug: 1018715

Updated

5 years ago
Depends on: 1018809

Updated

5 years ago
Depends on: 1019124

Updated

5 years ago
Depends on: 1019186

Updated

5 years ago
Depends on: 1019217

Comment 13

5 years ago
Finally finished ! \o/
Status: NEW → RESOLVED
Last Resolved: 5 years ago
relnote-firefox: --- → ?
Keywords: feature
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
(Assignee)

Comment 14

5 years ago
(In reply to Tim Nguyen [:ntim] from comment #13)
> Finally finished ! \o/

Yay! Thanks for all the patches ntim, looking sharp at 2x.

Updated

5 years ago
Blocks: 1016548

Updated

5 years ago
Depends on: 1022290

Updated

5 years ago
Blocks: 1023546

Updated

11 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.