Closed Bug 918553 Opened 6 years ago Closed 6 years ago

[B2G][DSDS][User Story] Signal strength bar

Categories

(Firefox OS Graveyard :: RIL, defect, P1, blocker)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 938440
1.3 Sprint 5 - 11/22

People

(Reporter: skamat, Unassigned)

References

()

Details

(Keywords: feature, Whiteboard: [FT:RIL, 1.3:p1, ucid:DSDS11] [L2])

Meta Bug:
Visual Indicators necessary for DSDS feature (break into separate bugs as needed)

1) As I user, I should be able to see signal strength (RSSI) bars per SIM. I should also be able to see absence of the SIM card and/or absence of network coverage.
2) As I user, I should be able to see operator names per SIM in homescreen as well as lock screen.
3) As I user, I should be able to see 2 different icons for voicemails and call forwarding indicating each subscription's status.
Depends on: 814629
Depends on: 814634
Make summary more clearly.
Summary: [B2G][DSDS] Visual Indicators necessary for DSDS feature → [B2G][DSDS][User Story] Visual Indicators necessary for DSDS feature
Depends on: 921389
Depends on: 921390
Depends on: 921391
blocking-b2g: --- → 1.3+
Whiteboard: [FT:RIL, 1.3:p1, ucid:DSDS11, ucid:DSDS12]
This bug is used to track DSDS11: As I user, I should be able to see signal strength (RSSI) bars per SIM. I should also be able to see absence of the SIM card and/or absence of network coverage.

DSDS12 is in bug 921980.
Summary: [B2G][DSDS][User Story] Visual Indicators necessary for DSDS feature → [B2G][DSDS][User Story] Signal strength bar
Whiteboard: [FT:RIL, 1.3:p1, ucid:DSDS11, ucid:DSDS12] → [FT:RIL, 1.3:p1, ucid:DSDS11]
Ivan, looks like signal bar(Gaia part) is something in system platform team? Can you help to make sure this is included in the backlog in system platform team? Thank you.
Flags: needinfo?(itsay)
No longer depends on: 921390
Kevin, per our discussion, once the engineering bug is created, it should be linked it to this user story. The engineering work will be tracked under DSDS team to reduce the communication effort. Regarding the engineering resource tracking, Tim will regularly have the sync-up with system platform team members on their workload. I will also check if there is any impact on the tasks of system platform and your team regularly.
Flags: needinfo?(itsay)
Depends on: 926169
Acceptance criteria from PM:

1) User should be able to check if the network coverage (signal bars) is available for 1 or both the SIMs. 

2) User should be able to see a visual indication if one or both of the SIM slots is/are empty.

3) User should be able to see a visual indication if one or both of the SIMs is/are out of coverage.

-----------------------------------------------------------------------------------------------------
Suggest to add data call icon checking in item 1.
Update acceptance criteria:

1) User should be able to check if the network coverage (voice signal bars, data coverage) is available for 1 or both the SIMs. 

2) User should be able to see a visual indication if one or both of the SIM slots is/are empty.

3) User should be able to see a visual indication if one or both of the SIMs is/are out of coverage.
Priority: -- → P1
Severity: normal → blocker
Keywords: feature
Blocks: 930299
Whiteboard: [FT:RIL, 1.3:p1, ucid:DSDS11] → [FT:RIL, 1.3:p1, ucid:DSDS11] [L2]
Target Milestone: --- → 1.3 Sprint 5 - 11/22
Blocks: 937014
update moztrap link.
Remove blocking-b2g flag from User Story bugs. Use whiteboard to indicate what FxOS version we target.
blocking-b2g: 1.3+ → ---
Per Google doc for user stories, this bug contains DSDS11, DSDS12 and DSDS13. We We need these into individual bugs for clarity.
Here is the split:

DSDS11	Bug 938440
DSDS12	Bug 938443
DSDS13	Bug 938438
No longer depends on: 933703
This bug was split into different bugs, and this one could be closed now.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
No longer depends on: 921391
Blocks: b2g-dsds-1.4
No longer blocks: b2g-dsds-1.4
Resolution: FIXED → DUPLICATE
Duplicate of bug: 938440
No longer blocks: b2g-dsds-1.3
You need to log in before you can comment on or make changes to this bug.