[Flatfish] [Music] support 2 column layout on music2 app for tablet

RESOLVED DUPLICATE of bug 906540

Status

Firefox OS
Gaia::Music
RESOLVED DUPLICATE of bug 906540
5 years ago
4 years ago

People

(Reporter: hema, Assigned: dkuo)

Tracking

unspecified
1.3 Sprint 5 - 11/22
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [flatfish])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
+++ This bug was initially created as a clone of Bug #903917 +++
(Reporter)

Updated

5 years ago
Assignee: nobody → dkuo
No longer depends on: 903917
(Reporter)

Comment 1

5 years ago
Opened this bug to track the layout changes for music 2 app on tablet. 

Dominic - assigning this to you
(Assignee)

Comment 2

5 years ago
Created attachment 826590 [details]
[Flatfish] Music Player release spec.
(Reporter)

Comment 4

5 years ago
Dominic Kuo added a comment in Pivotal Tracker:   
   
Assign to me to sync with Bugzilla

Updated

5 years ago
blocking-b2g: --- → 1.3+
Target Milestone: --- → 1.3 Sprint 5 - 11/22
(Assignee)

Comment 5

5 years ago
With the latest spec, I have separate the works into several items roughly, and they are some dependencies if we want to implement them in parallel. We can probably file more bugs base on the main items(1~7) to trace the progress.

0. Remember to add comments.
1. Re-layout the whole ui.
1-1. Handle tablet and phone sizes.
1-2. Handle switching between landscape and portrait.
2. Implement the current music features with tablet style.
2-1. Mix.
2-2. Playlists.
2-3. Albums, Artists and All Songs.
3. The Player.
3-1. Now playing view.
3-2. Repeat and Shuffle.
3-3. Rating and Share.
4. Search.
4-1. Activating.
4-2. Display and play the results.
5. Localization.
* 6. Lazy loading js, css or html files.
* 7. Handle large songs collection.
* 7-1. Display large collection in list view.
* 7-2. Shuffle all songs.

For those items with a *, they are the issues which we will encounter, from the experiences of developing the current music app, it won't block the features but we should definitely address them after the main features are complete.

Comment 6

5 years ago
I agree it would be a good idea to push changes incrementally. I've finished a lot of the structure for 1 and 2, should have something out for that soon. That feels like the base of the ui, after that we can probably expand out in parallel.
(Assignee)

Comment 7

5 years ago
Evan, do you mind to paste your branch here so that Jim and I can have a look and know the progress first? and if you have finished 1, then you can send PR and try to land it first, cause I think once 1 is landed, we can implement 2, 3 and probably 4 in parallel.
(Assignee)

Updated

5 years ago
Depends on: 936385
(Assignee)

Updated

5 years ago
Depends on: 936397
(Assignee)

Updated

5 years ago
Depends on: 936405
(Assignee)

Updated

5 years ago
Depends on: 936419
(Assignee)

Updated

5 years ago
Depends on: 936423

Comment 8

5 years ago
implementation resource and ETA date are both agree with RD team. this has to be done before 1.3FC
Whiteboard: [Flatfish only] → [Flatfish only][developer+]

Updated

5 years ago
blocking-b2g: 1.3+ → ---
Blocks: 1018519
No longer blocks: 903304

Updated

4 years ago
Whiteboard: [Flatfish only][developer+] → [flatfish][TCP]
Whiteboard: [flatfish][TCP] → [flatfish]

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 906540
You need to log in before you can comment on or make changes to this bug.