Open Bug 1799516 (firefox-deb-repackage) Opened 2 years ago Updated 1 month ago

[meta] Ship Firefox Linux releases in deb packages

Categories

(Release Engineering :: General, enhancement)

Desktop
Linux
enhancement

Tracking

(Not tracked)

REOPENED

People

(Reporter: gabriel, Assigned: gabriel)

References

(Depends on 14 open bugs, Blocks 2 open bugs, Regressed 1 open bug)

Details

(Keywords: meta)

Attachments

(1 file)

There is no Mozilla repository (or deb packages) for people to update and install Firefox via APT on Debian, Ubuntu, and derivatives.

Depends on: 1799763
Depends on: 1799769
Depends on: 1799770

I guess two questions here: Should we host our debian repository out of archive.mozilla.org, or another sub-domain? And should we manage it ourselves, or use a managed service like Artifact Registry?

My understanding is that Artifact Registry doesn't support custom domains, so that might force our decision for us? Or we'd need to put something in front of Artifact Registry. Probably also good to look at bandwidth costs for Artifact Registry vs our own load balancers.

For future reference: jbuck found https://cloud.google.com/blog/topics/developers-practitioners/hack-your-own-custom-domains-container-registry which implies we can just put a reverse proxy (and CDN) in front of artifact registry and serve it the same way we do the rest of productdelivery

The layout on archive.m.o has an impact on other processes and standing practices. The official version should be stored in the normal release build hierarchy.

Reminder: A user accessible package repository is a new service, and an RRA needs to be done prior to any go-live. That can also address the domain question.

Depends on: 1811104
Depends on: 1811114
Alias: firefox-debian-repackage → firefox-deb-repackage
Summary: [meta] Ship Firefox Linux releases in Debian Packages → [meta] Ship Firefox Linux releases in deb packages
Depends on: 1816076
Assignee: nobody → gabriel
Attachment #9317951 - Attachment description: WIP: Bug 1799516 - Update firefox bin link to match the name of the .deb package → Bug 1799516 - Update firefox bin link to match the name of the .deb package r?#releng-reviewers
Status: NEW → ASSIGNED
Attachment #9317951 - Attachment description: Bug 1799516 - Update firefox bin link to match the name of the .deb package r?#releng-reviewers → Bug 1799516 - Update firefox bin link to match the name of the .deb package r?jlorenzo,#releng-reviewers
Depends on: 1817943
Depends on: 1818168
Depends on: 1818275
Pushed by gbustamante@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2678385eb9b2
Update firefox bin link to match the name of the .deb package r=releng-reviewers,jlorenzo
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Reopening bug for being a meta one.

Status: RESOLVED → REOPENED
Keywords: meta
Resolution: FIXED → ---
Depends on: 1822869
No longer depends on: 1816076
See Also: → 1816076
Depends on: 1824089
Depends on: 1824327
Depends on: 1825582
No longer depends on: 1825582

That's my bad, I cloned one of the beetmover bugs here to file a different one and forgot to delete the "blocks" section 🤦‍♂️

Depends on: 1825834
Depends on: 1825847
Depends on: 1825886
See Also: → 1772219

I linked Bug 1772219 because this might impact users of the Firefox .deb packages when they run apt-get upgrade

Depends on: 1826540
Depends on: 1826748
Depends on: 1826792
Depends on: 1827849
See Also: → 1705217
See Also: → 1724360

What does Chrome differently or does it also suffer from bug 1705217, etc?

(In reply to Darkspirit from comment #10)

  1. What does Chrome differently or does it also suffer from bug 1705217, etc?

They use a fork server that they call the zygote process to launch new processes from in-memory data rather than relying on the files on disk. See this page for more details.

See Also: → forkserver
Depends on: 1828775

(In reply to Robin Steuber (they/them) [:bytesized] from comment #11)

(In reply to Darkspirit from comment #10)

  1. What does Chrome differently or does it also suffer from bug 1705217, etc?

They use a fork server that they call the zygote process to launch new processes from in-memory data rather than relying on the files on disk. See this page for more details.

I am getting the feeling that the Nightly .deb builds might not be viable without fixing this.

Depends on: 1830165
No longer depends on: 1830516
See Also: 1772219
Depends on: 1835051
Depends on: 1835141
Depends on: 1835711
Severity: -- → N/A
Depends on: 1836348
Depends on: 1839244
Depends on: 1832206
See Also: → 1832206
No longer depends on: 1832206
Depends on: 1842885

Johan, can you please clarify what's needed from a relnote perspective here?

Flags: needinfo?(jlorenzo)

I'm no expert in release notes. I was thinking of something like:

New: Mozilla's new .deb package for Debian, Ubuntu, and Linux Mint users. See these instructions[add link].

Would an entry like this make sense?

Flags: needinfo?(jlorenzo)
Depends on: 1845367
Depends on: 1853803
Depends on: 1853807
Blocks: 1856895
Depends on: 1860752
Depends on: 1861929
Depends on: 1862456
Depends on: 1863757
Regressions: 1868466
Depends on: 1876829
Depends on: 1879893
Depends on: 1882556
Depends on: 1884980
See Also: → 1887210
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: