The default bug view has changed. See this FAQ.

Status

()

Core
WebRTC
--
enhancement
RESOLVED INVALID
6 years ago
a year ago

People

(Reporter: Aaron Kaluszka, Assigned: mreavy)

Tracking

(Depends on: 4 bugs, Blocks: 2 bugs, {meta})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-kilimanjaro:-)

Details

(Whiteboard: tracking-webrtc, URL)

(Reporter)

Description

6 years ago
"WebRTC is a free, open project that enables web browsers with Real-Time Communications (RTC) capabilities via simple Javascript APIs. The WebRTC components have been optimized to best serve this purpose. 

Our mission: To enable rich, high quality, RTC applications to be developed in the browser via simple Javascript APIs and HTML5.

Our first milestone: To provide the key RTC components to the browser community and collaborate on implementing a universal set of Javascript APIs.

The WebRTC initiative is a project supported by Google, Mozilla and Opera."

Since this hits several technologies, I expect this will serve as the tracking bug, with new bugs for relevant components.
(Reporter)

Updated

6 years ago
Keywords: meta

Comment 1

6 years ago
Dupe of Bug 650295?

Comment 2

6 years ago
That bug doesn't seem to be tracking everything in the FAQ at http://www.webrtc.org/faq#TOC-What-is-WebRTC-
"It includes the fundamental building blocks for high quality communications on the web such as network, audio and video components used in voice and video chat applications."
Depends on: 650295
Blocks: 673923

Updated

6 years ago
Depends on: 683620
(Reporter)

Updated

6 years ago
Alias: webrtc

Updated

6 years ago
Depends on: 688178

Updated

6 years ago
Depends on: 689680

Updated

6 years ago
Depends on: 691234

Updated

6 years ago
Depends on: 664918

Updated

6 years ago
Depends on: 694807

Updated

6 years ago
Depends on: 694808

Updated

6 years ago
Depends on: 694810

Updated

6 years ago
Depends on: 694812

Updated

6 years ago
Depends on: 694813

Updated

6 years ago
Depends on: 694814

Updated

6 years ago
Depends on: 694815

Updated

6 years ago
Depends on: 694817
Depends on: 693057

Updated

6 years ago
Depends on: 697754
Depends on: 709883

Updated

5 years ago
Depends on: 711628

Updated

5 years ago
Depends on: 718031
Assignee: nobody → mreavy

Updated

5 years ago
Depends on: 729522

Updated

5 years ago
Depends on: 729710

Updated

5 years ago
Depends on: 731429

Updated

5 years ago
Assignee: mreavy → nobody
Component: General → WebRTC
QA Contact: general → webrtc-general

Updated

5 years ago
Assignee: nobody → mreavy

Updated

5 years ago
Depends on: 732474

Updated

5 years ago
Depends on: 732492

Updated

5 years ago
Depends on: 739566

Updated

5 years ago
Depends on: 740350

Updated

5 years ago
Depends on: 745259

Updated

5 years ago
blocking-kilimanjaro: --- → +
Whiteboard: [k9o:p2:fx17?]

Updated

5 years ago
Blocks: 746388

Updated

5 years ago
No longer blocks: 746388
blocking-kilimanjaro: + → ---
Whiteboard: [k9o:p2:fx17?]
Depends on: 748844

Updated

5 years ago
Depends on: 749318

Updated

5 years ago
Depends on: 749522
This will not make FF15 or 16.  We'd like to ship this in 2012.
blocking-kilimanjaro: --- → ?
Whiteboard: [k9o:p2:fx17?]

Updated

5 years ago
Depends on: 750010

Updated

5 years ago
Depends on: 750011

Updated

5 years ago
blocking-kilimanjaro: ? → -
Blocks: 748250

Updated

5 years ago
Depends on: 757637

Updated

5 years ago
Depends on: 757669

Updated

5 years ago
Depends on: 729541

Updated

5 years ago
No longer depends on: 729541
Blocks: 720139

Updated

5 years ago
Depends on: 761367

Updated

5 years ago
Depends on: 773454

Updated

5 years ago
QA Contact: jsmith
Depends on: 784082

Comment 4

5 years ago
When I try the Video at the gUM Test Page the browser crashes.

Mac OS X 10.6.8
Browser: 17.0a1
(In reply to Andy Bajka from comment #4)
> When I try the Video at the gUM Test Page the browser crashes.
> 
> Mac OS X 10.6.8
> Browser: 17.0a1

Can you give me a link to your crash report? Do the following:

1. Go to about:crashes
2. Find the date of when you think the crash happened
3. Go to that link
4. Copy and paste the URL here

Comment 6

5 years ago
Hi Jason, here's the crash url you requested.

https://crash-stats.mozilla.com/report/index/bp-fa5e2fa6-8717-45fd-a26b-e86432120824

Comment 7

5 years ago
(In reply to Jason Smith [:jsmith] from comment #5)
> (In reply to Andy Bajka from comment #4)
> > When I try the Video at the gUM Test Page the browser crashes.
> Can you give me a link to your crash report? Do the following:
> 
> 1. Go to about:crashes
> 2. Find the date of when you think the crash happened
> 3. Go to that link
> 4. Copy and paste the URL here

It crashes for me too (click video, webcam light turns on, browser crashes).

https://crash-stats.mozilla.com/report/index/fe2263ee-c388-4808-afd8-0cc492120824

Comment 8

5 years ago
Andy, Rob, your crashes are consistent, both in mozilla::layers::PlanarYCbCrImage::CopyData, and Scoobidiver filed bug 785001 for that one.

As this here is a tracking bug, let's just track the crash over there.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
Any explanation about why this bug has been resolved as WONTFIX?
(In reply to Mounir Lamouri (:mounir) from comment #9)
> Any explanation about why this bug has been resolved as WONTFIX?

Sorry for the lack of response (triage just happened that went massively fast). We are moving to a different tracking mechanism that won't use the tracking bug, but instead use:

- [WebRTC] in the whiteboard for a bug related to the full stack of WebRTC implementation
- [blocking-webrtc+] in the whiteboard for blocker to ship full stack of webrtc
- [blocking-webrtc-] in the whiteboard for a non-blocker to ship full stack of webrtc
Lets mark this INVALID then. WONTFIX would means we no longer want to have WebRTC.
Resolution: WONTFIX → INVALID
Depends on: 790929
Whiteboard: [k9o:p2:fx17?] → tracking-webrtc

Updated

4 years ago
No longer depends on: 750010

Updated

4 years ago
Depends on: 871577

Updated

4 years ago
No longer depends on: 871577

Updated

4 years ago
Depends on: 882145

Updated

4 years ago
No longer depends on: 882145
Blocks: 802882

Updated

3 years ago
Depends on: 970265

Comment 12

2 years ago
WebRtc is a great addition that could bring more users to Firefox. 

However it is odd that there is not more control over the settings. 

Why does the webcam come on by default and this cannot be disabled, easily at least. This has privacy implications.

More people want to make voice-chats only than video and chats; and this market is clearly larger. 

When enabling Firefox Hello, the option to have a voice chat only should be given upfront. 

Firefox Hello should also allow the camera to be disabled entirely, about:permissions doesn't work on this.
Flags: needinfo?(mreavy)
(In reply to stochos from comment #12)
> WebRtc is a great addition that could bring more users to Firefox. 

This sort of general commentary should go in the mozilla.dev.media newsgroup/mailing-list; an old, closed bug on the general feature is not a good way to get results.

> 
> However it is odd that there is not more control over the settings. 
> 
> Why does the webcam come on by default and this cannot be disabled, easily
> at least. This has privacy implications.

It's always easy to disable the camera/mic from the top-of-the-screen, always-visible indicator.  Also, it only comes on from a direct request from the user of one sort or another.
  
> 
> More people want to make voice-chats only than video and chats; and this
> market is clearly larger. 

Quite arguable, and likely dependent on the subset of the user population you're familiar with.  Hello (which uses WebRTC, but is a separate feature/service built on top of WebRTC) has the option for voice-only in any direct call to a user from the contact list, and the camera can be turned off at any time.

Applications using WebRTC can do Audio, Video or let the user decide.  That's up to the application built on top of WebRTC, not WebRTC itself.

> 
> When enabling Firefox Hello, the option to have a voice chat only should be
> given upfront. 
> 
> Firefox Hello should also allow the camera to be disabled entirely,
> about:permissions doesn't work on this.

For these, file bugs ((enhancement requests) in Loop::Client (Loop is the codename for Hello)
Flags: needinfo?(mreavy)

Comment 14

a year ago
Host-relay pair failed in firefox webrtc. What is the reason?
You need to log in before you can comment on or make changes to this bug.