[WFM]Impossible to make a selection in a comboBox (script, document.write)

VERIFIED FIXED in mozilla0.9.8

Status

()

P1
major
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: jrojas, Assigned: rods)

Tracking

({regression})

Trunk
mozilla0.9.8
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Fixed? bug 34297 landed partially; test with Nov. 2 or newer builds, URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
There is no way I can make a selection in that comboBox. You can open it but
when you click on the list it closes with no selection. If after opening it you
try to make the selection using keyboard the page scrolls leaving the list in
the same position of the screen.

Comment 1

17 years ago
same problem on WinNT4 + 2001091803
When I looked to source, I didn't find starting tag SELECT for this select-box.
It  isn't in HTML or in document.write function.

In MSIE5.5 this select box works... 
seeing this on current cvs linux as well.  Over to form controls.  The
javascript seems to be messing things up for us....
Assignee: asa → rods
Status: UNCONFIRMED → NEW
Component: Browser-General → HTML Form Controls
Ever confirmed: true
OS: Windows ME → All
QA Contact: doronr → madhur
Looks like 0.9.4 handles this.  regression.  ccing Harish in case his parser
changes somehow affected this (doubtful).
Keywords: regression

Comment 5

17 years ago
On my local tree ( 0.9.4 branch ), with all my changes, I'm able to the selection.

Comment 6

17 years ago
On my local tree ( 0.9.4 branch ), with all my changes, I'm able to make the
selection.

Comment 7

17 years ago
0.9.4 is able to do it.  Latest CVS (2001091908 Linux) is not.

This will be fixed with the rewrite of select for bug 34297 (it is working
correctly).  Depending on reviews, I am *guessing* this first patch will be in
within 2-4 weeks.  (We hope to have the first rev. of the patch done this
weekend.)  I'm adding a dependency.

The source of the problem is probably jesup's select insertion performance
improvement (bug 97345), but I can't be sure because I redid that in my patch. 
The problem for me (which was probably also a problem for him) was the fact that
AppendChildTo() is called twice, once for the AppendChildTo(<SCRIPT>) and then
immediately afterwards (recursively) to the created <OPTION>.  The catch is,
when the call is made to AppendChildTo(<OPTION>), the <SCRIPT> element is
already in the tree (in front of the option)!  This means that the tree is no
longer flat, but since the AppendChildTo(<SCRIPT>) call that triggered it hasn't
finished, the select is not yet aware of this (it checks *after* calling the
parent AppendChildTo()).

Note that we have an artifact, even in 0.9.4, where a blank spot shows up at the
beginning of the list.  This is (probably) unrelated.  It still shows up after I
fix the bug in my tree.  (I will file--or search for--a bug on this when I
finish the present patch).
Depends on: 34297

Comment 8

17 years ago
*** Bug 99836 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
From the dup, if the <select> is the first tag on the page (before <html> and 
<body>!), this bug doesn't occur.
Severity: normal → major
Summary: Impossible to make a selection in a comboBox → Impossible to make a selection in a comboBox (script, document.write)
*** Bug 100810 has been marked as a duplicate of this bug. ***
*** Bug 102680 has been marked as a duplicate of this bug. ***
*** Bug 103645 has been marked as a duplicate of this bug. ***
*** Bug 103642 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
*** Bug 99781 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
*** Bug 104726 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
*** Bug 104786 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
*** Bug 104832 has been marked as a duplicate of this bug. ***
*** Bug 104964 has been marked as a duplicate of this bug. ***

Comment 19

17 years ago
*** Bug 104985 has been marked as a duplicate of this bug. ***

Comment 20

17 years ago
*** Bug 105215 has been marked as a duplicate of this bug. ***

Comment 21

17 years ago
this seems to happen with every couple of new release of Mozilla, in 0.9.4 it
was ok, but not before (i recalll 0.9.2 was ok too) and now it is dead again.
*** Bug 105557 has been marked as a duplicate of this bug. ***
*** Bug 105695 has been marked as a duplicate of this bug. ***
*** Bug 105958 has been marked as a duplicate of this bug. ***
*** Bug 105947 has been marked as a duplicate of this bug. ***

Comment 26

17 years ago
*** Bug 105876 has been marked as a duplicate of this bug. ***

Comment 27

17 years ago
*** Bug 106089 has been marked as a duplicate of this bug. ***
*** Bug 105034 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla0.9.6
(Assignee)

Comment 29

17 years ago
This works for me with yesterday's build.
Summary: Impossible to make a selection in a comboBox (script, document.write) → [WFM]Impossible to make a selection in a comboBox (script, document.write)
Rods: This doesn't WFM with 2001102203 on Win2k, fwiw.
*** Bug 106371 has been marked as a duplicate of this bug. ***

Comment 32

17 years ago
Bug 91658 seems to be closely related, but still doesn't have a fix. 
*** Bug 106579 has been marked as a duplicate of this bug. ***
*** Bug 105599 has been marked as a duplicate of this bug. ***
*** Bug 106926 has been marked as a duplicate of this bug. ***

Comment 36

17 years ago
*** Bug 106900 has been marked as a duplicate of this bug. ***

Comment 37

17 years ago
*** Bug 107070 has been marked as a duplicate of this bug. ***

Comment 38

17 years ago
*** Bug 107197 has been marked as a duplicate of this bug. ***
*** Bug 107388 has been marked as a duplicate of this bug. ***
*** Bug 107903 has been marked as a duplicate of this bug. ***

Comment 41

17 years ago
*** Bug 107690 has been marked as a duplicate of this bug. ***

Comment 42

17 years ago
Hmm... I've seen bugs marked 'mostfreq' for less duplicates than this!
Whiteboard: Fixed? bug 34297 landed partially; test with Nov. 2 or newer builds
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.6 → mozilla0.9.8

Comment 43

17 years ago
Reinout: the mostfreq keyword was removed since we now have the more accurate
http://bugzilla.mozilla.org/duplicates.cgi and 
http://bugzilla.mozilla.org/duplicates.cgi?sortby=delta&changedsince=7 to tell 
us which bugs have the most dups and which bugs are gathering dups quickly.
Fixed with bug 34297 landing.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
*** Bug 108355 has been marked as a duplicate of this bug. ***

Comment 46

17 years ago
This definitely fixed the bug I'd reported (in a different bug now duped to this
one). Thanks for the effort. Great job!
*** Bug 108554 has been marked as a duplicate of this bug. ***

Comment 48

17 years ago
verified fixed on win2000 build ID: 2001-11-08-06trunk
Status: RESOLVED → VERIFIED
*** Bug 109484 has been marked as a duplicate of this bug. ***
*** Bug 110862 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.