Mozilla.exe Entry Point Not Found ?ToNewUnicode@nsString@@QBEPAGXZ

VERIFIED FIXED

Status

SeaMonkey
Installer
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Greg Henschen, Assigned: Curt Patrick (gone))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Received the following Stop error upon completing the install of build:
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.5+) Gecko/20011105

The procedure entry point ?ToNewUnicode@nsString@@QBEPAGXZ could not be located
in the dynamic link library xpcom.dll.
--> curt

reporter, please sort your components directory by date and report which .dll's
appear older than the rest. This problem typically means an obsolete file was
left over from a previous install.
Assignee: syd → curt
Component: Installer → Installer: XPI Packages
Summary: Mozilla.exe Entry Point Not Found stop error as part of install → Mozilla.exe Entry Point Not Found ?ToNewUnicode@nsString@@QBEPAGXZ
*** Bug 108544 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

17 years ago
The following files have older dates in my component directory:
fullsoft.dll     10/11/2001
Acctldl.dll      10/11/2001
chardetc.dll     10/11/2001
evntloop.dll      9/13/2001
nativapp.dll      9/13/2001

the new components all had dates of 11/5/2001

Updated

17 years ago
QA Contact: bugzilla → ktrina

Comment 4

17 years ago
Error not appearing after reinstall...

Matti@epost.de kindly pointed out that I should not install new builds over
older builds (notes on BUG 108544). I fumigated the old build, reinstalled the
new build, and cannot reproduce the error.
(Assignee)

Comment 5

17 years ago
But there will always be customers who do install over their old builds, so this
is a real bug.  We will address it.

Comment 6

17 years ago
Using the nightly of 2001-11-15 on Windows NT 4.0, this bug is still present.  I tried to install it 
over a Mozilla 0.9.5 install, and got the reported error message.
marking NEW based on the comments
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

17 years ago
I encountered this problem while trying to install the 0.9.6 build on top of 
0.9.5.
I uninstalled the botched 0.9.6 install and physically removed the C:\Program 
Files\mozilla.org\Mozilla directory, and rebooted the machine, then tried to 
reinstall. I don't see this message any more, but Mozilla crashes before the 
install is completed, and refuses to start.

Comment 9

17 years ago
Nope, nothing to be done, I had to revert to 0.9.5 (fortunately, I didn't have 
to go all the way back to a Ghost image). I have submitted Full circle reports, 
however.
(Assignee)

Comment 10

17 years ago
Fazal's problem seems to be different.  Others are not crashing, only receiving
a benign error message but proceeding to be able to use the product
subsequently, correct?
*** Bug 104824 has been marked as a duplicate of this bug. ***
*** Bug 111236 has been marked as a duplicate of this bug. ***
*** Bug 111127 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
I've installed (full) Mozilla 0.9.6 on win2000sp2, upgrading from Mozilla 0.9.5,
and I get "The procedure entry point ?ToNewUnicode@nsString@@QBEPAGXZ could not
be located in the dynamic link library xpcom.dll" at the first automatic launch
after installation. Next (manual) launches don't show the error (quick launch
not activated).
*** Bug 111409 has been marked as a duplicate of this bug. ***
*** Bug 111501 has been marked as a duplicate of this bug. ***
Depends on: 104465
(Reporter)

Comment 17

17 years ago
Installed 0.9.6 now and the following old components are still present:

Acctldl.dll      10/11/2001
chardetc.dll     10/11/2001
evntloop.dll      9/13/2001
nativapp.dll      9/13/2001

(these were previously reported)

one previously reported old component now changed

fullsoft.dll    was  10/11/2001  is now 11/20/2001

previously reported error message still present 


(Assignee)

Comment 18

17 years ago
Checked in the fix to both mozilla and ns trunks.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
*** Bug 112160 has been marked as a duplicate of this bug. ***
*** Bug 112600 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 21

17 years ago
*** Bug 96095 has been marked as a duplicate of this bug. ***

Comment 22

17 years ago
I received this message just now on 2001113003 on W2K. Seems to still be 
present. If it was checked into the trunk on 11/26, shouldn't it be resolved in 
this 11/30 nightly build?

(Assignee)

Comment 23

17 years ago
Yup.  It should.  Could you insert a dir of your components folder.  Make sure
you include the dates on the files, please.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
*** Bug 108768 has been marked as a duplicate of this bug. ***
I'm guessing the message isn't EXACTLY the same. If it isn't please open a new
bug since there is no doubt a newly obsoleted file.

Once we get a handle on this we should have an in-place-upgrade added to the
daily smoketests so we can stay right on top of the problem.
*** Bug 113178 has been marked as a duplicate of this bug. ***

Comment 27

17 years ago
*** Bug 115260 has been marked as a duplicate of this bug. ***
Isn't this one fixed? If not it should be fixed for milestones, and it's not
hard to do.
Keywords: mozilla0.9.7
I'm not seeing this anymore and there were checkins for this (apparently under
another bug). I'm going to close this.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 30

17 years ago
Marking Verified.
Status: RESOLVED → VERIFIED

Comment 31

17 years ago
I have just installed 0.9.7 on top of 0.9.5 (which I had reverted to after a 
botched install of 0.9.6, see comment #9), and the install went fine.

Comment 32

17 years ago
Install of full 0.9.7 on top of full 0.9.6 worked fine for me on machine using Win98. Looks like it is fixed.
*** Bug 117689 has been marked as a duplicate of this bug. ***
*** Bug 117721 has been marked as a duplicate of this bug. ***

Comment 35

16 years ago
Just installed the nightly build for 3/15/2002 on windows 2000, still seeing
this bug.

.dll files older than 3/15/2002 in the components directory:
chardetnativeTest.dll
intlcmpt.dll
MyService.dll
sample.dll
TestDynamic.dll
universalchrdet.dll
xpacct32.dll
xpctest.dll

All dated 8/28/2001

Also, there are a whole load of .xpt files in there, which ALL have the same
date (8/28/2001)
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
I strongly doubt you're getting this exact message. Please open a new bug for 
each individual entry point that's a problem, they are actually different 
problems.

Several of the files in your list appear to have come from a .zip build, they 
are not delivered with an installer build. The installer WONTFIX those. If you 
install .zip builds you need to be responsible for your own cleanup, and 
generally it's just easier and safer to unzip builds into a fresh directory.

At least one of those files (intlcmpt.dll) appears to have been created and 
then removed in the middle of a milestone. The install team really only worries 
about cleaning up milestone to milestone since those are the builds that get a 
lot of traffic. As with the .zip builds, if you install nightlies you're better 
off installing to a fresh directory
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED

Comment 37

16 years ago
Verified fixed - New bug should be opened per comment #36
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: Installer: XPI Packages → Installer
QA Contact: ktrina → general
You need to log in before you can comment on or make changes to this bug.