RFE: Single button to automatically send spam w/headers to spamcop or other anti-spam systems

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
17 years ago
10 years ago

People

(Reporter: masri, Unassigned)

Tracking

({helpwanted})

Trunk
Future
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Platform: PowerBook G3/300/192Mb/48Gb, MacOS X 10.1.1
Fizzilla Build ID: 2001112005

This is an RFE. The volume of spam these days is getting a little silly. So, I
have an RFE. It would be awesome, as we're reading mail and we come across spam,
if we could hit a single button and have an email instantly sent to a specific
email address and deleted. An example of how this would be useful would be
spamcop.net. If we have an email address setup to submit spam, then we could
just hit this button when reading email. The spam would be automatically sent
with headers to the anti-spam system and deleted from our inbox to save us time.
This would also be simple enough to use that more people would probably use such
a system, which would help all of us receive less spam.

- Adam
Keywords: helpwanted

Comment 1

17 years ago
Note that this feature might be easily abused by users who don't know exactly
what spamcop considers to be spam.

"My father-in-law sent me this dumb joke" is not really spam (in the spamcop sense).

Perhaps the feature could be disabled by default, and only enabled via a pref
which encourages folks to click a "more information" button before using the
feature. If the feature is set up to work through some mozilla-universal
connection with spamcop, then spamcop might be willing to maintain a page with
that information (they probably already have one they could copy to a URL
guaranteed not to change... so that URL could be locked into Mozilla)

-matt
(Reporter)

Comment 2

17 years ago
Your idea is good, but it makes this more complex than it needs to be. All this
button is actually doing is sending the complete email, with headers, to another
email address (of the user's choosing) and deleting the message. Spamcop no
longer accepts spam from people who haven't signed up for their service. Since
the user must put in a valid email address to use this Moz feature, and Spamcop
will only accept email to a specially formatted email address that is given to
the user when they sign up, this entire point is moot.

- Adam

Comment 3

17 years ago
ahh...

I had missunderstood that Mozilla was to register on behalf of all those users
using this feature so that the user would hit the button, and *poof* that's it...
no user registration beforehand, as Mozilla.org already registered and obtained
the specially formated address.

mea culpa

Comment 4

17 years ago
I've been wanting this for awhile.  What I'm imagining:

Highlight a message and either click a toolbar button, select a menu item, or
right-click and select a contextual menu option.  This will forward the message
to a user-defined address (specified in Preferences), which Spamcop provides
when you sign up.  The forwarded message can either be sent as an attachment, or
with the FULL headers included inline.  The forwarded message should be copied
to the Sent folder, and the original message moved to the Trash.

I'm thinking the option in Preferences should like this, disabled by default:

[X] Enable Spamcop button
      Address to forward to:
      [__________________________]

This should be global for all accounts, so it should go in Preferences under
Mail & Newsgroups, not in Mail & Newsgroup Account Settings.

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 5

17 years ago
Most systems will not work with a forwarded email, the email must be sent as is.
 How Pine handles this is with an additional email action like Reply or Forward
called "Bounce".  Just like clicking forward, you are asked for an email address
to bounce the email to.  Nothing it quoted or changed about the email.  So it
might be good to study those email systems and see how they handle it.
(Reporter)

Comment 6

17 years ago
What I'm envisioning for this RFE is the following:

This feature is not enabled or visible by default. It must be specifically
checked in Prefs. "Display Anti-Spam Button in Toolbar?" If this check button is
checked, a text area below it is enabled. "Anti-spam email address".

When these two things are done, a button appears in the Mail window. "Anti-spam"
(Icon: John Cleese with the universal "no" circle with slash over him? ;)  )

If a user is reading a spam, they simply click the Anti-spam button (or hit a
cmd/cntrl-key combo). The message is immediately forwarded as is, including
headers, no mods to the message, to the listed anti-spam address.

The beauty of this is that it is minimal work to add to Moz, and will work with
any anti-spam system that can take submissions through an email address. If a
user must sign up for that special email address, so be it. We don't get into
that, so it makes implementation simpler. In the help system, we could list URLs
of various anti-spam systems for them to register with, explaining that
Netscape/Mozilla.org doesn't handle that.

- Adam

Comment 7

17 years ago
John Cleese would be perfect, although I don't know how recognizable he'd be in
an icon that small.  Note that a picture of a can of SPAM, a pink blob of meat,
or "SPAM" in all caps is a no-no; " spam" in lower-case is fine.  See
http://www.spam.com/ci/ci_in.htm for Hormel Foods' trademark policy.

Ideally, if the option is checked in Preferences, there should be:

1) a button in the toolbar
2) an item in the Message menu, possibly with a keyboard shortcut
3) an item in the contextual menu when you right-click the message

All these would apply in the Preview pane; the first two would also apply if you
double-click the message to open it.

Comment 8

17 years ago
And, what I didn't see mentioned here, was it should delete the message too.

Comment 9

17 years ago
Comment #4:  "...and the original message moved to the Trash."

Comment 10

17 years ago
What about adding also a one step action to send it back to the original sender
as a simulated  delivery failure from posmaster@mydomain ?

I've heard it works not so bad.
(Reporter)

Comment 11

17 years ago
Please add that as a new RFE bug. I want to keep this RFE very tight, so it will
(hopefully) actually get implemented. :)

- Adam

Comment 12

17 years ago
That's bug 109930.

Comment 13

16 years ago
*** Bug 163101 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
I've been diligently sending spam to spamcop and UCE@FTC.GOV for months now
without any noticable effect on the amount of spam i receive (i actually seem to
be getting more now). I wonder how useful this feature would be (although I
still would like the feature). :(

RE comment #4: perhaps multiple forwarding addresses would be better (e.g.,
SpamCop AND UCE@FTC.GOV, etc.)

Comment 15

16 years ago
Agreed, and spam with stock tips goes to enforcement@sec.gov as well.  Should be
able to specify a list of recipients and checkboxes for which of them to send to
by default in Preferences, and override the checkbox defaults on a per-message
basis as easily as possible.

For UI, I'm thinking a button with a popup menu (similar to the Back button with
a history list in Navigator) with checkmarks in the menu; select the menu item
to reverse the checkmarks.  Click the button to forward to everything checked. 
Checkmarks for each new message reverts to defaults set in Preferences.

Comment 16

16 years ago
The reason I want it, is so that I can forward it my local "spam
knowledegebase", hopefully improving the ability of any spam filter.  Sending it
out to government organziations is the last thing I (personally) want to do with it.

Comment 17

16 years ago
*** Bug 163521 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago
*** Bug 121146 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
How about incorporating this into the new bayesian junk mail filter? I haven't
thought through *how* this could be done, but maybe one of you guys have an idea. 

Comment 20

16 years ago
Can this bug also be expanded (slightly) to include sending *multiple* e-mails
to spamcop (or similar organisation) with a single click of a button? Suggested
new subject line:

"Single button to automatically send (multiple) junk mail (spam) w/headers to
spamcop or other anti-spam systems"

Comment 21

16 years ago
I'm thinking it shouldn't be integrated too closely with the bayesian spam
filter - if there's any chance of legitimate mail getting flagged as spam, I
don't want it being autoforwarded to SpamCop until I've seen it.  I just want a
button.

Comment 22

16 years ago
Yeah, perhaps there just is no "creative" solutuion to joining junk mail filters
with autoreport Junkmail (spamcop). 

In absence of that, we then definetely could use a way to report a *large
number* of junk mail simultaneously with a minimum of clicks:

1. The Junk Mail Controls move junk to the "Junk" folder.

2. The user goes to Junk folder and selects multiple junk mails 
   (CTRL-A, SHIFT-click or CTRL-click).

3. user presses "Report Junk Mail" button, upon which each of the selected 
   mails is reported (to spamcop) *individually*.

PS. Notice I've changed the terminology from "spamcop" to "Report Junk Mail", as
i think that *wherever* the junk mail is forwarded to needs to be configurable
(inc. multiple recipients).
(Reporter)

Comment 23

16 years ago
Perhaps there could be a safety mechanism. Sometimes you're going through your
email pretty quickly, and it would be easy to accidentally click this button
twice, or hit it when you didn't mean to.

I'd suggest there be an additional checkbox, "Only allow submission when email
in folder <<POP-UP MENU OF FOLDER NAMES>>". Here's the concept: you've received
email. Moz has already run spam filtering on your email, flagged potential spam,
and moved it to a "spam" folder that you view later. This checkbox would only
allow you to use the one-button spam submission if the spam has already been
moved to the spam folder. This way, there's less likelihood of submitting an
email that isn't spam to SpamCop. And you're probably going to go through all
these and delete them anyway, so while you're at it, you're submitting to
SpamCop as well.

- Adam
(Reporter)

Comment 24

16 years ago
Another thought for this bug:

if this button is clicked, the message is automatically marked as spam if it
wasn't before. This way we don't have to click multiple things to report spam &
improve Moz's filtering.

- Adam

Comment 25

16 years ago
*** Bug 196111 has been marked as a duplicate of this bug. ***

Comment 26

15 years ago
Created attachment 129869 [details]
generates email reports from attachments

I have an interim workaround.. It's actually done as a forward within sendmail.

The program simply peels apart the first level of attachments to an email, and
presumes tham to be emails which are sent to spamassassin.

Line 27 denotes the program to send the spams to -- which could just as easily
be  ' sendmail my.email.alias@spamcop.com'

This program (I call it 'detach') or a symlink should be placed in /etc/smrsh
the line in /etc/aliases would be:

spam-report:|exec /etc/smrsh/detach

Of course, it doesn't delete the email, but it does allow you to select
multiple spam-mails and attach them all to one uber-email. Once they're sent,
you just hit 'delete'. to remove all of the sent spams.

Updated

15 years ago
Attachment #129869 - Attachment mime type: application/octet-stream → application/x-perl

Comment 27

15 years ago
*** Bug 237270 has been marked as a duplicate of this bug. ***
I think this would be best made an extension for thunderbird.  There is
definately a need for such a feature, but the amount of actual end users that
would use such a feature is most likely below 10%.  If even that high.

Comment 29

15 years ago
*** Bug 238950 has been marked as a duplicate of this bug. ***

Comment 30

15 years ago
*** Bug 243985 has been marked as a duplicate of this bug. ***

Comment 31

14 years ago
I am currently using a anti spam program as well as mozilla mail and in the 
anti spma applicaton all you need to put in is your special email account 
that you get from spamcop after signing up. This is so simple and should be 
intergrated asap. and by the way it DOES HELP. I see certain spammers email 
being marked by spamcop during a period of days. It is all about how many 
people submit spam to the system.
Product: Browser → Seamonkey

Comment 32

14 years ago
*** Bug 273727 has been marked as a duplicate of this bug. ***

Comment 33

14 years ago
*** Bug 284586 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Assignee: sspitzer → mail
Status: ASSIGNED → NEW

Comment 34

13 years ago
I just recently joined the Blue Frog community, and I don't know yet if it works or not, though the reviews and testimonials seem convincing. If I understand what you're asking for, this is more or less what the Thunderbird extension on this page does:
http://members.bluesecurity.com/cwa/adds_on.do?from=corporate&promotion=_

This extension only works for the Blue Frog community, but it does what is being asked here: It forwards marked junk mail to a pre-approved e-mail address on a spam reporting system. The functionality in this RFE could be implemented by hacking the XPI to forward e-mail to any user-defined e-mail address, which shouldn't be so hard (though I've never hacked XPIs before myself).

Comment 35

13 years ago
An RFE to this RFE I would like to see is for the location to which the email is sent a choice of either a) an email address or B) to abuse@ispOfSender where this mail address is searched and discovered by thunderbird/mozilla using the headers and whois databases.

Comment 36

12 years ago
This functionality is provided by the Okopipi extension for Thunderbird.

http://www.ibiblio.org/shadow/okopipi/

Comment 37

12 years ago
Ahm, as I noticed Okopipi just forwards messages. It does not "bounce" them. But bouncing the original message is important because of the original headers.

I would use this feature to bounce messages back to dspam (I'm using dspam with signature in header). So what is the state of this bug? Is someone implementing it? Get's it ever implemented?

cheers
Daniel
This is quite clearly a job for an extension, one per spam system.

Gerv
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.