NS_THEME_* implementations (meta bug)

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
18 years ago
5 years ago

People

(Reporter: ian, Unassigned)

Tracking

(Depends on 6 bugs, {meta})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-CSSUI2])

Attachments

(1 attachment)

Reporter

Description

18 years ago
 
Reporter

Updated

18 years ago
Blocks: 39375
Reporter

Comment 1

18 years ago
hyatt: Why no NS_THEME_MENUBAR, NS_THEME_MENU_POPUP and NS_THEME_MENUITEM?

Comment 2

18 years ago
There should be. Add bugs. :)
Reporter

Updated

18 years ago
Depends on: 118024
Reporter

Updated

18 years ago
Depends on: 118025
Reporter

Comment 3

18 years ago
Ok, bug 118024 and bug 118025 filed. Note that those constants are not currently
defined. This might mean the Windows XP theme API does not have a way to get to
them, I don't know how you made the list.
No longer depends on: 118024, 118025
Reporter

Updated

18 years ago
Depends on: 118292
Reporter

Updated

18 years ago
Depends on: 118293
Reporter

Updated

18 years ago
Depends on: 118312
Reporter

Updated

18 years ago
Depends on: 118310
Reporter

Updated

18 years ago
Depends on: 118309
Reporter

Updated

18 years ago
Depends on: 118307
Reporter

Updated

18 years ago
Depends on: 118306
Reporter

Updated

18 years ago
Depends on: 118304
Reporter

Updated

18 years ago
Depends on: 118302, 118303
Reporter

Updated

18 years ago
Depends on: 118295
Reporter

Updated

18 years ago
Depends on: 118025
Reporter

Updated

18 years ago
Depends on: 118294
Reporter

Updated

18 years ago
Depends on: 118308
Reporter

Updated

18 years ago
Depends on: 118301
Reporter

Updated

18 years ago
Depends on: 118299
Reporter

Updated

18 years ago
Depends on: 118298
Reporter

Updated

18 years ago
Depends on: 118297
Reporter

Updated

18 years ago
Depends on: 118296
Reporter

Updated

18 years ago
Depends on: 118024
Posted image mac osx progress
a screenshot of how far i've gotten on mac
Reporter

Updated

18 years ago
Depends on: 119737
Reporter

Updated

18 years ago
Depends on: 119736
Reporter

Updated

18 years ago
Depends on: 119735

Updated

18 years ago
Blocks: 98995

Updated

18 years ago
Blocks: 74292
Reporter

Updated

18 years ago
Depends on: 118290
Reporter

Updated

18 years ago
Depends on: 115462

Comment 5

18 years ago
I think we need a way to distinguish between simple push buttons that only
contain text and are of normal size and push buttons that are oversized or
contain icons. On the mac, the former corresponds to simple buttons and the
latter corresponds to bevel buttons.

Two buttons that should be bevel buttons on the mac are the 'Search' and 'M'
buttons in Navigator toolbar. This issue will become more important once xbl
form controls are implemented because buttons created with the input tag should
be regular buttons and buttons created with the button tag should be bevel buttons.
yup, i totally agree. i've been thinking that for a while, just haven't done
anything about it ;)

Comment 7

18 years ago
I'm not sure I like the claim that <input type="button" value="hello"> will look
different from <button>hello</button>. As a webdesigner (well, a programmer that
works on server-side web development and thus ends up writing a lot of website
code), that's not what I'd expect, and it'd be even more unexpected if windows
and/or linux made no such distinction.

Since I don't know much about OSX, I'm not sure how great of a difference there
is between the two button types, but I'd like to see some justification of the
claim that the two ways of creating buttons in html should look different (and
on mac only, even!).
we're talking about chrome, not html ;)

Comment 9

18 years ago
Actually there is a precedent in the HTML standard for button elements being
drawn differently from input elements:

http://www.w3.org/TR/html4/interact/forms.html#h-17.5

"Visual user agents may render BUTTON buttons with relief and an up/down motion
when clicked, while they may render INPUT buttons as "flat" images."

Although button and input tags would not be distinguished in the way described
in the standard, they would be distinguished in a different way that is
consistent with the mac look and feel.
Reporter

Updated

17 years ago
Whiteboard: [Hixie-CSSUI2]

Comment 10

17 years ago
Do we need NS_THEME_* implementation for the activity icon? (The spinning arrows
seen on Modern's tabs during load, for example.)

Updated

17 years ago
Depends on: 185435

Comment 11

16 years ago
*** Bug 74292 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
Hmm, should bug 174471 be in the dependencies here?

Comment 13

15 years ago
How about adding helpwanted keyword here? Some of the remaining implementations
should be easy (just more of the same) and would greatly improve the UI.

I've been looking at the code and it seems like the menu part should be trivial
(WinXP). Mostly copy and paste. Unfortunately my Mozilla dev environment is
broken at the moment. I'll see if I can get it working anytime soon to see if
this is as easy as I think it is.
Filter on "Nobody_NScomTLD_20080620"
QA Contact: pmac → skinability
Product: Core → Core Graveyard
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.