On non-100% DPI windows 10, the cut-out for the titlebar buttons and/or its placeholder are too small, causing caption buttons to be cut off or overlap

VERIFIED FIXED

Status

()

Core
Widget: Win32
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed by bug 1173725)

Attachments

(4 attachments)

This doesn't happen if my VM uses 100% DPI. If I change it to 150% it goes sadfaces. On things where we don't seem to cut out titlebar things (default theme) this is causing the minimize button to overlap with the tablist dropdown button (all-tabs button). On lightweight themes, we seem to be sizing the cutout for the titlebar buttons wrongly and so the minimize button is cut off instead. The height of the cutout is also wrong.

I don't see any of this on windows 8. I wonder if this is related to bug 1173732 and if this both are win10-only problems.

Dão, can you clarify if that bug happens on win8 or previous at all? I'm not 100% up-to-date on it (and don't have hidpi win8).
Flags: needinfo?
Created attachment 8628307 [details]
Developer Edition caption buttons being cut off
Flags: needinfo?
(In reply to :Gijs Kruitbosch from comment #0)
> bug 1173732 and if this both are win10-only problems.
> 
> Dão, can you clarify if that bug happens on win8 or previous at all? I'm not
> 100% up-to-date on it (and don't have hidpi win8).

Erm, I don't know what happened with the needinfo here, but let's try again.
Flags: needinfo?(dao)
Created attachment 8628310 [details]
Overlap on default theme
FWIW, this didn't happen pre-build-10158, so in theory maybe MS will fix it before release? Or, alternatively, it might be an intentional change.
Hm, this also results in the minimize button being rendered outside the window frame if the window is too small... o.O
Created attachment 8628315 [details]
Minimize button outside window frame

This is making me think it's actually an MS bug, though I'm not 100% sure.

Comment 7

2 years ago
(In reply to :Gijs Kruitbosch from comment #6)
> Created attachment 8628315 [details]
> Minimize button outside window frame
> 
> This is making me think it's actually an MS bug, though I'm not 100% sure.

I agree.
Duplicate of this bug: 1179352
I can't check Windows 8 right now, but surely we'd have noticed by now if it was an issue there.
Flags: needinfo?(dao)
(In reply to Dão Gottwald [:dao] from comment #9)
> I can't check Windows 8 right now, but surely we'd have noticed by now if it
> was an issue there.

I don't actually understand bug 1173732, so, I don't know.
Checked out Windows 8.1, this isn't an issue there.

Comment 12

2 years ago
Created attachment 8630462 [details]
Win 10 10162 + Dev Edition 41.0a2 (2015-07-06) x64 e10s enabled

Still seems to be an issue with the latest build

Updated

2 years ago
Attachment #8630462 - Attachment description: Win 10 10162 + Dev Edition 41.0a2 (2015-07-06) x64 e10s enable → Win 10 10162 + Dev Edition 41.0a2 (2015-07-06) x64 e10s enabled

Comment 13

2 years ago
Further,

Setting "layout.css.devPixelsPerPx" to 1 or 1.5 in about:config scales the tabs / etc, but does not solve the issue.

Checking "Disable display scaling on high DPI settings" in compatibility for the shortcut has no effect at all.
Blocks: 1077146
Priority: -- → P1
Works for me with the letest Nightly.
Bug 1173725 should be fixing this.
Depends on: 1173725
Duplicate of this bug: 1181552
This seems to happen in private browsing as well, where the PB label from the title bar overlaps the minimize button. See: http://i.imgur.com/61Og7s5.png - screenshot from a Microsoft Surface Pro 2 using Windows 10 Pro x64 (Insider Preview Build 10162) with Beta 40.0b2 (20150706172413).
Duplicate of this bug: 1182912
It looks like this may have been fixed in build 10240? I didn't do a direct before-after comparison, though, and have only tested 150% so far.
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to Dão Gottwald [:dao] from comment #19)
> It looks like this may have been fixed in build 10240? I didn't do a direct
> before-after comparison, though, and have only tested 150% so far.

I still saw this with lightweight themes in the build I just got (which I presume is 10240, but the build id on the bottom right of the desktop is gone, so I don't know for sure). Likewise, I still see overlap between the _/+\_ hover state and the minimize button when using the default theme (ie comparing the hover states). I'm also on 150%. Any idea what's different?
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(dao)
(I checked the registry, definitely running 10240)
Fixed by bug 1173725, anyway.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Comment 23

2 years ago
Definitely appears to be fixed on 41.0a2 (2015-07-16) on 10240.

Updated

2 years ago
Flags: needinfo?(dao)
(In reply to Scott Frost from comment #23)
> Definitely appears to be fixed on 41.0a2 (2015-07-16) on 10240.

Thanks!
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1180514

Updated

2 years ago
Duplicate of this bug: 1188953

Updated

2 years ago
Duplicate of this bug: 1184062
Duplicate of this bug: 1189245

Updated

2 years ago
status-firefox42: affected → ---
Whiteboard: fixed by bug 1173725
Duplicate of this bug: 1191844

Updated

2 years ago
Duplicate of this bug: 1195074
You need to log in before you can comment on or make changes to this bug.