superfluous horizontal grippy and clicking "X" doesn't close/hide/remove/switch off sidebar

VERIFIED FIXED in mozilla0.9.9

Status

SeaMonkey
Sidebar
P1
blocker
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Pierre Chanial, Assigned: Blake Ross)

Tracking

({regression})

Trunk
mozilla0.9.9
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

17 years ago
in today's build (linux 2002 02 08 21), a grippy is on top of the navigator sidebar.
expected: no horizontal grippy
(Reporter)

Updated

17 years ago
Keywords: regression
confirming with win2k build 20020209..

Also the right grippy doesn't close when i close the sidebar.
(The sidebar area is black and the main content doesn't resize)
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: mozilla0.9.9
OS: Linux → All
Hardware: PC → All

Comment 2

17 years ago
Created attachment 68747 [details] [diff] [review]
Moving the tooltip node out of the sidebar-box fixes this bug.

Comment 3

17 years ago
morse, please r.
blake, please sr.
Status: NEW → ASSIGNED
Keywords: nsbeta1, patch, review
Priority: -- → P1
Target Milestone: --- → mozilla0.9.9

Comment 4

17 years ago
Comment on attachment 68747 [details] [diff] [review]
Moving the tooltip node out of the sidebar-box fixes this bug.

r=morse
Attachment #68747 - Flags: review+

Comment 5

17 years ago
This patch doesn't work for mailnews and composer.  Blake says he'll take it. 
Thanks!
Assignee: sgehani → blaker
Status: ASSIGNED → NEW
Keywords: patch, review

Comment 6

17 years ago
*** Bug 124679 has been marked as a duplicate of this bug. ***
*** Bug 124752 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

17 years ago
Created attachment 68812 [details] [diff] [review]
patch
Attachment #68747 - Attachment is obsolete: true

Comment 9

17 years ago
*** Bug 124794 has been marked as a duplicate of this bug. ***
Summary: superfluous horizontal grippy on top of the sidebar → superfluous horizontal grippy on top of the sidebar (hiding sidebar fails)
does this include the close 'x' in sidebar not closing sidebar correctly either
as before, now it gets rid of sidebar content, but not the sidebar pane.

Comment 11

17 years ago
Built with the patch on Linux:

-The superfluous grippies are gone in all windows
-In browser and composer all is well (including the "x" function)
-One single problems remains: In mailnews, alternate three-pane only:

Clicking the sidebar grippy there has no effect other than swithing how it looks
(arrows up or down).
(Reporter)

Comment 12

17 years ago
R.K.Aa: the sidebar problem in MailNews (bug 121215) was occurring before this
regression.

Comment 13

17 years ago
ok.... was there also a problem with tooltips not showing up in content-area
anymore? I wonder if something went astray there in this patch. Tooltips over
buttons in toolbars is still OK though.

Comment 14

17 years ago
 Pierre Chanial: you are wrong. I checked a build from the 8: the grippy was
still functioning on click then. After this patch is does nothing at all in
mailnews, exept swapping to the gif indicating opposite direction. Meaning that
something isn't fixed here yet.

Comment 15

17 years ago
oops.. i'm confusing the three-panes:
in the 2+1 msg pane on bottom: grippy works.
in the 1+2 setup, it's numb.
It appears that with this patch tooltips show up in browser content area only
when the sidebar is open (not shaded or turned off).

Comment 17

17 years ago
Comment on attachment 68812 [details] [diff] [review]
patch

Need to address comment 16.  Since this tooltip is required accross components
maybe the tooltip should be moved to communicator files that are already
overlaid in all the components.  I am weary of moving it into sidebar code
cause there is nothing sidebar-specific about tooltips.
Attachment #68812 - Flags: needs-work+
(Assignee)

Comment 18

17 years ago
I'm just going to change the id for now to fix that.  This code should be
encapsulated into the <browser/> widget and sidebar should use <browser/> but
I'm not going to do that to close out this bug...
RKAa, the other serious Mail/News sidebar issues we have is bug 123205.. related
to bug 121515 and bug 117130.
opps, my bad, bug the bug pierre noted: 121215, not 121515.
(Assignee)

Comment 21

17 years ago
Created attachment 68929 [details] [diff] [review]
new patch

samir: r= please?
Attachment #68812 - Attachment is obsolete: true

Comment 22

17 years ago
*** Bug 125008 has been marked as a duplicate of this bug. ***

Comment 23

17 years ago
cc: twalker
*** Bug 125050 has been marked as a duplicate of this bug. ***

Comment 25

17 years ago
the summary of this bug does not reflect the other issue having to do with
clicking on the "X" not closing the sidebar, leaving a grey area.

Comment 26

17 years ago
The patch in attachment 68929 [details] [diff] [review] doesn't work unfortunately so Blake says he'll fix
this by just making the sidebar use <browser/> instead of <iframe/> for
webcontent sidebar tabs (and make <browser/> have the context menu of course).

Comment 27

17 years ago
as mentioned in comment 25 i really suggest you update the descrition, since i
was close to filing a dup - i only ran accross this due to bug 124979 which is
probably just another dup of this one. the grippy is there, right, but that's
not that annoying as not to be able to turn the sidebar on/off via F9 (or X or
View->sidebar) - just a suggestion to avoid having even more dups. - [i'm
looking forward to be clicking on bugzillas 'bugs already reported today' and
get the response 'zarro bugs found' =]

Comment 28

17 years ago
updating summary
Summary: superfluous horizontal grippy on top of the sidebar (hiding sidebar fails) → superfluous horizontal grippy and clicking "X" doesn't close sidebar

Comment 29

17 years ago
summary: + hide/remove/switch off

  ;)
Summary: superfluous horizontal grippy and clicking "X" doesn't close sidebar → superfluous horizontal grippy and clicking "X" doesn't close/hide/remove/switch off sidebar

Comment 30

17 years ago
*** Bug 124979 has been marked as a duplicate of this bug. ***
*** Bug 125180 has been marked as a duplicate of this bug. ***

Comment 32

17 years ago
*** Bug 125284 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Blocks: 125255
this currently blocks my perf testing.
Severity: major → critical
hm, chatted w/samir: since it blocks me there w/perf testing, am raising it to
blocker...
Severity: critical → blocker
(Assignee)

Comment 35

17 years ago
no worries, i'm actively working on it.

Comment 36

17 years ago
*** Bug 125409 has been marked as a duplicate of this bug. ***

Comment 37

17 years ago
*** Bug 125547 has been marked as a duplicate of this bug. ***

Comment 38

17 years ago
*** Bug 125572 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 39

17 years ago
Crap. I am just gonna back out the changes to sidebarOverlay.xul for now (remove
<tooltip/> and tooltip="..."). But I can't, because the tree is closed! argh.

Comment 40

17 years ago
Workaround (since no-one has mentioned it yet :

in ~/.mozilla/user/salt/localstore.rdf, change :

<RDF:Description
about="chrome://navigator/content/navigator.xul#sidebar-splitter" ...

to

<RDF:Description
about="chrome://navigator/content/navigator.xul#sidebar-splitter" hidden="true"
...
blake, many thanks for looking into this...

john, i had tried the localstore.rdf trick, but it somehow didn't work for me...
(Assignee)

Comment 42

17 years ago
This is "fixed".
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 43

17 years ago
verified in today's 2/18 build.

horizontal grippy is gone
closing sidebar using X works fine. no gray area anymore, sidebar
  closes with out any problems.
Status: RESOLVED → VERIFIED

Comment 44

17 years ago
I noticed that now Sidebar does not have horisontal splitter. We can not change
the size vertically. For instance, in 3-pane window we can not make Folders
visible and  have Sidebar opened. Should I log it as a separate issue, or it is
known/logged already?

Comment 45

17 years ago
Olga,
Are you talking about symptoms described in bug 123205?

Comment 46

17 years ago
I guess no. Bug 123205 is generally the same as this one. Now there is no
different positions with blank sidebar - we just can not move it up/down on
Browser - no horisontal splitter, but it presents on Mail after any actions
performed, (like Cancel password dialog).
Olga, 

the addition of horizonal spitler was introduced by a new checkin to
sidebarOverlay.xul.  This is not what browser's sidebar should be doing (why do
we at all need such functionality here, is why we got the backout), nor composer.  

Mail/News & Addressbook are separate and need a splitter because they have a
folder pane view, while Mail News also has a 2 pane view, (which should act like
the browser & composer view, right?).  So what you then described is this bug. 
This bug was introduced, because we dont need a horizontal splitter in the
browser.  Based on my observations with my bug 123205, the browser/mail
news/composer/addressbook all seem to have some seperate code from the global
sidebarOverlay.xul & .js file.  

Blake, Samir, 

is there a way to just figure out what methods & code are in place for each
component & sidebar.  I'm thinking if a coder knows those relationships (ER
diagram) maybe that should help with adding back tooltips & while keeping out
the horizontal splitter problems & 'x' close issue here & fixing Mail/News
sidebar issues in bug 123205.
It would give myself and others a better understanding of how it all fits
together, Thanks.

Comment 48

17 years ago
I see, no need for Browser horisontal splitter. Thanks!

Comment 49

17 years ago
Dennis,
Regarding comment 47: you could use the DOM inspector to give you some insight
about the relationship of the sidebar and various components.  

About the documentation bit: you are right that it would be nice if we had the
design documented.  It would certainly help folks look at the big picture. 
Maybe we'll get to it one of these days and then it'll be easier for folks to
ramp-up fast on the project and help sooner and more thoroughly.  Thanks.
*** Bug 126564 has been marked as a duplicate of this bug. ***

Comment 51

16 years ago
Re-tested on build 20020328. While this is marked as fixed, i still see the same
behaviour as initially described in #124979: Activate sidebar through F9. Then
open a new nav window from mailnews. The sidebar is shown, but without any
content. It is just grey. On the other hand, if you activate the sidebar from
WITHIN the navigator window, all is fine. I thing this is a real mozilla1.0
issue ...

Comment 52

16 years ago
Thommie: I tried what you encountered, but on my system (build 2002032916 on
win98) I don't see the problem you're having. Maybe consider the following:

- Get the latest build for your OS
- Completely delete and reinstall Mozilla
- Make sure you use a new, clean profile

Comment 53

16 years ago
Mark, yeah, at least on Linux it looks ok. I need to test on Win2000 too. 

Any idea which file needs to be hacked for getting this fixed in an OLD profile
too? (its my all-day work profile, I wouldn want to delete it ;-) 
guys, what you are seeing is bug 121215, and bug 123205..

oh yeah samir.. regarding comment #49.. I've not found the problem with the
sidebar/Mail news yet.. 
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.