Remove old Console front-end

RESOLVED FIXED in Firefox 61

Status

P1
normal
RESOLVED FIXED
a year ago
3 months ago

People

(Reporter: Honza, Assigned: bgrins)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 61
Dependency tree / graph

Firefox Tracking Flags

(firefox61 fixed)

Details

Attachments

(1 attachment)

Entire code base related to the old Console front-end including all preferences should be removed.

Honza
See also bug 1375778 comment #c8

Honza
Whiteboard: [console-html]
See also bug 1378850 comment #c8

Honza
Whiteboard: [console-html] → [console-html] [triage]
Flags: qe-verify?
Priority: -- → P3
Whiteboard: [console-html] [triage] → [reserve-console-html]
Flags: qe-verify? → qe-verify-
Priority: P3 → P4
(Assignee)

Updated

a year ago
status-firefox57: --- → wontfix
Depends on: 1362023, 1308219
(Assignee)

Updated

a year ago
Blocks: 1399837
Flags: qe-verify-
Priority: P4 → P2
Whiteboard: [reserve-console-html] → [newconsole-mvp]

Updated

10 months ago
Blocks: 1434860
(Assignee)

Updated

8 months ago
Duplicate of this bug: 1395590
(Assignee)

Updated

8 months ago
Depends on: 1347127
(Assignee)

Updated

8 months ago
No longer blocks: 1434860
Depends on: 1434860

Updated

8 months ago
Whiteboard: [newconsole-mvp]
Blocks: 1448936
(Assignee)

Updated

7 months ago
Depends on: 1304794
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Updated

7 months ago
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Priority: P2 → P1

Comment 6

7 months ago
mozreview-review
Comment on attachment 8967444 [details]
Bug 1381834 - Remove old Console front-end;

https://reviewboard.mozilla.org/r/236114/#review242128

Looks good to me (and feel soooo good \o/)
I might have missed it, but I don't think we take care of the old frontend prefs (and the new frontend console and browserconsole) from devtools/client/preferences/devtools-client.js ?
Should we do it here or in a follow up ?
Attachment #8967444 - Flags: review?(nchevobbe) → review+

Comment 7

7 months ago
Should we clean devtools/shared/webconsole/server-logger-monitor.js and devtools/shared/webconsole/server-logger.js here ? 
Maybe a follow up would be better since I think there is some actor code
(Assignee)

Comment 8

7 months ago
Thanks, I'll make follow ups for your suggestions

Comment 9

7 months ago
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s 87a8961b7ee8dd8347e3c3b2b0da19281b001982 -d 40ab295f68f7: rebasing 457869:87a8961b7ee8 "Bug 1381834 - Remove old Console front-end;r=nchevobbe" (tip)
local [dest] changed devtools/client/webconsole/old/test/head.js which other [source] deleted
use (c)hanged version, (d)elete, or leave (u)nresolved? u
merging devtools/client/framework/toolbox-options.js
merging devtools/client/jar.mn
unresolved conflicts (see hg resolve, then hg rebase --continue)
Comment hidden (mozreview-request)

Comment 11

7 months ago
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s 934fb6223874bbbfe5c6755e9a302775f81bab84 -d 1cece7d5df17: rebasing 457871:934fb6223874 "Bug 1381834 - Remove old Console front-end;r=nchevobbe" (tip)
local [dest] changed devtools/client/webconsole/old/test/head.js which other [source] deleted
use (c)hanged version, (d)elete, or leave (u)nresolved? u
unresolved conflicts (see hg resolve, then hg rebase --continue)
(Assignee)

Updated

7 months ago
Blocks: 1452424
(Assignee)

Comment 12

7 months ago
Ah, this needs to land on top of Bug 1453712
Comment hidden (mozreview-request)

Comment 14

7 months ago
Pushed by bgrinstead@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1e71c12ebd74
Remove old Console front-end;r=nchevobbe
(Assignee)

Updated

7 months ago
Blocks: 1454012

Comment 15

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/1e71c12ebd74
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
status-firefox61: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61

Updated

7 months ago
Blocks: 1310129

Updated

7 months ago
Blocks: 1377808, 1447957

Updated

7 months ago
Blocks: 1358821

Updated

7 months ago
Blocks: 1351391, 1338653

Updated

7 months ago
Blocks: 1450829

Updated

7 months ago
Blocks: 1448433

Updated

7 months ago
Blocks: 1277440

Updated

7 months ago
Blocks: 1452921

Updated

7 months ago
Blocks: 1256017

Updated

7 months ago
Blocks: 1340608, 1451141

Updated

7 months ago
Blocks: 1298364

Updated

7 months ago
Blocks: 1238198, 1452354

Updated

7 months ago
Blocks: 1411278
(Assignee)

Updated

7 months ago
Blocks: 1454419

Updated

5 months ago
Product: Firefox → DevTools
status-firefox57: wontfix → ---
Duplicate of this bug: 1414358
You need to log in before you can comment on or make changes to this bug.