Large emojis displaying and text alignment problems in message subject because of linux font size issue

RESOLVED FIXED in Thunderbird 54.0

Status

defect
RESOLVED FIXED
2 years ago
7 months ago

People

(Reporter: naught101, Unassigned)

Tracking

52 Branch
Thunderbird 54.0
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [duptome])

Attachments

(5 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170807221116

Steps to reproduce:

Open a mail folder that includes an email with emoji characters in the subject line.


Actual results:

Huge get displayed over the top of the mail list. See attached screen shot. The truck appears far too large in the message list. It also appears in the subject line in the mail view panes.


Expected results:

The truck should be the correct size. I guess this may be a font issue?

Thunderbird 52.2.1 on Kde Neon user edition (based on *buntu 16.04 LTS).

Comment 1

2 years ago
Could you please check the message source and paste the subject line here so we can try it and see how large our truck gets.

I've never seen it on Windows.
(Reporter)

Comment 2

2 years ago
Subject: =?UTF-8?Q?=F0=9F=9A=9A_ORDER_SENT:_TETRIS_NINTENDO_GAME...?=

Comment 3

2 years ago
Thanks, works fine for me, I see a truck which has about the height of the text "ORDER SENT".

I guess this is a Linux Font problem. Richard, can you reproduce this with the attached e-mail?
Flags: needinfo?(richard.marti)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Tested it on Mint 18.2, Ubuntu 17.4 and Fedora 26. All show a tiny truck and not like at naught. I tested it with TB 57 and 56 as I have no 52 on these systems, but this should be no difference for this issue.
Flags: needinfo?(richard.marti)
(Reporter)

Comment 5

2 years ago
I had to wipe my root partition and re-install over the weekend. I now have 52.2.1 installed on Kubuntu 17.04 beta, and the problem does not appear. I guess perhaps it was caused by some kind of library mis-match in KDE Neon? Anyway, may as well close this. Others can re-open if it seems necessary..
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID

Updated

2 years ago
Duplicate of this bug: 1394133

Updated

2 years ago
Duplicate of this bug: 1390879

Comment 8

2 years ago
same problem for me under gnome-shell

Updated

a year ago
Duplicate of this bug: 1436363

Updated

a year ago
Duplicate of this bug: 1444099

Updated

a year ago
Duplicate of this bug: 1448708

Comment 12

a year ago
Re my report https://bugzilla.mozilla.org/show_bug.cgi?id=1448708 - what could be the workaround/fix for my problem?

Should I change used font in TB?

Comment 13

a year ago
workaround
OK, I fixed it on my system (Manjaro):
1) I removed 'Noto Color Emoji' font (or package noto-fonts-emoji),
2) installed package 'aur/ttf-emojione-color' (or Mozilla's EmojiOne font manually from https://github.com/mozilla/twemoji-colr).

Updated

a year ago
Duplicate of this bug: 1448641

Updated

a year ago
Duplicate of this bug: 1448642
Duplicate of this bug: 1454881
I get this bug with a clean install of Ubuntu 18.04 which comes with Thunderbird 52.7.0

I tested the same emoji on Thunderbird, Firefox, gedit, Nautilus and VS Code. The emoji is huge only on Thunderbird.
The same problem as #17 in ubuntu 18.04, if is not a Thunderbird bug, could you give us more detailed instructions on how to fix it?
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---

Comment 19

a year ago
Fix the font. Read through the bug and its duplicates.
Status: REOPENED → RESOLVED
Last Resolved: 2 years agoa year ago
Resolution: --- → INVALID
Duplicate of this bug: 1457770
(In reply to Jorg K (GMT+1) from comment #19)
> Fix the font. Read through the bug and its duplicates.

Isn't this a little complicated for a new Ubuntu 18.04 installation?

Personally, I would like it to look right from the start.

Note: My Thunderbird profile is old, can this be the problem?

Or is it Ubuntu's problem that it has to install the right fonts?
Duplicate of this bug: 1457897
Duplicate of this bug: 1458496

Comment 24

a year ago
Thanks Wayne Mery for spotting all these duplicates- it's an important service.
I just reported 1458496, which Wayne correctly deduped. The problem is still occurring for me. What can I do to help find and fix the underlying cause please? My Manjaro installation is current and fairly clean, and I am happy to provide information on my system if you would like.
Thanks guys for making Thunderbird work so nicely in every other regard.
Duplicate of this bug: 1458772
hope this ends soon
Summary: Large emojis displaying in message subject → Large emojis displaying and text alignment problems in message subject because of linux font issue
(Reporter)

Comment 27

a year ago
Indeed. Is there way to unsubscribe from just this bug? I don't want to unsubscribe from all bugs for which I'm a reporter...

Updated

a year ago
Duplicate of this bug: 1459422
To not receive mails about this bug, click at the top right on "Edit bug" and then at the bottom at "Never email me about this bug " and "Save Changes".

Updated

a year ago
Duplicate of this bug: 1459493
Anyone filed an ubuntu bug report for this?
Or is this font the user's choice?
Duplicate of this bug: 1460512
Duplicate of this bug: 1461086
Duplicate of this bug: 1461175

Comment 35

a year ago
This bug came to me after upgrading from ubuntu 17.10 to 18.04. I tried Petr Nehez's workaround (replace noto emoji font with emoji one) but it doesn't work for me.

Comment 36

a year ago
fixed for me today under arch linux with thunderbird 52.8.0
Duplicate of this bug: 1458797
Duplicate of this bug: 1464502
Duplicate of this bug: 1465356

Comment 40

a year ago
(In reply to Lavande from comment #35)
> This bug came to me after upgrading from ubuntu 17.10 to 18.04. I tried Petr
> Nehez's workaround (replace noto emoji font with emoji one) but it doesn't
> work for me.

Same here. Fresh install of Ubuntu 18.04. The workaround has no effect. Still showing large icon in subject line. Thunderbird 52.8.0 on Ubuntu 18.04
Posted image Emoji Bug
Same here. Clean install of Ubuntu 18.04. Using Thunderbird 52.8.0.
I speak from a technical ignorance, but if it doesn't happen in Firefox (I see correctly emojis in the titles of the tabs, inside the pages...).

Couldn't Thunderbird solve it somehow?

Comment 43

a year ago
I have same problem on a clean install of Ubuntu 18.04.
Duplicate of this bug: 1467064
Duplicate of this bug: 1467701
Summary: Large emojis displaying and text alignment problems in message subject because of linux font issue → Large emojis displaying and text alignment problems in message subject because of linux font size issue
Whiteboard: [duptome]

Updated

11 months ago
Duplicate of this bug: 1467951

Updated

11 months ago
Duplicate of this bug: 1468458

Comment 48

11 months ago
I confirm, the bug is still actual for Ubuntu 18.04. Using Thunderbird 52.8.0. 
In the same time it does not actual for Ubuntu-16, cause that version is using <Unity>. The Ubuntu science 17v start using <Gnome>. 
So that, the problem, more probable, is connected with Thunderbird GUI framework which is relying to specific graphical engine functions.

As I see, Thunderbird-team should investigate the problem.

Comment 49

11 months ago
(In reply to s.kosik from comment #48)
> 
> As I see, Thunderbird-team should investigate the problem.

This issue was fixed in core, which Thunderbird shares with Firefox on the whole in version 55.  SO it should also be fixed in TB 60 and the current beta.  Perhaps you would like to try it out and see.

Bug 1267909 refers

Comment 50

11 months ago
(In reply to Matt from comment #49)
> This issue was fixed in core, which Thunderbird shares with Firefox on the
> whole in version 55.  SO it should also be fixed in TB 60 and the current
> beta.  Perhaps you would like to try it out and see.
> 

I downloaded Thunderbird 60.0b7 (https://download.mozilla.org/?product=thunderbird-60.0b7-SSL&os=linux64&lang=en-US) and can confirm that the issue is resolved there on Ubuntu 18.04.

Comment 51

11 months ago
This was fixed by bug 1267909 in mozilla54. Sadly, we didn't hear about this fix until 2018-05-06 in bug 1458797 comment #7. Mozilla core never uplifted it to mozilla52 ESR, so we never picked it up.
Resolution: INVALID → FIXED
Target Milestone: --- → Thunderbird 54.0

Comment 52

11 months ago
>> As I see, Thunderbird-team should investigate the problem.
> 
> This issue was fixed in core, which Thunderbird shares with Firefox on the
> whole in version 55.  SO it should also be fixed in TB 60 and the current
> beta.  Perhaps you would like to try it out and see.

In a mount-two i going to install new Ubuntu update pack. So that will verify it. If TB version is still not updated i, will notify.

...Cheers!
Verified, in Thunderbird 60 emojis are already displayed at the correct size.

Updated

11 months ago
Duplicate of this bug: 1470385

Updated

11 months ago
Duplicate of this bug: 1470511

Updated

11 months ago
Duplicate of this bug: 1471064

Updated

11 months ago
Duplicate of this bug: 1472448

Comment 60

11 months ago
Will this be backported to 52?

Comment 61

11 months ago
No. Also too late. TB 52.9 has shipped and we don't plan to do 52.10 :-(

Comment 62

10 months ago
Just installed the newest Manjaro 17.1 with KDE Plasma 5.13.2 and Thunderbird 52.9.1. 

Thunderbird is showing the bug...

Comment 63

10 months ago
(In reply to karl.roberts from comment #62)
> Just installed the newest Manjaro 17.1 with KDE Plasma 5.13.2 and
> Thunderbird 52.9.1. 
> 
> Thunderbird is showing the bug...

bug is fixed in version 60 and later

Updated

10 months ago
Duplicate of this bug: 1477464

Comment 65

10 months ago
(In reply to Petr Nehez from comment #13)
> OK, I fixed it on my system (Manjaro):
> 1) I removed 'Noto Color Emoji' font (or package noto-fonts-emoji),
> 2) installed package 'aur/ttf-emojione-color' (or Mozilla's EmojiOne font
> manually from https://github.com/mozilla/twemoji-colr).

Ubuntu is using different package names.  I just removed fonts-noto-color-emoji and replaced it with 
 "fonts-emojione", 

however...

The problem also occurred with fonts-emojione, so I removed that as well, after which the problem stopped expressing itself.

Updated

10 months ago
Duplicate of this bug: 1481144

Updated

9 months ago
Duplicate of this bug: 1482617

Updated

9 months ago
Duplicate of this bug: 1482903

Updated

9 months ago
Duplicate of this bug: 1483371

Updated

9 months ago
Duplicate of this bug: 1485919

Updated

8 months ago
Duplicate of this bug: 1490223

Updated

8 months ago
Duplicate of this bug: 1491623

Updated

7 months ago
Duplicate of this bug: 1498104

Updated

7 months ago
Duplicate of this bug: 1499263

Comment 75

7 months ago
TB 60.2.1 installed in update and bug is confirmed fixed in Ubuntu 18.04.
Thanks for the great TB work.
You need to log in before you can comment on or make changes to this bug.