Open Bug 1535365 Opened 1 year ago Updated 3 months ago

Add support for extension process.

Categories

(GeckoView :: Extensions, enhancement, P2)

Unspecified
Android
enhancement

Tracking

(firefox76 fixed)

REOPENED
mozilla76
Tracking Status
firefox76 --- fixed

People

(Reporter: agi, Assigned: agi)

References

(Depends on 6 open bugs, Blocks 1 open bug)

Details

(Keywords: leave-open, Whiteboard: [geckoview:p1])

Attachments

(2 files)

Now that we have at least some WebExtension support we should look into running extensions stuff in its own process similar to what desktop does.

P2 because an extension process is not a blocker for Fenix MVP.

OS: All → Android
Priority: -- → P2
See Also: → android-e10s-multi

A lot of the plumbing for this is similar to e10s so I'm going to block this on that.

Depends on: android-e10s-multi
Rank: 45

Mass moving bugs to the Extension component.

Component: General → Extensions
No longer blocks: 1534640
See Also: → 1502525
See Also: → 1613141
Whiteboard: [geckoview:m76]
Assignee: nobody → agi
Depends on: 1619798
No longer depends on: android-e10s-multi
Duplicate of this bug: 1626349
Duplicate of this bug: 1620093
Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5c3c02b4f8ca
Enable the extension process. r=snorp,aklotz
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76

Until Bug 1355239 is fixed we cannot leave this on, since it causes extensions to randomly die.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

We don't currently restart the extension process and this causes extensions to
randomly stop working when Android kills the extension process.

We can re-enable it once Bug 1355239 is fixed.

Severity: normal → blocker
Rank: 10 → 1
Priority: P1 → P2
Whiteboard: [geckoview:m77] → [geckoview:p1]
Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9ba0d3a69fea
Disable extension process. r=snorp,rbarker
See Also: → 1622610
Depends on: 1630066
Depends on: 1630073
Depends on: 1631945
Depends on: 1423168
You need to log in before you can comment on or make changes to this bug.