Closed Bug 1725127 Opened 3 years ago Closed 2 months ago

Inbox randomly reverts to default view (unthreaded/threaded, depending on TB version) after moving/deleting messages, which may trigger auto compact.

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr115? fixed, thunderbird122? fixed)

RESOLVED FIXED
123 Branch
Tracking Status
thunderbird_esr115 ? fixed
thunderbird122 ? fixed

People

(Reporter: andy.vines, Assigned: welpy-cw)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.131 Safari/537.36 Edg/92.0.902.67

Steps to reproduce:

When messages are shown as threaded, sometimes when you drag a message from the inbox to another folder the threaded view reverts back to being unthreaded.

Actual results:

Inbox view changes from threaded to un-threaded

Expected results:

Inbox folder view should stay as threaded

Blocks: tb91found

Sometimes?

Does it reproduce using Help > Troubleshoot Mode?

Flags: needinfo?(andy.vines)

Yes it still does it in TroubleShoot Mode?

You can move 4-5 messages OK and then randomly the problem occurs.

Flags: needinfo?(andy.vines)

Can't reproduce.

Summary: Message Threads disable when moving a message from Inbox → Inbox view randomly changes from threaded to un-threaded after dragging messages to other folder

Just noticed this morning that this also happens randomly if I click the archive button, the message view goes blank for a second or two and then the threaded view will be reset to not threaded.

Current version I am using is 92.0b5

Version 91.1.0, regular mode, regular mode with all extensions off, and troubleshooting mode. MacOS Mojave

I'm seeing something that's probably related. Thunderbird will at times fall out of threaded mode, that is View > Sort By > Threaded checked will change to View > Sort By > Unthreaded checked, and the list of messages won't be threaded. It happens sometimes (but not all the time) when I delete a message (which is moving a message to Trash, so sort of matches the original report), and other times I'll switch to Thunderbird from some other app and it will be unthreaded, so I won't know when it happened. I have enough conversation threads in my Inbox that it's very obvious when it happens, it didn't happen in the previous version I was running (78.13.0), and I immediately started noticing it upon updating to 91.0.0. I don't have a foolproof way to reproduce it, but it happens 3-4 times per day so there's something going on.

This is still happening in 91.4.1.

I am now on 96.0b3 and it still randomly happens.

Moving a message and deleting a message can both trigger it to happen.

Same problem (TB 91.4.1 64 bit, de).
Deleting a message - the view with the list of messages turns white for a moment, returning as unthreaded view (and "sort by"-option is switched to unthreaded).
This happens a few times per day. I'd say most of the time in the morning after starting TB and deleting the first message and during the day perhaps 1...3 times.

Unfortunately, the problem is not that easily reproducible.
I copied a message into my inbox, clicked on "Delete" -> problem triggered.
The same message copied again, click on 'Delete' -> no problem.
I closed TB, opened TB, same procedure -> no problem.
Perhaps when moving or deleting messages, TB is doing a cleanup task every few hours.

I too have now noticed that all of the messages briefly disappear (message view goes to blank white panel) when it happens.

I'm still seeing this as well. I can't reproduce it at will, but it seems like when I've been away from my computer for a few hours with Thunderbird running, it almost always does it the first time I delete a message when I return to it. While that doesn't make it easy to reproduce, maybe it's a clue as to what's happening.

Same problem TB 91.6.1, 64 bit, US English, regular mode
I've been using TB since it was Netscape in the 1990s and I donate $ to aid with development. I'm experiencing this bug, also, and am more than disappointed there's no priority set for it. Like others, I can't reproduce at will either, but I've observed the same behaviors. Decided to create a Bugzilla account so I could add to the list. I update TB by downloading the full exe file and then executing it on Win 10 (Start > Run > Browse [grab the file] > OK). Prior to v91.xxx I was using 78.14.0 and I waited until the proper v91.xxx was available before updating. Hope this helps move the ball forward.

(In reply to Anne G from comment #11)

Same problem TB 91.6.1, 64 bit, US English, regular mode
I've been using TB since it was Netscape in the 1990s and I donate $ to aid with development. I'm experiencing this bug, also, and am more than disappointed there's no priority set for it.

Thank you for the donation! Unfortuantely, the cruel reality is this isn't reproducible, and fixing most often requires ability to reproduce. On top of that, three reports out of ten million users doesn't warrant a high priority. So if a priority were to be formally set, it would be low.

But somewhat more important, a) is anyone now able to reproduce this at will? b) does this reproduce in version 102?

Flags: needinfo?(anne2060)
Flags: needinfo?(andy.vines)

The problem still occurs with TB 102.3.0 64bit de
It's still not arbitrarily reproducible, at least not more than once a day.
The first delete action after starting TB (after it hasn't been running for a few hours, e.g. in the morning) seems to trigger it. After TB is closed and restarted, this is not immediately triggered by another delete action, so it doesn't just matter that TB has been freshly started. However, after a few hours, a delete action may trigger the problem again (without restarting TB).
Maybe a cleanup action to run after deletion, but only once every few hours?

Makes it more bearable for me: I'm now using the "Threadkey" addon (switch to thread view via hotkey) as a workaround.

Still happening for me in 102.3.0 (64-bit) on macOS 10.14.6. I can't reproduce it at will, but it happens a few times per day, and also seems to me to be related to deleting a message after Thunderbird has been sitting in the background for a while.

That being said, I've assigned a keyboard shortcut in System Preferences -> Keyboard -> Shortcuts -> App Shortcuts so I can get back to threaded with a keystroke. However, when it happens at the start of a thread, when I switch back to threaded it's usually on a different thread or the threads are in a different order, so it still makes Thunderbird kind of hard to use.

Using thunderbird 91.11.0 in Ubuntu 20.04 here, it happens randomly.
I've tried to find how to reproduce it, but until now without success.

Ubuntu 22.04 LTS with Thunderbird 102.5.0 (64-bit) and still showing at random times. I am unable to figure out why it happens, which would help with the reproduction process, but otherwise it seems to be happening quite regularly. Most of the times, it seems to happen when Thunderbird is running in the background and I am working in other applications.

Still doing it on Win10 TB 102.5.0. Here's one circumstance (there may be others):

  • Privacy/Security Settings set to defaults EXCEPT "Accept cookies from sites" is set to "Keep until: I close TB"
  • Set View -> Sort by ->Threaded
  • Close & restart TB, to reduce other possibilities.
  • Move 1 message (any message) from Inbox to a folder.
  • Hit "ok" when prompted for folder compression (in other words, TB compresses the folder)
  • Post compression, the previously threaded Inbox emails are now un-threaded.

Hope this helps!

I tried the steps outlined above and did not seem to trigger the issue on Ubuntu 22.04 LTS with Thunderbird 102.5.0 (64-bit). I did not see any compression prompt, though, but I do have automatic compacting in the background enabled, so perhaps it has something to do with compression after all.

(In reply to Anne G from comment #17)

Still doing it on Win10 TB 102.5.0. Here's one circumstance (there may be others):

  • Privacy/Security Settings set to defaults EXCEPT "Accept cookies from sites" is set to "Keep until: I close TB"
  • Set View -> Sort by ->Threaded
  • Close & restart TB, to reduce other possibilities.
  • Move 1 message (any message) from Inbox to a folder.
  • Hit "ok" when prompted for folder compression (in other words, TB compresses the folder)
  • Post compression, the previously threaded Inbox emails are now un-threaded.

Hope this helps!

I'm having as much problem as everyone in trying to figure out what causes this but there might be a clue here. I have auto compact turned on (1 MB) but I have the option to confirm disabled. I've turned it on now so I can see for definite if this issue is linked to compacting of the Inbox.

The one consistent thing for me is that it only happens after I delete a message and I presume that could trigger a compaction.

I've wondered if it's compaction (not compression) related, as I've noticed that when folders are compacted automatically, if one or more messages are selected, that selection is lost (which didn't seem a big enough problem to report).

For this bug, I had automatic compaction turned on (Ask every time before compacting unchecked), so I checked it. It just asked me to compact, I said to, and it fell out of threaded mode.

Explicitly choosing File > Compact Folders doesn't revert to non-threaded mode, but maybe being I just compacted there isn't any space to save so Compact Folders isn't doing anything.

(In reply to Brian L. Matthews from comment #20)

I've wondered if it's compaction (not compression) related, as I've noticed that when folders are compacted automatically, if one or more messages are selected, that selection is lost (which didn't seem a big enough problem to report).

For this bug, I had automatic compaction turned on (Ask every time before compacting unchecked), so I checked it. It just asked me to compact, I said to, and it fell out of threaded mode.

Explicitly choosing File > Compact Folders doesn't revert to non-threaded mode, but maybe being I just compacted there isn't any space to save so Compact Folders isn't doing anything.

With the background compacting enabled and with the confirmation dialog enabled, I can definitely see the problem. Once the dialog comes up and I confirm I do want the folder to be compacted, two things happen:

  1. threaded view is disabled, even though it was enabled before for sure
  2. previously selected sorting choice is gone (I use a combination of date and origin)
    When the dialog is NOT enabled, I do not see the very same problem.

(In reply to gitzone83 from comment #21)

(In reply to Brian L. Matthews from comment #20)

I've wondered if it's compaction (not compression) related, as I've noticed that when folders are compacted automatically, if one or more messages are selected, that selection is lost (which didn't seem a big enough problem to report).

For this bug, I had automatic compaction turned on (Ask every time before compacting unchecked), so I checked it. It just asked me to compact, I said to, and it fell out of threaded mode.

Explicitly choosing File > Compact Folders doesn't revert to non-threaded mode, but maybe being I just compacted there isn't any space to save so Compact Folders isn't doing anything.

With the background compacting enabled and with the confirmation dialog enabled, I can definitely see the problem. Once the dialog comes up and I confirm I do want the folder to be compacted, two things happen:

  1. threaded view is disabled, even though it was enabled before for sure
  2. previously selected sorting choice is gone (I use a combination of date and origin)
    When the dialog is NOT enabled, I do not see the very same problem.

I am seeing issue #1 for definite. The dialog comes up and, the moment I confirm, the inbox view changes to unthreaded. So I'm convinced this issue is related to compacting and that even explains why it only happens sometimes.

I only sort by date, though, and I'm not seeing your second issue.

That would explain it indeed. Thinking about it, any changes to the view likely happen when items are moved around - I have plenty of automated email processing rules, which move emails around as they come in. With automated background compacting with no confirmation dialog, it is very possible that I hit the compacting threshold without knowing it, triggering whatever issue we have.

Since I turned off auto-compact 2 days ago, I've been asked to compact 4 or 5 times, and the 3 or 4 times I've said to, it's dropped me out of threaded. So this seems like a way to reproduce it, although you'll have to delete enough messages to pass the compaction threshold (but one or two large messages should probably do it). Leave Compact all folders... on (or turn it on), turn off Ask every time, turn on View > Sort by > Threaded, then delete enough messages to pass the compaction threshold. When it asks you to compact, tell it to. That should drop out of threaded mode.

I wonder whether that is sufficient for someone to look at it with more detail. It should be easily reproducible then?

The interesting part is that when you enable background compacting with no dialog, the probability of this happen decreases substantially.

Another behaviour I've noticed that might be a clue. When the prompt to compact appears, if I reject it and do a manual compact (rich-click on the folder and compact) the threading is preserved. So the issue only seems to happen with the auto-compact (with or without confirmation).

Yes, I can confirm that the issue does not happen when background compacting is disabled. I went for 3 days with no issues, and it popped up immediately when background compacting was enabled and folders got compacted.
I wonder whether this is sufficient for Wayne Mery (:wsmwk) to classify as reproducible?

Any updates here? It has been a month and reproduction path clearly identified.

(In reply to gitzone83 from comment #26)

The interesting part is that when you enable background compacting with no dialog, the probability of this happen decreases substantially.

I doubt effort will be put into fixing this in version 102, given that there is a partial workaround and most effort for the next few months is focused on the next version, which may fix this issue.

It would be interesting to know whether this is better when using the current beta. It is described at https://www.thunderbird.net/en-US/download/beta/ and is currently a bit buggy. But In the next couple months there will be an opportunity to jump on beta wth an update path to version 112.

Flags: needinfo?(anne2060)
Flags: needinfo?(andy.vines)

Bug 540857 would have been my first choice for this, but it was closed.
So confirming this, and linking

Blocks: 498274
Status: UNCONFIRMED → NEW
Ever confirmed: true
See Also: → 494752
Summary: Inbox view randomly changes from threaded to un-threaded after dragging messages to other folder → Inbox view randomly changes from threaded to un-threaded after dragging messages to other folder, which triggers compact

(In reply to Wayne Mery (:wsmwk) from comment #30)

(In reply to gitzone83 from comment #26)

The interesting part is that when you enable background compacting with no dialog, the probability of this happen decreases substantially.

I doubt effort will be put into fixing this...

Hoping this is not the official stance on bugs here.

(In reply to Worcester12345 from comment #32)

(In reply to Wayne Mery (:wsmwk) from comment #30)

I doubt effort will be put into fixing this...

Hoping this is not the official stance on bugs here.

You totally change the meaning of my statement by dropping the rest of the sentence, "in version 102, given that there is a partial workaround and most effort for the next few months is focused on the next version, which may fix this issue."

And so the question now is, with version 115 are you or anyone else still seeing this issue?

Flags: needinfo?(andy.vines)

(In reply to Wayne Mery (:wsmwk) from comment #33)

And so the question now is, with version 115 are you or anyone else still seeing this issue?

For me this switching from threaded to unthreaded just started in 115.0. It is still happening in 115.1.

I don't know what is causing it for me... I haven't been able to pinpoint the problem. But every once in awhile View > Sort by > threaded is getting changed to View > Sort by > unthreaded in the one inbox that i use threaded.

Bill

I should have made it clear that I am not dragging messages out of the folder. I have TB set to do automatic compacting in the background, so I don't know if this might be the cause or not.

Bill

Why is there no way to edit a comment?

I should also say that my problem occurs in a newsroup (the only place I use threaded vew). I do not manually delete any messages, they are only deleted when they are more than 62 days old.

Bill

Well, detection of the need to compact seems broken for me. I've been waiting for the "want to compact?" dialog so I could test this, but I haven't seen one since installing 115.1 yesterday. That's unusual, but it was a Sunday with relatively light email. But this morning, I've been through a lot of email and it seems like it should have compacted. So I did an explicit Compact Folders, and it says it saved 2.9MB. But my "Compact all folders when it will save over" is checked and set to 1MB, which, I believe, is less than 2.9MB? I'll keep watching but if Thunderbird doesn't decide on its own compacting is needed, I can't test this, as that's the only circumstance I saw the problem.

Of course a couple of hours after I write that it's not noticing compacting is needed it notices compacting is needed. It prompted me (I have Ask every time before compacting checked), I clicked Compact Now, and it switched back to Unthreaded. So this isn't fixed for me in 115.1.

I've just be pointed to this thread as I complained on a thunderbird newsgroup.
I just installed 115 on my system and I added a news server and 5 groups. I can't mark the groups as view->unread. I go down all 5 groups and mark them and when I go back to the first it's set as view->all threads. Same for the other 4 groups.

Not sure if this sheds any light. I did not spend a lot of time reading all the details above but just thought I'd toss this in the mix.

Yesterday I had changed compacting to prompt me before doing a compaction. Today it prompted me. I went ahead and did the compaction. This did not cause the folder to switch from threaded to un-threaded. So... that may not be the issue for me, but it is still a problem.

Bill

And so the question now is, with version 115 are you or anyone else still seeing this issue?

With the current version TB 115.1, the problem is still present.

I'm running TB 115.4.2 on Windows 10. I'm seeing this but unthreaded is becoming threaded. I have auto-compact turned on and realized reading the post above that compacting seems to trigger the change from unthreaded to threaded. And it's happening to me much more frequently in 115 than in any prior version - if fact I did not notice it ever happening before 115 and I've been using TB since at least 2015. It's frequent enough that it's starting to be a pain!

Seconding the comment above by Jus. TB 115.4.3, on Windows 10, unthreaded is desired but it turns on threaded sort by itself multiple times a day. Seems to be mostly if not entirely related to auto-compacting. This is impacting multiple users in my office.

(In reply to Ray Kremer from comment #43)

Seconding the comment above by Jus. TB 115.4.3, on Windows 10, unthreaded is desired but it turns on threaded sort by itself multiple times a day. Seems to be mostly if not entirely related to auto-compacting. This is impacting multiple users in my office.

While it doesn't happen for me due to auto-compacting or if I do a manual compact action, I know I've seen it switch to threading when a folder repair action is done. Any chance you may have experienced some folder corruption in the recent past?

I have not noticed any corruption and have not done a folder repair. I have only seen TB change to threaded on it's own during auto-compaction. And I have not yet determined if it's every auto-compaction, or only some. Manual compaction does not seem to trigger the change to threaded.

I will note that it always appears to be the inbox folder, and only the inbox, that changes to threaded and I have multiple accounts combined in the global inbox.

Duplicate of this bug: 1867957
Duplicate of this bug: 1869331

When an AutoCompactEvent is triggered after messages have been deleted in a local folder, the view
is destroyed beforehand and refreshed afterwards. This patch ensures that the view flags are
properly saved and restored.

Assignee: nobody → h.w.forms
Status: NEW → ASSIGNED
Attachment #9369937 - Attachment description: Bug 1725127 - Preserve the view flags of a folder that is compacted automatically. r=#thunderbird-reviewers → Bug 1725127 - Preserve the view flags of a folder that is automatically compacted. r=#thunderbird-reviewers
See Also: → 1858917
Duplicate of this bug: 1858917
See Also: 1858917
Summary: Inbox view randomly changes from threaded to un-threaded after dragging messages to other folder, which triggers compact → Inbox randomly reverts to default view (unthreaded/threaded, depending on TB version) after moving/deleting messages, which may trigger auto compact.
Duplicate of this bug: 1870914
Duplicate of this bug: 1791437
See Also: → 1859691

One thought on this. It does seem odd that this bug was opened 2 years ago, but we just started experiencing the behavior a couple of months ago. Has the bug been previously fixed and then reverted again? Or is there something that triggers it to start to occur? We have been using Thurderbird for about 8 years and this is the first we've seen the issue. Thanks!

That is probably because the default value of "mailnews.default_view_flags" has changed.
See bug 1867957

Target Milestone: --- → 123 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/2b7101b15726
Preserve the view flags of a folder that is automatically compacted. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Comment on attachment 9369937 [details]
Bug 1725127 - Preserve the view flags of a folder that is automatically compacted. r=#thunderbird-reviewers

[Approval Request Comment]
Regressed by: This bug seems to have been around since 2009.
User impact if declined: Unmotivated reversal of view settings to default may happen.
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): fairly low

Attachment #9369937 - Flags: approval-comm-beta?

Comment on attachment 9369937 [details]
Bug 1725127 - Preserve the view flags of a folder that is automatically compacted. r=#thunderbird-reviewers

[Triage Comment]
Approved for beta

Attachment #9369937 - Flags: approval-comm-beta? → approval-comm-beta+
Flags: needinfo?(andy.vines)
See Also: → 1874085
Duplicate of this bug: 1875538
Duplicate of this bug: 1875596

Comment on attachment 9369937 [details]
Bug 1725127 - Preserve the view flags of a folder that is automatically compacted. r=#thunderbird-reviewers

[Approval Request Comment]
User impact if declined: Unmotivated reversal of view settings to default may happen.
Testing completed (on c-c, etc.): c-c and beta
Risk to taking this patch (and alternatives if risky): fairly low

Attachment #9369937 - Flags: approval-comm-esr115?
Duplicate of this bug: 1879748

Comment on attachment 9369937 [details]
Bug 1725127 - Preserve the view flags of a folder that is automatically compacted. r=#thunderbird-reviewers

[Triage Comment]
Approved for esr115

Attachment #9369937 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.