Last Comment Bug 22112 - Thread pane icons should show state of mail (replied, forwarded)
: Thread pane icons should show state of mail (replied, forwarded)
Status: RESOLVED FIXED
: helpwanted, polish
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Message Display (show other bugs)
: Trunk
: All All
: -- enhancement with 24 votes (vote)
: seamonkey2.5
Assigned To: neil@parkwaycc.co.uk
:
:
Mentors:
: 23890 28668 76675 84641 88027 95141 142729 159501 165695 195327 223872 262884 329704 (view as bug list)
Depends on: 43601
Blocks: 518625 669450 669453 icons
  Show dependency treegraph
 
Reported: 1999-12-18 00:52 PST by Henrik Gemal
Modified: 2011-11-11 01:51 PST (History)
43 users (show)
iann_bugzilla: blocking‑seamonkey2.0a1-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Mailsymbols used in Outlook (3.86 KB, image/gif)
1999-12-18 00:53 PST, Henrik Gemal
no flags Details
Screenshot of icons used in Outlook Express 5.5 (15.33 KB, image/png)
2000-07-21 02:09 PDT, Henrik Gemal
no flags Details
Very quick mockup of what it would look like. Each column would have a differant type of flag. (31.11 KB, image/gif)
2000-08-05 05:13 PDT, Ian Thomas ('thelem')
no flags Details
new states for mail-icons ( without state read) (7.30 KB, image/gif)
2003-12-22 05:26 PST, Alexander Kluss
no flags Details
the file include new icons for the modern-theme (19.79 KB, application/x-zip-compressed)
2003-12-22 05:31 PST, Alexander Kluss
no flags Details
patch (36.14 KB, patch)
2011-06-21 15:34 PDT, Jens Hatlak (:InvisibleSmiley)
mnyromyr: review-
neil: superreview-
Details | Diff | Splinter Review
Mockup (398 bytes, image/png)
2011-06-22 07:33 PDT, neil@parkwaycc.co.uk
no flags Details
More mockups (14.59 KB, application/x-jar)
2011-07-01 14:35 PDT, neil@parkwaycc.co.uk
mnyromyr: feedback-
Details
Proposed patch (31.09 KB, patch)
2011-07-05 05:46 PDT, neil@parkwaycc.co.uk
mnyromyr: review+
Details | Diff | Splinter Review

Description Henrik Gemal 1999-12-18 00:52:32 PST
There a icon for a mail having an attachment, but there should also be a icon
for mails that have been replied and forwarded.
It's in Outlook and gives you a fast overview of the current status of the mail.
I know there is a status "column" but having an icon could be so easy done and
help a lot of people coming from Outlook to Mozilla!
I forwarded icon should be normal mail icon just with an arrow pointing to the
right. The reply icon should be an icon with a icon pointing to the left.
Comment 1 Henrik Gemal 1999-12-18 00:53:59 PST
Created attachment 3611 [details]
Mailsymbols used in Outlook
Comment 2 Phil Peterson 1999-12-20 14:57:59 PST
Our design goal for 5.0 is to make the message icons and folder icons simpler,
and hopefully easier to understand. Plus, it's a ton of work to produce icons
which can have a number of simultaneous states (e.g. an unread forwarded message
with an attachment).

So, we're not likely to do this, but I'll add it to the [HELP WANTED] list. It's
probably possible for a skin author to add in this kind of functionality.
Comment 3 Phil Peterson 1999-12-20 17:00:59 PST
Reassign to nobody@mozilla.org
Comment 4 Ian Thomas ('thelem') 1999-12-21 15:19:59 PST
I should be able to get some work done on this on thursday. I am assuming that
we want all these icons except encrypted and signed.
Also, are there plans to convert the icons like the mail folders or should I
deal with these too?
Assigned to ian@lemnet.com
Comment 5 Matthew Paul Thomas 1999-12-22 00:03:59 PST
Heh. What you need is icon overlays ... iconlets for `replied to', `saved',
`encrypted', etc, any of which can be overlaid on the read/unread message icon.
Like the Shortcut iconlet for Windows/MacOS, and the Locked iconlet for MacOS.
Comment 6 jglick 1999-12-22 09:39:59 PST
+ ------- Additional Comments From german@netscape.com  1999-12-22 06:36 -------
 Can we find a solution where this is a matter of a CSS stylesheet and some
 attribute it gets attached. So those who want to have the different icons at
 Mozilla can have them, those who don't don't! (By simply attaching the same
 message icon to the the different states. I agree that for Netscape folks we
are interested in keeping the visual complexity down. It is then easy to take it
 apart for any skin designer and create those alternative states displays.
 That way flexibility has been served.
Comment 7 Ian Thomas ('thelem') 1999-12-22 11:18:59 PST
German: I agree that would be 'kewl' but I don't think it would be very useable.
If you relied on a little LED to tell you the status of something, and it was
green in one case and red in another, what would you think when you looked at it
and it was blue. Something like this can only really change if it is not an
indicator also. Added to that they will not be that many (proportionally) using
the Mozilla mail client, and this definatly want to get removed from Netscape,
they want it as simple as possible.

This brings me to another point, will the icons change with the skin? I would
personally say that I should make some overlay in black and magenta
(transparent) which are then converted in memory to the correct colour by
Mozilla. Or is that too resource expensive?
Comment 8 Ian Thomas ('thelem') 1999-12-24 11:03:59 PST
German: Sorry, I think I misunderstood your last message. I thought you meant
that an incoming mail would be able to include and icon. Not sure where i got
that idea from.

I have been working on overlay versions, but it has been harder than I had
hoped, because I have so little space.
Comment 9 Asa Dotzler [:asa] 2000-01-15 14:21:59 PST
is this the same as bug 23890
Comment 10 Ian Thomas ('thelem') 2000-01-15 15:35:59 PST
*** Bug 23890 has been marked as a duplicate of this bug. ***
Comment 11 Ian Thomas ('thelem') 2000-01-15 15:52:59 PST
From bug 23890
Alternatively, you could replace the status column with icons.  Having the
status column resized so that you can see the replied to/forwarded status of
each message would cut the usable width of the thread display in half, since the
status column actually says "replied and forwarded"!  Make it icons and the
status bar would only take up 1-2 characters in width.

This would be a better idea, and would solve the problems I was having with
size.
Comment 12 Richard Zach 2000-02-21 10:13:50 PST
*** Bug 28668 has been marked as a duplicate of this bug. ***
Comment 13 Ian Thomas ('thelem') 2000-03-10 04:38:56 PST
Setting milestone.
Could we have some decision as to where the icons should be, in the status 
column or on the message icon itself please?
Comment 14 Matthew Paul Thomas 2000-03-10 07:07:55 PST
Well, that depends on whether Replied-To and Forwarded are columns by themselves, 
like Read/Unread and Marked are at the moment.

I think they should be separate columns, with separate icons: I often mark `read' 
messages as unread to remind me to read them again, and similarly I'd want to 
mark a `replied-to' message as not replied-to, to remind me to reply to it again 
(e.g. reply to a sender and then make a public followup to the newsgroup).
Comment 15 Mike 2000-06-21 13:38:03 PDT
M16 has been out for a while now, these bugs target milestones need to be 
updated.
Comment 16 Ian Thomas ('thelem') 2000-06-21 13:54:19 PDT
I am reassigning this bug to the owner, something I should have done a while 
ago. A decision needs to be made on how these things are being shown, and I 
agree with Matthew Thomas that seperate columns (In the style of the read/unread 
column) is the best way forward.

Setting target milestone to M17 to draw attention, but more realistically M18.
Comment 17 lchiang 2000-06-21 13:58:39 PDT
I think you reassigned the wrong bug. This bug is in the mail front end, not in 
printing.

dcone - I don't think this belongs to you.  Can you confirm?
Comment 18 Ian Thomas ('thelem') 2000-06-21 14:00:33 PDT
OK, I am sure this isn't a printing problem, not sure how the module change 
occured. Setting back to Mail Windows Front End. Sorry.
Comment 19 lchiang 2000-06-21 14:02:26 PDT
reassign back to nobody@mozilla.org then.
Comment 20 Matthew Paul Thomas 2000-06-21 20:55:11 PDT
Do we even have the back-end ability to store these flags (e.g. this message
has/hasn't been replied to) for messages?
Comment 21 Henrik Gemal 2000-06-23 05:15:12 PDT
Currently there is no support for status=forward but status=replied is there. 
Just check the Status column in the threadpane.
Comment 22 Ian Thomas ('thelem') 2000-06-23 05:25:06 PDT
It is not enough to have a variable like status=forward, we need things like 
read=true, replied=false, forwarded=true, attachment=false etc. I don't have the 
skills to do things like this myself, but it shouldn't be too hard to program, 
I would have thought.
Comment 23 Henrik Gemal 2000-06-23 05:39:35 PDT
I filled bug 43601. Lets see if it gets invalid....:(
Comment 24 Ian Thomas ('thelem') 2000-06-23 05:48:12 PDT
Adding depends, not sure why Gemal didn't do this
Comment 25 Henrik Gemal 2000-07-21 01:37:34 PDT
Not just reply and forward. I'm also talking about encrypted, signed, draft, 
deleted(not purged), etc...
Comment 26 Matthew Paul Thomas 2000-07-21 02:05:26 PDT
No, that's too much information to show in such a small icon. The icons would 
start looking like Swiss army knives instead of messages.
Comment 27 Henrik Gemal 2000-07-21 02:09:45 PDT
Created attachment 11688 [details]
Screenshot of icons used in Outlook Express 5.5
Comment 28 Ian Thomas ('thelem') 2000-07-21 02:16:54 PDT
That is the point of the suggestion above, which does not seem to have any 
objections, of putting icons in a special status column. (I recommend one, 
unresizable status column, containing a grid of some kind (table?) which has the 
icons inside it in columns. Understand? Or do you want to do a mockup?

BTW: Nice one M$, use the same icon for digitally signed as you did for 
invalidly signed in the previous release :-)
Comment 29 Matthew Paul Thomas 2000-07-21 09:58:59 PDT
Ok, slap me with a wet fish for not reading my own previous comments. :-/

No, make the status columns completely separate from each other, so I can pick 
and choose which ones I want to display (and in which order I want to display 
them). However, there are some you'll want to group together. How about:
* read/unread + unsigned/signed (overlay) + unencrypted/encrypted (overlay)
* priority
* attachments (may include number, and/or saved status of attachments, in the
  future)
* replied-to + forwarded
* flagged (a future RFE would be to allow you to specify your own flags).

See also <http://microsoft.com/mac/products/office/2001/preview/
entourage_preview1.asp#flag>.
Comment 30 timeless 2000-08-04 05:12:37 PDT
Sounds like this could use a mockup. Anyone up for doing it?
Comment 31 Ian Thomas ('thelem') 2000-08-04 05:56:24 PDT
doing mockup now.
Comment 32 Ian Thomas ('thelem') 2000-08-05 05:13:00 PDT
Created attachment 12417 [details]
Very quick mockup of what it would look like. Each column would have a differant type of flag.
Comment 33 Alexey Chernyak 2001-04-19 11:20:21 PDT
*** Bug 76675 has been marked as a duplicate of this bug. ***
Comment 34 Henrik Gemal 2001-05-14 06:33:29 PDT
the "mail with attachment" has now been implemented.
Comment 35 Grey Hodge (jX) 2001-10-24 20:43:41 PDT
I'm willing to make icons for all the possible states, if this i still wanted,
and I can get a list of states.
Comment 36 Alfonso Martinez 2002-07-27 05:41:16 PDT
*** Bug 159501 has been marked as a duplicate of this bug. ***
Comment 37 Olav Vitters 2002-08-30 05:05:28 PDT
*** Bug 165695 has been marked as a duplicate of this bug. ***
Comment 38 R.K.Aa. 2003-02-27 15:44:42 PST
*** Bug 195327 has been marked as a duplicate of this bug. ***
Comment 39 Mike Cowperthwaite 2003-07-14 18:11:25 PDT
*** Bug 88027 has been marked as a duplicate of this bug. ***
Comment 40 Vidar Haarr (not reading bugmail) 2003-08-23 05:19:11 PDT
Is this not an RFE ?
Comment 41 johann.petrak@gmail.com 2003-10-27 13:21:49 PST
*** Bug 223872 has been marked as a duplicate of this bug. ***
Comment 42 johann.petrak@gmail.com 2003-10-27 13:23:16 PST
It is a RFE
Comment 43 Mike Coppins 2003-10-27 14:00:12 PST
This is one of those little features that nobody notices until they try a new
mail client and find it isn't there, sigh and go back to their previous mail
client.  Pleeeeeeeeeeeeeeeeease someone implement this feature!

(I can whine in a more annoying fashion if that would help)
Comment 44 Pratik 2003-10-27 14:13:26 PST
fyi, the nitpick_mod theme for ThunderBird has this feauture. See
<http://tberg.net/_/G.php3?page=MOZILLA/1>. Would be nice if someone wrote a
similar theme for Mozilla.
Comment 45 David Tenser [:djst] 2003-12-19 07:58:09 PST
Just for the record, this is now fixed in the default theme of Mozilla Thunderbird.
Comment 46 Alexander Kluss 2003-12-22 05:26:32 PST
Created attachment 137832 [details]
new states for mail-icons ( without state read)

This icons include the state replied, forwarded for mails with and without
attachment.
Comment 47 Alexander Kluss 2003-12-22 05:31:57 PST
Created attachment 137833 [details]
the file include new icons for the modern-theme

Here are the icons for the standard-theme from Mozilla. The file includes also
the changes from the threadppane.css in a txt-file.
Which of you can check in these changes?
Comment 48 Mike Coppins 2003-12-22 06:04:35 PST
the orange/white arrow is a bit hard to see on a white background.  In
Thunderbird 0.4 release they look pretty good.
Comment 49 Alexander Kluss 2003-12-22 10:41:41 PST
OK, but it's no problem to change the color of the forwarded-state.
Which color would you think is better?
Comment 50 Mike Coppins 2003-12-22 12:50:11 PST
The Thunderbird icons are spot-on, IMO.  Pilfer those.
Comment 51 Mike Cowperthwaite 2003-12-31 13:40:44 PST
*** Bug 142729 has been marked as a duplicate of this bug. ***
Comment 52 Tim Fry 2004-05-03 12:30:57 PDT
Is this really still a bug?  It seems to be fixed in all Thunderbird versions 
I have used...  Am I missing the point of this?
Comment 53 José Jeria 2004-05-03 12:32:49 PDT
(In reply to comment #52)
> Is this really still a bug?  It seems to be fixed in all Thunderbird versions 
> I have used...  Am I missing the point of this?

This is a Mozilla Mail bug... not a Thunderbird bug.
Comment 54 Stefan Borggraefe 2004-10-04 16:41:23 PDT
*** Bug 262884 has been marked as a duplicate of this bug. ***
Comment 55 Mike Coppins 2004-11-07 15:31:51 PST
Having another look at those icons (the 'new states for mail-icons' attachment),
they look fine to me.

</not so subtle attempt at *bump*>
Comment 56 Mike Coppins 2005-02-14 09:30:15 PST
Are these icons going to get put into MozMail then?
Comment 57 Mike Cowperthwaite 2005-02-14 09:50:34 PST
For what it's worth, the Pinball theme for Mozilla MailNews, which I like very 
much for other reasons, has icons in place for this.  There may be other themes 
that have this feature as well.
Comment 58 Mike Coppins 2005-02-16 06:00:15 PST
Ok, following advice from a mozillazine user on how to add the mail state icons
in myself, I've created a modified modern.jar file with the message icons and
necessary code, and it works fine here on Mozilla 1.7.5.

http://lorien.legolas.com/modern.jar
Comment 59 Andre Ulrich 2005-02-25 13:10:14 PST
*** Bug 84641 has been marked as a duplicate of this bug. ***
Comment 60 Ian Neal 2006-02-07 13:23:06 PST
I can see reply and forwarded being the most useful states to show within the icon with reply taking precidence over forwarded. Another alternative perhaps is for the status column to have the option of displaying as an icon instead of text.
Comment 61 zug_treno 2006-03-08 03:11:35 PST
*** Bug 329704 has been marked as a duplicate of this bug. ***
Comment 62 Ian Neal 2008-08-16 13:38:27 PDT
Not something we are going to block 2.0a1, as this is an enhancement, renominate for blocking on 2.0 when this bug is assigned and there is a patch.
Comment 63 Jens Hatlak (:InvisibleSmiley) 2010-11-30 12:13:42 PST
MiK's Orbit 3+1 is another theme that has icons for replied and forwarded mail, and those should be compatible with Modern (so in fact fixing Modern might be easier that fixing the default theme/classic). Since morbit is the theme I'm using, I haven't found this is a problem with the bundled themes until now.

Also, TB has had such icons at least since version 2. The CSS rules start with "treechildren::-moz-tree-image(subjectCol," and then contain "replied" and/or "forwarded".

Adjusting summary to make this more findable.
Comment 64 Jens Hatlak (:InvisibleSmiley) 2011-06-21 15:34:54 PDT
Created attachment 540914 [details] [diff] [review]
patch

This is "heavily inspired" by the morbit theme. It has icons for all forwarded/replied icons, and fixes both Classic and Modern (the icons look very similar, but Classic uses a light brown while Modern uses gray). Since I did some image manipulations, the result might not be perfect, but certainly better than nothing. I'd appreciate if we could finish this off quickly, maybe even in time for next Aurora.

Tools used:
- Paint.NET (saved with depth 8, which for some reason was bigger than depth 24)
- convert -depth 24 (from imagemagick)
- pngcrush (stupid tool was unable to do the 24-bit part but optimized afterwards)
Comment 65 neil@parkwaycc.co.uk 2011-06-22 07:33:25 PDT
Created attachment 541041 [details]
Mockup

I have to say, I'm not convinced that these overlays blend in. So I set about creating a mockup message replied icon based on taking the arrow from the new message icon and changing its hue from 64 to 150. Unfortunately this arrow is somewhat larger and you can't fit both reply and forward on the same image...
Oh, and I haven't run this through pngcrush or optipng or better still, both.
Comment 66 Jens Hatlak (:InvisibleSmiley) 2011-06-22 09:23:44 PDT
(In reply to comment #65)
> Created attachment 541041 [details]
> Mockup
> 
> I have to say, I'm not convinced that these overlays blend in. So I set
> about creating a mockup message replied icon

If you want to take over, fine by me. But then you'll have to go the whole way (or find someone who will). Adapting the icons from morbit took me about 5 hours (2x12 icons, plus the optimization) and I'm not going to go through that again.

IOW: If a new set of icons will be required, I'll unassign myself and probably create an add-on. My priorities are to have this ASAP (since I lack the time to fully fix morbit any time soon, and this part bugs me the most) and to have it complete, i.e. with all variants.

> Unfortunately this arrow is somewhat larger and you can't fit both reply and
> forward on the same image...

So that approach is doomed; I'd say that's a requirement.
Comment 67 Glenn Randers-Pehrson 2011-06-23 07:13:38 PDT
(In reply to comment #64)

> - convert -depth 24 (from imagemagick)

   ImageMagick's "depth 24" means 24 bits per sample.  If you
were using the default Q16 or the Q8 build, this request would
be handled as "-depth 16" or "-depth 8", respectively.

> - pngcrush (stupid tool was unable to do the 24-bit part but optimized
> afterwards)

   pngcrush would also understand (and ignore with a warning) the request to
write 24 bits/sample.

   In both cases you probably really wanted to call for depth==8.
Comment 68 Jens Hatlak (:InvisibleSmiley) 2011-06-23 08:33:12 PDT
(In reply to comment #67)
> > - pngcrush (stupid tool was unable to do the 24-bit part but optimized
> > afterwards)
> 
>    pngcrush would also understand (and ignore with a warning) the request to
> write 24 bits/sample.

I really wanted to optimize for file size and the combination I ended up with resulted in the smallest file size, without any visible loss of quality (to my eyes at least). The alternatives I tried (most notably the default) resulted in files that were several hundred KB larger. Maybe I really was using the tools the wrong way or misunderstood the parameters, but it appears as a fact to me that it's overly hard/complicated to achieve that goal using those tools (and here I blame both the default settings and the documentation).

>    In both cases you probably really wanted to call for depth==8.

I have to admit that I don't fully understand the difference between depth and "bits per sample", but I do think that those tools should provide me with an easy way to either optimize for size *or* specify the effective target depth.
Comment 69 Karsten Düsterloh 2011-06-25 14:08:27 PDT
Comment on attachment 540914 [details] [diff] [review]
patch

(In reply to comment #64)
> I did some image manipulations, the result might not be perfect, but
> certainly better than nothing.

Better than nothing for sure, but I have to agree with Neil:

(In reply to comment #65)
> I have to say, I'm not convinced that these overlays blend in.> So I set about creating a mockup message replied icon based on taking the
> arrow from the new message icon and changing its hue from 64 to 150.

Yes, that fits in better.

> Unfortunately this arrow is somewhat larger and you can't fit both reply
> and forward on the same image...

I don't see why? The images are 16x16 and the arrow is 8px across. You can't see the letter's lid, but that's okay, imo.

That said, the CSS part of the patch is missing the rules for the tab icons.

(In reply to comment #66)
> IOW: If a new set of icons will be required, I'll unassign myself and
> probably create an add-on. My priorities are to have this ASAP (since I lack
> the time to fully fix morbit any time soon, and this part bugs me the most)
> and to have it complete, i.e. with all variants.

Sad to hear, but understandable.
Comment 70 Jens Hatlak (:InvisibleSmiley) 2011-06-25 14:13:21 PDT
(In reply to comment #69)
> That said, the CSS part of the patch is missing the rules for the tab icons.

I noticed that, but tabmail is missing the properties/attributes/whatever for that in the first place, so maybe that should go into a follow-up. But that's really up to the one to finishes this; of course that could be done here, too.
Comment 71 Jens Hatlak (:InvisibleSmiley) 2011-06-26 02:43:43 PDT
I'm done:
https://addons.mozilla.org/de/seamonkey/addon/mailnews-status-icons/
Comment 72 Michael Lueck 2011-06-26 05:06:41 PDT
Thank you very much, Jens! Much better!!! :-)

Not quite as clear as the former TB 2.x icons, but a vast improvement.
Comment 73 neil@parkwaycc.co.uk 2011-06-30 09:52:00 PDT
(In reply to comment #69)
> (In reply to comment #65)
> > I have to say, I'm not convinced that these overlays blend in.
> ...
> > So I set about creating a mockup message replied icon based on taking the
> > arrow from the new message icon and changing its hue from 64 to 150.
> 
> Yes, that fits in better.
> 
> > Unfortunately this arrow is somewhat larger and you can't fit both reply
> > and forward on the same image...
> 
> I don't see why? The images are 16x16 and the arrow is 8px across. You can't
> see the letter's lid, but that's okay, imo.
> 
OK, I'll try to make a complete set of icons.
Comment 74 neil@parkwaycc.co.uk 2011-07-01 14:35:15 PDT
Created attachment 543514 [details]
More mockups
Comment 75 Michael Lueck 2011-07-01 19:10:19 PDT
Neil, would you consider a more simple set of icons without the message envelope, and different colors for the left / right arrow? Yes, more like TB2.

I think the envelope reduces clarity, and I was fond of thinking "is it blue / is it green / is it both" and thus understood what the icon meant.
Comment 76 Karsten Düsterloh 2011-07-04 00:18:28 PDT
Comment on attachment 543514 [details]
More mockups

The icons as such look decent, but — as Michael points out rightly — having two different blue arrows is confusing, hence we should pick different (primary) colours for reply and forward. Given that we're already using green for "new" and that "replied" should be more visible than "forwarded", I'd propose red and blue, respectively.
Comment 77 neil@parkwaycc.co.uk 2011-07-05 05:30:33 PDT
Comment on attachment 540914 [details] [diff] [review]
patch

Trees don't respect rule weights, so you have to ensure that your rules are in the correct order, which yours aren't. For instance, the imapdeleted rules have to be at the end of their block. (It's OK to put the offline icons after the online imapdeleted icon because there's an offline imapdeleted icon later on.)
Comment 78 neil@parkwaycc.co.uk 2011-07-05 05:46:12 PDT
Created attachment 543912 [details] [diff] [review]
Proposed patch
Comment 79 Karsten Düsterloh 2011-07-05 13:58:33 PDT
Comment on attachment 543912 [details] [diff] [review]
Proposed patch

Cool!
I filed bug 669450 and bug 669453 on two follow-up issues.
Comment 80 neil@parkwaycc.co.uk 2011-07-08 14:12:19 PDT
Pushed changeset ed3204911417 to comm-central.
Comment 81 Ian Neal 2011-10-30 05:22:48 PDT
*** Bug 95141 has been marked as a duplicate of this bug. ***
Comment 82 Rob Janssen 2011-11-11 01:51:53 PST
(In reply to Karsten Düsterloh from comment #76)
> Comment on attachment 543514 [details]
> More mockups
> 
> The icons as such look decent, but — as Michael points out rightly — having
> two different blue arrows is confusing, hence we should pick different
> (primary) colours for reply and forward. Given that we're already using
> green for "new" and that "replied" should be more visible than "forwarded",
> I'd propose red and blue, respectively.

I don't like the reddish color chosen for "replied".
It tends to alert the user as if something is wrong with the message.
The color green or blue would have been more appropriate for a status like this.
It does not really matter that it is the same as for "new" because the arrow is different.
Using too many colors also makes the interface looking amateurish.

Note You need to log in before you can comment on or make changes to this bug.