Ability to export/backup saved passwords

NEW
Unassigned

Status

()

enhancement
P5
normal
15 years ago
16 days ago

People

(Reporter: sanderhartveld, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [passwords:management])

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.8

It should be nice if a button shows in the password manager that gives the
functionallity to export/backup saved passwords to a file.

Reproducible: Couldn't Reproduce
Steps to Reproduce:

Comment 1

15 years ago
Similar to bug 208338.

Comment 2

15 years ago
*** Bug 250681 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
Hardware/OS both changed to ALL
OS: Windows XP → All
Hardware: PC → All

Comment 4

15 years ago
Ok, because bug 250681 is considered a dupe, I recommend to use a 'portable'
format for the external file and request an additional function to _reimport_
the data. :-)

Comment 5

15 years ago
*** Bug 277138 has been marked as a duplicate of this bug. ***
*** Bug 284259 has been marked as a duplicate of this bug. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

14 years ago
This feature request should probably be expanded to include the Form Manager
data in addition to just the Password Manager data. 

It would really be nice if all the user information (bookmarks, cookies,
certificates, preferences, etc) was written to a structured archive so that all
the data can be imported again when firefox has been reloaded. 

Comment 8

13 years ago
This data is stored in your profile. Backing it up is something that very few users would need or want, hence, this is an extension. See http://www.pikey.me.uk/mozilla/?addon=bb (even though it's called Bookmark Backup, it includes options to backup other profile data also.)

Comment 9

13 years ago
Mass edit: Changing QA to default QA Contact
QA Contact: davidpjames → password.manager

Comment 10

13 years ago
(In reply to comment #8)
> This data is stored in your profile. Backing it up is something that very few
> users would need or want, hence, this is an extension. See
> http://www.pikey.me.uk/mozilla/?addon=bb (even though it's called Bookmark
> Backup, it includes options to backup other profile data also.)
> 
I would have to question your observation that very few users would need ot back up their passwords. I should think that everyone needs their passwords backed up, whether they know it or not. The loss of all of one's passwords is a terrible loss which should be considered avoidable or preventable. The point of a good browser should be that it takes care of thing seemlessly or in a manner that is transparent to the user. As the vast majority of users do not know much about profiles, manually backing them up is not likely to happen. The extensions are good as far as they go, but I believe that backing up essential data should be a basic function of a brower...this is supposed to be a better mouse trap isn't it?

Regards
Assignee: bryner → nobody
Version: unspecified → Trunk

Updated

13 years ago
Depends on: 22689

Comment 11

13 years ago
Backing up passwords and the like is rather easy (although not format-independent):

https://stier.dynu.com/~moinmoin/MarksWiki/Firefox#head-2b4e2fc47a07161d5e4e31c4da82a078fbecea86
Blocks: 376682
Duplicate of this bug: 436461
Other available options:

Password Exporter extension:
https://addons.mozilla.org/en-US/firefox/addon/2848

Mozilla Labs' "Weave" will support password syncing between computers in the next version:
http://labs.mozilla.com/2007/12/introducing-weave/
Reporter

Comment 14

11 years ago
Grant!
Thanks a lot!
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Actually, I want to leave this bug open for now... I think adding import/export to the core product might be a good idea. (Or might not be, based on availability of extensions -- just not ready to make a final decision right now).
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Duplicate of this bug: 448362
Product: Firefox → Toolkit

Updated

4 years ago
Duplicate of this bug: 1226995

Comment 18

4 years ago
Should bug 180582 be duped to this, even though it's older?
Whiteboard: [passwords:management]

Comment 21

a year ago
I had opened https://bugzilla.mozilla.org/show_bug.cgi?id=1444769 detailing the need for similar functionality.

I realize that this is an incredibly old ticket, but could it be updated to also include IMPORTING of the backed up passwords? I also realize that some might consider this to be pedantic considering that we're talking about related functionalities and that importing could almost be implied in the requirement. But we all know what they say about assuming... Anyway, I would really hate for this to finally be worked on, only to then have it done half-@$$ed by not having IMPORT to go with EXPORT simply because it wasn't spelled out in the description...

If a mod / OP could update, that'd be much appreciated.
Reporter

Comment 22

a year ago
Pretty amazing that after 14 years this is feature request still active. Maybe I will actually try and make it myself sometime.

Comment 23

a year ago
Just want to add a couple things:

Google Chrome now has the ability to export passwords. Does this mean chrome respects user freedom more than Firefox?

Firefox is now completely unable to export passwords. There are no addons compatible with Firefox Quantum which enable the export of Firefox passwords. Even if there were, exporting passwords should be a core feature of Firefox, not something which depends on an addon.
There are tools which can decrypt logins.json so this is possible outside of the Firefox UI.
Status: REOPENED → NEW
Summary: add ability to export/backup saved passwords → Ability to export/backup saved passwords

Updated

8 months ago
Duplicate of this bug: 1497044

Comment 26

8 months ago
Since import/export of logins is not something you do every day, I wouldn't mind an external tool. But instead of an Electron/node app (such as https://github.com/kspearrin/ff-password-exporter) it should be a Mozilla-supported tool.

In addition, there is code posted at https://support.mozilla.org/en-US/questions/1077630#answer-834769 that allows to export the saved logins to a file -- but it has to be run from the browser console -- the existence of such code means it **really easy** to export passwords from inside Firefox and it's probably an intended omission -- but why?

Comment 27

16 days ago

Maybe the lockbox / lockwise addon (whatever the name is...) can do this...

You need to log in before you can comment on or make changes to this bug.