Attaching out-of-locale Unicode-named file fails: won't send

VERIFIED FIXED in mozilla1.9

Status

MailNews Core
Composition
--
major
VERIFIED FIXED
12 years ago
8 years ago

People

(Reporter: Mike Cowperthwaite, Assigned: smontagu)

Tracking

(Depends on: 1 bug, {intl})

Trunk
mozilla1.9
x86
Windows 2000
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Very similar to bug 332108.

1) Start a new message composition
2) Attach a file with a Unicode name by dragging from Explorer to attachment 
panel.
3) Send the file

Actual results:
2) filename in panel shows ???? instead of proper name
3) Error:
  Sending of message failed.
  Unable to open the temporary file [[<path>\_____.ext]]. ...

Expected results
2) filename shown as seen in the Explorer or File Open windows.
3) Transmission without a problem.

I first reported this (bug 285073 comment 5) in 2005 with Gecko 1.8b2 versions
of TB and Mozilla.  Still present in TB 1.5, 2a1-0328 and (importantly) 
3a1-0327, which has the patch for bug 162361 in place.
I am running an English installation of Windows 2000.  I see the same results
whether the compose window has the (default) ISO-8859-1 charset or the UTF-8 or
UTF-16LE charset.

Per Jungshik, this is a problem in the Drag-and-Drop code, hence the 
dependency.  This may also be dependent on bug 33451.
(Reporter)

Updated

12 years ago
Severity: normal → major
(Reporter)

Comment 1

11 years ago
The original symptoms of this bug have changed somewhat:

  result (2): the filename appears correctly in the Attachment panel

However, result (3) still occurs; and it occurs whether the attachment is made by drag-and-drop or by using the Attach command.  I thought there was a bug open just for this latter case, but I can't locate it.  I'm repurposing this bug for the 'can't send' problem.

I'm seeing this now with TB 2b2-0215, 3a1-0214, Seamonkey 1.5a-0210.
I think this is Windows-only.


> Per Jungshik, this [...] may also be dependent on bug 33451.

Bug 234681 was dependent on 33451, but it seems to have been fixed by the patch at bug 359148 which simply replaced a few 'nsCAutoString' instances with 'nsAutoString'.  (33451 has a patch checked in since this bug was opened, but for part of the code unrelated to this problem.)
Summary: Attaching Unicode-named file (via drag-and-drop) fails: substitutes '?' characters in name, won't send → Attaching out-of-locale Unicode-named file fails: won't send
(Reporter)

Updated

11 years ago
Duplicate of this bug: 370748

Comment 3

11 years ago
Result (3) still occurs vith TB 2.0 Italian, on Win XP PRO Italian, attaching a file with Jap character in file name (and in folder who contain it)

Comment 4

11 years ago
(In reply to comment #1)

> Bug 234681 was dependent on 33451, but it seems to have been fixed by the patch
> at bug 359148 which simply replaced a few 'nsCAutoString' instances with
> 'nsAutoString'.  (33451 has a patch checked in since this bug was opened, but
> for part of the code unrelated to this problem.)

Was bug 234681 fixed in TB 2.0? I guess not. 

Do NOT expect this bug to be fixed in TB 2.0 unless bug 33451 and 'drag and drop' bug are fixed there, too. Please, concentrate on the trunk. 



Depends on: 33451

Comment 5

11 years ago
the file spec removal work is trunk-only.

Updated

11 years ago
Depends on: 378601
(Reporter)

Comment 6

11 years ago
(In reply to comment #4)
> (In reply to comment #1)
> > Bug 234681 was dependent on 33451, but it seems to have been fixed by the
> > patch at bug 359148 which simply replaced a few 'nsCAutoString' instances
> > with 'nsAutoString'.  (33451 has a patch checked in since this bug was
> > opened, but for part of the code unrelated to this problem.)
> 
> Was bug 234681 fixed in TB 2.0? I guess not. 
> Do NOT expect this bug to be fixed in TB 2.0 unless bug 33451 and 'drag and
> drop' bug are fixed there, too. Please, concentrate on the trunk. 

I didn't mean to imply anything about the branch.  My point was, 234681 was apparently fixed on trunk without a corresponding patch for bug 33451, and I was speculating that perhaps *this* bug could have been fixed on trunk without 33451 getting fixed.

Now, of course, there's a lot of new work for 33451 since late March, but I had no way of knowing that was imminent when I posted comment 1.
(Reporter)

Comment 7

11 years ago
This bug, at least, was not completely fixed by the work from bug 33451.  Testing with 3a1-0527, Win2K.  The filename now displays correctly on attaching (whether dragged in or attached via dialog), but the error described in comment 0 step 3 still occurs.

(Bug 370761 -- attaching via MAPI -- also still manifests, but I don't think that had the same cause.)

Comment 8

11 years ago
On Linux + Gnome 2.18.2 I experience this problem with Thunderbird 2 and a trunk build, but only when I drag the file from Nautilus, not when I attach it using the Attach File filepicker.

Comment 9

10 years ago
the bug still exists for thunderbird 2.0.0.6 and 3.0a with korean letters in the file name. any progress on the subject yet? would be nice to have this fixed...

thx

Updated

10 years ago
QA Contact: composition
(Assignee)

Updated

10 years ago
Duplicate of this bug: 334280
(Assignee)

Comment 11

10 years ago
Created attachment 294665 [details] [diff] [review]
Patch

As the comment implies, the code block I'm removing is unnecessary now that bug 33451 is fixed.
Assignee: nobody → smontagu
Status: NEW → ASSIGNED
Attachment #294665 - Flags: superreview?
Attachment #294665 - Flags: review?
(Assignee)

Updated

10 years ago
Attachment #294665 - Flags: superreview?(bienvenu)
Attachment #294665 - Flags: superreview?
Attachment #294665 - Flags: review?(mscott)
Attachment #294665 - Flags: review?

Updated

10 years ago
Attachment #294665 - Flags: review?(mscott) → review+

Comment 12

10 years ago
As of today ( TB 2.009) the bug has not been fixed; may be is nt clear how important is to solve this damn problem. We cannot save attachments with Jap. names. Please be patient, solve it, otherwise we must switch to other products and this would be a shame.

Thanks.

Gino de Simone

Comment 13

10 years ago
Gino, in case you didn't notice: there's been a patch. Hope it will be included in the next release.

Updated

10 years ago
Duplicate of this bug: 410790

Updated

10 years ago
Duplicate of this bug: 380903

Updated

10 years ago
Duplicate of this bug: 287209

Updated

10 years ago
Duplicate of this bug: 379703

Comment 18

10 years ago
Sorry to bother everyone, but the patch has been proposed four months ago, and I'm still using MS Outlook.
Flags: blocking-thunderbird3?

Comment 19

10 years ago
David: ping on the sr for this.

Updated

10 years ago
Duplicate of this bug: 430046

Updated

10 years ago
Attachment #294665 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Comment 21

10 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Flags: blocking-thunderbird3?
Target Milestone: --- → mozilla1.9

Updated

10 years ago
Duplicate of this bug: 333644

Updated

10 years ago
Status: RESOLVED → VERIFIED
Product: Core → MailNews Core

Updated

9 years ago
Duplicate of this bug: 447606

Comment 24

9 years ago
Any chance to get that patch in 1.8 branch?

Updated

9 years ago
Duplicate of this bug: 447694

Updated

9 years ago
Duplicate of this bug: 476588

Comment 27

9 years ago
I really like Thunderbird and will keep using it.  However, it would be great if this patch could be compiled into an update soon.  It would make Thunderbird that much better.
I'm confused. Thiss bug VERIFIED FIXED and there's a patch?  

Can someone confirm that it's fixed in Shredder nightlies?

Comment 29

9 years ago
Oh, yes, it's fixed. It's been some time I've been switching to beta version every time I need to send an attachment.
But the fix depended entirely on bug 33451, which is absolutely not going into Tb 2.x, so unfortunately this is just another reason why we need to hurry up and ship 3.0.

Updated

9 years ago
Duplicate of this bug: 501199

Updated

8 years ago
Duplicate of this bug: 510362

Updated

8 years ago
Duplicate of this bug: 513656

Updated

8 years ago
Duplicate of this bug: 119246
You need to log in before you can comment on or make changes to this bug.