Closed Bug 632749 Opened 9 years ago Closed 9 years ago

Doesn't show bookmark manager or code source (if Mac dual-monitor)

Categories

(Core :: Widget: Cocoa, defect, major)

2.0 Branch
x86_64
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 644733
Tracking Status
blocking2.0 --- -

People

(Reporter: m+bugzilla, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10) Gecko/20100101 Firefox/4.0b10
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

When I try to do cmd+shift+b or cmd+u, nothing happens. I've got an hover effect on the macos application bar which means the command is started but nothing, no window.

It does the same when I do "source code" with right click on the page.

I've tried to do another profile, a clean one, but still the same problem

Reproducible: Always
Can you please try with beta 11 (http://firefox.com/beta)
Same on beta 11. :/
This is happening for me as well, at least in a particular situation:

I have a dual-monitor setup.  When Firefox is located on the monitor without the OSX menubar on it, and when that monitor is positioned to the left of the menubar monitor in the display settings, I can't view source, see downloads in progress, or do anything else in a secondary window.

In any other configuration (FF on the monitor w/ the OSX menubar, in any position, or without but positioned to the right, above, or below the menubar monitor), view source and other secondary window operations work as expected.

I'm on the latest Snow Leopard, running FF4b12.
Confirmation,

I'm on the latest Snow Leopard too, running FF4b12 too.

What Jason said is perfectly what I've got.

When I've Firefox on the main screen, no bug, the source window and bookmark manager window correctly appear.

If I place Firefox on my second screen, the windows don't appear. That's it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Doesn't show bookmark manager or code source → Doesn't show bookmark manager or code source (if dual-monitor)
blocking2.0: --- → ?
I can't reproduce those STR. This works as expected for me, OSX Snow Leopard, latest nightly. Can you guys grab the latest nightly from http://nightly.mozilla.org and confirm? Please make sure you're in a clean profile.
Still happening for me with the latest nightly and a fresh profile.  

Further system details:

  Model Name:	MacBook
  Model Identifier:	MacBook5,1
  Processor Name:	Intel Core 2 Duo
  Processor Speed:	2.4 GHz
  Number Of Processors:	1
  Total Number Of Cores:	2
  L2 Cache:	3 MB
  Memory:	4 GB
  Bus Speed:	1.07 GHz
  Boot ROM Version:	MB51.007D.B03
  SMC Version (system):	1.32f8

 Chipset Model:	NVIDIA GeForce 9400M
  Type:	GPU
  Bus:	PCI
  VRAM (Total):	256 MB
  Vendor:	NVIDIA (0x10de)
  Device ID:	0x0863
  Revision ID:	0x00b1
  ROM Revision:	3385
  Displays:
Color LCD:
  Resolution:	1280 x 800
  Pixel Depth:	32-Bit Color (ARGB8888)
  Mirror:	Off
  Online:	Yes
  Built-In:	Yes
DELL U2410:
  Resolution:	1920 x 1200 @ 60 Hz
  Pixel Depth:	32-Bit Color (ARGB8888)
  Main Display:	Yes
  Mirror:	Off
  Online:	Yes
  Rotation:	Supported
I don't think this would block, sadly. Might be WFM.
blocking2.0: ? → -
I have no problem with it not blocking.  I'd be a little disappointed if it were closed as WFM, though, as it seems it's affecting at least two of us, and it's pretty disruptive to my daily work.  I don't know the FF codebase and I don't do much C++, but I'd be willing to help out as much as I can.

I did get a debug build up.  When the browser is on the left secondary monitor and I try to open the Downloads window, I'm seeing two assertion failures that I don't see when I do the same thing with the browser on the main monitor:

###!!! ASSERTION: non-root frame's desired size changed during an incremental reflow: '(target == rootFrame && size.height == NS_UNCONSTRAINEDSIZE) || (desiredSize.width == size.width && desiredSize.height == size.height)', file /Users/jason/src/mozilla/layout/base/nsPresShell.cpp, line 7907
++DOMWINDOW == 22 (0x122d79638) [serial = 29] [outer = 0x12acec3c0]
###!!! ASSERTION: root view / pres context visible size mismatch: 'bounds.Size() == mPresContext->GetVisibleArea().Size()', file /Users/jason/src/mozilla/layout/base/nsPresShell.cpp, line 4939 

If you think it would help, I can attach full debug output for both a working attempt and a broken one.

Thank you for taking a look.
Same annoying problem on my configuration:
MacBook Pro with secondary monitor attached, Snow Leopard 10.6.6, Firefox 4.0 RC

"View Source" or "Download" window, or any other window does not apper when Firefox is on my secondary screen.
WFM with 2009 Mac Mini with primary screen in DisplayPort and the secondary screen in DVI. The View Source window appears on the main screen, though, even if invoked for a browser window that's on the secondary screen.
@Henri

Is your secondary screen positioned to the left of your primary?  The issue occurs for me only when that's the case; above, below, and to the right work, but like you're seeing, display the new window on the primary screen.
I can reproduce:
Latest nightly on Snow Leopard 10.6.6.
Latest MacBook Air 13", attached monitor to the right, menu bar on external monitor.

When the browser window is on the internal monitor (without menu bar) I can't open the bookmarks manager or the source code view, neither through the menu nor through shortcuts
(In reply to comment #11)
> @Henri
> 
> Is your secondary screen positioned to the left of your primary?

Yes.
I can reproduce also, using 4.0b11 on 10.6.6. It did not occur when the second monitor was below the primary monitor, but did occur when the second monitor was to the left the primary monitor. Only tested with "View Page Source" right-click menu and keyboard shortcut.
I can reproduce this using 4.0 RC on OS X 10.6.6.

Steps to reproduce:

1) MacBook Pro to the left of my external monitor, menubar on the external monitor
2) Launch Firefox on the external (menubar-ed) monitor
3) View source (Cmd-U) works fine
4) Move Firefox window to my laptop's screen
5) View source (Cmd-U) no longer makes anything appear

Laptop: MacBook Pro 13-inch 1280x800
Display: Samsung 2048x1152
I've tried it with these steps and can reproduce this on OSX 10.6.6 with 4.0 RC:

1) iMac to the right of my external monitor
2) Launch Firefox on my external monitor
3) Right-click 'View Source' nothings comes up same for Cmd+U
4) If I move Firefox back to my iMac then 'View Source' works (both right click and Cmd+U)

It doesn't even look as though it's opening outside of the viewable area because if I gather the windows (F3) then it doesn't come up at all.

Hardware:
iMac 27"
External monitor: iiyama 17"

Cheers,

James
Could be great to vote for this ticket in order to see a patch soon.
+1 vote
Firefox 4.1, OS X 10.6.7:

15" MacBook Pro with 24" Apple LED Cinema Display. ACD is primary display (has menubar). MBP is to left of ACD.

1) Place FF window on MBP screen.
2) Go to http://google.com/
3) Hit CMD+U
4) Nothing appears, though "Source of: http://google.com/" does appear as last item in Window menu.

Placing window 50% or more on ACD screen works as expected. Changing arrangement of displays so that MBP is to right of ACD also works as expected on both displays.
This is a regression?
Duplicate of this bug: 642443
Duplicate of this bug: 657880
Duplicate of this bug: 661147
FYI

Macbook pro is to the left of the right main Screen.
Menu bar is on the right main screen.
I have Open Spaces enabled and firefox is assigned to screen 1.

When I enable firefox on all screens it works but the new window has a very small width.
View source also works when firefox is enabled on all screens.
looks like the fixing is progressing in Bug 644733 - Can't open new windows if any windows are on a secondary monitor

other possible duplicates:
bug 646555, bug 650374, bug 651282, bug 655599, bug 656106, bug 632749, bug 633901, bug 635089, bug 644345, bug 645512, bug 609405
Summary: Doesn't show bookmark manager or code source (if dual-monitor) → Doesn't show bookmark manager or code source (if Mac dual-monitor)
WFM on 2007 MBP (DVI port) with second monitor either right or left of laptop. This bug and its relatives clearly affect a fair number of Macs, but mine isn't one of them. I hope we can find the cause.
Erwann, Jason, etc
Do you agree the steps to reproduce are bug 644733 comment 16?
And it didn't happen with Fx 3.6?

Neil, might you be able to take the review? (last mentioned in bug 644733 comment 28)
Component: General → Widget
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → 2.0 Branch
Component: Widget → Widget: Cocoa
QA Contact: general → cocoa
Only difference between my repro steps and the one in that bug is in the second step: my dock is on the laptop screen (docked to the left, if that matters), but my menu bar is on the external display.

It did not start until version 4.
> Neil, might you be able to take the review? (last mentioned in bug 644733
> comment 28)

No, one of Mac module owners/peers (from https://wiki.mozilla.org/Modules/Core) should review it.
Not sure if this is useful, but FWIW I'm seeing this bug now too. My monitor arrangement is vertical, top to bottom:

* 24" Dell LCD on DVI-to-DisplayPort adapter
* 7" LCD USB monitor
* 15" MacBook Pro (2009) (menubar here)

If I keep Firefox Aurora on the MBP, everything's fine. 

If I move to the Dell monitor, I can no longer open chrome windows associated with that window (eg. view-source, downloads) until I restart Firefox or open a new window that never leaves the laptop screen. And, then, I can only ever open windows from the window that stays on the laptop screen.
Can someone try the nightly on Monday morning to confirm if the bug is gone? This may be a dupe of bug 644733 which just got fixed.
(In reply to Benoit Girard (:BenWa) from comment #32)
> Can someone try the nightly on Monday morning to confirm if the bug is gone?
> This may be a dupe of bug 644733 which just got fixed.

I have tested the nightly: firefox-9.0a1.en-US.mac-shark.dmg 22-Aug-2011 05:41 and can confirm this issue is resolved.
This is either a DUPE or FIXED-BY bug 644733.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 644733
Duplicate of this bug: 680434
Duplicate of this bug: 646555
Duplicate of this bug: 650374
Duplicate of this bug: 651282
Duplicate of this bug: 655599
Duplicate of this bug: 644345
I meant to dup these last bugs to bug 644733 which has the fix but I goofed up :(  sorry.

I'll leave them as is for now.
Thanks for finding them, I didn't think there was that many.
Duplicate of this bug: 656106
confirmed that nightly firefox-9.0a1.en-US.mac.dmg in OSX 10.6.7 resolves specific issues in dupe bug #656106
You need to log in before you can comment on or make changes to this bug.