[Edit Message As New] adds existing Bcc address

VERIFIED FIXED in mozilla1.3alpha

Status

MailNews Core
Composition
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: Koike Kazuhiko, Assigned: varada)

Tracking

Trunk
mozilla1.3alpha
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3])

Attachments

(1 attachment, 2 obsolete attachments)

2.14 KB, patch
Jean-Francois Ducarroz
: review+
Bienvenu
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

17 years ago
If you checked "Bcc <your address>" in Mail Account Settings,
[Edit Message As New] adds Bcc address which is already included
in the header.

Duplicate check is necessary.
(Reporter)

Comment 1

17 years ago
bug 41150 is a related bug.

Updated

17 years ago
QA Contact: esther → pmock
(Reporter)

Comment 2

17 years ago
*** Bug 79086 has been marked as a duplicate of this bug. ***

Updated

17 years ago
QA Contact: pmock → esther

Comment 3

16 years ago
Sounds related to bug 83080.
reassign to varada
Assignee: ducarroz → varada

Comment 5

16 years ago
*** Bug 83080 has been marked as a duplicate of this bug. ***
*** Bug 128191 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 7

16 years ago
Created attachment 72588 [details] [diff] [review]
patch

It's necessary to check the existing Bcc list.
(Reporter)

Comment 8

16 years ago
Comment on attachment 72588 [details] [diff] [review]
patch

The fix for bug 64092 made  this patch obsolete.
Attachment #72588 - Flags: needs-work+
(Reporter)

Comment 9

16 years ago
Created attachment 74498 [details] [diff] [review]
patch v2
Attachment #72588 - Attachment is obsolete: true
*** Bug 137070 has been marked as a duplicate of this bug. ***
*** Bug 136894 has been marked as a duplicate of this bug. ***
Reply-to does the same thing apparently (bug 82775), should/could these be fixed
in one go? Seen on linux too, Os->All
OS: Windows 98 → All
patch applies to trunk, builds, runs, fixes bug. linux
Keywords: patch
(Reporter)

Comment 14

16 years ago
Created attachment 79022 [details] [diff] [review]
patch v3

Added a fix code for bug 82775
Attachment #74498 - Attachment is obsolete: true

Comment 15

16 years ago
*** Bug 140913 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago
*** Bug 154873 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
*** Bug 154748 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago
CC ducarroz and bienvenu for r= and sr=

Comment 19

16 years ago
>If you checked "Bcc <your address>" in Mail Account Settings,
>[Edit Message As New] adds Bcc address which is already included
>in the header.

I've got the same still in 1.1a B:2002070908
for "BCC to _another_ address"

Comment 20

15 years ago
*** Bug 143494 has been marked as a duplicate of this bug. ***
Blocks: 82775
KOIKE, have you mailed for reviews, yet?
Keywords: review
*** Bug 165515 has been marked as a duplicate of this bug. ***
*** Bug 167734 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Keywords: nsbeta1+
Whiteboard: [adt3]
*** Bug 176211 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 25

15 years ago
Comment on attachment 79022 [details] [diff] [review]
patch v3

varada, please review the patch.
Attachment #79022 - Flags: review?(varada)
Comment on attachment 79022 [details] [diff] [review]
patch v3

R=ducarroz
Attachment #79022 - Flags: review?(varada) → review+

Comment 27

15 years ago
Comment on attachment 79022 [details] [diff] [review]
patch v3

sr=bienvenu
Attachment #79022 - Flags: superreview+
(Reporter)

Updated

15 years ago
Attachment #79022 - Flags: checkin?(ducarroz)
Fix checked in the trunk. Thanks Koike Kazuhiko for the patch.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.3alpha

Updated

15 years ago
Attachment #79022 - Flags: checkin?(ducarroz)

Comment 29

15 years ago
*** Bug 191900 has been marked as a duplicate of this bug. ***

Comment 30

15 years ago
Trunk build 2003-03-20: Mac 10.1.5, WinXP
Verified Fixed.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.