Ability to sort bookmarks in each folder

RESOLVED FIXED in mozilla1.4final

Status

P3
enhancement
RESOLVED FIXED
18 years ago
14 years ago

People

(Reporter: basic, Assigned: janv)

Tracking

Trunk
mozilla1.4final
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Currently when sorting in Manage Bookmark, it only affects the display in 
Manage Bookmark. There is no way of really sorting the bookmark besides 
arranging the bookmark by drag-n-drop in Manage Bookmark.

I'd like to be able to sort each folder individualy:
- Where I can right click on a folder and select sort bookmark in folder by 
name or by date or whatever. 
- That would mean that the sort only affects that particular folder.
- This sort should affect the bookmark menu, personal toolbar, bookmark sidebar 
panel and should be saved.

Comment 1

18 years ago
That would be really nice.

Comment 2

18 years ago
Marking NEW to get it off our radar.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted
Summary: ability to sort bookmarks in each folder → [RFE] Ability to sort bookmarks in each folder

Comment 3

18 years ago
This should only be done if we get the ability to open individual bookmarks 
folders in their own windows. In the main bookmarks window, folders should always 
follow the sort pattern used by the root folder -- anything else would be 
extremely confusing.
(Reporter)

Comment 4

18 years ago
This doesn't have need subfolders opened in a new window. It only need to have
effect when viewing in unsorted mode.

Comment 5

18 years ago
mpt: this bug is about the bookmarks menu, not the manage bookmarks window.

See also bug 70571.

Comment 6

18 years ago
*** Bug 70571 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
*** Bug 79700 has been marked as a duplicate of this bug. ***

Comment 8

18 years ago
*** Bug 83599 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
Not sure if this duplicates or extends the original description.

The bookmark sort options being discussed (Sort by Name, Sort by Date Created)
should appear in the context menu when you right-click on a folder on the
"Personal Toolbar"
Sorting in the actual datasource is the easiest way to ensure that a sort is 
applied across all UI that hold bookmarks, be that outliner, tree, menu, etc 
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → Future
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW

Comment 12

17 years ago
Not funny, Ben.  More like sickening.

Comment 13

17 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben

Comment 14

17 years ago
Sort order could be a Property of a bookmark folder (sorted/unsorted).  This
would be better than a one-time sort because new links (added via drag+drop or
"file bookmark") would be sorted according to the folder's preference.

Comment 15

17 years ago
*** Bug 139671 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
*** Bug 141522 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
*** Bug 145422 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
Any update on this bug ?

Earlier, I was using IE to manage book marks and would export from IE, improt to
mozilla. I always had my bookmarks sorted that way, but since I now use mozilla
exclusively, I have lost the ability to sort my bookmarks.

Would really appreciate help in this area.

Thanks

Updated

16 years ago
Summary: [RFE] Ability to sort bookmarks in each folder → Ability to sort bookmarks in each folder

Comment 19

16 years ago
I'm using Mozilla 1.2b.I have gone into the Bookmarks menu/Manage Bookmarks.
Here, I have the ability to request that bookmarks be sorted but the command
does nothing. Even after I have selected a set of bookmarks to sort - Nada effect.

Comment 20

16 years ago
*** Bug 181933 has been marked as a duplicate of this bug. ***

Comment 21

16 years ago
Currently (Moz 1.2) there is no way (that I can find) of sorting bookmarks which
live in folders created inside My Personal Toolbar folder. In IE, the analogous
"Links" bar/folder/subfolders where extremely easy to sort/manage -- you simply
clicked on the folder name to open it, then right-click and choose "Sort by
Name." Not being able to do this in Mozilla makes managing one's ever growing
bookmarks nearly impossible. I would like to see the ability to sort without
having to enter Manage Bookamrks.
(Assignee)

Comment 22

16 years ago
-> me
Assignee: ben → varga

Comment 23

16 years ago
Just as an FYI, this bug exist in the latest build of Phoenix as well.
(Assignee)

Comment 24

16 years ago
This is needed for bug 77411.
Keywords: helpwanted → nsbeta1
Target Milestone: Future → mozilla1.4beta
(Assignee)

Updated

16 years ago
Depends on: 202845
Keywords: nsbeta1
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.4beta → mozilla1.4final
(Assignee)

Updated

16 years ago
Blocks: 205378

Comment 25

16 years ago
Fixed by 205378. Verified in both the 2003-05-23-09 Win32 and 2003-05-23-07
Macho trunk builds.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 26

15 years ago
I would agree that would be a neat thing
(Assignee)

Comment 27

15 years ago
You mean in Firefox?
It's already fixed in the suite and is also available as an extension in Firefox.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.