[win32] ctrl++ (using numeric keypad) doesn't affect font / text zoom

VERIFIED FIXED in mozilla1.1alpha

Status

()

Core
Event Handling
P3
minor
VERIFIED FIXED
17 years ago
15 years ago

People

(Reporter: Jesse Ruderman, Assigned: joki (gone))

Tracking

({pp})

Trunk
mozilla1.1alpha
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

887 bytes, patch
timeless
: review+
jag (Peter Annema)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

17 years ago
Ctrl++ doesn't do anything on Windows.  It should increase the font size one 
notch.  Jag says it works fine on Linux with both the + above = and the + on 
the numeric keypad.

This bug may depend on bug 70140.

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → Future
(Reporter)

Comment 1

17 years ago
*** Bug 74477 has been marked as a duplicate of this bug. ***

Comment 2

17 years ago
*** Bug 85008 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
ctrl++ works on the keyboard but not the numerical keypad
(Reporter)

Comment 4

17 years ago
*** Bug 88571 has been marked as a duplicate of this bug. ***
->jag?
Assignee: alecf → jaggernaut
Status: ASSIGNED → NEW
(Reporter)

Comment 6

17 years ago
*** Bug 89735 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
*** Bug 102087 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
*** Bug 103958 has been marked as a duplicate of this bug. ***
Keywords: pp
Summary: ctrl++ doesn't increase font size on windows (ctrl+= works) → ctrl++ doesn't increase font size on windows (ctrl+= works) [numpad doesn't work]

Comment 9

17 years ago
*** Bug 104667 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
Please add the word keypad and zoom to the summary so its easier to find this bug

Comment 11

17 years ago
Okay.

Old summary: ctrl++ doesn't increase font size on windows (ctrl+= works) [numpad
doesn't work]

New summary: ctrl++ doesn't increase font size (zoom) on windows (ctrl+= works)
[numpad/numerical keypad doesn't work]
Summary: ctrl++ doesn't increase font size on windows (ctrl+= works) [numpad doesn't work] → ctrl++ doesn't increase font size (zoom) on windows (ctrl+= works) [numpad/numerical keypad doesn't work]

Comment 12

17 years ago
sure, let's make the summary even uglier. This is a dom events thing 
(reassign, nuke priority).

... when reporters search bugzilla they should check dupes, as such they should 
be able to find this bug based on any of the dupes here some of which should 
have whatever summary you like.  If you feel that this summary is missing 
something which the assignee doesn't feel is necessary then you can file a new 
bug w/ that summary and then dupe it against this bug.  You won't lose karma 
points for doing this since bugzilla doesn't implement that.
Assignee: jaggernaut → joki
Component: Keyboard Navigation → Event Handling
QA Contact: sairuh → madhur
Summary: ctrl++ doesn't increase font size (zoom) on windows (ctrl+= works) [numpad/numerical keypad doesn't work] → windows ctrl+<add numeric keypad> doesn't increase font size (zoom)
Target Milestone: Future → ---

Comment 13

17 years ago
http://lxr.mozilla.org/seamonkey/search?string=VK_ADD
mkaply, does this affect OS/2? i'm guessing it doesn't.
(Reporter)

Updated

17 years ago
Summary: windows ctrl+<add numeric keypad> doesn't increase font size (zoom) → [win32] ctrl++ (using numeric keypad) doesn't affect font zoom

Comment 14

17 years ago
sorry the spam

>sure, let's make the summary even uglier.
Agree here, the old sumary was too bad
now is perfect

>... when reporters search bugzilla they should check dupes, 
but dont agree here...

the sumary should be a good one to keep the dupes the lowest possible

reporting bugs, searching bugs, marking bugs dups, verifying  all cost time
searching with the dupes add more search, one for open bugs, one for
closed/verified bugs marked as dupes and then see in the dupes the status of the
main bug...
and this is just for people that know about this!

isnt karma or something like this, but dupes cost time and people doesnt like to
post dupes because dupes doesnt help, only add more useless work

i will open a bugzilla bug for the query show up too the dupes that have their
parent still open, to see if this helps this problem




Updated

17 years ago
Target Milestone: --- → mozilla0.9.7

Comment 15

17 years ago
To : timeless@mac.com, Daniel Mota Leite

Hello. I was one of people who reported "Crl++ problem" of Mozill for Windows.
I'd like to comment on "Duplicated Bug Reporting" issue.
I absolutely agree with you. I always try to search if bugs I find is already 
reported. But very often, the bug finder can't find appropriate bug reports 
which is already posted.
So, I think there must be easier way to find reported bugs which are similar to 
what reporters try posting.

I'm sorry to bother you guys.

Comment 16

17 years ago
Save the bugzilla discussion for a newsgroup guys.
*** Bug 113242 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago
I'm the one who reported "Bug 113242"  ... It's a menu text problem!  It's a
documentation issue!  It's a typographical error! It is not a bug! 

"CTRL + +" (using shift key) happens to make text bigger in LINUX and not in
Windows ... but it's only being reported because the menu shortcut text is
giving a shortcut that works in LINUX and not Windows. "CTRL + =" works in both OS. 

On the menu text, change "CTRL + +" to be "CTRL + =" and your bug goes away in
seconds. All the user wants is ONE method that works - if there are more than
one they don't care. 

Comment 19

16 years ago
Ha. It's not that easy.

See does.http://bugzilla.mozilla.org/show_bug.cgi?id=54402

I tried to convince people of that, but everyone disagreed.

Besides, not every keyboard as + and = as a US keyboard 

Comment 20

16 years ago
And the issue is really that it should work. It doesn't just happen to work on
Linux, there is a specific keybinding for {accel shift =} (which works out to be
{ctrl +} for most people) which should work on all platforms. The fact that it
doesn't on Windows means there's a bug somewhere.

Comment 21

16 years ago
(somewhere in the key handling code, that is)

Comment 22

16 years ago
jag - 
  While you track down the bug in the esoterica of keybindings and PC keyboards,
and Windows keyboard APIs, please make the menu text match the keystrokes that
actually work in Windows AND in LINUX.  

  Documenting programs "as observed" instead of "as intended" saves the users a
lot of hassle.  
(Assignee)

Comment 23

16 years ago
Moving bugs from 0.9.7 for triaging in 0.9.8
Target Milestone: mozilla0.9.7 → mozilla0.9.8
*** Bug 119466 has been marked as a duplicate of this bug. ***

Comment 25

16 years ago
*** Bug 122318 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9
I seen this on Mozillazine for the first time under 098 feedback, I see Ctrl +
'-' is hooked up on the keypad, but not this. So is the problem that it is not
binded yet, or doesn't work?
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.9 → mozilla1.1

Comment 27

16 years ago
*** Bug 131564 has been marked as a duplicate of this bug. ***

Comment 28

16 years ago
Guys,

11 (eleven!) duplicates of this bug?!? something MUST be wrong with the title.
I almost posted another one, but luckily I did a more thorough search ("Look in
both Summary and Description Fields" for the following: text zoom ctrl++)

I would add the "text" as another keyword.

Prog.
Summary: [win32] ctrl++ (using numeric keypad) doesn't affect font zoom → [win32] ctrl++ (using numeric keypad) doesn't affect font / text zoom
11 dupes are not much !
see : http://bugzilla.mozilla.org/duplicates.cgi
The number one has 90 dupes !

Comment 30

16 years ago
*** Bug 137158 has been marked as a duplicate of this bug. ***

Comment 31

16 years ago
*** Bug 137288 has been marked as a duplicate of this bug. ***

Updated

16 years ago
QA Contact: madhur → rakeshmishra

Comment 32

16 years ago
This bug is still a factor in 1.0 RC1 in Win98.  I'd vote that you fix it to use
Ctl-+ on the numeric keypad or the Ctrl-+ (=) on the keyboard rather than
changing the menu documentation to Ctrl-=.  Ctrl-+ and Ctrl-- for text zoom
larger and smaller is much more intuitive and easy to remember.  The numeric
keypad Ctl-- works, so it should be possible to get Ctrt-+ working there too, eh?

Comment 33

16 years ago
Perhaps the number of duplicates is a good indicator or how many people are
annoyed by this supposedly minor bug...
*** Bug 140618 has been marked as a duplicate of this bug. ***
*** Bug 143717 has been marked as a duplicate of this bug. ***

Comment 36

16 years ago
*** Bug 145835 has been marked as a duplicate of this bug. ***

Comment 37

16 years ago
*** Bug 146986 has been marked as a duplicate of this bug. ***

Comment 38

16 years ago
The reason Ctrl Shift = doesn't work is because the binding is to Ctrl Shift +

Comment 39

16 years ago
*** Bug 149600 has been marked as a duplicate of this bug. ***

Comment 40

16 years ago
Neil: that binding works just fine on this linux box. Could you try changing it
to ctrl-shift-+ and see if that works on Windows?

Comment 41

16 years ago
CTRL + on numeric keypad works fine on OS/2. It's broken on Windows.
*** Bug 151006 has been marked as a duplicate of this bug. ***

Comment 43

16 years ago
Created attachment 87369 [details] [diff] [review]
The fix

The issue was that the + on the numeric keypad was generated a vkey but no
charcode.

Interesting enough, the same was true of the - but someone special cased it.
For some reason they didn't special case + at the same time.

So the fix is to special case VK_ADD and pass in a charcode of '+' so Mozilla
can accelerate it.

I also changed the VK_SUBTRACT code to make it a little clearer what it was
doing - virtualkeycode - 64 is silly. just pass '-'

Enjoy!

Updated

16 years ago
Keywords: mozilla1.0.1, nsbeta1

Comment 44

16 years ago
Incidentally this appears also to be a bug with * and /

I set my enlarge and reduce accels to * and / and got some interesting results.

/ and * on the numeric keypad worked, and of course 8(*) worked, but the slash 
on the main keyboard doesn't.

Turns out the DOM key codes have a little mistake in them. They have a 
DOM_VK_SLASH and a DOM_VK_DIVIDE, and I think Mozilla gets confused between the 
two. There can be only one.

So either way, we should also add cases for DOM_VK_MULTIPLY and DOM_VK_DIVIDE, 
since this will fix things that were broken before.

Using / as an accelerator never worked, because internally mozilla is using 
DOM_VK_DIVIDE for that value, and the / beside shift (or elsewhere on your 
keyboard) generates a DOM_VK_SLASH.

Comment 45

16 years ago
I've also been told that numpad DELETE doesn't work to delete emails.

Comment 46

16 years ago
> I've also been told that numpad DELETE doesn't work to delete emails.

WFM with numlock disabled.

Comment 47

16 years ago
*** Bug 151455 has been marked as a duplicate of this bug. ***
*** Bug 151841 has been marked as a duplicate of this bug. ***

Comment 49

16 years ago
Anyone of the zillions of people copied on this bug want to r= it? and maybe an 
sr?

I'm not going to try to fix the other issues right now because it will just hold 
up getting this necessary fix in.

Updated

16 years ago
Attachment #87369 - Flags: review+

Comment 50

16 years ago
Comment on attachment 87369 [details] [diff] [review]
The fix

sr=jag
Attachment #87369 - Flags: superreview+

Comment 51

16 years ago
Fix checked into trunk.

Sending note to drivers.

Comment 52

16 years ago
please checkin to the 1.0.1 branch. once there, remove the "mozilla1.0.1+"
keyword and add the "fixed1.0.1" keyword.
Keywords: mozilla1.0.1 → mozilla1.0.1+

Comment 53

16 years ago
Fix checked into branch. Hurrah!
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: mozilla1.0.1+ → fixed1.0.1
Resolution: --- → FIXED
(Reporter)

Comment 54

16 years ago
*** Bug 155375 has been marked as a duplicate of this bug. ***

Comment 55

16 years ago
*** Bug 157309 has been marked as a duplicate of this bug. ***

Comment 56

16 years ago
*** Bug 158414 has been marked as a duplicate of this bug. ***

Comment 57

16 years ago
*** Bug 159373 has been marked as a duplicate of this bug. ***

Comment 58

16 years ago
*** Bug 159784 has been marked as a duplicate of this bug. ***

Updated

16 years ago
QA Contact: rakeshmishra → trix

Comment 59

15 years ago
verified on latest trunk build 2002121308
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.