Closed Bug 825821 Opened 7 years ago Closed 7 years ago

Request Desktop site doesn't work on Wikipedia

Categories

(Firefox for Android :: General, defect)

18 Branch
Other
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 21
Tracking Status
firefox19 + verified
firefox20 + verified
firefox21 --- verified

People

(Reporter: pjmiller2001, Assigned: bnicholson)

References

Details

(Keywords: productization)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20121227073833

Steps to reproduce:

When using integrated search of wikipedia clicking on the suggestion that appears takes me to the mobile site rather than desktop site even though it is checked in settings. Going directly to website through web address takes me to desktop version as it should.


Actual results:

Read explanation above


Expected results:

Should have gone go desktop site rather than mobile site as selected in settings.
I am able to reproduce this on latest Beta. 
On nightly requesting Desktop site will lead you to main_page wikipedia
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Mobile website → Request Desktop site doesn't work on Wikipedia
Brian, is this  a dupe? Expected behaviour?
This happens because we specify the mobile Wikipedia URL in the search template: http://mxr.mozilla.org/mozilla-central/source/mobile/locales/en-US/searchplugins/wikipedia.xml#13

We used to do the same thing for Google searches - I think it was because Google gave us a terrible WAP site for our UA. Assuming we're using the mobile Wikipedia template for the same reason, it's probably unnecessary now (since going to wikipedia.org redirects to en.m.wikipedia.org, which is what we use in the template).
I agree with Brian. We should stop using the hardcoded "http://en.m.wikipedia.org/wiki" and just let Wikipedia handle the redirect.
Uses the same template as URL as desktop's wikipedia.xml, which seems to work fine.
Assignee: nobody → bnicholson
Status: NEW → ASSIGNED
Attachment #699508 - Flags: review?(mark.finkle)
Comment on attachment 699508 [details] [diff] [review]
Use standard URL for wikipedia search template

Did you test a tablet too? Ideally, a tablet would show the desktop Wikipedia, but showing a mobile version would be acceptable for now. It would be up to Wikipedia to fix the tablet layout.
Attachment #699508 - Flags: review?(mark.finkle) → review+
(In reply to Mark Finkle (:mfinkle) from comment #6)
> Comment on attachment 699508 [details] [diff] [review]
> Use standard URL for wikipedia search template
> 
> Did you test a tablet too? Ideally, a tablet would show the desktop
> Wikipedia, but showing a mobile version would be acceptable for now. It
> would be up to Wikipedia to fix the tablet layout.

I just tested it on my ASUS Transformer tablet, and it does in fact use desktop Wikipedia.
Uplift potential?
Comment on attachment 699508 [details] [diff] [review]
Use standard URL for wikipedia search template

[Approval Request Comment]
Bug caused by (feature/regressing bug #): none
User impact if declined: When searching Wikipedia from the AwesomeScreen, tablets show mobile Wikipedia and the "Request Desktop Site" preference is ignored.
Testing completed (on m-c, etc.): m-i
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: none
Attachment #699508 - Flags: approval-mozilla-beta?
Attachment #699508 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/762d7ec784e7
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Attachment #699508 - Flags: approval-mozilla-beta?
Attachment #699508 - Flags: approval-mozilla-beta+
Attachment #699508 - Flags: approval-mozilla-aurora?
Attachment #699508 - Flags: approval-mozilla-aurora+
Verified fixed on Nightly 21.0a1 (2013-01-13).
Verified fixed on Aurora 20.0a2 (2013-01-23) and on Firefox 19.0b2 (2013-01-16)
Status: RESOLVED → VERIFIED
Keywords: qawanted, verifyme
I'll go out and file bugs on l10n for this, too.

http://mxr.mozilla.org/l10n-mozilla-aurora/search?string=.m.wiki&find=mobile/searchplugins/wikipedia- shows the affected locales, fr is already having a bug open.
Keywords: productization
Blocks: 846712
Blocks: 846713
Blocks: 846714
Blocks: 846715
Blocks: 846716
Blocks: 846718
Blocks: 846719
Blocks: 846720
Blocks: 846721
Blocks: 846722
Blocks: 846723
Blocks: 846724
Blocks: 846725
Blocks: 846726
Blocks: 846727
Blocks: 846728
You need to log in before you can comment on or make changes to this bug.