Expanding a folder on the Personal Toolbar stays on top of all other windows

RESOLVED FIXED in mozilla1.1alpha

Status

SeaMonkey
Bookmarks & History
P3
normal
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: Chris Lyon, Assigned: neil@parkwaycc.co.uk)

Tracking

Trunk
mozilla1.1alpha
x86
All

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
Using build 2001061905 on Win2K

Steps to Reproduce:
1. Create a folder on the Personal Toolbar
2. Right click on the folder and select "Expand"
3. Either minimize Mozilla or bring another window in front of it

Results:
The expanded folder will remain visible with Mozilla minimized, and stay on top 
of all other windows.

Comment 1

17 years ago
Similar case in bug 85199.

Comment 2

17 years ago
See also bug 86649, Personal toolbar bookmark folder context menu should not
contain Expand.
(Reporter)

Comment 3

17 years ago
As of build 2001092803, I"m not seeing the Expand menu item for Personal 
Toolbar folders.  If someone can confirm, I think we can close this bug.
(Reporter)

Updated

17 years ago
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

17 years ago
WFM
(Reporter)

Comment 5

17 years ago
Reopening
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 6

17 years ago
*** Bug 116775 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 7

17 years ago
*** Bug 116866 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

17 years ago
Created attachment 63806 [details] [diff] [review]
Proposed patch
Comment on attachment 63806 [details] [diff] [review]
Proposed patch

r=db48x
Attachment #63806 - Flags: review+
(Reporter)

Comment 10

17 years ago
*** Bug 119528 has been marked as a duplicate of this bug. ***
-> 1.1 as there is a patch. 
Status: REOPENED → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.1
(Reporter)

Comment 12

17 years ago
*** Bug 115480 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 13

17 years ago
Please note:
While the folder is "expanded" Mozilla does not repond to keyboard input.

Changing OS to all based on duplicates.

Adding patch keyword.
Keywords: patch
OS: Windows 2000 → All
(Reporter)

Updated

17 years ago
Blocks: 70812
*** Bug 133100 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
I am seeing a very similar situation here.  Only, the way to reproduce it is to 
drag a link to the personal toolbar over 2 or more folders on the toolbar.  A 
couple of the folders will expand, one will close, but the other is left 
hanging open and won't go away just like when you right click and 
choose "expand" on a personal toolbar folder.

That bug 70812 is pretty insidious.  If there is a patch for this, please get 
it in before 1.0!!!  This could be *very* annoying.

Jake

Comment 16

16 years ago
Related problem. If I have multiple folders on Personal Toolbar, expanding more
than one thru Expand context menu will not close any of the previously expanded.
Each newly expanded folder becomes a top-level window on top of all the
previously expanded folders. Also, Mozilla wouldn't minimize.

Related, bug 113427 is about using a bookmark two levels down inside expanded
folder.

W2K SP2, Build ID 2002031104

Comment 17

16 years ago
*** Bug 163719 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago
*** Bug 163721 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Attachment #63806 - Flags: superreview?(bzbarsky)
Attachment #63806 - Flags: superreview?(bzbarsky) → superreview+
(Assignee)

Comment 19

16 years ago
A patch to bug 113247 was just checked in which I hope will also fix this bug.
(Reporter)

Comment 20

16 years ago
Looks fixed to me using 20021120 on winxp
(Assignee)

Comment 21

16 years ago
Fix checked in as part of fix to 113247.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 22

16 years ago
Bug 113427 ;)

Comment 23

15 years ago
This happens again with Build 2003040518 and Windows XP. Also see bug 83141.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 24

15 years ago
I'd also like to note this affects Linux Gecko/20030405 Phoenix/0.5 as well. If
Mozilla will be moving to that toolkit, make sure you don't just fix it in the old

Comment 25

15 years ago
it sucks that this is not fixed even in Netscape 7.1

Netscape = Mozilla + AOL Junk

Comment 26

14 years ago
Neil, why didn't your original fix take care of this permanently?

Why do we even have an "Expand" option in the context menu? What does that do
that clicking on the link in the personal toolbar doesn't do? Seems pretty strange.

See comment #16 for a related problem, which no separate bug was filed for.

This bug is not preventing keyboard input, so it does not block 70812.
Assignee: bugs → neil.parkwaycc.co.uk
No longer blocks: 70812
Status: REOPENED → NEW

Comment 27

14 years ago
Is this bug even still valid?  Bug 232649 says that Expand doesn't even work
anymore, and bug 243235 argues for the option's removal.  I agree with comment
26.  The choice's existance doesn't make any sense.  We don't have "follow this
link" as the first option for the context menu for an <a> tag, do we?
(Assignee)

Comment 28

14 years ago
pch's bookmarks rewrite (bug 196756) broke this. Naughty pch!
(Assignee)

Comment 29

14 years ago
Created attachment 150535 [details] [diff] [review]
New patch
Attachment #63806 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #150535 - Flags: superreview?(alecf)
Attachment #150535 - Flags: review?(varga)

Comment 30

14 years ago
Comment on attachment 150535 [details] [diff] [review]
New patch

huh. Ok, if that works...sr=alecf
Attachment #150535 - Flags: superreview?(alecf) → superreview+

Updated

14 years ago
Attachment #150535 - Flags: review?(varga) → review+
(Assignee)

Comment 31

14 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago14 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.