The default bug view has changed. See this FAQ.

Upgrade wiki.mozilla.org to MediaWiki 1.23

RESOLVED FIXED in 2014-Q3

Status

Websites
wiki.mozilla.org
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: joasqueeniebee, Assigned: cyliang)

Tracking

(Blocks: 5 bugs)

Production
2014-Q3

Details

(Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/1199] , URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140623175014

Steps to reproduce:

The Mediawiki version (v1.19.11) running wiki.mozilla.org is behind the current stable release v1.23.1.
(Reporter)

Updated

3 years ago
(Reporter)

Comment 1

3 years ago
The Mediawiki version (v1.19.11) running wiki.mozilla.org is behind the current stable release v1.23.1.
(Assignee)

Updated

3 years ago
Depends on: 1032877
The 1.23.x branch of MediaWiki is the current stable branch and the current LTS branch. The most recent version is 1.23.1 (released 2014-06-25), with 1.23.2 coming shortly (scheduled for release on 2014-07-30).

Confirming this and clarifying the summary.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Mediawiki upgrade for wiki.mozilla.org → Upgrade MediaWiki on wiki.mozilla.org to 1.23
Summary: Upgrade MediaWiki on wiki.mozilla.org to 1.23 → Upgrade wiki.mozilla.org to MediaWiki 1.23
Blocks: 492874
Blocks: 1044583, 1017714
Blocks: 515484
Blocks: 769204
Blocks: 670523
Blocks: 949701
Blocks: 1047872
Blocks: 1049082
Whiteboard: [q3]
Whiteboard: [q3] → [2014q3]
Depends on: 1055321
Whiteboard: [2014q3]
Target Milestone: --- → 2014-Q3
Version: unspecified → Production
Depends on: 1053113
Depends on: 1055857
Depends on: 1055895
As a sidebar note, I just upgraded my own MediaWiki install from an ancient 1.15 to the latest 1.23.2 and a very simple and straight-forward process it was. Only required commenting out the installed extensions initially then loading the latest versions before un-commenting them and everything working perfectly.

I also switched from MySQL to MariaDB at the same time as that is now the preferred backend. Also problem-less.

(/me wishes I could say the same for the upgrade process of some other programs)
Depends on: 1058726
Depends on: 1058736
Depends on: 1058819
Blocks: 1058914
No longer blocks: 1049082
No longer depends on: 1058726, 1058736, 1058819
MediaWiki 1.23.3 will be released tomorrow ("27th August between 20:00-22:00 UTC"), so we should updated dev when we get a chance.
We've scheduled time to do this on 4 September between 13:30-15:00 PT.
Let's remember to put wiki in read-only mode when we begin this work so folks don't loose any in-progress edits:
https://www.mediawiki.org/wiki/Manual:$wgReadOnly
Blocks: 1062656
(Assignee)

Updated

3 years ago
Assignee: nobody → cliang

Updated

3 years ago
Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/1199]
(Assignee)

Comment 7

3 years ago
Production was updated today.  I did the following:
  * downtime wiki.mo Nagios checks  
  * hardhat wiki.mo
  * set wiki.mo into read only mode & push changes to webheads
  * grab backup of wiki DB on mysql slave for prod DB cluster
  * make backup copy of wiki directory on genericadm
  * upgrade wiki software itself 
  * run DB maintenance script (for update)
  * upgrade WikiEditor extension
  * upgrade ConfirmAccount extension & run DB maintenance script (for extension changes) again
  * make changes to LocalSettings.php & push changes to webheads
  * unhard-hat wiki.mo

Christie and JD did some basic tests to verify that the upgrade had not broken the production environment.
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 957319
(Assignee)

Updated

3 years ago
See Also: → bug 938337
See Also: → bug 1063479
Blocks: 1072641
Blocks: 767167

Comment 9

2 years ago
Can we update to 1.24.0 I can add a bug for it
Blocks: 1121177
You need to log in before you can comment on or make changes to this bug.