Last Comment Bug 1043696 - Enable Apple PlatformDecoderModule for HTML5 video playback (MP4 playback on OSX)
: Enable Apple PlatformDecoderModule for HTML5 video playback (MP4 playback on ...
Status: RESOLVED FIXED
: dev-doc-needed
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: x86 Mac OS X
-- normal with 5 votes (vote)
: mozilla34
Assigned To: Ralph Giles (:rillian) | needinfo me
:
: Maire Reavy [:mreavy] Please needinfo me
Mentors:
: 942130 1030516 1085687 (view as bug list)
Depends on: 941296 1043695 1043710 1054023 1054024 1056394 1057877 1058399 1061395 1093567 1100482
Blocks: MSE 799318 1030516
  Show dependency treegraph
 
Reported: 2014-07-24 16:46 PDT by Ralph Giles (:rillian) | needinfo me
Modified: 2014-12-19 14:27 PST (History)
22 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
35+


Attachments
Enable the fmp4 decoder unconditionally for <video> (1.14 KB, patch)
2014-08-13 17:26 PDT, Ralph Giles (:rillian) | needinfo me
no flags Details | Diff | Splinter Review
Enable the fmp4 decoder for <video> on non-release osx builds (1.12 KB, patch)
2014-08-21 14:42 PDT, Ralph Giles (:rillian) | needinfo me
cpearce: review+
Details | Diff | Splinter Review
Enable fmp4 decoder for <video> on MacOS X (992 bytes, patch)
2014-08-26 13:29 PDT, Ralph Giles (:rillian) | needinfo me
no flags Details | Diff | Splinter Review
Enable fmp4 decoder for <video> on MacOS X (990 bytes, patch)
2014-08-26 13:58 PDT, Ralph Giles (:rillian) | needinfo me
no flags Details | Diff | Splinter Review

Description User image Ralph Giles (:rillian) | needinfo me 2014-07-24 16:46:10 PDT
Quoth :cpearce: Now, try exposing the MP4Reader in normal <video> on MacOSX, and see what tests fail. We want H.264/AAC on MacOSX in <video> ASAP. :)
Comment 1 User image Chris Pearce (:cpearce) 2014-07-24 18:26:43 PDT
I bet we need bug 1039128 fixed before this is green. kft is working on a fix (drain isn't working properly).
Comment 2 User image Florian Bender 2014-07-27 10:12:46 PDT
How does this bug relate to Bug 1030516?
Comment 3 User image Ralph Giles (:rillian) | needinfo me 2014-07-27 11:05:53 PDT
It's probably a duplicate. Marking as blocking until ajones can clarify if he wanted something different there.
Comment 4 User image Anthony Jones (:kentuckyfriedtakahe, :k17e) 2014-07-27 17:53:30 PDT
Sounds like the same thing to me.
Comment 5 User image Frank Yan (:fryn) 2014-07-31 16:00:22 PDT
*** Bug 1030516 has been marked as a duplicate of this bug. ***
Comment 6 User image Ralph Giles (:rillian) | needinfo me 2014-08-13 17:26:32 PDT
Created attachment 8472735 [details] [diff] [review]
Enable the fmp4 decoder unconditionally for <video>

Patch pushed to try for osx hosts. Passed on 10.6 as expected, since decoding doesn't work there. Got timeouts and errors on 10.8:

test_autoplay_contentEditable.html | Test timed out.
test_buffered.html | gizmo.mp4: Should be buffered in one range - got 0, expected 1
test_buffered.html | uncaught exception - IndexSizeError: Index or size is negative or greater than the allowed amount at http://mochi.test:8888/tests/content/media/test/test_buffered.html:32
test_bug448534.html | Test timed out.
test_bug465498.html | Test timed out.
test_bug495145.html | Test timed out.

Trying again now that the range calculation cleanup patches have landed.
Comment 7 User image Ralph Giles (:rillian) | needinfo me 2014-08-13 17:28:18 PDT
N.B. If we can get tests passing for osx before we get mp3-in-mp4 support landed, we want to enable this in nightly just for osx. Doing so unconditionally would be a regression on Windows.
Comment 8 User image Ralph Giles (:rillian) | needinfo me 2014-08-14 13:51:28 PDT
Same errors with bug 1050060 fixed. https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=dd5e88f7a193
Comment 9 User image Anthony Jones (:kentuckyfriedtakahe, :k17e) 2014-08-14 16:42:03 PDT
W(In reply to Ralph Giles (:rillian) from comment #7)
> N.B. If we can get tests passing for osx before we get mp3-in-mp4 support
> landed, we want to enable this in nightly just for osx. Doing so
> unconditionally would be a regression on Windows.

We can pref off mp3-in-mp4.
Comment 10 User image Ralph Giles (:rillian) | needinfo me 2014-08-19 17:06:18 PDT
New try push since some demuxer changes have landed. https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=a86aa41e92e
Comment 11 User image Ralph Giles (:rillian) | needinfo me 2014-08-21 14:42:44 PDT
Created attachment 8476982 [details] [diff] [review]
Enable the fmp4 decoder for <video> on non-release osx builds

We expect to get this working on Mac before other platforms and want to enable it asap since it's the path to mp4 playback there. Adapt to patch to the conditional on the platform.
Comment 12 User image Ralph Giles (:rillian) | needinfo me 2014-08-25 17:13:35 PDT
Comment on attachment 8476982 [details] [diff] [review]
Enable the fmp4 decoder for <video> on non-release osx builds

Review of attachment 8476982 [details] [diff] [review]:
-----------------------------------------------------------------

Asking for review now, since we're nearly ready to push the switch. Will land once I clean try pushes.
Comment 13 User image Chris Pearce (:cpearce) 2014-08-25 18:22:50 PDT
Comment on attachment 8476982 [details] [diff] [review]
Enable the fmp4 decoder for <video> on non-release osx builds

Review of attachment 8476982 [details] [diff] [review]:
-----------------------------------------------------------------

::: modules/libpref/init/all.js
@@ +245,4 @@
>  #ifdef MOZ_FMP4
>  pref("media.fragmented-mp4.enabled", true);
>  pref("media.fragmented-mp4.ffmpeg.enabled", false);
> +#if defined(XP_MACOSX) && !defined(RELEASE_BUILD)

Remove the !defined(RELEASE_BUILD) check. We can pref it off if we can't stabilize it by the time this gets to beta.
Comment 14 User image Ralph Giles (:rillian) | needinfo me 2014-08-26 13:29:14 PDT
Created attachment 8479321 [details] [diff] [review]
Enable fmp4 decoder for <video> on MacOS X

Update addressing review comments and changes from bug 1057879. Carrying forward r=cpearce
Comment 15 User image Ralph Giles (:rillian) | needinfo me 2014-08-26 13:58:57 PDT
Created attachment 8479331 [details] [diff] [review]
Enable fmp4 decoder for <video> on MacOS X

Work around bug 1058897. Carrying forward r=cpearce again.
Comment 16 User image Ralph Giles (:rillian) | needinfo me 2014-08-26 20:59:00 PDT
Green on try https://tbpl.mozilla.org/?tree=Try&rev=7232395497f6
Comment 17 User image Ralph Giles (:rillian) | needinfo me 2014-08-26 21:00:59 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/9da9ea6bd08e
Comment 18 User image Wes Kocher (:KWierso) 2014-08-27 16:42:26 PDT
https://hg.mozilla.org/mozilla-central/rev/9da9ea6bd08e
Comment 19 User image Florian Bender 2014-08-29 11:20:01 PDT
Yes! Thanks to all who made this possible!

Any chance this and any necessary fixes can be uplifted to Fx 33 / Aurora?

This is Lion and newer, right?


Release Note Request (optional, but appreciated)
[Why is this notable]: First time h264 is available on Mac without plugins
[Suggested wording]: (Added) Built-in support for H264 (MP4) on OS X Lion(??) and newer through native APIs.
[Links (documentation, blog post, etc)]: -
Comment 20 User image Anthony Jones (:kentuckyfriedtakahe, :k17e) 2014-08-29 16:55:22 PDT
(In reply to Florian Bender from comment #19)
> Any chance this and any necessary fixes can be uplifted to Fx 33 / Aurora?

There's Buckley's chance of that happening. There are way too many commits to the MP4 parser and related code that this depends on.

Anthony
Comment 21 User image Florian Bender 2014-08-30 08:47:08 PDT
Yeah I thought so. Thanks anyway!
Comment 22 User image Jonny Barnes 2014-09-03 05:47:36 PDT
With `media.apple.mp4.enabled` set to true, the video on youtube HTML5's player becomes black/blank, the audio for me. A quick fix is to manually toggle that flag to false.

I am using a Late-2009 MacBook running Yosemite public beta 2.
Comment 23 User image Chris Pearce (:cpearce) 2014-09-15 01:08:12 PDT
(In reply to Jonny Barnes from comment #22)
> With `media.apple.mp4.enabled` set to true, the video on youtube HTML5's
> player becomes black/blank, the audio for me. A quick fix is to manually
> toggle that flag to false.
> 
> I am using a Late-2009 MacBook running Yosemite public beta 2.

This was tracked in bug 1054789, and is thought to be fixed. Can you re-test nightly, and if it still occurs, please file a new bug. Thanks!
Comment 24 User image Jonny Barnes 2014-09-15 01:50:06 PDT
(In reply to Chris Pearce (:cpearce) from comment #23)
> (In reply to Jonny Barnes from comment #22)
> > With `media.apple.mp4.enabled` set to true, the video on youtube HTML5's
> > player becomes black/blank, the audio for me. A quick fix is to manually
> > toggle that flag to false.
> > 
> > I am using a Late-2009 MacBook running Yosemite public beta 2.
> 
> This was tracked in bug 1054789, and is thought to be fixed. Can you re-test
> nightly, and if it still occurs, please file a new bug. Thanks!

Nightly works with YouTube as expected now.
Comment 25 User image Sylvestre Ledru [:sylvestre] 2014-10-03 05:39:01 PDT
Added to the release notes with "Built-in support for H264 (MP4) on Mac OS X Lion and newer through native APIs" as wording.
Comment 26 User image Masatoshi Kimura [:emk] 2014-10-03 05:49:22 PDT
Also supported on Snow Leopard (10.6). See bug 1070703.
Comment 27 User image Sylvestre Ledru [:sylvestre] 2014-10-03 05:52:05 PDT
OK, Updated! thanks
Comment 28 User image Matthias Versen [:Matti] 2014-10-20 16:13:49 PDT
*** Bug 1085687 has been marked as a duplicate of this bug. ***
Comment 29 User image Anthony Jones (:kentuckyfriedtakahe, :k17e) 2014-11-17 18:00:19 PST
MP4 support on Mac OSX has been pushed out to Firefox 35 due to unresolved issues in the demuxer.
Comment 30 User image Liz Henry (:lizzard) (needinfo? me) 2014-11-18 09:18:06 PST
Sylvestre or lmandel, the release notes may need updating here.
Comment 31 User image Sylvestre Ledru [:sylvestre] 2014-11-18 09:27:28 PST
OK. Thanks. Moved to 35 then!
Comment 32 User image Brad Dougherty 2014-11-18 12:54:35 PST
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #29)
> MP4 support on Mac OSX has been pushed out to Firefox 35 due to unresolved
> issues in the demuxer.

Do you have a link to those issues so that I can follow them?

This is pretty disappointing for us :(
Comment 33 User image Ralph Giles (:rillian) | needinfo me 2014-12-19 14:27:25 PST
*** Bug 942130 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.