Closed Bug 122055 Opened 20 years ago Closed 20 years ago

Page info/Media/size of the URL listbox shrinks and grows

Categories

(SeaMonkey :: Page Info, defect)

defect
Not set
critical

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9.9

People

(Reporter: Matti, Assigned: db48x)

References

()

Details

Attachments

(1 file, 3 obsolete files)

win2k build 20020126..

1. go to the URL
2. Select Page Info/Media
3. select different image URLs

What you see : The size of the URL Listbox grows and shrinks

Exptected result: Should not change the size
Blocks: 82059
Component: XP Apps → XP Apps: GUI Features
QA Contact: sairuh → pmac
However, if you move the grippie even once, this shrinking/growing behavior
stops.  Some kind of uninitialized variable, maybe?
yes, that's essentially correct. basically the heights start out as unspecified,
but some of the parts of the window are told that they should share the space,
growing until the size of the children is the same as the size of the container.
Unfortunatly, this means that mozilla just sorta gives out space randomly (the
system is underspecified.) Also unfortunatly there doesn't seem to be a way to
specify that one part should take up a percentage of the available space, though
you can tell it to be a certain number of ems or pixels high, neither of which
are terribly useful. If I could tell the image list to be 33% of the available
height, the rest would work perfectly.
which gives me an idea. Specifing the height in pixels is obviously out, but
using ems might be ok. Afterall, since an em corresponds to the height of a line
of text, and since the image list comprises of lines of text, it won't be so bad
to use ems. Not as good as a percentage though, in my opinion.
Status: NEW → ASSIGNED
Attached patch patch (obsolete) — Splinter Review
and after getting distracted by other things, here is a patch
Attached patch diff -uw (obsolete) — Splinter Review
and a version that ignores the whitespace changes I made
Component: XP Apps: GUI Features → Page Info
Attachment #66660 - Flags: review+
*** Bug 126926 has been marked as a duplicate of this bug. ***
*** Bug 125201 has been marked as a duplicate of this bug. ***
*** Bug 121780 has been marked as a duplicate of this bug. ***
Severity: minor → critical
OS: Windows 2000 → All
Hardware: PC → All
Target Milestone: --- → mozilla0.9.9
*** Bug 127478 has been marked as a duplicate of this bug. ***
Attached patch also fixes form tab (obsolete) — Splinter Review
Attachment #66659 - Attachment is obsolete: true
Attachment #66660 - Attachment is obsolete: true
Comment on attachment 71165 [details] [diff] [review]
also fixes form tab

sr=alecf
Attachment #71165 - Flags: superreview+
*** Bug 128976 has been marked as a duplicate of this bug. ***
*** Bug 130081 has been marked as a duplicate of this bug. ***
Adding a dependency on bug 121583, although this bug can be worked around
without 121583 getting fixed.
Depends on: 121583
*** Bug 127481 has been marked as a duplicate of this bug. ***
*** Bug 123387 has been marked as a duplicate of this bug. ***
*** Bug 130357 has been marked as a duplicate of this bug. ***
Blocks: 130754
Comment on attachment 71165 [details] [diff] [review]
also fixes form tab

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #71165 - Flags: approval+
*** Bug 131039 has been marked as a duplicate of this bug. ***
*** Bug 131055 has been marked as a duplicate of this bug. ***
Sorry for the dupe. I did see this one, but it didn't sound like quite the same
thing.
Attachment #71165 - Attachment is obsolete: true
stephend just checked this in :)
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
*** Bug 130754 has been marked as a duplicate of this bug. ***
*** Bug 132303 has been marked as a duplicate of this bug. ***
verified on windows and linux (commercial netscape build: 2002-03-26-05-TRUNK)
Status: RESOLVED → VERIFIED
Keywords: nsbeta1
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.