Closed Bug 1558086 Opened 2 years ago Closed 15 days ago

[10.15] Theme does not adapt to automatic dark mode on MacOS Catalina

Categories

(Core :: Widget: Cocoa, defect, P2)

All
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1593390
Tracking Status
firefox-esr68 --- wontfix
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- wontfix
firefox73 --- wontfix
firefox74 --- wontfix
firefox75 --- wontfix
firefox76 --- wontfix
firefox77 --- wontfix

People

(Reporter: gauthier.pogam-lemontagner, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [mac:darkmode])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

  • Update Mac OS to 10.15 (Catalina)
  • Install Firefox Nightly and keep default theme
  • Select "Automatic" theme in system preferences
  • Firefox does not update itself to match the system theme

A good example is to switch from Dark theme to Automatic theme during the day (automatic will select the Light theme). Firefox won't update according to the system theme.

Actual results:

Firefox keep using the colour depending on the theme used before choosing the automatic mode.

Expected results:

Firefox should match the system theme when using automatic mode, the same way it does when switch between Light and Dark theme in system preferences.

Restarting firefox does not update the theme.

Summary: Theme does not adapt to automatic dark mode on MacOS Catalina → [10.15] Theme does not adapt to automatic dark mode on MacOS Catalina

Hi gauthier.pogam-lemontagner,

I noticed that this is a duplicate of the bug 1483858. I marked it as such. Please do follow the other bug to see it solved.

Best regards, Flor.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1483858

(In reply to Florencia Marina Di Ciocco from comment #2)

Hi gauthier.pogam-lemontagner,

I noticed that this is a duplicate of the bug 1483858. I marked it as such.
Please do follow the other bug to see it solved.

Best regards, Flor.

*** This bug has been marked as a duplicate of bug 1483858 ***

Hello, I don't think the issue here is not a duplicate of bug 1483858. The issue here is specific to Mac OS to 10.15 (Catalina) and bug 1483858 is specific to iOS

Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Hi Simon,

Sorry for the delay, I was still unable to reproduce this bug. Either way, I've set a component to try to move forward with this issue.

But maybe you can provide me with a bit more info. Can you please download Firefox Nightly from here: https://nightly.mozilla.org/ and retest the problem and see if the issue still occurs there as well?
Does this issue occur with a fresh profile? you can find the steps here: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?redirectlocale=en-US&redirectslug=Managing-profiles#w_starting-the-profile-manager

If after doing this you can still reproduce the bug, could you send me a screenshot or a video of the bug? That always helps a lot.

Thanks in advance, Flor.

Component: Untriaged → General
Flags: needinfo?(gauthier.pogam-lemontagner)
Product: Firefox → Firefox for iOS
Version: 69 Branch → unspecified

Hello,

I can confirm the bug is still happening with the lastest version of Nightly (69.0a1 (2019-07-04) (64 bits)).
I also created a new profile to test the issue, and I can confirm the issue is still here. After creating the new profile and starting a new browser with it, the dark theme is used despite the system theme being the light one (Automatic theme during day period).

Since I reported this bug, I had to install Firefox Stable and uninstall Nightly (because of notarization issue that is now fixed) and the problem was present on all installs (which all had a different profile).
My guess is that the issue come from a theme detection issue, which do not detect the automatic theme selection newly introduced in Catalina.

Please check the video above that perfectly demonstrate the issue and was made on a fresh install of Nightly, just after synchronising my Firefox account.

My current version of macOS is 10.15 (19A501i).
Also, the product is not Firefox for iOS but Firefox for MacOS (I prefer to remind it in case of).

Flags: needinfo?(gauthier.pogam-lemontagner)

I tested this on Mac OS X 10.15 Beta 3 with FF Nightly 70.0a1(2019-07-16) and FF release 68 and I can reproduce this issue.

Blocks: catalina
Status: UNCONFIRMED → NEW
Component: General → Widget: Cocoa
Ever confirmed: true
OS: Unspecified → macOS
Product: Firefox for iOS → Core
Hardware: Unspecified → All
Version: unspecified → Trunk
Priority: -- → P2
Duplicate of this bug: 1565469

I can say that it's still there with the current version of macOS Catalina beta and Firefox.

I can confirm that it's still happening under MacOS Catalina Public Beta 8, that Apple released yesterday. (10.15 Beta (19A573a) and Firefox version 69.0.1 general release.

Still happening in firefox 70 in MacOS Catalina 10.15 final release

Duplicate of this bug: 1588755

Still on Firefox 71 beta 7 in MacOS 10.15.1

I can confirm this issue is still happening in Firefox 71.0 stable and MacOS 10.15.2.

I am also seeing this issue in Firefox 71.0 on MacOS 10.15.2. Even when I switch to the dark theme, upon relaunching Firefox, the light theme comes back for some reason... why? I get the automatic theme not working, but it's odd that my dark theme won't even "stick."

I'm still seeing this issue in Firefox 72.0.1. Dark Mode isn't switching off, so the browser is permanently dark. Can't see any way to change that.

Yup, same here: Firefox 72.0.1 / macOS Catalina 10.15.2 (19C57) on a clean install of macOS and Firefox...

What is the current status of this bug? Is there progress on when a fix might be released.

Duplicate of this bug: 1615492
Duplicate of this bug: 1619989
Duplicate of this bug: 1591095
See Also: → 1596887

Guys, I think this issue is fixed with Firefox 75.0!!!!

Can you confirm that's the case for you too?

(I'm on macOS Catalina 10.15.4 (19E266))

(In reply to pierre.achard from comment #21)

Can you confirm that's the case for you too?

I saw it on 76 or 77 the other day so I don't think it is.

MacOS 10.15.4 + Firefox 75 and Firefox 77
At night there was the dark theme and Firefox was dark. Every morning when I turn on the mac, the system automatically has the light theme. I open Firefox (both, stable and nightly): it still has the dark theme. To change it I have to go to the system settings, click on light theme (now Firefox "understands" to change to the light theme) and then click again on automatic theme. However, it changes by itself to the dark theme......
It’s not just a problem with Firefox, other applications also have the same identical problem in switching from dark theme to light theme automatically.
I think the reason is that when I change to the dark theme, Firefox is open, it assists live to the theme change.
(sorry for my english)

Duplicate of this bug: 1632989

I was going to look into this today but I can't seem to reproduce the issue. This is with macOS 10.15.4 (19E287). Can anyone please confirm that they're still experiencing this with the latest macOS update from April 8 applied?

Paste copy of my message: https://bugzilla.mozilla.org/show_bug.cgi?id=1558086#c23

Tonight I left the mac on, with Firefox open and changed the theme automatically!
Instead the problem persists when Firefox (or Macos?) does not receive (or sends?) the theme change signal. It’s also a problem with other apps that maybe don’t read the new state of the theme... A few months ago I uninstalled them but they had the same problem as Firefox.

(In reply to Stephen A Pohl [:spohl] from comment #25)

I was going to look into this today but I can't seem to reproduce the issue. This is with macOS 10.15.4 (19E287). Can anyone please confirm that they're still experiencing this with the latest macOS update from April 8 applied?

I'm able to reproduce this issue with the supplemental update from April 8 applied and MacOS 10.15.4 (19E287)

My appearance settings are set to Auto and Firefox still shows dark mode. I'm running Firefox version 76.0.

Attached are two screen shots: one of system preferences and about my Mac (https://drive.google.com/open?id=12pTW3THaAGAk6ImbvEAy3-JTYaqF8N49) and the other is the Firefox version I'm running (https://drive.google.com/file/d/1i4UnGpYD44Jcy62hA0WcdE6lM5EKhxOZ/view?usp=sharing).

The only way to fix this is to go to System Preferences > General and click light next to appearance.

I hope this issue can be fixed or if there is a solution please post it.

Confirming that the issue is still occurring in the latest stable macOS and Firefox releases as of today. Here's how I experience the issue:

Settings:

  • macOS is configured to Auto appearance mode to automatically transition between Light and Dark depending on the time of day
  • Firefox is configured to the Default theme ("A theme with the operating system color scheme.")

Steps:

  1. macOS is in Light mode
  2. macOS gets to a time of day that it transitions to Dark mode automatically
  3. ^ Firefox automatically transitions to a dark appearance (this works correctly)
  4. macOS gets to a time of day that it transitions back to Light mode automatically
  5. ^ Firefox does NOT transition to light appearance

Expected results:

Firefox does transition to Light

Hope that helps!

I do also suffer this issue with default theme of Firefox, latest stable version available of both MacOs and Firefox.
I can confirm that Jeff's steps do definitely reproduce this issue.

MacOs changes to light mode but Firefox remains, at least in my case, dark all the day if you do not change the theme manually to "Light", which is different to the default one.

When you have MacOs's auto mode activated, during the day (while light mode), and you change from Firefox "Light" theme to "Default" theme, it still remains in dark mode, so the default theme does not inherit "light" or "day" mode not even changing from another theme to default, once default has been set to dark by MacOs auto mode.

Now, I've done a little experiment and found this:

  1. Set MacOs theme mode to "Auto"
  2. Set manually an hour of "dark theme", for example, 23:45. Now close the lid and open it back, your mac will change the theme. MacOs goes dark, Firefox does too, as it would happen spontaneously.
  3. Set manually back an hour of "light theme", for example 12:00, or your actual hour if it is not night. Nothing happens. Close the lid and open it again. MacOs goes light, and Firefox automatically inherits that change too, going back light "default", which does not do spontaneously when mac changes theme during the day by itself.
    (*) An alternative if you have not a Laptop would be to "suspend".

I, as many, close the lid many times a day and I have never seen that Firefox spontaneously changes the theme when closing and opening up back the lid during the day-mode, but this way it does.

I don't really know if this is interesting to this topic, but at least this says that inheriting light theme back does work to some extent if you force it. I don't know what this phenomena does imply.

Hope you all the best, many thanks.
Regards.

Severity: normal → S3

Why hasn't this been fixed yet, It's been over a year since this was submitted so just wondering. Is it this difficult to fix?

(In reply to sorenpearson from comment #30)

Why hasn't this been fixed yet, It's been over a year since this was submitted so just wondering. Is it this difficult to fix?

In this particular case, the issue that is slowing down any progress is the fact that we don't have a reliable way to mimic the automatic theme switching. This was described in comment 29. To debug and test any potential fix, we would need to have a way to manually trigger this automatic theme switching. For example, we would need to know what the theme switching is based on and manually set the system clock to one minute before the change occurs. Is it based on sundown? Is it based on a hardcoded time? This would dramatically speed up a fix. If someone has found a way to do this manually, please let us know.

Alternatively, if we cannot manually trigger this automatic theme switching, we will need to run a custom build of Firefox with extra logging. This is a lengthy process, as we only get one chance per day to test a potential fix.

(In reply to Stephen A Pohl [:spohl] from comment #31)

(In reply to sorenpearson from comment #30)

Why hasn't this been fixed yet, It's been over a year since this was submitted so just wondering. Is it this difficult to fix?

In this particular case, the issue that is slowing down any progress is the fact that we don't have a reliable way to mimic the automatic theme switching. This was described in comment 29. To debug and test any potential fix, we would need to have a way to manually trigger this automatic theme switching. For example, we would need to know what the theme switching is based on and manually set the system clock to one minute before the change occurs. Is it based on sundown? Is it based on a hardcoded time? This would dramatically speed up a fix. If someone has found a way to do this manually, please let us know.

Alternatively, if we cannot manually trigger this automatic theme switching, we will need to run a custom build of Firefox with extra logging. This is a lengthy process, as we only get one chance per day to test a potential fix.

Thanks for clarifying and and hopefully a someone can come up with a solution to do it manually or if needed run a custom build of Firefox with the logging necessary to capture the data.

(In reply to Stephen A Pohl [:spohl] from comment #31)

(In reply to sorenpearson from comment #30)

Why hasn't this been fixed yet, It's been over a year since this was submitted so just wondering. Is it this difficult to fix?

In this particular case, the issue that is slowing down any progress is the fact that we don't have a reliable way to mimic the automatic theme switching. This was described in comment 29. To debug and test any potential fix, we would need to have a way to manually trigger this automatic theme switching. For example, we would need to know what the theme switching is based on and manually set the system clock to one minute before the change occurs. Is it based on sundown? Is it based on a hardcoded time? This would dramatically speed up a fix. If someone has found a way to do this manually, please let us know.

Alternatively, if we cannot manually trigger this automatic theme switching, we will need to run a custom build of Firefox with extra logging. This is a lengthy process, as we only get one chance per day to test a potential fix.

Good night,

I am not an expert, nor programmer, but when I had time I gave a look at theme changing mechanism in my MacBook Air 13" early 2015 running MacOs Catalina 10.15.4. I took notes about what you comment, trying to make the theme change, and I post them here. Hope this is helpful, if not, so sorry in advance, I tried my best.

METHOD: Trial-error settings changing.
OBJECTIVE: Find a way to manually trigger theme transition.
I changed these settings:

  • Location to get timezone ON/OFF
  • Automatic time and date ON/OFF
  • NightShift modes: AUTOMATIC/CUSTOM/DISABLED
    Console is registering “Appeareance” related entries.

RESULTS:
I found 3 ways in which theme switching is set in different situations, depending on your settings. The only one in which you can see theme transitioning while using the Mac is (1). In (2) and (3) the system apparently waits you do not use it.

(1) ALL AUTOMATED LOCATION-BASED DEFAULT MODE
MacOs Catalina has this mode by default. Day-night change is defined by location data. This mode works with this settings:

  • Location to get time zone ON
  • Automatic time and date ON
  • NightShift modes: ANY
    Theme change is done even while using the mac, so you can see the theme transition.

(2) NIGHTSHIFT SETTINGS DEPENDENT CHANGING MODE, LID DOWN-UP REQUIRED
MacOs Catalina goes dark when NightShift is set to start, and goes light when finished. Day-night change has effect when you close the lid and open it up again. This mode works with this settings:

  • Location to get time zone OFF
  • Automatic time and date ON
  • NightShift modes: CUSTOM – you must set trigger hours.

(3) CLOCK-BASED NON NIGHTSHIFT-SETTINGS-DEPENDENT CHANGING MODE, LID DOWN-UP REQUIRED
MacOs Catalina goes dark when NightShift is set to start, and goes light when finished. Day-night change has effect when you close the lid and open it up again. This mode works with this settings:

  • Location to get time zone OFF
  • Automatic time and date OFF – You must set adequate time.
  • NightShift modes: DISABLED – if enabled, works with this.

Theme changes to dark sometime between 21:30 and 21:40, but lid down-up required.
Theme changes to light sometime between 6:45 and 7:00, but lid down-up required.

It seems reasonable loging off and on before trying each mode.

When theme change depends on a lid down-up, Firefox does well the dark-to light transition, though, when it depends on (1) all-automated mode, it does not, and gets seems to get stuck in dark, and so, many of us see dark Firefox during the day.

NIGHTOWL APP DOES NOT SEEM A VIABLE ALTERNATIVE
You may think on NightOul app to thange theme mode manually, but it changes it from always light to always dark, completely bypassing automatic setting, because it was designed to work in Mojave, not in Catalina, and Mojave does not have that automation.

Even if I assume that Firefox does not transition to light when the system does, because it is still dark, while the rest is light, when I open it in the morning, I have never been using Firefox at the exact moment in which it goes light. Though, comment #28 confirms this disfunction.

So I can confirm that FF does transition to dark correctly, FF remains dark during the day when Auto mode is set in default settings (1).
FF appears to transition correctly when you open the lid and theme changes when you set the time at a changing time-hour.

Many thanks to all,
have a good night or day,
and stay safe.

See Also: → 1635640

(In reply to humblemumble453 from comment #33)

(In reply to Stephen A Pohl [:spohl] from comment #31)

(In reply to sorenpearson from comment #30)

Why hasn't this been fixed yet, It's been over a year since this was submitted so just wondering. Is it this difficult to fix?

In this particular case, the issue that is slowing down any progress is the fact that we don't have a reliable way to mimic the automatic theme switching. This was described in comment 29. To debug and test any potential fix, we would need to have a way to manually trigger this automatic theme switching. For example, we would need to know what the theme switching is based on and manually set the system clock to one minute before the change occurs. Is it based on sundown? Is it based on a hardcoded time? This would dramatically speed up a fix. If someone has found a way to do this manually, please let us know.

Alternatively, if we cannot manually trigger this automatic theme switching, we will need to run a custom build of Firefox with extra logging. This is a lengthy process, as we only get one chance per day to test a potential fix.

Good night,

I am not an expert, nor programmer, but when I had time I gave a look at theme changing mechanism in my MacBook Air 13" early 2015 running MacOs Catalina 10.15.4. I took notes about what you comment, trying to make the theme change, and I post them here. Hope this is helpful, if not, so sorry in advance, I tried my best.

METHOD: Trial-error settings changing.
OBJECTIVE: Find a way to manually trigger theme transition.
I changed these settings:

  • Location to get timezone ON/OFF
  • Automatic time and date ON/OFF
  • NightShift modes: AUTOMATIC/CUSTOM/DISABLED
    Console is registering “Appeareance” related entries.

RESULTS:
I found 3 ways in which theme switching is set in different situations, depending on your settings. The only one in which you can see theme transitioning while using the Mac is (1). In (2) and (3) the system apparently waits you do not use it.

(1) ALL AUTOMATED LOCATION-BASED DEFAULT MODE
MacOs Catalina has this mode by default. Day-night change is defined by location data. This mode works with this settings:

  • Location to get time zone ON
  • Automatic time and date ON
  • NightShift modes: ANY
    Theme change is done even while using the mac, so you can see the theme transition.

(2) NIGHTSHIFT SETTINGS DEPENDENT CHANGING MODE, LID DOWN-UP REQUIRED
MacOs Catalina goes dark when NightShift is set to start, and goes light when finished. Day-night change has effect when you close the lid and open it up again. This mode works with this settings:

  • Location to get time zone OFF
  • Automatic time and date ON
  • NightShift modes: CUSTOM – you must set trigger hours.

(3) CLOCK-BASED NON NIGHTSHIFT-SETTINGS-DEPENDENT CHANGING MODE, LID DOWN-UP REQUIRED
MacOs Catalina goes dark when NightShift is set to start, and goes light when finished. Day-night change has effect when you close the lid and open it up again. This mode works with this settings:

  • Location to get time zone OFF
  • Automatic time and date OFF – You must set adequate time.
  • NightShift modes: DISABLED – if enabled, works with this.

Theme changes to dark sometime between 21:30 and 21:40, but lid down-up required.
Theme changes to light sometime between 6:45 and 7:00, but lid down-up required.

It seems reasonable loging off and on before trying each mode.

When theme change depends on a lid down-up, Firefox does well the dark-to light transition, though, when it depends on (1) all-automated mode, it does not, and gets seems to get stuck in dark, and so, many of us see dark Firefox during the day.

NIGHTOWL APP DOES NOT SEEM A VIABLE ALTERNATIVE
You may think on NightOul app to thange theme mode manually, but it changes it from always light to always dark, completely bypassing automatic setting, because it was designed to work in Mojave, not in Catalina, and Mojave does not have that automation.

Even if I assume that Firefox does not transition to light when the system does, because it is still dark, while the rest is light, when I open it in the morning, I have never been using Firefox at the exact moment in which it goes light. Though, comment #28 confirms this disfunction.

So I can confirm that FF does transition to dark correctly, FF remains dark during the day when Auto mode is set in default settings (1).
FF appears to transition correctly when you open the lid and theme changes when you set the time at a changing time-hour.

Many thanks to all,
have a good night or day,
and stay safe.

Hello,

Well, this is weird to me. (0-0")
After doing al that "testing" I wrote above, FF has adopted well light theme since that day, and I have experienced no bug, being, still, in 76.0.1 (64-bit).
I don't really know what changed.

Best regards.

(In reply to humblemumble453 from comment #34)

(In reply to humblemumble453 from comment #33)

(In reply to Stephen A Pohl [:spohl] from comment #31)

(In reply to sorenpearson from comment #30)

Why hasn't this been fixed yet, It's been over a year since this was submitted so just wondering. Is it this difficult to fix?

In this particular case, the issue that is slowing down any progress is the fact that we don't have a reliable way to mimic the automatic theme switching. This was described in comment 29. To debug and test any potential fix, we would need to have a way to manually trigger this automatic theme switching. For example, we would need to know what the theme switching is based on and manually set the system clock to one minute before the change occurs. Is it based on sundown? Is it based on a hardcoded time? This would dramatically speed up a fix. If someone has found a way to do this manually, please let us know.

Alternatively, if we cannot manually trigger this automatic theme switching, we will need to run a custom build of Firefox with extra logging. This is a lengthy process, as we only get one chance per day to test a potential fix.

Good night,

I am not an expert, nor programmer, but when I had time I gave a look at theme changing mechanism in my MacBook Air 13" early 2015 running MacOs Catalina 10.15.4. I took notes about what you comment, trying to make the theme change, and I post them here. Hope this is helpful, if not, so sorry in advance, I tried my best.

METHOD: Trial-error settings changing.
OBJECTIVE: Find a way to manually trigger theme transition.
I changed these settings:

  • Location to get timezone ON/OFF
  • Automatic time and date ON/OFF
  • NightShift modes: AUTOMATIC/CUSTOM/DISABLED
    Console is registering “Appeareance” related entries.

RESULTS:
I found 3 ways in which theme switching is set in different situations, depending on your settings. The only one in which you can see theme transitioning while using the Mac is (1). In (2) and (3) the system apparently waits you do not use it.

(1) ALL AUTOMATED LOCATION-BASED DEFAULT MODE
MacOs Catalina has this mode by default. Day-night change is defined by location data. This mode works with this settings:

  • Location to get time zone ON
  • Automatic time and date ON
  • NightShift modes: ANY
    Theme change is done even while using the mac, so you can see the theme transition.

(2) NIGHTSHIFT SETTINGS DEPENDENT CHANGING MODE, LID DOWN-UP REQUIRED
MacOs Catalina goes dark when NightShift is set to start, and goes light when finished. Day-night change has effect when you close the lid and open it up again. This mode works with this settings:

  • Location to get time zone OFF
  • Automatic time and date ON
  • NightShift modes: CUSTOM – you must set trigger hours.

(3) CLOCK-BASED NON NIGHTSHIFT-SETTINGS-DEPENDENT CHANGING MODE, LID DOWN-UP REQUIRED
MacOs Catalina goes dark when NightShift is set to start, and goes light when finished. Day-night change has effect when you close the lid and open it up again. This mode works with this settings:

  • Location to get time zone OFF
  • Automatic time and date OFF – You must set adequate time.
  • NightShift modes: DISABLED – if enabled, works with this.

Theme changes to dark sometime between 21:30 and 21:40, but lid down-up required.
Theme changes to light sometime between 6:45 and 7:00, but lid down-up required.

It seems reasonable loging off and on before trying each mode.

When theme change depends on a lid down-up, Firefox does well the dark-to light transition, though, when it depends on (1) all-automated mode, it does not, and gets seems to get stuck in dark, and so, many of us see dark Firefox during the day.

NIGHTOWL APP DOES NOT SEEM A VIABLE ALTERNATIVE
You may think on NightOul app to thange theme mode manually, but it changes it from always light to always dark, completely bypassing automatic setting, because it was designed to work in Mojave, not in Catalina, and Mojave does not have that automation.

Even if I assume that Firefox does not transition to light when the system does, because it is still dark, while the rest is light, when I open it in the morning, I have never been using Firefox at the exact moment in which it goes light. Though, comment #28 confirms this disfunction.

So I can confirm that FF does transition to dark correctly, FF remains dark during the day when Auto mode is set in default settings (1).
FF appears to transition correctly when you open the lid and theme changes when you set the time at a changing time-hour.

Many thanks to all,
have a good night or day,
and stay safe.

Hello,

Well, this is weird to me. (0-0")
After doing al that "testing" I wrote above, FF has adopted well light theme since that day, and I have experienced no bug, being, still, in 76.0.1 (64-bit).
I don't really know what changed.

Best regards.

Hi,

And since I said my FF transitioned well from one theme to the other, the next day started not to do so again.

Best regards.

Blocks: 1611766

This is something weird I've noticed: If I try to tell Night Owl (yes, I'm on Catalina, I did this for testing purposes though) to put an app like say, Sketch, or Chrome, in a permanent light mode, it DOES work fine, as expected. On the other hand, if I tell Night Owl to put Firefox in a permanent light mode, it DOESN'T work, even if I have the theme set to Default in the Firefox theme settings. That's really weird.

My theory is that Firefox doesn't use the system API to set its light or dark mode, it uses something else. Hopefully what I found helps.

Also, I still have this issue on Firefox 79. It's really annoying and it honestly stops me from using Firefox as my default browser. I am VERY open to using the custom build or helping out in other ways if it means that this bug fix will be rectified sooner. :)

Blocks: dark-mode

Just experienced this on 80.0b7 on macOS 10.15.6. My system was in (auto-selected) light mode, but FFX chrome & pages were rendering in dark mode. Toggling the theme in Firefox didn't help. Toggling my system theme to Light fixed it, and then switching back to Auto system theme left FFX in light mode as it should be.

Seems like the bug may be related to bug 1593390.

This bug has not been fixed in Firefox Stable 80.0.1 (64-bit) running in MacOs Catalina 10.15.6 (19G2021).
Regards.

(In reply to Alexei Solonari from comment #38)

Seems like the bug may be related to https://bugzilla.mozilla.org/show_bug.cgi?id=1593390.

Okay so I think I've determined this is the issue. Assuming this answer is correct and I understand correctly, someone on StackOverflow says that using UserDefaults checks the last stored value of the mode on the OS, but not the actual current OS theme. Fixing that issue would therefore fix this. If anyone could put that this bug depends on bug 1593390 I would appreciate it.

Depends on: 1593390

(In reply to Stephen A Pohl [:spohl] (PTO 9/3 - 9/13) from comment #25)

I was going to look into this today but I can't seem to reproduce the issue. This is with macOS 10.15.4 (19E287). Can anyone please confirm that they're still experiencing this with the latest macOS update from April 8 applied?

(In reply to Alexei Solonari from comment #40)

(In reply to Alexei Solonari from comment #38)

Seems like the bug may be related to https://bugzilla.mozilla.org/show_bug.cgi?id=1593390.

Okay so I think I've determined this is the issue. Assuming this answer is correct and I understand correctly, someone on StackOverflow says that using UserDefaults checks the last stored value of the mode on the OS, but not the actual current OS theme. Fixing that issue would therefore fix this. If anyone could put that this bug depends on bug 1593390 I would appreciate it.

Sorry, I just want to request info from spohl about this issue since they seemed interested in resolving it. I didn't know I could do that earlier. Please see the reply above :)

Flags: needinfo?(spohl.mozilla.bugs)

I'm on MacOS Big Sur beta, (20A5364e) and experience the same issue where the browser doesn't change based on the system settings. I have to go to System Preferences > General and change the appearance manually from Auto to light mode and back to auto and then firefox changes from dark mode to white mode.

Also, I believe this started happening with build 20A5364e as the previous build of Big Sur I didn't have to manually change it.

Hope this helps.

(In reply to Alexei Solonari from comment #41)

(In reply to Alexei Solonari from comment #40)

(In reply to Alexei Solonari from comment #38)

Seems like the bug may be related to https://bugzilla.mozilla.org/show_bug.cgi?id=1593390.

Okay so I think I've determined this is the issue. Assuming this answer is correct and I understand correctly, someone on StackOverflow says that using UserDefaults checks the last stored value of the mode on the OS, but not the actual current OS theme. Fixing that issue would therefore fix this. If anyone could put that this bug depends on bug 1593390 I would appreciate it.

Sorry, I just want to request info from spohl about this issue since they seemed interested in resolving it. I didn't know I could do that earlier. Please see the reply above :)

Thanks. I have commented in bug 1593390 comment 8. And this bug was previously set to block bug 1593390.

Flags: needinfo?(spohl.mozilla.bugs)
Duplicate of this bug: 1670869

Any updates on this? This bug was reported over one year ago and has not been fixed yet! It's still happening and it completely ruins the experience of Firefox on MacOS.

(In reply to g from comment #45)

Any updates on this? This bug was reported over one year ago and has not been fixed yet! It's still happening and it completely ruins the experience of Firefox on MacOS.

I get your frustration but right now there's nothing. The developers need to get dark mode completely working in Firefox before this bug will be fixed, unfortunately. If you want to follow along with progress, then once this is fixed, then this bug will need to be fixed. The developers seem to have this at a fairly high priority which will help. After that it will work correctly. Sit tight :)

For now, you can try using Night Owl.

(In reply to Alexei Solonari from comment #46)

(In reply to g from comment #45)

Any updates on this? This bug was reported over one year ago and has not been fixed yet! It's still happening and it completely ruins the experience of Firefox on MacOS.

I get your frustration but right now there's nothing. The developers need to get dark mode completely working in Firefox before this bug will be fixed, unfortunately. If you want to follow along with progress, then once this is fixed, then this bug will need to be fixed. The developers seem to have this at a fairly high priority which will help. After that it will work correctly. Sit tight :)

For now, you can try using Night Owl.

First of all thanks a lot for the reply! My intent was not being polemical but just "conveying" my frustration :) Again I really hope the bug will be fixed soon because it's not severe from a security standpoint, however it is from a UX one (a lot of people use auto dark mode on MacOS).

The problem with the add-on you suggested is that it doesn't fix the issue. Night Owl toggles light/dark modes of the Firefox interface, however, due to this bug, this action does not consecutively change the prefers-color-scheme css property that websites use to adapt to dark mode (it remains stuck in dark mode). So websites keep being dark all day long. Unfortunately there's not really any solution to this except manually switching off and on dark mode every day from Mac's system preferences, or disabling auto dark mode altogether.

Duplicate of this bug: 1674072

I am using MacOS Catalina (10.15.7) and am experiencing the same issue: using the default theme, Firefox (82.0.2) does not automatically switch between light and dark modes.

Duplicate of this bug: 1676720

I am using MacOS Cataline (10.15.7) and Firefox Developer Edition (84.0) and facing the same issue. Firefox does not automatically switch back to light theme from dark when system theme changes. Manually changing theme from preferences work, which makes me think there is something wrong with the background monitoring for system theme.

I just want to report that this bug with MaxOS Big Sur (11.01) is still happening. The theme does not switch back to light theme even while MacOS does.

Whiteboard: [mac:darkmode]
Duplicate of this bug: 1702207
Depends on: 1702351

With bug 1593390 now fixed, this issue might be resolved as well. If you could check with a current nightly build and let us know, that would be great. Thank you!

Flags: needinfo?(solonarialexei)
Flags: needinfo?(gauthier.pogam-lemontagner)

(In reply to Stephen A Pohl [:spohl] from comment #54)

With bug 1593390 now fixed, this issue might be resolved as well. If you could check with a current nightly build and let us know, that would be great. Thank you!

Unfortunately, I'm not on macOS anymore partially because Hackintoshing is... a mess. Maybe some other time!

Thanks for needinfoing me though! You all are doing great work and I'm still eagerly following progress on these bugs :)

Flags: needinfo?(solonarialexei)

I have downloaded Firefox Nightly (89.0a1, 64 bit) for Big Sur (11.1), and it resolves the issue. When I switch the system theme from dark to light, Firefox automatically changes its theme, and so do websites that use prefers-color-scheme media queries. It's really smooth!

Second that. Tested on macOS 11.2.3 + the current 89.0a1: switching the OS from dark to light and vice versa switches Alpenglow from dark to light automatically, so does the default theme, while the dark theme stays put as it should.

Thank you for confirming!

Status: NEW → RESOLVED
Closed: 2 years ago15 days ago
Flags: needinfo?(gauthier.pogam-lemontagner)
Resolution: --- → DUPLICATE
Duplicate of bug: 1593390
You need to log in before you can comment on or make changes to this bug.