Last Comment Bug 178870 - [news filters] implement filter after the fact (make Run Filters on Folder available for newsgroups)
: [news filters] implement filter after the fact (make Run Filters on Folder av...
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: Filters (show other bugs)
: Trunk
: All All
: -- enhancement with 14 votes (vote)
: Thunderbird 5.0b1
Assigned To: Kent James (:rkent)
:
:
Mentors:
: 180016 197517 273925 366904 390089 406209 410960 418315 476323 510777 524240 (view as bug list)
Depends on: 654231
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-07 08:21 PST by (not reading, please use seth@sspitzer.org instead)
Modified: 2011-05-18 20:57 PDT (History)
31 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Just enable it [Checked in: Comment 29 & 36] (1.59 KB, patch)
2011-04-26 17:31 PDT, Kent James (:rkent)
Pidgeot18: review+
mozilla: review+
Details | Diff | Splinter Review
SM part [Checkin: comment 35 & 37] (829 bytes, patch)
2011-04-30 02:24 PDT, Jens Hatlak (:InvisibleSmiley)
mnyromyr: review+
mnyromyr: superreview+
Details | Diff | Splinter Review

Description (not reading, please use seth@sspitzer.org instead) 2002-11-07 08:21:24 PST
[news filters] implement filter after the fact
Comment 1 Adam Macznik 2002-11-07 16:11:16 PST
Using build 2002110604 on Linux, I see the following:

The menuitem Tools -> Run Filters on Selected Folder is available for news.

It seems to do nothing while online (although it seems to talk to the server and
the Filter Log shows some actions).
It runs filters fine while offline - it marks the existing messages properly.
But I only used 'label message' and 'mark as read' actions.
Comment 2 esther 2003-05-27 13:43:05 PDT
Update, using trunk build 20030523 on winxp, the menu item to Run Filters on
Folder is disabled when a Newsgroup is selected and the Run Now button is not in
the Filter Rules dialog when a Newsgroup is selected.  This is correct at this
time since we haven't implemented Filter After the Fact for News yet. 
Comment 3 Mike Cowperthwaite 2003-08-01 10:24:37 PDT
*** Bug 180016 has been marked as a duplicate of this bug. ***
Comment 4 Mike Cowperthwaite 2003-08-01 10:25:22 PDT
*** Bug 197517 has been marked as a duplicate of this bug. ***
Comment 5 Rainer Bielefeld 2003-09-12 02:21:10 PDT
I still see that Problem in 
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030910

I created a filter to label posts of a special sender as "later"
The filter does not work, existing posts of the sender will not be labeled.
There is no button "run now" in my "Message Filter" dialog window for NG-filters
Menu: Tools/Run Filters on folder is ghosted, I can not run filters.

We had this function somewhere 1.3 (?), I am missing it.

Rainer
Comment 6 Rainer Bielefeld 2003-09-12 02:35:11 PDT
might be reasonable to reopen bug 17483 because of regression?

Rainer
Comment 7 Oliver Klee 2004-12-09 10:20:30 PST
*** Bug 273925 has been marked as a duplicate of this bug. ***
Comment 8 Mike Cowperthwaite 2007-01-13 12:28:41 PST
*** Bug 366904 has been marked as a duplicate of this bug. ***
Comment 9 Daniel Kabs, reporting bugs since 2002 2007-01-13 13:00:46 PST
News filtering works (here Thunderbird 1.5.0.9), but it's really a pain that you can not apply the filters for news groups folders (e.g. for testing the filter).

Will this change in TB 2.0?
Comment 10 John David Galt 2007-05-24 13:04:16 PDT
It seems to me the right way to handle this problem would be to add an option "Discard already-read messages at exit" in Tools -> Account Settings -> Server Settings.  If I want to keep a message, I'll copy it to a local mail folder.

Certainly if there is an option to manually delete messages from the cache, the documentation should be written to make clear that this is not the same thing as cancelling a message on the newsgroup.
Comment 11 Magnus Melin 2007-12-01 07:33:30 PST
*** Bug 406209 has been marked as a duplicate of this bug. ***
Comment 12 Frank Wein [:mcsmurf] 2008-01-05 16:03:32 PST
*** Bug 410960 has been marked as a duplicate of this bug. ***
Comment 13 Melchert Fruitema 2008-01-31 15:02:21 PST
(In reply to comment #9)
> News filtering works (here Thunderbird 1.5.0.9), but it's really a pain that
> you can not apply the filters for news groups folders (e.g. for testing the
> filter).
> 
> Will this change in TB 2.0?
> 

Not in TB 2.0! or even 3.0?
Comment 14 Melchert Fruitema 2008-02-01 02:53:26 PST
(In reply to comment #9)
> News filtering works (here Thunderbird 1.5.0.9), but it's really a pain that
> you can not apply the filters for news groups folders (e.g. for testing the
> filter).
> 
> Will this change in TB 2.0?
> 

Not in TB 2.0! or even 3.0?
Comment 15 Magnus Melin 2008-02-18 22:24:19 PST
*** Bug 418315 has been marked as a duplicate of this bug. ***
Comment 16 Ray Kiddy 2008-05-27 09:51:53 PDT
Ok. If I see a message I want to kill, I can create a filter. And I still see the message in every single newsgroup I go to. Please. Does not one else get bothered by news spam? Is it really just me?
Comment 17 Joshua Cranmer [:jcranmer] 2008-05-27 13:39:58 PDT
I'm just as bothered by news spam, but there are far more important things for me to work on than this extension. No developer is obligated to fulfill an enhancement request; if this feature is so important to you, then you have the power to actually write the code to implement the feature yourself.

So please, stop advocating for this feature or demanding that it be written this minute.
Comment 18 Wayne Mery (:wsmwk, NI for questions) 2009-01-24 12:49:02 PST
*** Bug 390089 has been marked as a duplicate of this bug. ***
Comment 19 Joshua Cranmer [:jcranmer] 2009-01-31 20:19:08 PST
*** Bug 476323 has been marked as a duplicate of this bug. ***
Comment 20 Kent James (:rkent) 2009-07-13 13:34:59 PDT
I've been running after-the-fact filters on newsgroups in some of my development work, and I am not aware of any issues. I have done a few small changes in folder handling and filtering though that might have made it start to work. Let me investigate this a little, it might not be that difficult to finish what needs doing, and enable the UI. Not making any promises though.
Comment 21 Joshua Cranmer [:jcranmer] 2009-08-16 09:45:29 PDT
*** Bug 510777 has been marked as a duplicate of this bug. ***
Comment 22 asmwarrior 2009-08-16 20:15:06 PDT
I noticed that when viewing newsgroup, the menu item:
Tools->"Run filters on Message" does not run the filters for the current newsgroup.Actually it does nothing.
See the screen shot below:

http://i683.photobucket.com/albums/vv194/ollydbg_cb/Snap2.png
Comment 23 Joshua Cranmer [:jcranmer] 2009-10-23 17:40:37 PDT
*** Bug 524240 has been marked as a duplicate of this bug. ***
Comment 24 pacificsymphony3 2010-04-15 15:22:48 PDT
Wow, 8 years later, and this bug still hasn't been fixed. There are probably Thunderbird users who weren't born yet when the bug was first reported. Joshua Cranmer is of course correct that nobody can force him to fix a bug that he doesn't want to fix. But if the usenet functionality in Thunderbird isn't going to be actively maintained, maybe Thunderbird should stop claiming to have usenet functionality.
Comment 25 Kent James (:rkent) 2011-04-26 17:31:58 PDT
Created attachment 528496 [details] [diff] [review]
Just enable it
[Checked in: Comment 29 & 36]

After the fact filters just seem to work. As I said, some work I did earlier may have cleaned this up. Joshua am I missing something? I tried all of the searches and actions and they just worked.
Comment 26 Joshua Cranmer [:jcranmer] 2011-04-28 18:56:49 PDT
First off, I'm sure SeaMonkey would also love to have this feature.

The only other concerns that strike me are potential corner cases in the differences between news and mail handling of code in the filter action backend.

I also want to worry about filter-on-any-header in filter-after-the-fact, but I won't r- this patch just because of that not working properly, especially since I think IMAP has the same problem.

Otherwise, I'm tempted to mark r+, but I want to compile + run with this patch first, so I won't get to it until next Tuesday or so.
Comment 27 Joshua Cranmer [:jcranmer] 2011-04-29 10:20:48 PDT
Comment on attachment 528496 [details] [diff] [review]
Just enable it
[Checked in: Comment 29 & 36]

Okay, I lied, I got to it earlier than expected. r+, modulo fixing it for SeaMonkey as well. You should also probably file a bug on getting it to work for the case of filter-on-any-header.
Comment 28 Kent James (:rkent) 2011-04-29 10:28:32 PDT
Comment on attachment 528496 [details] [diff] [review]
Just enable it
[Checked in: Comment 29 & 36]

I'm not really sure who needs to look at this. Since neither Joshua nor I are module peers of the code that will actually be modified for this, let me give bienvenu a chance to chime in on this.

I will do a separate patch to enable it for SM.
Comment 29 Kent James (:rkent) 2011-04-29 13:42:15 PDT
Comment on attachment 528496 [details] [diff] [review]
Just enable it
[Checked in: Comment 29 & 36]

http://hg.mozilla.org/comm-central/rev/1e34f71069bc
Comment 30 Kent James (:rkent) 2011-04-29 13:43:02 PDT
Leaving bug open for SeaMonkey patch.
Comment 31 John David Galt 2011-04-29 17:31:06 PDT
(In reply to comment #27)
> Okay, I lied, I got to it earlier than expected. r+, modulo fixing it for
> SeaMonkey as well. You should also probably file a bug on getting it to work
> for the case of filter-on-any-header.

Please cc: me on that bug.
Comment 32 Philip Chee 2011-04-29 21:57:14 PDT
Suite needs to be patched here:
/suite/mailnews/search/FilterListDialog.js
Comment 33 Jens Hatlak (:InvisibleSmiley) 2011-04-30 02:24:39 PDT
Created attachment 529270 [details] [diff] [review]
SM part [Checkin: comment 35 & 37]

Seeing this seems to take longer, here's the patch, already verified against SM2.1 branch (c-2.0) since trunk it currently FUBAR (patch applies against trunk, too, though). Thanks for the core patch, it's really appreciated! :-)

Mnyromyr, r+moa?
Comment 34 Karsten Düsterloh 2011-04-30 13:15:10 PDT
Comment on attachment 529270 [details] [diff] [review]
SM part [Checkin: comment 35 & 37]

> Thanks for the core patch, it's really appreciated! :-)

Indeed!

> Mnyromyr, r+moa?

Certainly!
Comment 35 Jens Hatlak (:InvisibleSmiley) 2011-04-30 13:24:40 PDT
Comment on attachment 529270 [details] [diff] [review]
SM part [Checkin: comment 35 & 37]

http://hg.mozilla.org/comm-central/rev/4af027ba1614
Comment 36 Serge Gautherie (:sgautherie) 2011-04-30 17:28:55 PDT
Comment on attachment 528496 [details] [diff] [review]
Just enable it
[Checked in: Comment 29 & 36]

http://hg.mozilla.org/releases/comm-2.0/rev/5a3482f2d9d6
Comment 37 Serge Gautherie (:sgautherie) 2011-04-30 17:29:38 PDT
Comment on attachment 529270 [details] [diff] [review]
SM part [Checkin: comment 35 & 37]

http://hg.mozilla.org/releases/comm-2.0/rev/ddbb9066bafe

Note You need to log in before you can comment on or make changes to this bug.